(address . guix-patches@gnu.org)
This patch is related to the following issue:
Tried to send it there without success, maybe because of email change.
Found two issues - unspecified version in pkgconfig of gerbv and some
incompatibility with optional geos library.
Related discussions:
The attached patch fixes those problems and allows to build pcb2gcode.
From 2f73c340abf3df2690b3778cbf0eb1de7a63ab33 Mon Sep 17 00:00:00 2001
Message-ID: <2f73c340abf3df2690b3778cbf0eb1de7a63ab33.1720013503.git.mail@pisemsky.site>
From: Evgeny Pisemsky <mail@pisemsky.site>
Date: Wed, 3 Jul 2024 15:15:25 +0300
Subject: [PATCH] gnu: pcb2gcode: Fix build.
* gnu/packages/engineering.scm (pcb2gcode): Fix build.
Change-Id: Id9a167c8859520f6e051c9b5efb4b960d50e4b7b
---
gnu/packages/engineering.scm | 13 +++++++++++--
1 file changed, 11 insertions(+), 2 deletions(-)
Toggle diff (35 lines)
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 64335d89f7..0855f44d13 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -844,7 +844,15 @@ (define-public gerbv
"06bcm5zw7whsnnmfld3gl2j907lxc68gnsbzr2pc4w6qc923rgmj"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("CFLAGS=-fcommon")))
+ (list
+ #:configure-flags '(list "CFLAGS=-fcommon")
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'fix-pkg-config-version
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* (string-append (assoc-ref outputs "out")
+ "/lib/pkgconfig/libgerbv.pc")
+ (("^Version:.*$")
+ (string-append "Version: " #$version "\n"))))))))
(native-inputs (list autoconf
automake
desktop-file-utils
@@ -3257,7 +3265,8 @@ (define-public pcb2gcode
(build-system gnu-build-system)
(inputs
(list boost
- geos
+ ;; TODO: Try to build with geos in the following revisions.
+ ;; geos
gerbv
glibmm
gtkmm-2
base-commit: bab73e413b3421f4aa051e9438d147040a52e1be
--
2.45.2