[PATCH 0/4] gnu: gvisor-tap-vsock, buildah, podman build fix.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jean-Pierre De Jesus DIAZ
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Jean-Pierre De Jesus DIAZ
Severity
normal
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jul 18:34 +0200
(address . guix-patches@gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
cover.1720024272.git.jean@foundation.xyz
This fixes these packages and additionally updates podman to 5.1.1.

I've verified with `strings <binaries> | grep '/gnu/store'` to check for
references in the store for go packages and found none after these
patches. (perhaps there's a clever way of checking that I'm not aware of
but it works).

Jean-Pierre De Jesus DIAZ (4):
gnu: gvisor-tap-vsock: Fix build.
gnu: podman: Fix build.
gnu: buildah: Fix build.
gnu: podman: Update to 5.1.1.

gnu/packages/containers.scm | 45 ++++++++++++++-----------------------
1 file changed, 17 insertions(+), 28 deletions(-)


base-commit: cf6f06b4461867f32d70354e8799516f991075e1
--
2.45.2
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jul 18:36 +0200
[PATCH 1/4] gnu: gvisor-tap-vsock: Fix build.
(address . 71923@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
49da27736e5834aa9444c8bf7b9fa727f938b521.1720024272.git.jean@foundation.xyz
* gnu/packages/containers.scm (gvisor-tap-vsock)<arguments>: Remove
'remove-go-references phase, add 'patch-go-reference phase and remove
imported modules.

Change-Id: I202292e303268b3ec0f13f19d4ceba517cd73aaa
---
gnu/packages/containers.scm | 13 +++++++------
1 file changed, 7 insertions(+), 6 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index c57f249ebd..396324284e 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -392,12 +392,15 @@ (define-public gvisor-tap-vsock
(list
#:make-flags `(list ,(string-append "GIT_VERSION=v" version))
#:test-target "test"
- #:imported-modules
- (source-module-closure `(,@%gnu-build-system-modules
- (guix build go-build-system)))
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
+ ;; Add -trimpath flag to avoid keeping references to go package
+ ;; in the store.
+ (add-after 'unpack 'patch-go-reference
+ (lambda _
+ (substitute* "Makefile"
+ (("go build") "go build -trimpath"))))
(add-before 'build 'setenv
(lambda _
;; For golang toolchain.
@@ -408,9 +411,7 @@ (define-public gvisor-tap-vsock
(invoke "rm" "-r" "test")))
(replace 'install
(lambda _
- (install-file "bin/gvproxy" (string-append #$output "/bin"))))
- (add-after 'install 'remove-go-references
- (@@ (guix build go-build-system) remove-go-references)))))
+ (install-file "bin/gvproxy" (string-append #$output "/bin")))))))
(native-inputs (list go-1.20))
(home-page "https://github.com/containers/gvisor-tap-vsock")
(synopsis "Network stack for virtualization based on gVisor")
--
2.45.2
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jul 18:36 +0200
[PATCH 2/4] gnu: podman: Fix build.
(address . 71923@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
a7575dd74bb5caa0a2d2c3c607d9b19e5292cb37.1720024272.git.jean@foundation.xyz
* gnu/packages/containers.scm (podman)<arguments>: Remove
'remove-go-references phase, add BUILDFLAGS=-trimpath to make-flags and
remove imported modules.

Change-Id: I6ffca5bd5be21b8b61ea9aa50273f97c5e342f9d
---
gnu/packages/containers.scm | 17 ++---------------
1 file changed, 2 insertions(+), 15 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 396324284e..38af5cb3fb 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -473,12 +473,10 @@ (define-public podman
(string-append "PREFIX=" #$output)
(string-append "HELPER_BINARIES_DIR=" #$output "/_guix")
(string-append "GOMD2MAN="
- #$go-github-com-go-md2man "/bin/go-md2man"))
+ #$go-github-com-go-md2man "/bin/go-md2man")
+ (string-append "BUILDFLAGS=-trimpath"))
#:tests? #f ; /sys/fs/cgroup not set up in guix sandbox
#:test-target "test"
- #:imported-modules
- (source-module-closure `(,@%gnu-build-system-modules
- (guix build go-build-system)))
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
@@ -530,17 +528,6 @@ (define-public podman
,(string-append #$passt "/bin")
,(string-append #$procps "/bin") ; ps
"/run/setuid-programs")))))
- (add-after 'install 'remove-go-references
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((go (assoc-ref inputs "go")))
- (for-each
- (lambda (file)
- (when (executable-file? file)
- ((@@ (guix build go-build-system) remove-store-reference)
- file go)))
- (append (find-files (string-append #$output "/bin"))
- (find-files (string-append #$output "/libexec"))
- (find-files (string-append #$output "/lib")))))))
(add-after 'install 'install-completions
(lambda _
(invoke "make" "install.completions"
--
2.45.2
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jul 18:36 +0200
[PATCH 3/4] gnu: buildah: Fix build.
(address . 71923@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
ad36d90cc677c7e66d7426c24f6e9e4d4bc54a3d.1720024272.git.jean@foundation.xyz
* gnu/packages/containers.scm (buildah)<arguments>: Remove
'remove-go-references phase, add 'patch-buildflags phase and remove
imported modules.

Change-Id: Id89ea5c90ba8064484eec460efdfa592c974adca
---
gnu/packages/containers.scm | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 38af5cb3fb..1b7032ca82 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -617,9 +617,6 @@ (define-public buildah
#$go-github-com-go-md2man "/bin/go-md2man"))
#:tests? #f ; /sys/fs/cgroup not set up in guix sandbox
#:test-target "test-unit"
- #:imported-modules
- (source-module-closure `(,@%gnu-build-system-modules
- (guix build go-build-system)))
#:phases
#~(modify-phases %standard-phases
(delete 'configure)
@@ -631,6 +628,12 @@ (define-public buildah
;; Make <4.4 causing CC not to be propagated into $(shell ...)
;; calls. Can be removed once we update to >4.3.
(setenv "CC" #$(cc-for-target))))
+ ;; Add -trimpath to build flags to avoid keeping references to go
+ ;; packages.
+ (add-after 'set-env 'patch-buildflags
+ (lambda _
+ (substitute* "Makefile"
+ (("BUILDFLAGS :=") "BUILDFLAGS := -trimpath "))))
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
@@ -658,8 +661,6 @@ (define-public buildah
,(string-append #$gcc "/bin") ; cpp
,(string-append #$passt "/bin")
"/run/setuid-programs")))))
- (add-after 'install 'remove-go-references
- (@@ (guix build go-build-system) remove-go-references))
(add-after 'install 'install-completions
(lambda _
(invoke "make" "install.completions"
--
2.45.2
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jul 18:36 +0200
[PATCH 4/4] gnu: podman: Update to 5.1.1.
(address . 71923@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
462d564f81c159a7b720f3db2ff8bf302878fdc5.1720024272.git.jean@foundation.xyz
* gnu/packages/containers.scm (podman): Update to 5.1.1.

Change-Id: Ie2563c1862debefcd6b5d0268e6cb57b6ae7193b
---
gnu/packages/containers.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/containers.scm b/gnu/packages/containers.scm
index 1b7032ca82..fccb972b94 100644
--- a/gnu/packages/containers.scm
+++ b/gnu/packages/containers.scm
@@ -455,7 +455,7 @@ (define-public catatonit
(define-public podman
(package
(name "podman")
- (version "5.1.0")
+ (version "5.1.1")
(source
(origin
(method git-fetch)
@@ -463,7 +463,7 @@ (define-public podman
(url "https://github.com/containers/podman")
(commit (string-append "v" version))))
(sha256
- (base32 "0ldzrrz8jba6ka1xfs8msiy08iz4m674xhfxbcdsnc9lmxi3ys4f"))
+ (base32 "1rhlwd350ll472jn7gm4nbkfkbm609d5s97wdqfb7lfagqwi1vny"))
(file-name (git-file-name name version))))
(build-system gnu-build-system)
(arguments
--
2.45.2
S
S
Sharlatan Hellseher wrote on 3 Jul 23:36 +0200
[PATCH 0/4] gnu: gvisor-tap-vsock, buildah, podman build fix.
(address . 71923@debbugs.gnu.org)
87r0cadupb.fsf@gmail.com
Hi,

Thanks for the patches.

It looks like it was missed during the merge/cherry pick from go-team
branch where I've fixed it recently.

I'm checking the build and will apply shortly.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmaFxFAACgkQdtcnv/Ys
0rXMYhAAtKdXB7YCF85XU62cK2VuHTIHx/7c9QnW2rAmIimTF3mgSVpYmVfuaH5e
QxoDT1DqLpcmb6M/3Ex9uQ4ywfrdxjEP+dLhzFEDd6oQIGNrgfer62IzxFoUR+xA
0BM/yXF12BHNhzsaAS6hxHqZcEH0EV59852xvgmOZ/W+Cdak55nvtSupgIzwfxga
Dr2ckeeQcEU4SYWUv8ufVjjC+HVh8btdC4pkQb4Brt3GvhfBSYml6NI7eBnCMjBF
422knPcu7Z/nnwyYSrBtMFURPdEcdKOm14o8ePpQeElf3fMwTOKEA93i7fmUE+y8
6YTCjYgzRdJyrU82ULuIgE6sdwEZoka6XOUVg/2N4gHMPoWFEsspc2Ma9NBIqukD
GWU2i8+9uVfmPXkIC2O+fovj+syQvn4elDm4o2fo4wkOe+XnZZCi6FLQ0HzT1Lza
+JpAEUx1ccpNiNeGs/EJKyuC+2eRSTPUFFjiKLHaoTq0+T66cWclJA4jVCaE18YU
A1SCXWIDcIQX2yVDSZqZHnys34EvagXdC3FOH5FvByscpyfPAvbT3btSKDrwwQeR
45Oq9PajaHa2XsQMYKSiquZGHZuBgt0biFKCpmQ5XhNfCbR159IHK8h9aaDnxI8N
j62FqzqWAkDV0KQ+n6DrZkO5L4KyZfRO7+VT6Wetftw8z7iHsJs=
=/AcX
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 3 Jul 23:58 +0200
(address . 71923@debbugs.gnu.org)
87o77edto1.fsf@gmail.com
Hi,

It looks good!

Toggle snippet (6 lines)
> ./pre-inst-env guix build podman buildah podman gvisor-tap-vsock
/gnu/store/gzql3mr9r1w1h892lhab9pzq9g7wid1z-gvisor-tap-vsock-0.7.3
/gnu/store/12mvay4cpsx4zgbksrwfh5nw857n674l-podman-5.1.1
/gnu/store/ggmq3xhnbdvlyc22hxqdwhbbkh1z82q5-buildah-1.36.0
/gnu/store/12mvay4cpsx4zgbksrwfh5nw857n674l-podman-5.1.1
Check after build:

Toggle snippet (87 lines)
gnu_store=(
/gnu/store/gzql3mr9r1w1h892lhab9pzq9g7wid1z-gvisor-tap-vsock-0.7.3
/gnu/store/12mvay4cpsx4zgbksrwfh5nw857n674l-podman-5.1.1
/gnu/store/ggmq3xhnbdvlyc22hxqdwhbbkh1z82q5-buildah-1.36.0
/gnu/store/12mvay4cpsx4zgbksrwfh5nw857n674l-podman-5.1.1)

for store_item in ${gnu_store[@]}
do
find "$store_item" -type f -exec strings {} \; |
grep "/gnu/store/................................-" |
grep -v ":" |
sort -u
done

exec -a "$0" "/gnu/store/12mvay4cpsx4zgbksrwfh5nw857n674l-podman-5.1.1/bin/.podman-real" "$@"
exec -a "$0" "/gnu/store/ggmq3xhnbdvlyc22hxqdwhbbkh1z82q5-buildah-1.36.0/bin/.buildah-real" "$@"
export CONTAINERS_HELPER_BINARY_DIR="/gnu/store/ggmq3xhnbdvlyc22hxqdwhbbkh1z82q5-buildah-1.36.0/_guix"
/gnu/store/12mvay4cpsx4zgbksrwfh5nw857n674l-podman-5.1.1/bin
/gnu/store/12mvay4cpsx4zgbksrwfh5nw857n674l-podman-5.1.1/_guix
/gnu/store/4w1jppw9dv5ard2yi3dqlmscg0yfnarh-gpgme-1.18.0/lib/libgpgmepp.so
/gnu/store/4w1jppw9dv5ard2yi3dqlmscg0yfnarh-gpgme-1.18.0/lib/libgpgmepp.so.6
/gnu/store/4w1jppw9dv5ard2yi3dqlmscg0yfnarh-gpgme-1.18.0/lib/libgpgme.so
/gnu/store/4w1jppw9dv5ard2yi3dqlmscg0yfnarh-gpgme-1.18.0/lib/libgpgme.so.11
/gnu/store/55zmgnm171z03cx4y9iscvkkyf85phwr-libseccomp-2.5.4/lib/libseccomp.so
/gnu/store/55zmgnm171z03cx4y9iscvkkyf85phwr-libseccomp-2.5.4/lib/libseccomp.so.2
#!/gnu/store/5mzqf6fz9bz30ybgx7jrqw424qbg9rbk-bash-minimal-5.1.16/bin/bash
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libasan.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libasan.so.6
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libatomic.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libatomic.so.1
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libcc1.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libcc1.so.0
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libgcc_s.so.1
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libgomp.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libgomp.so.1
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libitm.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libitm.so.1
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/liblsan.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/liblsan.so.0
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libquadmath.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libquadmath.so.0
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libssp.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libssp.so.0
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libstdc++.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libstdc++.so.6
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libtsan.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libtsan.so.0
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libubsan.so
/gnu/store/6ncav55lbk5kqvwwflrzcr41hp5jbq0c-gcc-11.3.0-lib/lib/libubsan.so.1
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/ld-linux-x86-64.so.2
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libanl.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libanl.so.1
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libBrokenLocale.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libBrokenLocale.so.1
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libc_malloc_debug.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libc_malloc_debug.so.0
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libcrypt.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libcrypt.so.1
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libc.so.6
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libdl.so.2
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libmemusage.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libm.so.6
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libmvec.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libmvec.so.1
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnsl.so.1
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnss_compat.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnss_compat.so.2
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnss_db.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnss_db.so.2
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnss_dns.so.2
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnss_files.so.2
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnss_hesiod.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libnss_hesiod.so.2
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libpcprofile.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libpthread.so.0
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libresolv.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libresolv.so.2
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/librt.so.1
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libthread_db.so
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libthread_db.so.1
/gnu/store/ln6hxqjvz6m9gdd9s97pivlqck7hzs99-glibc-2.35/lib/libutil.so.1
/gnu/store/q36qjkk0vchk31q3jipmv1vbhj273yxn-libassuan-2.5.5/lib/libassuan.so
/gnu/store/q36qjkk0vchk31q3jipmv1vbhj273yxn-libassuan-2.5.5/lib/libassuan.so.0
/gnu/store/r2zwkcq2bqamhbz85i48l8rvrbvmyqp7-libgpg-error-1.45/lib/libgpg-error.so
/gnu/store/r2zwkcq2bqamhbz85i48l8rvrbvmyqp7-libgpg-error-1.45/lib/libgpg-error.so.0

The -trimpath is part of the go-build-system now.

Toggle snippet (7 lines)
-trimpath
remove all file system paths from the resulting executable.
Instead of absolute file system paths, the recorded file names
will begin either a module path@version (when using modules),
or a plain import path (when using the standard library, or GOPATH).

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmaFyY4ACgkQdtcnv/Ys
0rUG5hAAwUWwELTz3iQgA5TeWvfOkyuhE+Po8F6mhs3bhAIPb22nAabx9XBHz4w7
GHnZHJveCRYEDEXpn/Qes8Dc3xSJXodUJgMqpiSBndutPeNKZHEeEs609fEd9dvU
y0mljYe3IznhC5YpXPjC/M4yxE+t0OWW/dRYru+sGACvZqQ0BROvZu69YFvPyYMg
iqGGBxNgWIKlAfSfY2tp/x/K5uUEBwXW0LP3BFGxH2VIS1KLqthLZBFQxRkwiiNB
TIpTblmYK4GSqVJNp9hdqvNY/dWUwsa+UNTVVvOmeRd3GffIrdFZfBqwO6C/fAKH
MgOAWUWRQTLsogTUDYnCpG67Ips6b5VY2L6oF5knc37TSWOoII3JNn8sFETQKXn5
d4MgD9u8FrL8+HsRv/2OI5wiGxBm/cZgZVG/vKLRdS9umN55RB5jW04DxmgXgxhH
33m+BpEt0FRC3foDQ488vqJlQALh/vDntcD6cd3A6hENI8RAKMWixRyYl0HCks6/
0HfMQ1p3ZxD4p+sg9xWN8xi6212Dkbi6hnfCz1oeEb810EB+RQ9qbvhhxKVFl1gw
tAlqgqJ8uNzdGfd/l0OUVaR1TPBMoIT/HxAkfeHTN6BzqgiIF2pG288UMtC7TgWy
4Vq0lQuRGoM8yqitPFBtIT/mYgkuJY6YuRS8AtTwRTAXogwk6fQ=
=K4+j
-----END PGP SIGNATURE-----

S
S
Sharlatan Hellseher wrote on 4 Jul 00:00 +0200
(address . 71923-done@debbugs.gnu.org)
87le2idtkh.fsf@gmail.com
Pushed as 13ae21cd05..2dd43fdacc to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmaFyg4ACgkQdtcnv/Ys
0rVsJhAAugcWY+2BaC60PiSnn6NlY2tv9pDg9wxXHAnKkq+j2hS0Zoc4s1WC/cXG
U7r1TlemMbrgvDBLIWEYydM9MVsB11Ns3yMuT36v+L7Vqy0B44jlJys4u1f8IU2m
Yz4HEx2ynDuVlPr/cwJyBEEgyYMiH78dk7UV9MJShzuZ+uegszF2TSioEEZcx+Hq
sv/CGUIuxt1ktlz7DQ+Oki7GZpw0eFYN7+QzAiInEUHhbj8cpwCqznjevMZmFO78
y3QuiFC9PZUVAiALw/I/q0X3Tn3EcYj/NMCpIV/pMraTHZNuVWNPeB5RFPySs54q
6ZM8Lv7RbBbrtI0urKH/F7cBa42qoTsXKKPv8N0P86kfca9tzVZ7lZeNlOlsfRpm
YQOLzk9bjoZZD1ek2gXD0MD5FQNNKI+FhrUFYMnWUzYCOrSX6YR/uN7+QDxblDjX
CNR8XBGlOmBzpxsPXqYfk44NV32awCEzISIlTpmYuTvf9FJECXOgCCETitMrTiUd
eH0ZTrDj2KGZGON839ls1RGutTZlA+NhCuGX6Rz+cjj4v6UHS2QH3F9akt0ptYjH
PpVeEc/7Mf0c2S+I/NjtIYPHydO1+uivsaeI06ewsIdP64St1CSZbsa+bPT+VN1S
mB8ddpvRz9k5vhdu2103I2mgK2nwkwjeCRSCCxrAWUP0QAdF5sI=
=giZM
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71923@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71923
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch