Diffoscope test suite fails with openssh 9.8p1

  • Done
  • quality assurance status badge
Details
3 participants
  • Kaelyn
  • Richard Sent
  • Vagrant Cascadian
Owner
unassigned
Submitted by
Richard Sent
Severity
normal
R
R
Richard Sent wrote on 1 Jul 23:50 +0200
(address . bug-guix@gnu.org)
87frssdboj.fsf@freakingpenguin.com
Hi all,

With Guix 6522f93ed098fa13f51f6d017035607e26237d31 diffoscope's test
suite fails. I'm reporting this here in case we want to try to implement
some kind of workaround in the meantime.

Diffoscope does not seem to have an upstream issue opened yet. I tried
reporting it but was blocked by the classic "yet another gitlab account
that needs manual approval" problem. It's possible this problem is
unique to Guix though.

I tried upgrading Guix's Diffoscope to 271 and encountered the same
issue.

Toggle snippet (33 lines)
=================================== FAILURES ===================================
__________________________________ test_diff ___________________________________

differences = []

@skip_unless_tool_is_at_least("ssh-keygen", openssh_version, "6.9")
def test_diff(differences):
expected_diff = get_data("openssh_pub_key_expected_diff")
> assert differences[0].unified_diff == expected_diff
E IndexError: list index out of range

tests/comparators/test_openssh_pub_key.py:60: IndexError
__________________________ test_compare_non_existing ___________________________

monkeypatch = <_pytest.monkeypatch.MonkeyPatch object at 0x7fffefd20190>
opensshpubkey1 = <<class 'abc.PublicKeyFile'> /tmp/guix-build-diffoscope-271.drv-0/source/tests/data/test_openssh_pub_key1.pub>

@skip_unless_tools_exist("ssh-keygen")
def test_compare_non_existing(monkeypatch, opensshpubkey1):
monkeypatch.setattr(Config(), "new_file", True)
difference = opensshpubkey1.compare(
MissingFile("/nonexisting", opensshpubkey1)
)
assert difference.source2 == "/nonexisting"
> assert len(difference.details) > 0
E assert 0 > 0
E + where 0 = len([])
E + where [] = <Difference /tmp/guix-build-diffoscope-271.drv-0/source/tests/data/test_openssh_pub_key1.pub -- /nonexisting []>.details

tests/comparators/test_openssh_pub_key.py:70: AssertionError


--
Take it easy,
Richard Sent
Making my computer weirder one commit at a time.
R
K
K
Kaelyn wrote on 5 Jul 02:06 +0200
bug#71886: Diffoscope test suite fails with openssh 9.8p1
(name . 71886@debbugs.gnu.org)(address . 71886@debbugs.gnu.org)
zxddYTrEUyaI5wryH9PjIr42ADknyHienaBK9RoPwziscJAjb8L1cVL1iYA7Xgf8ckibB0lQ_a0IlyclQpM4puq-lLIaSQjzxluaKzLUphY=@protonmail.com
Hi Richard,

I've encountered the diffoscope failure as well, and looked at their repo to see how new version 271 was and what activity has happened since. It looks like they may have already fixed the test failures, pending a new release: https://salsa.debian.org/reproducible-builds/diffoscope/-/commit/0743d63f85f298131e78045ec6d73acdc50b97eb

Cheers,
Kaelyn
V
V
Vagrant Cascadian wrote on 5 Jul 21:13 +0200
(address . 71886@debbugs.gnu.org)
87zfqvd53z.fsf@wireframe
On 2024-07-05, Kaelyn wrote:
Toggle quote (6 lines)
> I've encountered the diffoscope failure as well, and looked at their
> repo to see how new version 271 was and what activity has happened
> since. It looks like they may have already fixed the test failures,
> pending a new release:
> https://salsa.debian.org/reproducible-builds/diffoscope/-/commit/0743d63f85f298131e78045ec6d73acdc50b97eb

And 272 is tagged with hopefully minor other changes ... working on a
patch now!

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZohF4AAKCRDcUY/If5cW
qo8EAP9GG21sbvM2v/ulPa5ST56SbhkfqzHPWkcfrAh3Ro5vmgD7B2WcgEQ/34GZ
xYCg9N9poOdNi/mvZvB5oe7LwhnAAgs=
=gG4/
-----END PGP SIGNATURE-----

V
V
Vagrant Cascadian wrote on 5 Jul 21:28 +0200
(address . 71886-done@debbugs.gnu.org)
87wmlzd4ei.fsf@wireframe
On 2024-07-05, Vagrant Cascadian wrote:
Toggle quote (10 lines)
> On 2024-07-05, Kaelyn wrote:
>> I've encountered the diffoscope failure as well, and looked at their
>> repo to see how new version 271 was and what activity has happened
>> since. It looks like they may have already fixed the test failures,
>> pending a new release:
>> https://salsa.debian.org/reproducible-builds/diffoscope/-/commit/0743d63f85f298131e78045ec6d73acdc50b97eb
>
> And 272 is tagged with hopefully minor other changes ... working on a
> patch now!

Pushed as e725e47a695c82305fa65e63e54477c6a210f53d.

The upstream changes were very minor, essentially only fixing this one
issue triggering build failure and a few debian-specific changes, so
hopefully it was ok to just go ahead and push it.

Thanks for reporting the issue and pointing out the fix was in progress!

live well,
vagrant
-----BEGIN PGP SIGNATURE-----

iHUEARYKAB0WIQRlgHNhO/zFx+LkXUXcUY/If5cWqgUCZohJdQAKCRDcUY/If5cW
qmWyAP9j4DTNH/5hFNRuo4Mx2HqNyepDet1Dm/drAwMYztARBgEAgVwAYeg1uEUc
PlNbHVihBo0n1jMr1rCXnH7aZ5Vo/AA=
=zn/4
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71886@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71886
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch