[PATCH 0/3] gnu: emacs-telega

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 8 months ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
cover.1719866335.git.sarg@sarg.org.ru
Hi guix,

Sergey Trofimov (3):
gnu: Add tgs2png.
gnu: emacs-telega: Separate server and lisp packages.
gnu: emacs-telega: Update to 0.8.291.

gnu/packages/animation.scm | 31 +++++++++
gnu/packages/emacs-xyz.scm | 128 +++++++++++++++++++++----------------
2 files changed, 104 insertions(+), 55 deletions(-)


base-commit: 85012e64819b39fd6112038134548b415fd5daff
prerequisite-patch-id: f9cc903b8048c8c6fde576fbf38ab110263020e3
prerequisite-patch-id: 1bcd992c56c1b094479b842032fc9731315cbf83
--
2.45.2
Sergey Trofimov wrote 8 months ago
[PATCH 1/3] gnu: Add tgs2png.
(address . 71885@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
07470723cc983df6e90a238ef65b8aca8ada9b6b.1719866335.git.sarg@sarg.org.ru
* gnu/packages/animation.scm (tgs2png): New variable.
---
gnu/packages/animation.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (44 lines)
diff --git a/gnu/packages/animation.scm b/gnu/packages/animation.scm
index 3bcf1cc8f0..869f0d2c00 100644
--- a/gnu/packages/animation.scm
+++ b/gnu/packages/animation.scm
@@ -468,6 +468,37 @@ (define-public pencil2d
and vector graphics.")
(license license:gpl2)))
+(define-public tgs2png
+ (let ((commit "25c15b7c2ca3b1a580a383d9d3cb13bf8531d04a")
+ (revision "0"))
+ (package
+ (name "tgs2png")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zevlg/tgs2png")
+ (commit commit)))
+ (sha256
+ (base32 "0camvzapkfvr9v0nkk96n26rdmw0g8wbpv41i5l03j6bzdgm4myl"))
+ (file-name (git-file-name "tgs2png" version))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ (delete-file-recursively "rlottie")
+ #t))))
+ (arguments '(#:tests? #f))
+ (build-system cmake-build-system)
+ (inputs
+ (list rlottie libpng))
+ (native-inputs
+ (list pkg-config))
+ (home-page "https://github.com/zevlg/tgs2png")
+ (synopsis "Convert Telegram's animated stickers to PNG")
+ (description "Convert Telegram's animated stickers in TGS format into series of PNG images.")
+ (license license:gpl3+))))
+
(define-public swftools
;; Last release of swftools was 0.9.2 on 2012-04-21 - it is really old and
;; does not compile with what's available in guix, master on the other hand works.
--
2.45.2
Sergey Trofimov wrote 8 months ago
[PATCH 2/3] gnu: emacs-telega: Separate server and lisp packages.
(address . 71885@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
970950e50d7bc58fcc56a4abd8b0f9d3288cf91b.1719866335.git.sarg@sarg.org.ru
* gnu/packages/emacs-xyz.scm (emacs-telega-server): Use own version.
(emacs-telega): Remove inheritance.
---
gnu/packages/emacs-xyz.scm | 123 ++++++++++++++++++++-----------------
1 file changed, 68 insertions(+), 55 deletions(-)

Toggle diff (153 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ab6a4cf4ab..57f1cfece4 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -35388,11 +35388,11 @@ (define-public emacs-helm-switch-to-repl
(license license:gpl3+)))
(define-public emacs-telega-server
- (let ((commit "009e5ce9d393aa049bb3b1182306db4b5b85833b")
+ (let ((commit "879a8c7afc8967942613b6b898d9ea8c1f3641bf")
(revision "0"))
(package
(name "emacs-telega-server")
- (version (git-version "0.8.290" revision commit))
+ (version (git-version "0.8.2" revision commit))
(source
(origin
(method git-fetch)
@@ -35400,11 +35400,8 @@ (define-public emacs-telega-server
(url "https://github.com/zevlg/telega.el")
(commit commit)))
(sha256
- (base32 "06k2qkxzq3l3cdqr70zrxrnm3q6qp9nw3zgm3p65nmx86ky1q72f"))
- (file-name (git-file-name "emacs-telega" version))
- (patches
- (search-patches "emacs-telega-path-placeholder.patch"
- "emacs-telega-test-env.patch"))))
+ (base32 "1ic14hzzgjxpky1r3mz4v72si9hw8cw72420a9lnpdaiw99l8q7h"))
+ (file-name (git-file-name "emacs-telega" version))))
(build-system gnu-build-system)
(arguments
(list
@@ -35438,54 +35435,70 @@ (define-public emacs-telega-server
(license license:gpl3+))))
(define-public emacs-telega
- (package
- (inherit emacs-telega-server)
- (name "emacs-telega")
- (build-system emacs-build-system)
- (arguments
- (list
- #:emacs (if (target-64bit?)
- emacs-minimal
- ;; Require wide-int support for 32-bit platform.
- emacs-wide-int)
- #:include #~(cons "^etc\\/" %default-include)
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'patch-sources
- (lambda* (#:key inputs #:allow-other-keys)
- ;; Hard-code paths to `ffplay` and `ffmpeg`.
- (let* ((ffplay-bin (search-input-file inputs "/bin/ffplay"))
- (ffmpeg-bin (search-input-file inputs "/bin/ffmpeg")))
- (substitute* '("telega-ffplay.el" "telega-vvnote.el")
- (("(shell-command-to-string\|concat) \"(ffmpeg\|ffprobe)"
- all func cmd)
- (string-append func " \""
- (search-input-file
- inputs (string-append "/bin/" cmd))))
- (("\\(executable-find \"ffplay\"\\)")
- (string-append "(and (file-executable-p \"" ffplay-bin "\")"
- "\"" ffplay-bin "\")"))
- (("\\(executable-find \"ffmpeg\"\\)")
- (string-append "(and (file-executable-p \"" ffmpeg-bin "\")"
- "\"" ffmpeg-bin "\")"))))))
- (add-after 'unpack 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (substitute* "telega-customize.el"
- (("@TELEGA_SERVER_BIN@")
- (search-input-file inputs "/bin/telega-server")))
- (substitute* "telega-core.el"
- (("@TELEGA_SHARE@")
- (string-append (elpa-directory (assoc-ref outputs "out"))
- "/etc"))))))))
- (inputs
- (list emacs-telega-server ffmpeg))
- (native-inputs '())
- (propagated-inputs
- (list emacs-visual-fill-column emacs-company
- emacs-rainbow-identifiers))
- (synopsis "GNU Emacs client for the Telegram messenger")
- (description "Telega is a full-featured, unofficial GNU Emacs-based client
-for the Telegram messaging platform.")))
+ (let ((commit "009e5ce9d393aa049bb3b1182306db4b5b85833b")
+ (revision "1"))
+ (package
+ (name "emacs-telega")
+ (version (git-version "0.8.290" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zevlg/telega.el")
+ (commit commit)))
+ (sha256
+ (base32 "06k2qkxzq3l3cdqr70zrxrnm3q6qp9nw3zgm3p65nmx86ky1q72f"))
+ (file-name (git-file-name "emacs-telega" version))
+ (patches
+ (search-patches "emacs-telega-path-placeholder.patch"
+ "emacs-telega-test-env.patch"))))
+ (build-system emacs-build-system)
+ (arguments
+ (list
+ #:emacs (if (target-64bit?)
+ emacs-minimal
+ ;; Require wide-int support for 32-bit platform.
+ emacs-wide-int)
+ #:include #~(cons "^etc\\/" %default-include)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-sources
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Hard-code paths to `ffplay` and `ffmpeg`.
+ (let* ((ffplay-bin (search-input-file inputs "/bin/ffplay"))
+ (ffmpeg-bin (search-input-file inputs "/bin/ffmpeg")))
+ (substitute* '("telega-ffplay.el" "telega-vvnote.el")
+ (("(shell-command-to-string\|concat) \"(ffmpeg\|ffprobe)"
+ all func cmd)
+ (string-append func " \""
+ (search-input-file
+ inputs (string-append "/bin/" cmd))))
+ (("\\(executable-find \"ffplay\"\\)")
+ (string-append "(and (file-executable-p \"" ffplay-bin "\")"
+ "\"" ffplay-bin "\")"))
+ (("\\(executable-find \"ffmpeg\"\\)")
+ (string-append "(and (file-executable-p \"" ffmpeg-bin "\")"
+ "\"" ffmpeg-bin "\")"))))))
+ (add-after 'unpack 'configure
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (substitute* "telega-customize.el"
+ (("@TELEGA_SERVER_BIN@")
+ (search-input-file inputs "/bin/telega-server")))
+ (substitute* "telega-core.el"
+ (("@TELEGA_SHARE@")
+ (string-append (elpa-directory (assoc-ref outputs "out"))
+ "/etc"))))))))
+ (inputs
+ (list emacs-telega-server ffmpeg))
+ (native-inputs '())
+ (propagated-inputs
+ (list emacs-visual-fill-column emacs-company
+ emacs-rainbow-identifiers))
+ (home-page "https://zevlg.github.io/telega.el/")
+ (synopsis "GNU Emacs client for the Telegram messenger")
+ (description "Telega is a full-featured, unofficial GNU Emacs-based client
+for the Telegram messaging platform.")
+ (license license:gpl3+))))
(define-public emacs-telega-contrib
(package
--
2.45.2
Sergey Trofimov wrote 8 months ago
[PATCH 3/3] gnu: emacs-telega: Update to 0.8.291.
(address . 71885@debbugs.gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
b9eb77b0f44a73c4d3aa19edcbecc47f94eecf06.1719866335.git.sarg@sarg.org.ru
* gnu/packages/emacs-xyz.scm (emacs-telega): Update to 0.8.291.
[inputs]: Add tgs2png.
---
gnu/packages/emacs-xyz.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)

Toggle diff (60 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 57f1cfece4..76cd340e5e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -262,6 +262,7 @@ (define-module (gnu packages emacs-xyz)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages password-utils)
#:use-module (gnu packages pulseaudio)
+ #:use-module (gnu packages animation)
#:use-module (gnu packages sphinx)
#:use-module (gnu packages screen)
#:use-module (gnu packages xdisorg)
@@ -35435,11 +35436,11 @@ (define-public emacs-telega-server
(license license:gpl3+))))
(define-public emacs-telega
- (let ((commit "009e5ce9d393aa049bb3b1182306db4b5b85833b")
- (revision "1"))
+ (let ((commit "58b4963b292ceb723d665df100b519eb5a99c676")
+ (revision "0"))
(package
(name "emacs-telega")
- (version (git-version "0.8.290" revision commit))
+ (version (git-version "0.8.291" revision commit))
(source
(origin
(method git-fetch)
@@ -35447,7 +35448,7 @@ (define-public emacs-telega
(url "https://github.com/zevlg/telega.el")
(commit commit)))
(sha256
- (base32 "06k2qkxzq3l3cdqr70zrxrnm3q6qp9nw3zgm3p65nmx86ky1q72f"))
+ (base32 "1q3ydbm0jhrsyvvdn0mpmxvskq0l53jkh40a5hlx7i3qkinbhbry"))
(file-name (git-file-name "emacs-telega" version))
(patches
(search-patches "emacs-telega-path-placeholder.patch"
@@ -35466,7 +35467,11 @@ (define-public emacs-telega
(lambda* (#:key inputs #:allow-other-keys)
;; Hard-code paths to `ffplay` and `ffmpeg`.
(let* ((ffplay-bin (search-input-file inputs "/bin/ffplay"))
- (ffmpeg-bin (search-input-file inputs "/bin/ffmpeg")))
+ (ffmpeg-bin (search-input-file inputs "/bin/ffmpeg"))
+ (tgs2png-bin (search-input-file inputs "/bin/tgs2png")))
+ (substitute* '("telega.el" "telega-sticker.el" "telega-customize.el")
+ (("\\(executable-find \"tgs2png\"\\)")
+ (string-append "\"" tgs2png-bin "\"")))
(substitute* '("telega-ffplay.el" "telega-vvnote.el")
(("(shell-command-to-string\|concat) \"(ffmpeg\|ffprobe)"
all func cmd)
@@ -35489,7 +35494,7 @@ (define-public emacs-telega
(string-append (elpa-directory (assoc-ref outputs "out"))
"/etc"))))))))
(inputs
- (list emacs-telega-server ffmpeg))
+ (list emacs-telega-server ffmpeg tgs2png))
(native-inputs '())
(propagated-inputs
(list emacs-visual-fill-column emacs-company
--
2.45.2
Andrew Tropin wrote 8 months ago
Re: [bug#71885] [PATCH 0/3] gnu: emacs-telega
877ce4i35b.fsf@trop.in
On 2024-07-01 22:47, Sergey Trofimov wrote:

Toggle quote (16 lines)
> Hi guix,
>
> Sergey Trofimov (3):
> gnu: Add tgs2png.
> gnu: emacs-telega: Separate server and lisp packages.
> gnu: emacs-telega: Update to 0.8.291.
>
> gnu/packages/animation.scm | 31 +++++++++
> gnu/packages/emacs-xyz.scm | 128 +++++++++++++++++++++----------------
> 2 files changed, 104 insertions(+), 55 deletions(-)
>
>
> base-commit: 85012e64819b39fd6112038134548b415fd5daff
> prerequisite-patch-id: f9cc903b8048c8c6fde576fbf38ab110263020e3
> prerequisite-patch-id: 1bcd992c56c1b094479b842032fc9731315cbf83

Hello Sergey!

Thank you for the updates, applied, pushed as

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmaDwJAACgkQIgjSCVjB
3rA2KBAAiTy5LwcSm5qNHQvWmDZ+ysIz2AtHrxgdNxI8Jnch0s2N+wkOrq1RyKxO
JuwaRtj2oz+hC8ZsM1X1V2iYjO0WtYraQ9Z6zID6kKUXB5ZEv+5wytMrl+LnkHVK
rYASQHSxGiE9HBciwKjlui6lImhQslP2gRJO7fAY9K807hg7dF4sHR+a0DCqAlSq
akDH1Gw1Nswl0+g2CmFZ6mjnz6DDhBe92q0D6pJyanEC+sa8p/AM7FW3waGjzqwB
0swzzewytgzOITYSscuB+xh9+XZC/JpSOF9aXfuSSn1MSaxHvMR9uDkuF+HfR6Zb
RFwC7/as7rU28ADVg2bJF8I0UpdRjEZEgvZ0freCdJxvyWyhiSx6WcJxhlxYibiS
XhFeyCrG/+hhAG7T8U47bAlBdZzP2Q6uUbmAL6/Hb35j0BRa9SFrx0F5RB5tbht/
nKgIEo2r62ePgnSSbW4nPA7gxGQoODOfnVn7z8iPg0v6DFpHV/5C8QohpT7sfsWw
cxArqGSHgZy2ZowOhojvwR8VMZXBvB/6Toxk9y+c06RQVD8qry3SlCRLCXkObUvu
7WdrAaj8gdCYkRTpUwUQexxssdPMkNTSXLBATMsGEHY4GFbrtXzv/YkvCvS5TThx
WCI6r2ADuhAZdN/9NIuZXRwNjLaZmVD9y9ed7Q8UXS/GE1v7QKg=
=nES6
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71885@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71885
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help