[PATCH 0/3] python-dolfin-adjoint: Refresh package style.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Sharlatan Hellseher
Severity
normal

Debbugs page

Sharlatan Hellseher wrote 8 months ago
(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
cover.1719866387.git.sharlatanus@gmail.com
Hi Guix!

that the package would need to be refreshed. I mistakenly thought it was
failing to build, but it actually failed to complete the build due to a
timeout with other dependencies, specifically fenics-dolfin.

Sharlatan Hellseher (3):
gnu: python-dolfin-adjoint: Fix indentation.
gnu: python-dolfin-adjoint: Adjust package style.
gnu: python-dolfin-adjoint: Swap to pyproject-build-system.

gnu/packages/simulation.scm | 122 +++++++++++++++++-------------------
1 file changed, 58 insertions(+), 64 deletions(-)


base-commit: 85012e64819b39fd6112038134548b415fd5daff
--
2.41.0
Sharlatan Hellseher wrote 8 months ago
[PATCH 1/3] gnu: python-dolfin-adjoint: Fix indentation.
(address . 71884@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
85179153ce289e6ad62faddb3022bc01b3c28afb.1719866387.git.sharlatanus@gmail.com
* gnu/packages/simulation.scm (python-dolfin-adjoint): Fix indentation.

Change-Id: I457639a98f1ae49d43042e557352d390afc9419d
---
gnu/packages/simulation.scm | 48 ++++++++++++++++++-------------------
1 file changed, 24 insertions(+), 24 deletions(-)

Toggle diff (68 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 4fa2e93d81..ab86e1d792 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1180,29 +1180,29 @@ (define-public python-dolfin-adjoint
(name "python-dolfin-adjoint")
(version "2019.1.0")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dolfin-adjoint/pyadjoint")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xhy76a5f33hz94wc9g2mc5qmwkxfccbbc6yxl7psm130afp8lhn"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; One of the migration tests attempts to call openmpi
- ;; recursively and fails. See
- ;; https://bitbucket.org/mpi4py/mpi4py/issues/95. Run the
- ;; test sequentially instead.
- (with-directory-excursion "tests/migration/optimal_control_mms"
- (substitute* "test_optimal_control_mms.py"
- (("\\\"mpirun\\\", \\\"-n\\\", \\\"2\\\", ") "")))
- ;; Result files are regenerated in the check phase.
- (delete-file-recursively
- "tests/migration/viscoelasticity/test-results")
- #t))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dolfin-adjoint/pyadjoint")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xhy76a5f33hz94wc9g2mc5qmwkxfccbbc6yxl7psm130afp8lhn"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; One of the migration tests attempts to call openmpi
+ ;; recursively and fails. See
+ ;; https://bitbucket.org/mpi4py/mpi4py/issues/95. Run the
+ ;; test sequentially instead.
+ (with-directory-excursion "tests/migration/optimal_control_mms"
+ (substitute* "test_optimal_control_mms.py"
+ (("\\\"mpirun\\\", \\\"-n\\\", \\\"2\\\", ") "")))
+ ;; Result files are regenerated in the check phase.
+ (delete-file-recursively
+ "tests/migration/viscoelasticity/test-results")
+ #t))))
(build-system python-build-system)
(inputs
(list fenics openmpi pybind11))
@@ -1219,7 +1219,7 @@ (define-public python-dolfin-adjoint
`(#:phases
(modify-phases %standard-phases
(add-after 'build 'mpi-setup
- ,%openmpi-setup)
+ ,%openmpi-setup)
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((doc (string-append (assoc-ref outputs "out")
--
2.41.0
Sharlatan Hellseher wrote 8 months ago
[PATCH 3/3] gnu: python-dolfin-adjoint: Swap to pyproject-build-system.
(address . 71884@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
b8fc7fae3685d40fc416833129bd7ac3ed2ee8a1.1719866387.git.sharlatanus@gmail.com
* gnu/packages/simulation.scm (python-dolfin-adjoint) [source]: Remove
trailing #t from snippet.
[build-system]: Swap to pyproject-build-system.
[arguments]: Apply G-expressions. <#:phases>: Swap back to defaul 'check
phase.

python-dolfin-adjoint

Change-Id: Idf100b718b44d9d6695e598c434fbbac55a38845
---
gnu/packages/simulation.scm | 58 +++++++++++++++++--------------------
1 file changed, 26 insertions(+), 32 deletions(-)

Toggle diff (72 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 5341c0ae55..182e00cec4 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1201,39 +1201,33 @@ (define-public python-dolfin-adjoint
(("\\\"mpirun\\\", \\\"-n\\\", \\\"2\\\", ") "")))
;; Result files are regenerated in the check phase.
(delete-file-recursively
- "tests/migration/viscoelasticity/test-results")
- #t))))
- (build-system python-build-system)
+ "tests/migration/viscoelasticity/test-results")))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'build 'mpi-setup
- ,%openmpi-setup)
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((doc (string-append (assoc-ref outputs "out")
- "/share/doc/" ,name "-"
- ,version))
- (examples (string-append doc "/examples")))
- (mkdir-p examples)
- (copy-recursively "examples" examples))
- #t))
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (setenv "HOME" (getcwd))
- (and (invoke "py.test" "-v" "tests/fenics_adjoint"
- "-k" "not test_read_checkpoint")
- (invoke "py.test" "-v" "tests/migration")
- (invoke "py.test" "-v" "tests/pyadjoint")))
- #t))
- ;; Remove 'sanity-check, because it tries to import
- ;; firedrake_adjoint after importing fenics_adjoint.
- ;; Both load a module named 'backend' and firedrake_adjoint
- ;; fails with an ImportError if it sees that the backend module
- ;; has already been loaded.
- (delete 'sanity-check))))
+ (list
+ #:test-flags
+ #~(list "tests/firedrake_adjoint/"
+ "tests/migration"
+ "tests/pyadjoint/"
+ "-k" "not test_read_checkpoint")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'mpi-setup ,%openmpi-setup)
+ (add-before 'check 'set-environment-variables
+ (lambda _
+ (setenv "HOME" "/tmp")))
+ (add-after 'install 'install-doc
+ (lambda _
+ (let* ((doc (string-append #$output "/share/doc/" name "-" version))
+ (examples (string-append doc "/examples")))
+ (mkdir-p examples)
+ (copy-recursively "examples" examples))))
+ ;; Remove 'sanity-check, because it tries to import
+ ;; firedrake_adjoint after importing fenics_adjoint.
+ ;; Both load a module named 'backend' and firedrake_adjoint
+ ;; fails with an ImportError if it sees that the backend module
+ ;; has already been loaded.
+ (delete 'sanity-check))))
(inputs
(list fenics openmpi pybind11))
(native-inputs
--
2.41.0
Sharlatan Hellseher wrote 8 months ago
[PATCH 2/3] gnu: python-dolfin-adjoint: Adjust package style.
(address . 71884@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
e867be72f70cea33a83eaf2709bd2cb1f4be8f9d.1719866387.git.sharlatanus@gmail.com
* gnu/packages/simulation.scm (python-dolfin-adjoint): Move inputs after
arguments.
[description]: Place it on a new line, fix indentation.

Change-Id: I3d971e48b4072258ed0b41af5c202e64af9de8f3
---
gnu/packages/simulation.scm | 40 ++++++++++++++++++-------------------
1 file changed, 20 insertions(+), 20 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index ab86e1d792..5341c0ae55 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1204,17 +1204,6 @@ (define-public python-dolfin-adjoint
"tests/migration/viscoelasticity/test-results")
#t))))
(build-system python-build-system)
- (inputs
- (list fenics openmpi pybind11))
- (native-inputs
- (list pkg-config
- python-coverage
- python-decorator
- python-flake8
- python-pkgconfig
- python-pytest))
- (propagated-inputs
- `(("scipy" ,python-scipy)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1245,17 +1234,28 @@ (define-public python-dolfin-adjoint
;; fails with an ImportError if it sees that the backend module
;; has already been loaded.
(delete 'sanity-check))))
+ (inputs
+ (list fenics openmpi pybind11))
+ (native-inputs
+ (list pkg-config
+ python-coverage
+ python-decorator
+ python-flake8
+ python-pkgconfig
+ python-pytest))
+ (propagated-inputs
+ (list python-scipy))
(home-page "https://www.dolfin-adjoint.org")
(synopsis "Automatic differentiation library")
- (description "@code{python-dolfin-adjoint} is a solver of
-differential equations associated with a governing system and a
-functional of interest. Working from the forward model the solver
-automatically derives the discrete adjoint and tangent linear models.
-These additional models are key ingredients in many algorithms such as
-data assimilation, optimal control, sensitivity analysis, design
-optimisation and error estimation. The dolfin-adjoint project
-provides the necessary tools and data structures for cases where the
-forward model is implemented in @code{fenics} or
+ (description
+ "@code{python-dolfin-adjoint} is a solver of differential equations
+associated with a governing system and a functional of interest. Working from
+the forward model the solver automatically derives the discrete adjoint and
+tangent linear models. These additional models are key ingredients in many
+algorithms such as data assimilation, optimal control, sensitivity analysis,
+design optimisation and error estimation. The dolfin-adjoint project provides
+the necessary tools and data structures for cases where the forward model is
+implemented in @code{fenics} or
@url{https://firedrakeproject.org,firedrake}.")
(license license:lgpl3)))
--
2.41.0
jgart wrote 8 months ago
Re: [PATCH 0/3] python-dolfin-adjoint: Refresh package style.
(address . 71884@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
87wmltlwcd.fsf@dismail.de
Hi, this fails with the following:

ice-9/psyntax.scm:2824:12: In procedure syntax-violation:
Syntax error:
/gnu/store/aswasipy8cny2y8smvvihhrspy22j5gg-python-dolfin-adjoint-2019.1.0-builder:1:21039: unquote: expression not valid outside of quasiquote in form (unquote %openmpi-setup)
builder for `/gnu/store/i3x10rwqjbnli7a7fy5xa0kfdsz653pp-python-dolfin-adjoint-2019.1.0.drv' failed with exit code 1
build of /gnu/store/i3x10rwqjbnli7a7fy5xa0kfdsz653pp-python-dolfin-adjoint-2019.1.0.drv failed

--
all the best,
jgart
Sharlatan Hellseher wrote 8 months ago
[PATCH v2 1/4] gnu: python-dolfin-adjoint: Fix indentation.
(address . 71884@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
6ebbf954f399ca8347144b087fae787c2b071354.1720653590.git.sharlatanus@gmail.com
* gnu/packages/simulation.scm (python-dolfin-adjoint): Fix indentation.

Change-Id: I457639a98f1ae49d43042e557352d390afc9419d
---
gnu/packages/simulation.scm | 48 ++++++++++++++++++-------------------
1 file changed, 24 insertions(+), 24 deletions(-)

Toggle diff (70 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 4fa2e93d81..ab86e1d792 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1180,29 +1180,29 @@ (define-public python-dolfin-adjoint
(name "python-dolfin-adjoint")
(version "2019.1.0")
(source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/dolfin-adjoint/pyadjoint")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0xhy76a5f33hz94wc9g2mc5qmwkxfccbbc6yxl7psm130afp8lhn"))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; One of the migration tests attempts to call openmpi
- ;; recursively and fails. See
- ;; https://bitbucket.org/mpi4py/mpi4py/issues/95. Run the
- ;; test sequentially instead.
- (with-directory-excursion "tests/migration/optimal_control_mms"
- (substitute* "test_optimal_control_mms.py"
- (("\\\"mpirun\\\", \\\"-n\\\", \\\"2\\\", ") "")))
- ;; Result files are regenerated in the check phase.
- (delete-file-recursively
- "tests/migration/viscoelasticity/test-results")
- #t))))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dolfin-adjoint/pyadjoint")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0xhy76a5f33hz94wc9g2mc5qmwkxfccbbc6yxl7psm130afp8lhn"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin
+ ;; One of the migration tests attempts to call openmpi
+ ;; recursively and fails. See
+ ;; https://bitbucket.org/mpi4py/mpi4py/issues/95. Run the
+ ;; test sequentially instead.
+ (with-directory-excursion "tests/migration/optimal_control_mms"
+ (substitute* "test_optimal_control_mms.py"
+ (("\\\"mpirun\\\", \\\"-n\\\", \\\"2\\\", ") "")))
+ ;; Result files are regenerated in the check phase.
+ (delete-file-recursively
+ "tests/migration/viscoelasticity/test-results")
+ #t))))
(build-system python-build-system)
(inputs
(list fenics openmpi pybind11))
@@ -1219,7 +1219,7 @@ (define-public python-dolfin-adjoint
`(#:phases
(modify-phases %standard-phases
(add-after 'build 'mpi-setup
- ,%openmpi-setup)
+ ,%openmpi-setup)
(add-after 'install 'install-doc
(lambda* (#:key outputs #:allow-other-keys)
(let* ((doc (string-append (assoc-ref outputs "out")

base-commit: a1f89695560dca1ecedab131a33bb6c5f4584226
--
2.41.0
Sharlatan Hellseher wrote 8 months ago
[PATCH v2 4/4] gnu: python-dolfin-adjoint:; Disable failing tests, fix build.
(address . 71884@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
1a53f626e1f543fc2ac7bb7dfd6e47bc60995ca3.1720653590.git.sharlatanus@gmail.com
* gnu/packages/simulation.scm (python-dolfin-adjoint) [arguments]:
<#:test-flags>: Explicitly ignore failing tests during collection phase
and some tests during runt test phase.
<#:phases>: Change HOME env to GETCWD in 'set-environment-variable phase.

Change-Id: Ibee5e45052a3828b4522752a87c97367d7caec65
---
gnu/packages/simulation.scm | 25 ++++++++++++++++++++-----
1 file changed, 20 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index ad9f0080cc..99bd107c94 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1205,16 +1205,31 @@ (define-public python-dolfin-adjoint
(arguments
(list
#:test-flags
- #~(list "tests/fenics_adjoint"
- "tests/migration"
- "tests/pyadjoint"
- "-k" "not test_read_checkpoint")
+ #~(list
+ ;; Ignore tests which require missing packages and/or failed during
+ ;; tests collection.
+ "--ignore=tests/firedrake_adjoint/test_assignment.py"
+ "--ignore=tests/firedrake_adjoint/test_burgers_newton.py"
+ "--ignore=tests/firedrake_adjoint/test_dynamic_meshes.py"
+ "--ignore=tests/firedrake_adjoint/test_hessian.py"
+ "--ignore=tests/firedrake_adjoint/test_reduced_functional.py"
+ "--ignore=tests/firedrake_adjoint/test_shape_derivatives.py"
+ "--ignore=tests/firedrake_adjoint/test_solving.py"
+ "--ignore=tests/firedrake_adjoint/test_tlm.py"
+ "--ignore=tests/migration/burgers_newton/test_burgers_newton.py"
+ "--ignore=tests/migration/linear_solver/test_linear_solver.py"
+ "--ignore=tests/migration/optimization_scipy/test_optimization_scipy.py"
+ "--ignore=tests/migration/projection/test_projection.py"
+ "--ignore=tests/migration/reduced_functional/test_reduced_functional.py"
+ "--ignore=tests/migration/split/test_split.py"
+ "-k" (string-append "not test_read_checkpoint"
+ " and not test_krylov_solver_preconditioner_function_ctrl"))
#:phases
#~(modify-phases %standard-phases
(add-after 'build 'mpi-setup #$%openmpi-setup)
(add-before 'check 'set-environment-variables
(lambda _
- (setenv "HOME" "/tmp")))
+ (setenv "HOME" (getcwd))))
(add-after 'install 'install-doc
(lambda _
(let* ((doc (string-append #$output "/share/doc/" #$name "-" #$version))
--
2.41.0
Sharlatan Hellseher wrote 8 months ago
[PATCH v2 2/4] gnu: python-dolfin-adjoint: Adjust package style.
(address . 71884@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
67fd2d1ce61e184b8fc4fdd21eb7eee3c375cc52.1720653590.git.sharlatanus@gmail.com
* gnu/packages/simulation.scm (python-dolfin-adjoint): Move inputs after
arguments.
[description]: Place it on a new line, fix indentation.

Change-Id: I3d971e48b4072258ed0b41af5c202e64af9de8f3
---
gnu/packages/simulation.scm | 40 ++++++++++++++++++-------------------
1 file changed, 20 insertions(+), 20 deletions(-)

Toggle diff (62 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index ab86e1d792..5341c0ae55 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1204,17 +1204,6 @@ (define-public python-dolfin-adjoint
"tests/migration/viscoelasticity/test-results")
#t))))
(build-system python-build-system)
- (inputs
- (list fenics openmpi pybind11))
- (native-inputs
- (list pkg-config
- python-coverage
- python-decorator
- python-flake8
- python-pkgconfig
- python-pytest))
- (propagated-inputs
- `(("scipy" ,python-scipy)))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -1245,17 +1234,28 @@ (define-public python-dolfin-adjoint
;; fails with an ImportError if it sees that the backend module
;; has already been loaded.
(delete 'sanity-check))))
+ (inputs
+ (list fenics openmpi pybind11))
+ (native-inputs
+ (list pkg-config
+ python-coverage
+ python-decorator
+ python-flake8
+ python-pkgconfig
+ python-pytest))
+ (propagated-inputs
+ (list python-scipy))
(home-page "https://www.dolfin-adjoint.org")
(synopsis "Automatic differentiation library")
- (description "@code{python-dolfin-adjoint} is a solver of
-differential equations associated with a governing system and a
-functional of interest. Working from the forward model the solver
-automatically derives the discrete adjoint and tangent linear models.
-These additional models are key ingredients in many algorithms such as
-data assimilation, optimal control, sensitivity analysis, design
-optimisation and error estimation. The dolfin-adjoint project
-provides the necessary tools and data structures for cases where the
-forward model is implemented in @code{fenics} or
+ (description
+ "@code{python-dolfin-adjoint} is a solver of differential equations
+associated with a governing system and a functional of interest. Working from
+the forward model the solver automatically derives the discrete adjoint and
+tangent linear models. These additional models are key ingredients in many
+algorithms such as data assimilation, optimal control, sensitivity analysis,
+design optimisation and error estimation. The dolfin-adjoint project provides
+the necessary tools and data structures for cases where the forward model is
+implemented in @code{fenics} or
@url{https://firedrakeproject.org,firedrake}.")
(license license:lgpl3)))
--
2.41.0
Sharlatan Hellseher wrote 8 months ago
[PATCH v2 3/4] gnu: python-dolfin-adjoint: Swap to pyproject-build-system.
(address . 71884@debbugs.gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
bd719ecd51297f3bab716c6127f93d2406309c1f.1720653590.git.sharlatanus@gmail.com
* gnu/packages/simulation.scm (python-dolfin-adjoint) [source]: Remove
trailing #t from snippet.
[build-system]: Swap to pyproject-build-system.
[arguments]: Apply G-expressions. <#:phases>: Swap back to defaul 'check
phase.

python-dolfin-adjoint

Change-Id: Idf100b718b44d9d6695e598c434fbbac55a38845
---
gnu/packages/simulation.scm | 61 ++++++++++++++++---------------------
1 file changed, 27 insertions(+), 34 deletions(-)

Toggle diff (82 lines)
diff --git a/gnu/packages/simulation.scm b/gnu/packages/simulation.scm
index 5341c0ae55..ad9f0080cc 100644
--- a/gnu/packages/simulation.scm
+++ b/gnu/packages/simulation.scm
@@ -1187,8 +1187,7 @@ (define-public python-dolfin-adjoint
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32
- "0xhy76a5f33hz94wc9g2mc5qmwkxfccbbc6yxl7psm130afp8lhn"))
+ (base32 "0xhy76a5f33hz94wc9g2mc5qmwkxfccbbc6yxl7psm130afp8lhn"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -1201,39 +1200,33 @@ (define-public python-dolfin-adjoint
(("\\\"mpirun\\\", \\\"-n\\\", \\\"2\\\", ") "")))
;; Result files are regenerated in the check phase.
(delete-file-recursively
- "tests/migration/viscoelasticity/test-results")
- #t))))
- (build-system python-build-system)
+ "tests/migration/viscoelasticity/test-results")))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'build 'mpi-setup
- ,%openmpi-setup)
- (add-after 'install 'install-doc
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((doc (string-append (assoc-ref outputs "out")
- "/share/doc/" ,name "-"
- ,version))
- (examples (string-append doc "/examples")))
- (mkdir-p examples)
- (copy-recursively "examples" examples))
- #t))
- (replace 'check
- (lambda* (#:key inputs outputs tests? #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (setenv "HOME" (getcwd))
- (and (invoke "py.test" "-v" "tests/fenics_adjoint"
- "-k" "not test_read_checkpoint")
- (invoke "py.test" "-v" "tests/migration")
- (invoke "py.test" "-v" "tests/pyadjoint")))
- #t))
- ;; Remove 'sanity-check, because it tries to import
- ;; firedrake_adjoint after importing fenics_adjoint.
- ;; Both load a module named 'backend' and firedrake_adjoint
- ;; fails with an ImportError if it sees that the backend module
- ;; has already been loaded.
- (delete 'sanity-check))))
+ (list
+ #:test-flags
+ #~(list "tests/fenics_adjoint"
+ "tests/migration"
+ "tests/pyadjoint"
+ "-k" "not test_read_checkpoint")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'build 'mpi-setup #$%openmpi-setup)
+ (add-before 'check 'set-environment-variables
+ (lambda _
+ (setenv "HOME" "/tmp")))
+ (add-after 'install 'install-doc
+ (lambda _
+ (let* ((doc (string-append #$output "/share/doc/" #$name "-" #$version))
+ (examples (string-append doc "/examples")))
+ (mkdir-p examples)
+ (copy-recursively "examples" examples))))
+ ;; Remove 'sanity-check, because it tries to import
+ ;; firedrake_adjoint after importing fenics_adjoint.
+ ;; Both load a module named 'backend' and firedrake_adjoint
+ ;; fails with an ImportError if it sees that the backend module
+ ;; has already been loaded.
+ (delete 'sanity-check))))
(inputs
(list fenics openmpi pybind11))
(native-inputs
--
2.41.0
Sharlatan Hellseher wrote 8 months ago
[PATCH 0/3] python-dolfin-adjoint: Refresh package style.
(address . 71884-done@debbugs.gnu.org)
87ed7zpzcy.fsf@gmail.com
Hi,

QA is qreen now, and it's built locally as well!

Pushed v2 as 5a33a71e67..9da142540e to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmaQIb0ACgkQdtcnv/Ys
0rV/oA/+L/chkJ5x3lOFQ80zI+G2qJSrFCI7nBxlVpANgHPw1ukEyuJAsDwbN2Nw
XOqYIRBjOQUn1AAwbVafRqePwBTElswipo7G97SovzJynaZuB+e9EjkZymgpqHhN
OfbRlh8gvKKVJtM+5uu6kEFvJr5/PZIEk3f9JbFEfk+sKhD0nne4Y2cBvh1U291Q
YSseLubbt6n1/ow0ZTybhA+DwbQkWIezy3O8vt2lGabSgBGEVoyhfWICt8R7o3oI
DXXUPs/ZhQ39VZTLU98T048KiNRWlQf4XhYVnJY4rcENDH8px+yFK2goTjhLt82f
bMxf4CkBEwkh737XO1xxmjm7Xn7uJMOr85ocjqOJMm3c+F92y/ZqmlLVzb8kHYil
Kb1nnZQ2jp9DYUWO6Iqq83F/LdKHpVfNPc2tk++gnj2tZDdeU6pGQfeQiuRXHgIG
SydCuebBFumT3CqDg75QzbHlCpIRzpw3GGmoQU1SumvQpRvzGxQp7VCyTdnVHtx+
86nlSFECfp8JIBzzV9nLgOyHQsRsFt+8VWN/OT+8n8ZOuaYsqtqvGPwD3mWFegoE
YtwKYyWpIeDHaqgyBmiNFMHyrm4miIHl8sz+bOS1N8H60n9815JJqAkTifd6N+hF
zCdZ5oMkgpb51XMVUcwe0OawoB9GGcl5pCDCEi3+WJTeem505iw=
=oNOT
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71884@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71884
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help