[core-updates 1/3] gnu: texlive-mflua-bin: Also install "-nowin" binaries.

  • Open
  • quality assurance status badge
Details
One participant
  • Nicolas Goaziou
Owner
unassigned
Submitted by
Nicolas Goaziou
Severity
normal

Debbugs page

Nicolas Goaziou wrote 8 months ago
(address . guix-patches@gnu.org)(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
4715acf0bab3b155770f9fe54b5e126bfc21a363.1719765328.git.mail@nicolasgoaziou.fr
* gnu/packages/tex.scm (texlive-mflua-bin)[arguments]<#:phases>: Also generate
and install "mfluajit-nowin" and "mflua-nowin" binaries.

Change-Id: I552340b991f0c46b317a04388aa4e62cddb25146
---
gnu/packages/tex.scm | 8 ++++++--
1 file changed, 6 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e309839a42..2c25949637 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -48693,7 +48693,9 @@ (define-public texlive-mflua-bin
(lambda _
(with-directory-excursion "texk/web2c"
(invoke "make" "mfluajit")
- (install-file ".libs/mfluajit" bin))))))
+ (invoke "make" "mfluajit-nowin")
+ (install-file ".libs/mfluajit" bin)
+ (install-file ".libs/mfluajit-nowin" bin))))))
(add-after 'unpack 'force-lua53-build
(lambda _
(substitute* "libs/configure"
@@ -48702,7 +48704,9 @@ (define-public texlive-mflua-bin
(lambda _
(with-directory-excursion "texk/web2c"
(invoke "make" "mflua")
- (install-file ".libs/mflua" bin)))))))))
+ (invoke "make" "mflua-nowin")
+ (install-file ".libs/mflua" bin)
+ (install-file ".libs/mflua-nowin" bin)))))))))
(native-inputs (list pkg-config))
(inputs (modify-inputs (package-inputs texlive-bin)
(append potrace)))

base-commit: 75b4a29e12011ae3d1814932591e80dcb0b80aae
--
2.45.2
Nicolas Goaziou wrote 8 months ago
[core-updates 2/3] gnu: texlive-kpathsea: Enable all format configurations.
(address . 71859@debbugs.gnu.org)(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
88f98b14444f534697988c78a8e55fcad2f81ada.1719765328.git.mail@nicolasgoaziou.fr
* gnu/packages/tex.scm (texlive-kpathsea)[arguments]<#:phases>: Allow
generating all formats provided in TeX Live.

Change-Id: Ibe29eb643ee27bc4223868a76acfa4f0cfc1f74e
---
gnu/packages/tex.scm | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)

Toggle diff (19 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2c25949637..e6914e5ced 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -58100,7 +58100,11 @@ (define-public texlive-kpathsea
"web2c/mktexupd")
(("^version=" m)
(format #false "PATH=\"~{~a:~}$PATH\"; export PATH~%~a"
- dirs m)))))))))
+ dirs m))))))
+ (add-after 'unpack 'enable-all-configurations
+ (lambda _
+ (substitute* "web2c/fmtutil.cnf"
+ (("^#! ") "")))))))
(inputs (list gawk sed))
(propagated-inputs (list texlive-libkpathsea)) ;for the executables
(home-page "https://ctan.org/pkg/kpathsea")
--
2.45.2
Nicolas Goaziou wrote 8 months ago
[core-updates 3/3] gnu: texlive-luahbtex: Generate missing "luahbtex.fmt".
(address . 71859@debbugs.gnu.org)(name . Nicolas Goaziou)(address . mail@nicolasgoaziou.fr)
0a953868d9ce5d62ee55a69f65d8c80fc671d06f.1719765328.git.mail@nicolasgoaziou.fr
* gnu/packages/tex.scm (texlive-luahbtex)[native-inputs]: Add
TEXLIVE-KPATHSEA.
[properties]: Preserve native-input from upgrade.

Change-Id: I35de793e4562cd21a9d624542c06f65dee5676f2
---
gnu/packages/tex.scm | 2 ++
1 file changed, 2 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index e6914e5ced..214e4f764e 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -60853,10 +60853,12 @@ (define-public texlive-luahbtex
"0y47q58jggwzy5hk9n2arh0g4a92pqcavadzxa38lpadf16zxbck"))))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (properties '((updater-extra-native-inputs "texlive-kpathsea")))
(arguments
(list
#:texlive-latex-bin? #f
#:create-formats #~(list "luahbtex")))
+ (native-inputs (list texlive-kpathsea))
(propagated-inputs
(list texlive-cm
texlive-etex
--
2.45.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71859@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71859
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help