(address . guix-patches@gnu.org)(name . Sharlatan Hellseher)(address . sharlatanus@gmail.com)
Hi Guix,
This is the first portion of patches bringing Vale - A markup-aware linter for
prose built with speed and extensibility in mind, to the latest version and
remove all bundled packages.
I don't want to hold them for a long time on my local checkout and make them
available for wide audience which may need to use them as dependencies.
My current stopping point to finlize the update is:
Toggle snippet (5 lines)
(define-public go-github-com-mholt-archiver-v4
;; v3.5.1 has an issuue with <github.com/xi2/xz> see
;; <https://github.com/mholt/archiver/issues/259>.
v3 has doubtful project <github.com/xi2/xz> as dependency, but v4 introduces
longer chain of unpacked projects.
--
Oleg
Sharlatan Hellseher (26):
gnu: Add packages/golang-math module.
gnu: Add go-github-com-montanaflynn-stats.
gnu: Add go-github-com-shopspring-decimal.
gnu: Add go-github-com-adrg-strutil.
gnu: Add go-github-com-adrg-xdg.
gnu: Add go-github-com-dsnet-golib.
gnu: Add go-github-com-dsnet-compress.
gnu: Add go-github-com-expr-lang-expr.
gnu: Add go-github-com-d5-tengo-v2.
gnu: Add go-tengo.
gnu: Add go-github-com-remeh-sizedwaitgroup.
gnu: Add go-github-com-gookit-color.
gnu: Add go-atomicgo-dev-assert.
gnu: Add go-github-com-otiai10-mint.
gnu: Add go-github-com-otiai10-copy.
gnu: Add go-github-com-neurosnap-sentences.
gnu: Add go-github-com-errata-ai-regexp2.
gnu: Add go-github-com-jdkato-twine.
gnu: Add go-github-com-errata-ai-ini.
gnu: Add go-atomicgo-dev-cursor.
gnu: Add go-atomicgo-dev-schedule.
gnu: Add go-atomicgo-dev-keyboard.
gnu: Add go-github-com-marvinjwendt-testza.
gnu: Add go-github-com-pterm-pterm.
gnu: go-github-com-masterminds-sprig-v3: Update to 3.2.3.
gnu: Add go-github-com-nwaples-rardecode-v2.
gnu/local.mk | 1 +
gnu/packages/golang-check.scm | 97 +++++
gnu/packages/golang-compression.scm | 72 +++-
gnu/packages/golang-maths.scm | 98 +++++
gnu/packages/golang-xyz.scm | 591 +++++++++++++++++++++++++++-
5 files changed, 855 insertions(+), 4 deletions(-)
create mode 100644 gnu/packages/golang-maths.scm
base-commit: f3689976da3d23b0a73cf1733da04add5e1035ee
--
2.41.0