[PATCH mumi] client: Do not print hash symbol in issue number.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • jgart
Owner
unassigned
Submitted by
jgart
Severity
normal

Debbugs page

jgart wrote 8 months ago
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
20240629064433.132460-1-jgart@dismail.de
Hi,

Printing the hash symbol in the mumi search output makes it harder to
conveniently double click on the issue number word and copy paste it
to another mumi command such as mumi current ISSUE. I think this
improves the terminal UI ergonomics.

This patch remove the hash symbol that is printed to standard output.

WDYT

all the best,

jgart

* mumi/client.scm (list-issue): Do not print hash symbol.
---
mumi/client.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)

Toggle diff (16 lines)
diff --git a/mumi/client.scm b/mumi/client.scm
index 9231589..77fe07c 100644
--- a/mumi/client.scm
+++ b/mumi/client.scm
@@ -96,8 +96,7 @@
(define (list-issue issue)
"List issue described by ISSUE association list."
(display (colorize-string
- (string-append "#"
- (number->string (assoc-ref issue "number")))
+ (number->string (assoc-ref issue "number"))
'YELLOW))
(display " ")
(unless (assoc-ref issue "open")
--
2.45.2
Arun Isaac wrote 5 months ago
Reassign 71836 to mumi
(address . control@debbugs.gnu.org)
874j5ru7sx.fsf@systemreboot.net
package guix-patches
reassign 71836 mumi
thanks
Arun Isaac wrote 5 months ago
Re: [PATCH mumi] client: Do not print hash symbol in issue number.
(address . 71836-done@debbugs.gnu.org)
87v7y7s8vj.fsf@systemreboot.net
Applied and pushed, thanks!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71836@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71836
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help