jgart wrote 8 months ago
(address . guix-patches@gnu.org)(name . jgart)(address . jgart@dismail.de)
Hi,
Printing the hash symbol in the mumi search output makes it harder to
conveniently double click on the issue number word and copy paste it
to another mumi command such as mumi current ISSUE. I think this
improves the terminal UI ergonomics.
This patch remove the hash symbol that is printed to standard output.
WDYT
all the best,
jgart
* mumi/client.scm (list-issue): Do not print hash symbol.
---
mumi/client.scm | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
Toggle diff (16 lines)
diff --git a/mumi/client.scm b/mumi/client.scm
index 9231589..77fe07c 100644
--- a/mumi/client.scm
+++ b/mumi/client.scm
@@ -96,8 +96,7 @@
(define (list-issue issue)
"List issue described by ISSUE association list."
(display (colorize-string
- (string-append "#"
- (number->string (assoc-ref issue "number")))
+ (number->string (assoc-ref issue "number"))
'YELLOW))
(display " ")
(unless (assoc-ref issue "open")
--
2.45.2