(address . bug-guix@gnu.org)
Hi,
Since an update, my Emacs crashes when trying to run it in a dedicated setup.
The two generations involved are at the end of the email.
I expect that there are some leftover files from byte compilation or
native compilation that cause the problem.
To do a clean run:
sudo mkdir -p /home/arne/eigenes/Webseiten/
sudo chmod a+rwx /home/arne/eigenes/Webseiten/
hg clone https://hg.sr.ht/~arnebab/draketo/home/arne/eigenes/Webseiten/arnebab-org
cd /home/arne/eigenes/Webseiten/arnebab-org
echo -e "utf-8\n" | HOME="/home/arne/eigenes/Webseiten/arnebab-org" emacs --batch --load .emacs.d/init.el --load setup.el "setup.el" -f org-feed-update-all -f kill-emacs && touch "external-rss.org.in"
Since I updated Guix, it is broken for me:
echo -e "utf-8\n" | HOME="/home/arne/eigenes/Webseiten/arnebab-org"
emacs --batch --load .emacs.d/init.el --load setup.el "setup.el" -f
org-feed-update-all -f kill-emacs && touch "external-rss.org.in" # the
echo is a hack to work around broken encoding -> no longer empty, but
still broken
Loading ido (native compiled elisp)...
Error: error ("Recursive ‘require’ for feature ‘ox’")
require(ox)
byte-code("\300\301!\210\302
\303\232\204\20\0\304\305\306\"\210\300\307!\210\300\310!\210\300\311!\210\312\313\314\315\316\317\320\321\322&\10\210\323\324\325\326\327\330\331\332&\7\210\333\334\335\336\337DD\340\331\324\341\342\343\344\345\346&\13\210\333\347\335\336\350DD\351\331\324\341\342\343\352\345\346&\13\210\333\353\335\336\354DD\355\331\324\341\342\343\356\345\346&\13\210\333\357\335\336\360DD\361\331\324\341\342\343\362\345\346&\13\210\333\363\335\336\364DD\365\331\324\341\366\343\367\345\346&\13\210\333\370\335\336\371DD\372\331\324\341\342\343\373\345\346&\13\210\333\374\335\336\375DD\376\331\324\341\342\343\377\345\201@\0&\13\210\333\201A\0\335\336\201B\0DD\201C\0\331\324\341\342\343\201D\0\345\201E\0&\13\210\333\201F\0\335\336\201G\0DD\201H\0\331\324\341\342\343\201I\0\345\201J\0&\13\210\333\201K\0\335\336\201L\0DD\201M\0\331\324\341\342\343\201N\0\345\201O\0&\13\210\333\201P\0\335\336\201Q\0DD\201R\0\331\324\341\342\343\201S\0\345\201T\0&\13\210\333\201U\0\335\336\201V\0DD\201W\0\331\324\341\342\343\201X\0\345\201Y\0&\13\210\333\201Z\0\335\336\201[\0DD\201\\\0\331\324\341\342\343\201]\0\345\201^\0&\13\210\333\201_\0\335\336\201`\0DD\201a\0\331\324\341\342\343\201b\0\345\201^\0&\13\207"
[require org-macs org-release "9.7.4" warn "Org version
mismatch.\nThis warning usually appears when a built-in Org version is
loaded\nprior to the more recent Org version.\n\nVersion mismatch is
commonly encountered in the following situations:\n\n1. Emacs is
loaded using literate Org config and more recent Org\n version is
loaded inside the file loaded by `org-babel-load-file'.\n
`org-babel-load-file' triggers the built-in Org version clashing\n the
newer Org version attempt to be loaded later.\n\n It is recommended to
move the Org loading code before the\n `org-babel-load-file'
call.\n\n2. New Org version is loaded manually by setting `load-path',
but some\n other package depending on Org is loaded before the
`load-path' is\n configured.\n This \"other package\" is triggering
built-in Org version, again\n causing the version mismatch.\n\n It is
recommended to set `load-path' as early in the config as\n
possible.\n\n3. New Org version is loaded using straight.el package
manager and\n other package depending on Org is loaded before straight
triggers\n loading of the newer Org version.\n\n It is recommended to
put\n\n %s\n\n early in the config. Ideally, right after the
straight.el\n bootstrap. Moving `use-package' :straight declaration
may not be\n sufficient if the corresponding `use-package' statement
is\n deferring the loading.\n\n4. A new Org version is synchronized
with Emacs git repository and\n stale .elc files are still left from
the previous build.\n\n It is recommended to remove .elc files from
lisp/org directory and\n re-compile." "(straight-use-package 'org)" ox
ox-publish cl-lib org-export-define-backend ascii ((bold .
org-ascii-bold) (center-block . org-ascii-center-block) (clock .
org-ascii-clock) (code . org-ascii-code) (drawer . org-ascii-drawer)
(dynamic-block . org-ascii-dynamic-block) (entity . org-ascii-entity)
(example-block . org-ascii-example-block) (export-block .
org-ascii-export-block) (export-snippet . org-ascii-export-snippet)
(fixed-width . org-ascii-fixed-width) (footnote-reference .
org-ascii-footnote-reference) (headline . org-ascii-headline)
(horizontal-rule . org-ascii-horizontal-rule) (inline-src-block .
org-ascii-inline-src-block) (inlinetask . org-ascii-inlinetask)
(inner-template . org-ascii-inner-template) (italic .
org-ascii-italic) (item . org-ascii-item) (keyword .
org-ascii-keyword) (latex-environment . org-ascii-latex-environment)
(latex-fragment . org-ascii-latex-fragment) (line-break .
org-ascii-line-break) (link . org-ascii-link) (node-property .
org-ascii-node-property) (paragraph . org-ascii-paragraph) (plain-list
. org-ascii-plain-list) (plain-text . org-ascii-plain-text) (planning
. org-ascii-planning) (property-drawer . org-ascii-property-drawer)
(quote-block . org-ascii-quote-block) (radio-target .
org-ascii-radio-target) (section . org-ascii-section) (special-block .
org-ascii-special-block) (src-block . org-ascii-src-block)
(statistics-cookie . org-ascii-statistics-cookie) (strike-through .
org-ascii-strike-through) (subscript . org-ascii-subscript)
(superscript . org-ascii-superscript) (table . org-ascii-table)
(table-cell . org-ascii-table-cell) (table-row . org-ascii-table-row)
(target . org-ascii-target) (template . org-ascii-template) (timestamp
. org-ascii-timestamp) (underline . org-ascii-underline) (verbatim .
org-ascii-verbatim) (verse-block . org-ascii-verse-block)) :menu-entry
(116 "Export to Plain Text" ((65 "As ASCII buffer" (lambda (a s v b)
(org-ascii-export-as-ascii a s v b '(:ascii-charset ascii)))) (97 "As
ASCII file" (lambda (a s v b) (org-ascii-export-to-ascii a s v b
'(:ascii-charset ascii)))) (76 "As Latin1 buffer" (lambda (a s v b)
(org-ascii-export-as-ascii a s v b '(:ascii-charset latin1)))) (108
"As Latin1 file" (lambda (a s v b) (org-ascii-export-to-ascii a s v b
'(:ascii-charset latin1)))) (85 "As UTF-8 buffer" (lambda (a s v b)
(org-ascii-export-as-ascii a s v b '(:ascii-charset utf-8)))) (117 "As
UTF-8 file" (lambda (a s v b) (org-ascii-export-to-ascii a s v b
'(:ascii-charset utf-8)))))) :filters-alist ((:filter-headline .
org-ascii-filter-headline-blank-lines) (:filter-parse-tree
org-ascii-filter-paragraph-spacing org-ascii-filter-comment-spacing)
(:filter-section . org-ascii-filter-headline-blank-lines))
:options-alist ((:subtitle "SUBTITLE" nil nil parse) (:ascii-bullets
nil nil org-ascii-bullets) (:ascii-caption-above nil nil
org-ascii-caption-above) (:ascii-charset nil nil org-ascii-charset)
(:ascii-global-margin nil nil org-ascii-global-margin)
(:ascii-format-drawer-function nil nil
org-ascii-format-drawer-function) (:ascii-format-inlinetask-function
nil nil org-ascii-format-inlinetask-function) (:ascii-headline-spacing
nil nil org-ascii-headline-spacing) (:ascii-indented-line-width nil
nil org-ascii-indented-line-width) (:ascii-inlinetask-width nil nil
org-ascii-inlinetask-width) (:ascii-inner-margin nil nil
org-ascii-inner-margin) (:ascii-links-to-notes nil nil
org-ascii-links-to-notes) (:ascii-list-margin nil nil
org-ascii-list-margin) (:ascii-paragraph-spacing nil nil
org-ascii-paragraph-spacing) (:ascii-quote-margin nil nil
org-ascii-quote-margin) (:ascii-table-keep-all-vertical-lines nil nil
org-ascii-table-keep-all-vertical-lines) (:ascii-table-use-ascii-art
nil nil org-ascii-table-use-ascii-art) (:ascii-table-widen-columns nil
nil org-ascii-table-widen-columns) (:ascii-text-width nil nil
org-ascii-text-width) (:ascii-underline nil nil org-ascii-underline)
(:ascii-verbatim-format nil nil org-ascii-verbatim-format))
custom-declare-group org-export-ascii nil "Options for exporting Org
mode files to ASCII." :tag "Org Export ASCII" :group org-export
custom-declare-variable org-ascii-text-width funcall function
#f(compiled-function () #<bytecode 0x18c000ae6ce14>) "Maximum width of
exported text.\nThis number includes margin size, as set
in\n`org-ascii-global-margin'." :version "24.4" :package-version (Org
. "8.0") :type integer org-ascii-global-margin #f(compiled-function ()
#<bytecode 0x18c000ae69414>) "Width of the left margin, in number of
characters." (Org . "8.0") org-ascii-inner-margin #f(compiled-function
() #<bytecode 0x18c000ae69694>) "Width of the inner margin, in number
of characters.\nInner margin is applied between each headline." (Org .
"8.0") org-ascii-quote-margin #f(compiled-function () #<bytecode
0x18c000ae69394>) "Width of margin used for quoting text, in
characters.\nThis margin is applied on both sides of the text. It is
also\napplied on the left side of contents in descriptive lists." (Org
. "8.0") org-ascii-list-margin #f(compiled-function () #<bytecode
0x18c000ae69414>) "Width of margin used for plain lists, in
characters.\nThis margin applies to top level list only, not to
its\nsub-lists." "26.1" (Org . "8.3") org-ascii-inlinetask-width
#f(compiled-function () #<bytecode 0x18c000ae6a594>) "Width of inline
tasks, in number of characters.\nThis number ignores any margin." (Org
. "8.0") org-ascii-headline-spacing #f(compiled-function () #<bytecode
0x18c000ae6aa94>) "Number of blank lines inserted around
headlines.\n\nThis variable can be set to a cons cell. In that case,
its car\nrepresents the number of blank lines present before
headline\ncontents whereas its cdr reflects the number of blank lines
after\ncontents.\n\nA nil value replicates the number of blank lines
found in the\noriginal Org buffer at the same place." (Org . "8.0")
(choice (const :tag "Replicate original spacing" nil) (cons :tag "Set
a uniform spacing" (integer :tag "Number of blank lines before
contents") (integer :tag "Number of blank lines after contents")))
org-ascii-indented-line-width #f(compiled-function () #<bytecode
0x29ac9a1ad7f794>) "Additional indentation width for the first line in
a paragraph.\nIf the value is an integer, indent the first line of
each\nparagraph by this width, unless it is located at the beginning
of\na section, in which case indentation is removed from that
line.\nIf it is the symbol `auto' preserve indentation from
original\ndocument." (Org . "8.0") (choice (integer :tag "Number of
white spaces characters") (const :tag "Preserve original width" auto))
org-ascii-paragraph-spacing #f(compiled-function () #<bytecode
0x29ac9a1ad7f794>) "Number of white lines between paragraphs.\nIf the
value is an integer, add this number of blank lines\nbetween
contiguous paragraphs. If is it the symbol `auto', keep\nthe same
number of blank lines as in the original document." (Org . "8.0")
(choice (integer :tag "Number of blank lines") (const :tag "Preserve
original spacing" auto)) org-ascii-charset #f(compiled-function ()
#<bytecode 0x18c000ae88114>) "The charset allowed to represent various
elements and objects.\nPossible values are:\n`ascii' Only use plain
ASCII characters\n`latin1' Include Latin-1 characters\n`utf-8' Use all
UTF-8 characters" (Org . "8.0") (choice (const :tag "ASCII" ascii)
(const :tag "Latin-1" latin1) (const :tag "UTF-8" utf-8))
org-ascii-underline #f(compiled-function () #<bytecode
0x18c000ae69414>) "Characters for underlining headings in ASCII
export.\n\nAlist whose key is a symbol among `ascii', `latin1' and
`utf-8'\nand whose value is a list of characters.\n\nFor each
supported charset, this variable associates a sequence\nof underline
characters. In a sequence, the characters will be\nused in order for
headlines level 1, 2, ... If no character is\navailable for a given
level, the headline won't be underlined." (Org . "8.0") (list (cons
:tag "Underline characters sequence" (const :tag "ASCII charset"
ascii) (repeat character)) (cons :tag "Underline characters sequence"
(const :tag "Latin-1 charset" latin1) (repeat character)) (cons :tag
"Underline characters sequence" (const :tag "UTF-8 charset" utf-8)
(repeat character))) org-ascii-bullets #f(compiled-function ()
#<bytecode 0x18c000ae69414>) "Bullet characters for headlines
converted to lists in ASCII export.\n\nAlist whose key is a symbol
among `ascii', `latin1' and `utf-8'\nand whose value is a list of
characters.\n\nThe first character is used for the first level
considered as low\nlevel, and so on. If there are more levels than
characters given\nhere, the list will be repeated.\n\nNote that this
variable doesn't affect plain lists\nrepresentation." (Org . "8.0")
(list (cons :tag "Bullet characters for low level headlines" (const
:tag "ASCII charset" ascii) (repeat character)) (cons :tag "Bullet
characters for low level headlines" (const :tag "Latin-1 charset"
latin1) (repeat character)) (cons :tag "Bullet characters for low
level headlines" (const :tag "UTF-8 charset" utf-8) (repeat
character))) org-ascii-links-to-notes #f(compiled-function ()
#<bytecode 0x18c000ae69b14>) "Non-nil means convert links to notes
before the next headline.\nWhen nil, the link will be exported in
place. If the line\nbecomes long in this way, it will be wrapped."
(Org . "8.0") boolean org-ascii-table-keep-all-vertical-lines
#f(compiled-function () #<bytecode 0x18c000ae69414>) "Non-nil means
keep all vertical lines in ASCII tables.\nWhen nil, vertical lines
will be removed except for those needed\nfor column grouping." (Org .
"8.0")] 12)
require(ox-ascii)
byte-code("\300\301!\210\302
\303\232\204\20\0\304\305\306\"\210\300\307!\210\300\301!\210\300\310!\207"
[require org-macs org-release "9.7.4" warn "Org version
mismatch.\nThis warning usually appears when a built-in Org version is
loaded\nprior to the more recent Org version.\n\nVersion mismatch is
commonly encountered in the following situations:\n\n1. Emacs is
loaded using literate Org config and more recent Org\n version is
loaded inside the file loaded by `org-babel-load-file'.\n
`org-babel-load-file' triggers the built-in Org version clashing\n the
newer Org version attempt to be loaded later.\n\n It is recommended to
move the Org loading code before the\n `org-babel-load-file'
call.\n\n2. New Org version is loaded manually by setting `load-path',
but some\n other package depending on Org is loaded before the
`load-path' is\n configured.\n This \"other package\" is triggering
built-in Org version, again\n causing the version mismatch.\n\n It is
recommended to set `load-path' as early in the config as\n
possible.\n\n3. New Org version is loaded using straight.el package
manager and\n other package depending on Org is loaded before straight
triggers\n loading of the newer Org version.\n\n It is recommended to
put\n\n %s\n\n early in the config. Ideally, right after the
straight.el\n bootstrap. Moving `use-package' :straight declaration
may not be\n sufficient if the corresponding `use-package' statement
is\n deferring the loading.\n\n4. A new Org version is synchronized
with Emacs git repository and\n stale .elc files are still left from
the previous build.\n\n It is recommended to remove .elc files from
lisp/org directory and\n re-compile." "(straight-use-package 'org)" ob
ox-ascii] 3)
require(ob-gnuplot)
org-babel-do-load-languages(org-babel-load-languages ((C . t) (R .
t) (asymptote) (awk) (calc) (clojure) (comint) (css) (ditaa . t) (dot
. t) (emacs-lisp . t) (fortran) (gnuplot . t) (haskell) (io) (java)
(js) (latex) (ledger) (lilypond) (lisp) (matlab) (maxima) (mscgen)
(ocaml) (octave) (org . t) (perl) (picolisp) (plantuml) (python . t)
(ref) (ruby) (sass) (scala) (scheme . t) (screen) (shell . t) (shen)
(sql) (sqlite)))
custom-initialize-reset(org-babel-load-languages (funcall #'#f(compiled-function () #<bytecode 0x18c000ae69414>)))
custom-declare-variable(org-babel-load-languages (funcall
#'#f(compiled-function () #<bytecode 0x18c000ae69414>)) "Languages
which can be evaluated in Org buffers.\n\\<org-mode-map>\nThis list
can be used to load support for any of the available\nlanguages with
babel support (see info node `(org) Languages'). Each\nlanguage will
depend on a different set of system executables and/or\nEmacs
modes.\n\nWhen a language is \"loaded\", code blocks in that language
can\nbe evaluated with `org-babel-execute-src-block', which is
bound\nby default to \\[org-ctrl-c-ctrl-c].\n\nThe
`org-babel-no-eval-on-ctrl-c-ctrl-c' option can be set to\nremove code
block evaluation from \\[org-ctrl-c-ctrl-c]. By\ndefault, only Emacs
Lisp is loaded, since it has no specific\nrequirement." :group
org-babel :set org-babel-do-load-languages :package-version (Org .
"9.6") :type (alist :tag "Babel Languages" :key-type (choice (const
:tag "Awk" awk) (const :tag "C, D, C++, and cpp" C) (const :tag "R" R)
(const :tag "Calc" calc) (const :tag "Clojure and ClojureScript"
clojure) (const :tag "CSS" css) (const :tag "Ditaa" ditaa) (const :tag
"Dot" dot) (const :tag "Emacs Lisp" emacs-lisp) (const :tag "Eshell"
eshell) (const :tag "Forth" forth) (const :tag "Fortran" fortran)
(const :tag "GnuPlot" gnuplot) (const :tag "Groovy" groovy) (const
:tag "Haskell" haskell) (const :tag "Java" java) (const :tag
"JavaScript" js) (const :tag "Julia" julia) (const :tag "LaTeX" latex)
(const :tag "LilyPond" lilypond) (const :tag "Lisp" lisp) (const :tag
"Lua" lua) (const :tag "Makefile" makefile) (const :tag "Maxima"
maxima) (const :tag "OCaml" ocaml) (const :tag "Octave and MatLab"
octave) (const :tag "Org" org) (const :tag "Perl" perl) (const :tag
"Processing" processing) (const :tag "PlantUML" plantuml) (const :tag
"Python" python) (const :tag "Ruby" ruby) (const :tag "Sass" sass)
(const :tag "Scheme" scheme) (const :tag "Screen" screen) (const :tag
"Sed" sed) (const :tag "Shell Script" shell) (const :tag "Sql" sql)
(const :tag "Sqlite" sqlite)) :value-type (boolean :tag "Activate"
:value t)))
byte-code("\300\301\302\303\304DD\305\306\307\310\311\312\313\314\315&\13\210\300\316\302\303\317DD\320\314\321\322\323\306\324&\11\210\325\326\327\"\210\325\330\327\"\207"
[custom-declare-variable org-babel-load-languages funcall function
#f(compiled-function () #<bytecode 0x18c000ae69414>) "Languages which
can be evaluated in Org buffers.\n\\<org-mode-map>\nThis list can be
used to load support for any of the available\nlanguages with babel
support (see info node `(org) Languages'). Each\nlanguage will depend
on a different set of system executables and/or\nEmacs modes.\n\nWhen
a language is \"loaded\", code blocks in that language can\nbe
evaluated with `org-babel-execute-src-block', which is bound\nby
default to \\[org-ctrl-c-ctrl-c].\n\nThe
`org-babel-no-eval-on-ctrl-c-ctrl-c' option can be set to\nremove code
block evaluation from \\[org-ctrl-c-ctrl-c]. By\ndefault, only Emacs
Lisp is loaded, since it has no specific\nrequirement." :group
org-babel :set org-babel-do-load-languages :package-version (Org .
"9.6") :type (alist :tag "Babel Languages" :key-type (choice (const
:tag "Awk" awk) (const :tag "C, D, C++, and cpp" C) (const :tag "R" R)
(const :tag "Calc" calc) (const :tag "Clojure and ClojureScript"
clojure) (const :tag "CSS" css) (const :tag "Ditaa" ditaa) (const :tag
"Dot" dot) (const :tag "Emacs Lisp" emacs-lisp) (const :tag "Eshell"
eshell) (const :tag "Forth" forth) (const :tag "Fortran" fortran)
(const :tag "GnuPlot" gnuplot) (const :tag "Groovy" groovy) (const
:tag "Haskell" haskell) (const :tag "Java" java) (const :tag
"JavaScript" js) (const :tag "Julia" julia) (const :tag "LaTeX" latex)
(const :tag "LilyPond" lilypond) (const :tag "Lisp" lisp) (const :tag
"Lua" lua) (const :tag "Makefile" makefile) (const :tag "Maxima"
maxima) (const :tag "OCaml" ocaml) (const :tag "Octave and MatLab"
octave) (const :tag "Org" org) (const :tag "Perl" perl) (const :tag
"Processing" processing) (const :tag "PlantUML" plantuml) (const :tag
"Python" python) (const :tag "Ruby" ruby) (const :tag "Sass" sass)
(const :tag "Scheme" scheme) (const :tag "Screen" screen) (const :tag
"Sed" sed) (const :tag "
This message was truncated. Download the full message here.
-----BEGIN PGP SIGNATURE-----
iQJEBAEBCAAuFiEE801qEjXQSQPNItXAE++NRSQDw+sFAmZ+aGMQHGFybmVfYmFi
QHdlYi5kZQAKCRAT741FJAPD60QQEACxHnZguvBuN05rPrFsrcvkhHaUnY8ftL9Z
VeKb+CemFhyXpfwTc6VZNyIU207RDhQUlYJ6KmUbU7ub9OvJEUmpsuQ7TzEp0j7V
M6LSZSCnIJwACP9pFOvwImTXcA/Nkn3hOkFfvKd4b/bmpno24KlL45lptZvPOyn+
NS+EriqwTbkkoBwB3XNMxClz2yQi0GJC0fZ/k7sCorKY09EGBelnbYbq+ztS8BLz
HAiC1WegNvyXt10te9AJACzQOWykTlsioTn+2Mc3dth8QHaqlbubRDdVp3QUyHsb
fCN27Pf3GXhGKHrBuYYP1BV9OsyQizrvayJnsCK5TRO18SgmOzURBGXEOJPdhzaC
f9mxMsC4EhrisoXW/7K9JB3Qj36/ZCuKPmlrp8GOSnV1QVc9lvZgkqQGsnubudgn
8TM/LVFRxFYgvsENqliaCHM7eW5heU+evN7HprvMbvR4oPnaX3suo7SJ19VZ0rrM
kLWilaws37SClQvPo6Kn0sYQKlhla7l3ImpU0bODI7Nm1crwtQnFsqj7nwckAaAy
xV/Qe21EDCfUJZNq4xfq3f7Iz3f6Vm3xv7cLu/w6s4Q+ehHu6BFXTOb2dCOjms5q
mOAjLRWMctanBmcXuugAezP8ldWj9ZO7sc/SYgRIbZO2pVobJSINZ+wCTrFpmGYQ
T5DiMrySIIjEBAEBCAAuFiEE3Si95tmHXKvOSosd3M8NswvBBUgFAmZ+aGMQHGFy
bmVfYmFiQHdlYi5kZQAKCRDczw2zC8EFSBv1A/9QH3VDTxFAbuY67IsgCrhe/GHp
jvnqLivFMXmzi3I061Dj0rD0ZyxbzGx811be6QpTnQMIw0bzhCAaTQ2+ZM3N0lEM
og1B8MyBfXAlMPiMgCcRVlzTwGsE+n9CZvD6yy92Sx5r/OrX+EoE4GWF3i8FkZbl
tx9M7i6HYH0MfJOpQQ==
=9PYO
-----END PGP SIGNATURE-----