[PATCH] gnu: hwloc: Update to 2.11.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Ludovic Courtès
  • Philippe SWARTVAGHER
Owner
unassigned
Submitted by
Philippe SWARTVAGHER
Severity
normal

Debbugs page

Philippe SWARTVAGHER wrote 9 months ago
(address . guix-patches@gnu.org)(name . Philippe SWARTVAGHER)(address . phil.swart@gmx.fr)
8e5f235e1eae9aff13f3435928f63153b433f443.1719431418.git.phil.swart@gmx.fr
* gnu/packages/mpi.scm (hwloc): Update to 2.11.0.

Change-Id: Icb72cf40c4e7029f66154db02d2ae8e44ff41faa
---
gnu/packages/mpi.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 6270108b16..29df9b0825 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -143,7 +143,7 @@ (define-public hwloc-1
(define-public hwloc-2
(package
(inherit hwloc-1)
- (version "2.10.0")
+ (version "2.11.0")
(source (origin
(method url-fetch)
(uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -151,7 +151,7 @@ (define-public hwloc-2
"/hwloc-" version ".tar.bz2"))
(sha256
(base32
- "14hkmq2hrs4j5f0sf32aazgbhgbdvj7lwapy35jvwbyyr5hds183"))))
+ "1yg4c0axrrqhhnvccf52qv2i0jvladm6v4pp02yp5nymra3kp403"))))

;; libnuma is no longer needed.
(inputs (modify-inputs (package-inputs hwloc-1)

base-commit: 03459ca165cec67edaadbd19a96572a74a10cc75
--
2.45.2
Ludovic Courtès wrote 8 months ago
[PATCH] gnu: hwloc: Update to 2.11.1.
(address . 71788@debbugs.gnu.org)(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)(name . Philippe SWARTVAGHER)(address . phil.swart@gmx.fr)
0f8acd5a9ae5e8df7e141f2c17e5fedd35264eb5.1720780359.git.ludo@gnu.org
From: Ludovic Courtès <ludovic.courtes@inria.fr>

* gnu/packages/mpi.scm (hwloc-2): Update to 2.11.1.
[native-inputs]: Add BASH.

Co-authored-by: Philippe SWARTVAGHER <phil.swart@gmx.fr>
Change-Id: If5531cb82911833153b0e795e9f20b0d0ae940c2
---
gnu/packages/mpi.scm | 10 ++++++----
1 file changed, 6 insertions(+), 4 deletions(-)

Toggle diff (41 lines)
diff --git a/gnu/packages/mpi.scm b/gnu/packages/mpi.scm
index 6270108b16..4c18da30ef 100644
--- a/gnu/packages/mpi.scm
+++ b/gnu/packages/mpi.scm
@@ -35,6 +35,7 @@ (define-module (gnu packages mpi)
#:use-module (guix build-system python)
#:use-module (gnu packages)
#:use-module (gnu packages base)
+ #:use-module (gnu packages bash)
#:use-module (gnu packages compression)
#:use-module (gnu packages fabric-management)
#:use-module (gnu packages gcc)
@@ -143,7 +144,7 @@ (define-public hwloc-1
(define-public hwloc-2
(package
(inherit hwloc-1)
- (version "2.10.0")
+ (version "2.11.1")
(source (origin
(method url-fetch)
(uri (string-append "https://download.open-mpi.org/release/hwloc/v"
@@ -151,11 +152,12 @@ (define-public hwloc-2
"/hwloc-" version ".tar.bz2"))
(sha256
(base32
- "14hkmq2hrs4j5f0sf32aazgbhgbdvj7lwapy35jvwbyyr5hds183"))))
+ "1ikhg35pll9zs628n2nii3ranz9j850hykqqcrgy2p12mpzzpk84"))))
- ;; libnuma is no longer needed.
+ (native-inputs (modify-inputs (package-native-inputs hwloc-1)
+ (append bash))) ;for completion tests
(inputs (modify-inputs (package-inputs hwloc-1)
- (delete "numactl")))
+ (delete "numactl"))) ;libnuma is no longer needed.
(arguments
(substitute-keyword-arguments (package-arguments hwloc-1)
((#:phases phases)

base-commit: 2d6a3799fcda5c017f653c6e96b91964b07a7ee0
--
2.45.2
Ludovic Courtès wrote 8 months ago
(address . 71788-done@debbugs.gnu.org)(name . Philippe SWARTVAGHER)(address . phil.swart@gmx.fr)
87a5ievhau.fsf@gnu.org
Ludovic Courtès <ludo@gnu.org> skribis:

Toggle quote (8 lines)
> From: Ludovic Courtès <ludovic.courtes@inria.fr>
>
> * gnu/packages/mpi.scm (hwloc-2): Update to 2.11.1.
> [native-inputs]: Add BASH.
>
> Co-authored-by: Philippe SWARTVAGHER <phil.swart@gmx.fr>
> Change-Id: If5531cb82911833153b0e795e9f20b0d0ae940c2

After some additional testing, and with qa.guix being overwhelmed these
days, I went ahead and pushed it as
fcd3c5d3aa2894218f357d69f7a307ebc3b318bc.

Thanks,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71788@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71788
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help