[PATCH] gnu: add sway-launcher-desktop

  • Open
  • quality assurance status badge
Details
One participant
  • JetpackJackson
Owner
unassigned
Submitted by
JetpackJackson
Severity
normal
J
J
JetpackJackson wrote on 25 Jun 03:59 +0200
(address . guix-patches@gnu.org)(name . JetpackJackson)(address . baileyannew@tutanota.com)
ec5f5dca13d9924835bee70d7cdfb84bc07ef655.1719280748.git.jetpackjackson@disroot.org
From: JetpackJackson <baileyannew@tutanota.com>

---
This patch adds sway-launcher-desktop to Guix. I wasn't sure where exactly to put it since it didn't seem to match things in packages/xdisorg.scm. This is my first time contributing, so please let me know if there's anything I need to fix.

gnu/packages/sway-launcher-desktop.scm | 41 ++++++++++++++++++++++++++
1 file changed, 41 insertions(+)
create mode 100644 gnu/packages/sway-launcher-desktop.scm

Toggle diff (51 lines)
diff --git a/gnu/packages/sway-launcher-desktop.scm b/gnu/packages/sway-launcher-desktop.scm
new file mode 100644
index 0000000000..81846b202f
--- /dev/null
+++ b/gnu/packages/sway-launcher-desktop.scm
@@ -0,0 +1,41 @@
+(define-module (sway-launcher-desktop)
+ #:use-module (gnu packages terminals)
+ #:use-module (gnu packages)
+ #:use-module (guix build-system copy)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix git-download)
+ #:use-module (guix packages))
+
+(define-public sway-launcher-desktop
+ (package
+ (name "sway-launcher-desktop")
+ (version "1.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Biont/sway-launcher-desktop")
+ (commit (string-append "v" version))))
+ (file-name (string-append "v" version))
+ (sha256
+ (base32 "0vphplphxfbdiwq0yk8ph7zlwlnghisnbwqjx7k9h93cy8n4rzcn"))))
+
+ (build-system copy-build-system)
+ (propagated-inputs (list fzf))
+ (arguments
+ `(#:install-plan '(("sway-launcher-desktop.sh"
+ "bin/sway-launcher-desktop"))
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'wrap-script
+ (lambda* (#:key outputs #:allow-other-keys)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/sway-launcher-desktop")
+ `("PATH" =
+ (,(getenv "PATH")))))))))
+
+ (synopsis "TUI application launcher menu")
+ (description
+ "sway-launcher-desktop is a TUI launcher made with bash and fzf.")
+ (home-page "https://github.com/Biont/sway-launcher-desktop")
+ (license license:gpl3)))
+sway-launcher-desktop

base-commit: 78d946b01162fbe986c6768800e8cfd6e70e67e5
--
2.45.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71769@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71769
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch