[PATCH python-team] gnu: python-immutables: Update to 0.20.

  • Done
  • quality assurance status badge
Details
2 participants
  • Felix Gruber
  • jgart
Owner
unassigned
Submitted by
Felix Gruber
Severity
normal

Debbugs page

Felix Gruber wrote 9 months ago
(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
e7a8b6ac55d477ff35d95fc9428c494673df587e.1719259470.git.felgru@posteo.net
* gnu/packages/python-xyz.scm (python-immutables): Update to 0.20.
[origin]: Use git-fetch as pypi package does not contain test-data
folder.

Change-Id: I9e7f632a9ff38d1b0f1f3efdb6a7dc0123214536
---
This fixes the build failure of python-immutables on the python-team
branch.

gnu/packages/python-xyz.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30b84d284d..2b5829647f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15868,13 +15868,17 @@ (define-public python-xlwt
(define-public python-immutables
(package
(name "python-immutables")
- (version "0.18")
+ (version "0.20")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "immutables" version))
+ ;; The PyPI package does not contain the test-data directory.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MagicStack/immutables")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1x4cinh0xbl6p6p2yfm2s07mxxy3lf0zzai9gqpydk4482bwfdjk"))))
+ (base32 "047z7xvdkr55c372sn7m3y8762w5kgh5yn1h9gq5qhcnzss04hbw"))))
(build-system pyproject-build-system)
(native-inputs
(list python-mypy python-pytest python-setuptools python-wheel))

base-commit: e4ad2f178af65be6c8ca6e98a667787674cd8c82
--
2.45.1
jgart wrote 8 months ago
(address . 71758@debbugs.gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
87ed7xe60b.fsf@dismail.de
Hi,

This doesn't apply for me.

Can you send with git send-email?

jgart@whereiseveryone:~/Code/guix-latest [env]$ mumi current 71758
#71758 [PATCH python-team] gnu: python-immutables: Update to 0.20.
opened on 24 Jun 15:06 -0500 by Felix Gruber
jgart@whereiseveryone:~/Code/guix-latest [env]$ mumi am -- -s -S
No patches found


--
all the best,
jgart
Felix Gruber wrote 8 months ago
e793afb7-fc72-4cfa-8d41-70382b1cdbe7@posteo.net
Hi jgart,

On 7/13/24 4:11 PM, jgart wrote:
Toggle quote (10 lines)
> This doesn't apply for me.
>
> Can you send with git send-email?
>
> jgart@whereiseveryone:~/Code/guix-latest [env]$ mumi current 71758
> #71758 [PATCH python-team] gnu: python-immutables: Update to 0.20.
> opened on 24 Jun 15:06 -0500 by Felix Gruber
> jgart@whereiseveryone:~/Code/guix-latest [env]$ mumi am -- -s -S
> No patches found

I had created this patch against the python-team branch, it shows a
merge conflict if I try to apply it to master. I will shortly sent an
updated patch, rebased to the master branch.

Kind regards,
Felix
Felix Gruber wrote 8 months ago
[PATCH v2] gnu: python-immutables: Update to 0.20.
(address . 71758@debbugs.gnu.org)
a065bbdcd8d28a25953f8a26b53ac41338724fa1.1721156998.git.felgru@posteo.net
* gnu/packages/python-xyz.scm (python-immutables): Update to 0.20.
[source]: Use git-fetch as pypi package does not contain test-data
folder.
[build-system] Use pyproject-build-system.
[native-inputs] Add python-setuptools and python-wheel.

Change-Id: I9e7f632a9ff38d1b0f1f3efdb6a7dc0123214536
---
gnu/packages/python-xyz.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a51320d59..ec42993728 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15728,15 +15728,20 @@ (define-public python-xlwt
(define-public python-immutables
(package
(name "python-immutables")
- (version "0.18")
+ (version "0.20")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "immutables" version))
+ ;; The PyPI package does not contain the test-data directory.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MagicStack/immutables")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1x4cinh0xbl6p6p2yfm2s07mxxy3lf0zzai9gqpydk4482bwfdjk"))))
- (build-system python-build-system)
- (native-inputs (list python-mypy python-pytest))
+ (base32 "047z7xvdkr55c372sn7m3y8762w5kgh5yn1h9gq5qhcnzss04hbw"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-mypy python-pytest python-setuptools python-wheel))
(home-page "https://github.com/MagicStack/immutables")
(synopsis "High-performance immutable mapping type for Python")
(description

base-commit: 325fed4c1514bffd084355455710fcc3f1c8da2c
--
2.43.0
Felix Gruber wrote 8 months ago
(address . 71758@debbugs.gnu.org)
a065bbdcd8d28a25953f8a26b53ac41338724fa1.1721157890.git.felgru@posteo.net
* gnu/packages/python-xyz.scm (python-immutables): Update to 0.20.
[source]: Use git-fetch as pypi package does not contain test-data
folder.
[build-system] Use pyproject-build-system.
[native-inputs] Add python-setuptools and python-wheel.

Change-Id: I9e7f632a9ff38d1b0f1f3efdb6a7dc0123214536
---
gnu/packages/python-xyz.scm | 17 +++++++++++------
1 file changed, 11 insertions(+), 6 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2a51320d59..ec42993728 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15728,15 +15728,20 @@ (define-public python-xlwt
(define-public python-immutables
(package
(name "python-immutables")
- (version "0.18")
+ (version "0.20")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "immutables" version))
+ ;; The PyPI package does not contain the test-data directory.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MagicStack/immutables")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1x4cinh0xbl6p6p2yfm2s07mxxy3lf0zzai9gqpydk4482bwfdjk"))))
- (build-system python-build-system)
- (native-inputs (list python-mypy python-pytest))
+ (base32 "047z7xvdkr55c372sn7m3y8762w5kgh5yn1h9gq5qhcnzss04hbw"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-mypy python-pytest python-setuptools python-wheel))
(home-page "https://github.com/MagicStack/immutables")
(synopsis "High-performance immutable mapping type for Python")
(description

base-commit: 325fed4c1514bffd084355455710fcc3f1c8da2c
--
2.43.0
Felix Gruber wrote 2 months ago
(address . 71758-done@debbugs.gnu.org)
ccc7b089-3c36-4149-b28c-3d8605e7b4e9@posteo.net
This patch has become obsolete as we now have python-immutables 0.21 on
master.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71758@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71758
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help