(address . guix-patches@gnu.org)(name . Felix Gruber)(address . felgru@posteo.net)
* gnu/packages/python-xyz.scm (python-immutables): Update to 0.20.
[origin]: Use git-fetch as pypi package does not contain test-data
folder.
Change-Id: I9e7f632a9ff38d1b0f1f3efdb6a7dc0123214536
---
This fixes the build failure of python-immutables on the python-team
branch.
gnu/packages/python-xyz.scm | 12 ++++++++----
1 file changed, 8 insertions(+), 4 deletions(-)
Toggle diff (30 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30b84d284d..2b5829647f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15868,13 +15868,17 @@ (define-public python-xlwt
(define-public python-immutables
(package
(name "python-immutables")
- (version "0.18")
+ (version "0.20")
(source
(origin
- (method url-fetch)
- (uri (pypi-uri "immutables" version))
+ ;; The PyPI package does not contain the test-data directory.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/MagicStack/immutables")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
- (base32 "1x4cinh0xbl6p6p2yfm2s07mxxy3lf0zzai9gqpydk4482bwfdjk"))))
+ (base32 "047z7xvdkr55c372sn7m3y8762w5kgh5yn1h9gq5qhcnzss04hbw"))))
(build-system pyproject-build-system)
(native-inputs
(list python-mypy python-pytest python-setuptools python-wheel))
base-commit: e4ad2f178af65be6c8ca6e98a667787674cd8c82
--
2.45.1