[PATCH 0/3] gnu: frama-c: Update to 29.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jean-Pierre De Jesus DIAZ
  • jgart
Owner
unassigned
Submitted by
Jean-Pierre De Jesus DIAZ
Severity
normal
J
J
Jean-Pierre De Jesus DIAZ wrote on 24 Jun 13:55 +0200
(address . guix-patches@gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
cover.1719229917.git.jean@foundation.xyz
This updates Frama-C to the latest version (29.0 Copper) and fixes
problems with the search paths so that Frama-C can be used without
the OCaml compiler in the profile[1][2].


Jean-Pierre De Jesus DIAZ (3):
gnu: frama-c: Update to 29.0.
gnu: frama-c: Use G-Expressions.
gnu: frama-c: Add wrap-programs phase.

gnu/packages/maths.scm | 29 ++++++++++++++++++++---------
1 file changed, 20 insertions(+), 9 deletions(-)


base-commit: c5fc11488c7bf6d9cf35513a43a40c61e5b8e1cd
--
2.45.1
J
J
Jean-Pierre De Jesus DIAZ wrote on 24 Jun 13:58 +0200
[PATCH 1/3] gnu: frama-c: Update to 29.0.
(address . 71748@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
63af342cc4745ebfe9c51fe4983f6cdcb5e62bc5.1719229917.git.jean@foundation.xyz
* gnu/packages/maths.scm (frama-c): Update to 29.0.

Change-Id: Ifca4712bc1d75b0c8837ac04151fa9a83ae95bbe
---
gnu/packages/maths.scm | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 02d8c704d8..90edd8a6e1 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9534,14 +9534,14 @@ (define-public why3
(define-public frama-c
(package
(name "frama-c")
- (version "28.1")
+ (version "29.0")
(source (origin
(method url-fetch)
(uri (string-append "https://frama-c.com/download/frama-c-"
- version "-Nickel.tar.gz"))
+ version "-Copper.tar.gz"))
(sha256
(base32
- "14zmwghwhcryvri7k91vc1yampvxvhg36vwjxf64d8kx7dsbq802"))))
+ "14vlvynp3yfmnkixm676c1ip0jlkiqjzmrp9f9c990zzs2wb7yyj"))))
(build-system dune-build-system)
(arguments
`(#:phases
--
2.45.1
J
J
Jean-Pierre De Jesus DIAZ wrote on 24 Jun 13:58 +0200
[PATCH 2/3] gnu: frama-c: Use G-Expressions.
(address . 71748@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
aa31f72ada4c091e11ff3db2afb70b7311f62153.1719229917.git.jean@foundation.xyz
* gnu/packages/maths.scm (frama-c) <arguments>: Use G-Expressions.

Change-Id: I25670a3d7e735e001aba63628c2f046be07fc643
---
gnu/packages/maths.scm | 10 +++++-----
1 file changed, 5 insertions(+), 5 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 90edd8a6e1..1df9931c69 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9544,11 +9544,11 @@ (define-public frama-c
"14vlvynp3yfmnkixm676c1ip0jlkiqjzmrp9f9c990zzs2wb7yyj"))))
(build-system dune-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'build 'set-env
- (lambda _
- (setenv "CC" "gcc"))))))
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'build 'set-env
+ (lambda _
+ (setenv "CC" "gcc"))))))
(inputs
(list gmp zlib))
(propagated-inputs (list
--
2.45.1
J
J
Jean-Pierre De Jesus DIAZ wrote on 24 Jun 13:58 +0200
[PATCH 3/3] gnu: frama-c: Add wrap-programs phase.
(address . 71748@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
de935cc73b8a05ce49a9b626829eb417f86b86b7.1719229917.git.jean@foundation.xyz
Frama-C needs the OCAMLPATH variable to be defined to load libraries, so
define it using the OCAMLPATH variable generated during build time.

Related issues:

- https://issues.guix.gnu.org/69996 (only Frama-C fixed from this one).

* gnu/packages/maths.scm (frama-c) <arguments>: Add wrap-programs phase.

Change-Id: Icc8a0be5fed6678b71649da2e39a83caaaee9df2
---
gnu/packages/maths.scm | 15 +++++++++++++--
1 file changed, 13 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 1df9931c69..858e7e75cc 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -9548,9 +9548,20 @@ (define-public frama-c
#~(modify-phases %standard-phases
(add-before 'build 'set-env
(lambda _
- (setenv "CC" "gcc"))))))
+ (setenv "CC" "gcc")))
+ (add-after 'install 'wrap-programs
+ (lambda _
+ (let ((ocamlpath
+ `(,(string-append #$output "/lib/ocaml/site-lib")
+ ,@(search-path-as-string->list
+ (getenv "OCAMLPATH")))))
+ (for-each
+ (lambda (program)
+ (wrap-program (string-append #$output "/bin/" program)
+ `("OCAMLPATH" ":" prefix ,ocamlpath)))
+ '("frama-c" "frama-c-gui"))))))))
(inputs
- (list gmp zlib))
+ (list bash-minimal gmp zlib))
(propagated-inputs (list
graphviz
lablgtk3
--
2.45.1
J
Re: [PATCH 0/3] gnu: frama-c: Update to 29.0.
(address . 71748-done@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
bec72573ddd9871319fd388c69aad7b73435a497@dismail.de
Applied! Thanks.

--
jgart
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71748@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71748
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch