[PATCH] gnu: imagemagick: Update to 7.1.1-33.

  • Open
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Andy Tai
  • Richard Sent
Owner
unassigned
Submitted by
Andy Tai
Severity
normal
A
A
Andy Tai wrote on 20 Jun 2024 07:08
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
33d29d243eb4cd848726790b86d14a51937cdaa4.1718860028.git.atai@atai.org
* gnu/packages/imagemagick.scm (imagemagick): Update to 7.1.1-33.
* gnu/packages/patches/imagemagick-CVE-2020-27829.patch: Removed.
* gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch: Removed.
* gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch: Removed.
* gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch: Removed.
* gnu/local.mk (dist_patch_DATA): Update accordingly.

Change-Id: Iabab606cc94f6db522f5ce3822f631bce93207d0
---
gnu/local.mk | 4 ---
gnu/packages/imagemagick.scm | 9 ++---
.../patches/imagemagick-CVE-2020-27829.patch | 27 --------------
.../imagemagick-ReadDCMImage-fix.patch | 26 --------------
.../imagemagick-ReadDCMPixels-fix.patch | 35 -------------------
.../imagemagick-WriteTHUMBNAILImage-fix.patch | 25 -------------
6 files changed, 2 insertions(+), 124 deletions(-)
delete mode 100644 gnu/packages/patches/imagemagick-CVE-2020-27829.patch
delete mode 100644 gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
delete mode 100644 gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
delete mode 100644 gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch

Toggle diff (182 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index cdf203777f..3d93cb13a5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1504,10 +1504,6 @@ dist_patch_DATA = \
%D%/packages/patches/idris-test-ffi008.patch \
%D%/packages/patches/igraph-fix-varargs-integer-size.patch \
%D%/packages/patches/ilmbase-fix-tests.patch \
- %D%/packages/patches/imagemagick-CVE-2020-27829.patch \
- %D%/packages/patches/imagemagick-ReadDCMImage-fix.patch \
- %D%/packages/patches/imagemagick-ReadDCMPixels-fix.patch \
- %D%/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch \
%D%/packages/patches/inkscape-poppler-compat.patch \
%D%/packages/patches/instead-use-games-path.patch \
%D%/packages/patches/intltool-perl-compatibility.patch \
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index b407af3588..4792b6d644 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -149,19 +149,14 @@ (define-public imagemagick
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-4")
+ (version "7.1.1-33")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "1pkwij76yz7vd5grl6520pgpa912qb6kh34qamx4zfndwcx6cf6b"))
- (patches
- (search-patches "imagemagick-ReadDCMImage-fix.patch"
- "imagemagick-ReadDCMPixels-fix.patch"
- "imagemagick-WriteTHUMBNAILImage-fix.patch"
- "imagemagick-CVE-2020-27829.patch"))))))
+ "18fy1ld4fvz1x3bhhfqld4c6qdlm1fqnigpvalpdy61dq3zfy8f0"))))))
(define-public perl-image-magick
(package
diff --git a/gnu/packages/patches/imagemagick-CVE-2020-27829.patch b/gnu/packages/patches/imagemagick-CVE-2020-27829.patch
deleted file mode 100644
index b15c1d0879..0000000000
--- a/gnu/packages/patches/imagemagick-CVE-2020-27829.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-We omit the ChangeLog changes below, since they do not apply cleanly.
-
-
-From 6ee5059cd3ac8d82714a1ab1321399b88539abf0 Mon Sep 17 00:00:00 2001
-From: Cristy <urban-warrior@imagemagick.org>
-Date: Mon, 30 Nov 2020 16:26:59 +0000
-Subject: [PATCH] possible TIFF related-heap buffer overflow (alert & POC by
- Hardik Shah)
-
----
- ChangeLog | 6 ++++++
- coders/tiff.c | 2 +-
- 2 files changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/coders/tiff.c b/coders/tiff.c
-index e98f927ab..1eecf17ae 100644
---- a/coders/tiff.c
-+++ b/coders/tiff.c
-@@ -1975,7 +1975,7 @@ static Image *ReadTIFFImage(const ImageInfo *image_info,
- extent+=image->columns*sizeof(uint32);
- #endif
- strip_pixels=(unsigned char *) AcquireQuantumMemory(extent,
-- sizeof(*strip_pixels));
-+ 2*sizeof(*strip_pixels));
- if (strip_pixels == (unsigned char *) NULL)
- ThrowTIFFException(ResourceLimitError,"MemoryAllocationFailed");
- (void) memset(strip_pixels,0,extent*sizeof(*strip_pixels));
diff --git a/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch b/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
deleted file mode 100644
index 42ece43682..0000000000
--- a/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 512668dfd92b20d0d08b91d62b422d8262573281 Mon Sep 17 00:00:00 2001
-From: Dirk Lemstra <dirk@lemstra.org>
-Date: Wed, 24 Mar 2021 20:37:15 +0100
-Subject: [PATCH] Throw exception when no exception was raised but status was
- false (#3432).
-
----
- coders/dcm.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/coders/dcm.c b/coders/dcm.c
-index 7a68ed6e8..ed17c9567 100644
---- a/coders/dcm.c
-+++ b/coders/dcm.c
-@@ -3989,6 +3989,8 @@ static Image *ReadDCMImage(const ImageInfo *image_info,ExceptionInfo *exception)
- if (redmap != (int *) NULL)
- redmap=(int *) RelinquishMagickMemory(redmap);
- image=DestroyImageList(image);
-+ if ((status == MagickFalse) && (exception->severity < ErrorException))
-+ ThrowReaderException(CorruptImageError,"CorruptImage");
- return(GetFirstImageInList(images));
- }
- if (info.depth != (1UL*MAGICKCORE_QUANTUM_DEPTH))
---
-2.31.0
-
diff --git a/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch b/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
deleted file mode 100644
index a91999186b..0000000000
--- a/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From c8f25953ad1dd38a8b2d92738f0f742ad7e0bce7 Mon Sep 17 00:00:00 2001
-From: Cristy <mikayla-grace@urban-warrior.org>
-Date: Sun, 21 Mar 2021 21:21:15 -0400
-Subject: [PATCH] https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=32322
-
----
- coders/dcm.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/coders/dcm.c b/coders/dcm.c
-index 29eed9618..7a68ed6e8 100644
---- a/coders/dcm.c
-+++ b/coders/dcm.c
-@@ -2984,12 +2984,12 @@ static MagickBooleanType ReadDCMPixels(Image *image,DCMInfo *info,
- }
- else
- {
-- SetPixelRed(q,(Quantum) (((ssize_t) pixel.red) |
-- (((ssize_t) GetPixelRed(q)) << 8)));
-- SetPixelGreen(q,(Quantum) (((ssize_t) pixel.green) |
-- (((ssize_t) GetPixelGreen(q)) << 8)));
-- SetPixelBlue(q,(Quantum) (((ssize_t) pixel.blue) |
-- (((ssize_t) GetPixelBlue(q)) << 8)));
-+ SetPixelRed(q,(Quantum) (((size_t) pixel.red) |
-+ (((size_t) GetPixelRed(q)) << 8)));
-+ SetPixelGreen(q,(Quantum) (((size_t) pixel.green) |
-+ (((size_t) GetPixelGreen(q)) << 8)));
-+ SetPixelBlue(q,(Quantum) (((size_t) pixel.blue) |
-+ (((size_t) GetPixelBlue(q)) << 8)));
- }
- q++;
- }
---
-2.31.0
-
diff --git a/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch b/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
deleted file mode 100644
index f38a45b800..0000000000
--- a/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 6a5d3575487487f2703383338bd17c8c25068f19 Mon Sep 17 00:00:00 2001
-From: Cristy <mikayla-grace@urban-warrior.org>
-Date: Thu, 25 Mar 2021 08:58:18 -0400
-Subject: [PATCH] eliminate compiler warning
-
----
- coders/thumbnail.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/coders/thumbnail.c b/coders/thumbnail.c
-index 3833341b0..1e2bfe8c2 100644
---- a/coders/thumbnail.c
-+++ b/coders/thumbnail.c
-@@ -199,7 +199,7 @@ static MagickBooleanType WriteTHUMBNAILImage(const ImageInfo *image_info,
- q++;
- }
- if ((q > (GetStringInfoDatum(profile)+GetStringInfoLength(profile))) ||
-- (length > (GetStringInfoDatum(profile)+GetStringInfoLength(profile)-q)))
-+ ((ssize_t) length > (GetStringInfoDatum(profile)+GetStringInfoLength(profile)-q)))
- ThrowWriterException(CoderError,"ImageDoesNotHaveAThumbnail");
- thumbnail_image=BlobToImage(image_info,q,length,&image->exception);
- if (thumbnail_image == (Image *) NULL)
---
-2.31.0
-

base-commit: 9a09ab433f6f5dfb3ce85266d8fb2286f79b5080
--
2.34.1
A
A
Andy Tai wrote on 19 Aug 2024 07:18
[PATCH v2] gnu: imagemagick: Update to 7.1.1-36.
(address . 71667@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
25e9c864523beb6b8e70ae4d0b18d57611e59e25.1724044693.git.atai@atai.org
* gnu/packages/imagemagick.scm (imagemagick): Update to 7.1.1-36.
* gnu/packages/patches/imagemagick-CVE-2020-27829.patch: Removed.
* gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch: Removed.
* gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch: Removed.
* gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch: Removed.
* gnu/local.mk (dist_patch_DATA): Update accordingly.

Change-Id: Iabab606cc94f6db522f5ce3822f631bce93207d0
---
gnu/local.mk | 4 ---
gnu/packages/imagemagick.scm | 9 ++---
.../patches/imagemagick-CVE-2020-27829.patch | 27 --------------
.../imagemagick-ReadDCMImage-fix.patch | 26 --------------
.../imagemagick-ReadDCMPixels-fix.patch | 35 -------------------
.../imagemagick-WriteTHUMBNAILImage-fix.patch | 25 -------------
6 files changed, 2 insertions(+), 124 deletions(-)
delete mode 100644 gnu/packages/patches/imagemagick-CVE-2020-27829.patch
delete mode 100644 gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
delete mode 100644 gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
delete mode 100644 gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch

Toggle diff (182 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index 3b0a3858f7..9808930840 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1518,10 +1518,6 @@ dist_patch_DATA = \
%D%/packages/patches/idris-test-ffi008.patch \
%D%/packages/patches/igraph-fix-varargs-integer-size.patch \
%D%/packages/patches/ilmbase-fix-tests.patch \
- %D%/packages/patches/imagemagick-CVE-2020-27829.patch \
- %D%/packages/patches/imagemagick-ReadDCMImage-fix.patch \
- %D%/packages/patches/imagemagick-ReadDCMPixels-fix.patch \
- %D%/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch \
%D%/packages/patches/inkscape-poppler-compat.patch \
%D%/packages/patches/instead-use-games-path.patch \
%D%/packages/patches/intltool-perl-compatibility.patch \
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index b407af3588..bb0615be80 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -149,19 +149,14 @@ (define-public imagemagick
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.12-4")
+ (version "7.1.1-36")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "1pkwij76yz7vd5grl6520pgpa912qb6kh34qamx4zfndwcx6cf6b"))
- (patches
- (search-patches "imagemagick-ReadDCMImage-fix.patch"
- "imagemagick-ReadDCMPixels-fix.patch"
- "imagemagick-WriteTHUMBNAILImage-fix.patch"
- "imagemagick-CVE-2020-27829.patch"))))))
+ "03w763wapi3xysg17l1cgs7s44dqnczc765097n90nx78h0lqaya"))))))
(define-public perl-image-magick
(package
diff --git a/gnu/packages/patches/imagemagick-CVE-2020-27829.patch b/gnu/packages/patches/imagemagick-CVE-2020-27829.patch
deleted file mode 100644
index b15c1d0879..0000000000
--- a/gnu/packages/patches/imagemagick-CVE-2020-27829.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-We omit the ChangeLog changes below, since they do not apply cleanly.
-
-
-From 6ee5059cd3ac8d82714a1ab1321399b88539abf0 Mon Sep 17 00:00:00 2001
-From: Cristy <urban-warrior@imagemagick.org>
-Date: Mon, 30 Nov 2020 16:26:59 +0000
-Subject: [PATCH] possible TIFF related-heap buffer overflow (alert & POC by
- Hardik Shah)
-
----
- ChangeLog | 6 ++++++
- coders/tiff.c | 2 +-
- 2 files changed, 7 insertions(+), 1 deletion(-)
-
-diff --git a/coders/tiff.c b/coders/tiff.c
-index e98f927ab..1eecf17ae 100644
---- a/coders/tiff.c
-+++ b/coders/tiff.c
-@@ -1975,7 +1975,7 @@ static Image *ReadTIFFImage(const ImageInfo *image_info,
- extent+=image->columns*sizeof(uint32);
- #endif
- strip_pixels=(unsigned char *) AcquireQuantumMemory(extent,
-- sizeof(*strip_pixels));
-+ 2*sizeof(*strip_pixels));
- if (strip_pixels == (unsigned char *) NULL)
- ThrowTIFFException(ResourceLimitError,"MemoryAllocationFailed");
- (void) memset(strip_pixels,0,extent*sizeof(*strip_pixels));
diff --git a/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch b/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
deleted file mode 100644
index 42ece43682..0000000000
--- a/gnu/packages/patches/imagemagick-ReadDCMImage-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 512668dfd92b20d0d08b91d62b422d8262573281 Mon Sep 17 00:00:00 2001
-From: Dirk Lemstra <dirk@lemstra.org>
-Date: Wed, 24 Mar 2021 20:37:15 +0100
-Subject: [PATCH] Throw exception when no exception was raised but status was
- false (#3432).
-
----
- coders/dcm.c | 2 ++
- 1 file changed, 2 insertions(+)
-
-diff --git a/coders/dcm.c b/coders/dcm.c
-index 7a68ed6e8..ed17c9567 100644
---- a/coders/dcm.c
-+++ b/coders/dcm.c
-@@ -3989,6 +3989,8 @@ static Image *ReadDCMImage(const ImageInfo *image_info,ExceptionInfo *exception)
- if (redmap != (int *) NULL)
- redmap=(int *) RelinquishMagickMemory(redmap);
- image=DestroyImageList(image);
-+ if ((status == MagickFalse) && (exception->severity < ErrorException))
-+ ThrowReaderException(CorruptImageError,"CorruptImage");
- return(GetFirstImageInList(images));
- }
- if (info.depth != (1UL*MAGICKCORE_QUANTUM_DEPTH))
---
-2.31.0
-
diff --git a/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch b/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
deleted file mode 100644
index a91999186b..0000000000
--- a/gnu/packages/patches/imagemagick-ReadDCMPixels-fix.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From c8f25953ad1dd38a8b2d92738f0f742ad7e0bce7 Mon Sep 17 00:00:00 2001
-From: Cristy <mikayla-grace@urban-warrior.org>
-Date: Sun, 21 Mar 2021 21:21:15 -0400
-Subject: [PATCH] https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=32322
-
----
- coders/dcm.c | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/coders/dcm.c b/coders/dcm.c
-index 29eed9618..7a68ed6e8 100644
---- a/coders/dcm.c
-+++ b/coders/dcm.c
-@@ -2984,12 +2984,12 @@ static MagickBooleanType ReadDCMPixels(Image *image,DCMInfo *info,
- }
- else
- {
-- SetPixelRed(q,(Quantum) (((ssize_t) pixel.red) |
-- (((ssize_t) GetPixelRed(q)) << 8)));
-- SetPixelGreen(q,(Quantum) (((ssize_t) pixel.green) |
-- (((ssize_t) GetPixelGreen(q)) << 8)));
-- SetPixelBlue(q,(Quantum) (((ssize_t) pixel.blue) |
-- (((ssize_t) GetPixelBlue(q)) << 8)));
-+ SetPixelRed(q,(Quantum) (((size_t) pixel.red) |
-+ (((size_t) GetPixelRed(q)) << 8)));
-+ SetPixelGreen(q,(Quantum) (((size_t) pixel.green) |
-+ (((size_t) GetPixelGreen(q)) << 8)));
-+ SetPixelBlue(q,(Quantum) (((size_t) pixel.blue) |
-+ (((size_t) GetPixelBlue(q)) << 8)));
- }
- q++;
- }
---
-2.31.0
-
diff --git a/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch b/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
deleted file mode 100644
index f38a45b800..0000000000
--- a/gnu/packages/patches/imagemagick-WriteTHUMBNAILImage-fix.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From 6a5d3575487487f2703383338bd17c8c25068f19 Mon Sep 17 00:00:00 2001
-From: Cristy <mikayla-grace@urban-warrior.org>
-Date: Thu, 25 Mar 2021 08:58:18 -0400
-Subject: [PATCH] eliminate compiler warning
-
----
- coders/thumbnail.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/coders/thumbnail.c b/coders/thumbnail.c
-index 3833341b0..1e2bfe8c2 100644
---- a/coders/thumbnail.c
-+++ b/coders/thumbnail.c
-@@ -199,7 +199,7 @@ static MagickBooleanType WriteTHUMBNAILImage(const ImageInfo *image_info,
- q++;
- }
- if ((q > (GetStringInfoDatum(profile)+GetStringInfoLength(profile))) ||
-- (length > (GetStringInfoDatum(profile)+GetStringInfoLength(profile)-q)))
-+ ((ssize_t) length > (GetStringInfoDatum(profile)+GetStringInfoLength(profile)-q)))
- ThrowWriterException(CoderError,"ImageDoesNotHaveAThumbnail");
- thumbnail_image=BlobToImage(image_info,q,length,&image->exception);
- if (thumbnail_image == (Image *) NULL)
---
-2.31.0
-

base-commit: 58a839273d1e4fac2b3a0ec456aabdf82deaa124
--
2.34.1
A
A
Andy Tai wrote on 3 Sep 2024 04:03
[PATCH v3] gnu: imagemagick: Update to 7.1.1-36.
(address . 71667@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
24547c956447ed1c0c1e451eac5a88fb2cad5c45.1725328969.git.atai@atai.org
* gnu/packages/imagemagick.scm (imagemagick): Update to 7.1.1-36.

Change-Id: Iabab606cc94f6db522f5ce3822f631bce93207d0
---
gnu/packages/imagemagick.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index e7734125ad..207e17381e 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -143,14 +143,14 @@ (define-public imagemagick
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.13-5")
+ (version "7.1.1-36")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "1j1chkw33vjc37509vdwss28qywfvckvs73pvscldj8d0wnwypa8"))))
+ "03w763wapi3xysg17l1cgs7s44dqnczc765097n90nx78h0lqaya"))))
(arguments
(substitute-keyword-arguments (package-arguments imagemagick/stable)
((#:configure-flags flags #~'())

base-commit: 61a7930cb03f5eb9e8003bade21d61262c3db8df
prerequisite-patch-id: c46cc240fed9cfc3513d85220162ee0191169a2a
--
2.34.1
A
A
Andy Tai wrote on 3 Sep 2024 04:06
[PATCH v4] gnu: imagemagick: Update to 7.1.1-38.
(address . 71667@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
3695e4e965d50307bf1027b922e429b912e8a905.1725329062.git.atai@atai.org
* gnu/packages/imagemagick.scm (imagemagick): Update to 7.1.1-38.

Change-Id: Iabab606cc94f6db522f5ce3822f631bce93207d0
---
gnu/packages/imagemagick.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/imagemagick.scm b/gnu/packages/imagemagick.scm
index e7734125ad..8ca24fe905 100644
--- a/gnu/packages/imagemagick.scm
+++ b/gnu/packages/imagemagick.scm
@@ -143,14 +143,14 @@ (define-public imagemagick
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.
- (version "6.9.13-5")
+ (version "7.1.1-38")
(source (origin
(method url-fetch)
(uri (string-append "mirror://imagemagick/ImageMagick-"
version ".tar.xz"))
(sha256
(base32
- "1j1chkw33vjc37509vdwss28qywfvckvs73pvscldj8d0wnwypa8"))))
+ "10mdqhxk6sfazm4jn56wv13in06qdafkp81ck1n25z3p966m9pj8"))))
(arguments
(substitute-keyword-arguments (package-arguments imagemagick/stable)
((#:configure-flags flags #~'())

base-commit: 61a7930cb03f5eb9e8003bade21d61262c3db8df
prerequisite-patch-id: c46cc240fed9cfc3513d85220162ee0191169a2a
--
2.34.1
A
A
Andreas Enge wrote on 11 Sep 2024 10:46
Change of major version
(address . 71667@debbugs.gnu.org)
ZuFYyV6pE0rGy1Rd@jurong
Hello Andy,

your version update from 6 to 7 comes immediately after these comments:
;; The 7 release series has an incompatible API, while the 6 series is still
;; maintained. Don't update to 7 until we've made sure that the ImageMagick
;; users are ready for the 7-series API.

Since there is also a variable imagemagick/stable, it might be possible to
advance the publicly visible version, but this would require further
discussion.

Maybe switching to 6.9.13-16 would be the safest option for the moment.

Andreas
R
R
Richard Sent wrote on 21 Nov 2024 03:19
(name . Andreas Enge)(address . andreas@enge.fr)
87ttc1ib04.fsf@freakingpenguin.com
I've had instances where version 7 would be useful. Perhaps v7 can be
added as imagemagick-next so it is available while the 6->7 transition
is worked out.

--
Take it easy,
Richard Sent
Making my computer weirder one commit at a time.
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71667@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71667
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch