[PATCH] gnu: Add r-anpan.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal

Debbugs page

Afkhami, Navid wrote 9 months ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
cd1df6868c6ab368e11f2e9882f08e60f378fbf7.1718809366.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-anpan): New variable.

Change-Id: Ia01ba3be7424306674b9c9b2904f1f0cfa66d818
---
gnu/packages/bioinformatics.scm | 48 +++++++++++++++++++++++++++++++++
1 file changed, 48 insertions(+)

Toggle diff (65 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index e2632a5aa4..8ffc46d86d 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -752,6 +752,54 @@ (define-public r-anndatar
@code{SingleCellExperiment} and Seurat objects.")
(license license:expat))))
+(define-public r-anpan
+ (let ((commit "286b88dcf5e9e963a595482139aade154ee1dc86")
+ (revision "1"))
+ (package
+ (name "r-anpan")
+ (version (git-version "0.3.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/biobakery/anpan")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10nw5v69gn4pxb4g5gd8nh9r1ywd6yczapl3dpdfms0434wcmkxm"))))
+ (properties `((upstream-name . "anpan")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ape
+ r-cmdstanr
+ r-data-table
+ r-dplyr
+ r-fastglm
+ r-furrr
+ r-future
+ r-ggdendro
+ r-ggnewscale
+ r-ggplot2
+ r-loo
+ r-mass
+ r-patchwork
+ r-phylogram
+ r-posterior
+ r-progressr
+ r-purrr
+ r-r-utils
+ r-stringr
+ r-tibble
+ r-tidyselect))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/biobakery/anpan")
+ (synopsis "Quantifying microbial strain-host associations")
+ (description
+ "The goal of anpan is to consolidate statistical methods for strain analysis.
+This includes automated filtering of metagenomic functional profiles, testing genetic
+elements for association with outcomes, phylogenetic association testing, and
+pathway-level random effects models.")
+ (license license:expat))))
+
(define-public r-bedtorch
(let ((commit "f5ff4f83b94f59eac660333c64e4b2f296b35cea")
(revision "1"))

base-commit: c551e406a75273583ae3fef92f32468f905cc07f
prerequisite-patch-id: 70095eccc2035390725bf119749d138d609d2b83
prerequisite-patch-id: 016f9a35b1da6b5916599f4cc6616fc9738c2b46
--
2.34.1
Ricardo Wurmus wrote 8 months ago
(address . 71651-done@debbugs.gnu.org)
87tth9te64.fsf@elephly.net
Applied, thank you!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71651@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71651
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help