[PATCH] gnu: Add r-fastglm.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Andreas Enge
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal

Debbugs page

Afkhami, Navid wrote 9 months ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
8f667593ab7837be32900950ae66b057d066d5e2.1718799631.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-fastglm): New variable.

Change-Id: I187c9579b1f8ff47e47d721d9684c16698066148
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 83f395a69e..c84e3c3687 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5273,6 +5273,30 @@ (define-public r-fastmap
data structures in C++.")
(license license:expat)))
+(define-public r-fastglm
+ (package
+ (name "r-fastglm")
+ (version "0.0.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "fastglm" version))
+ (sha256
+ (base32 "0283kgk81cxbii7ljmp1rzqg5mzkvf7cj7lflhhhkgj5ljqina2i"))))
+ (properties `((upstream-name . "fastglm")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-bh r-bigmemory r-rcpp r-rcppeigen))
+ (native-inputs (list r-knitr))
+ (home-page "https://cran.r-project.org/package=fastglm")
+ (synopsis
+ "Fast and stable fitting of generalized linear models using 'RcppEigen'")
+ (description
+ "This package fits generalized linear models efficiently using @code{RcppEigen}'.
+The iteratively reweighted least squares implementation utilizes the
+step-halving approach of Marschner to help safeguard against convergence
+issues.")
+ (license license:gpl2+)))
+
(define-public r-fastghquad
(package
(name "r-fastghquad")

base-commit: da1f3aff2ea9a98651ebc69c8385ba136fe2e325
prerequisite-patch-id: 01e990e85f2d1bd0c50ae32161d5ccf814a0ef7e
--
2.34.1
Andreas Enge wrote 8 months ago
Close
ZoEcUZ4_q8PjyFUX@jurong
Thanks for the patches, I have pushed them after small changes to the
synopsis or description and adding a 2024 copyright line for you.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71649@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71649
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help