[PATCH] gnu: Add r-cutpointr.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Andreas Enge
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal

Debbugs page

Afkhami, Navid wrote 9 months ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
771ef1935d7fa161da2ee81c735ddc8925c0dae2.1718793996.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-cutpointr): New variable.

Change-Id: I60e578fab1e251a526d90ce25dd1c3fc7ec4409d
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 85e0fa98f9..83f395a69e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -704,6 +704,40 @@ (define-public r-curry
etc.")
(license license:gpl2+)))
+(define-public r-cutpointr
+ (package
+ (name "r-cutpointr")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cutpointr" version))
+ (sha256
+ (base32 "1qxnh20hs3bh9v04ls7gwwl7lfc6bwl8c88dn8lkcdqyp3nyr01j"))))
+ (properties `((upstream-name . "cutpointr")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-foreach
+ r-ggplot2
+ r-gridextra
+ r-purrr
+ r-rcpp
+ r-rlang
+ r-tibble
+ r-tidyr
+ r-tidyselect))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/thie1e/cutpointr")
+ (synopsis "Determine and evaluate optimal cutpoints in binary")
+ (description
+ "This package estimates optimal cutpoints for binary classification metrics.
+It also validates performance using bootstrapping. Some methods for more
+robust cutpoint estimation are supported, e.g. a parametric method assuming
+normal distributions, bootstrapped cutpoints, and smoothing of the metric
+values per cutpoint using Generalized Additive Models. Various plotting
+functions are included.")
+ (license license:gpl3)))
+
(define-public r-datawizard
(package
(name "r-datawizard")

base-commit: da1f3aff2ea9a98651ebc69c8385ba136fe2e325
--
2.34.1
Andreas Enge wrote 8 months ago
Close
ZoEcUZ4_q8PjyFUX@jurong
Thanks for the patches, I have pushed them after small changes to the
synopsis or description and adding a 2024 copyright line for you.

Andreas
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71647@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71647
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help