Afkhami, Navid wrote 9 months ago
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
* gnu/packages/cran.scm (r-cutpointr): New variable.
Change-Id: I60e578fab1e251a526d90ce25dd1c3fc7ec4409d
---
gnu/packages/cran.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)
Toggle diff (49 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 85e0fa98f9..83f395a69e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -704,6 +704,40 @@ (define-public r-curry
etc.")
(license license:gpl2+)))
+(define-public r-cutpointr
+ (package
+ (name "r-cutpointr")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "cutpointr" version))
+ (sha256
+ (base32 "1qxnh20hs3bh9v04ls7gwwl7lfc6bwl8c88dn8lkcdqyp3nyr01j"))))
+ (properties `((upstream-name . "cutpointr")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dplyr
+ r-foreach
+ r-ggplot2
+ r-gridextra
+ r-purrr
+ r-rcpp
+ r-rlang
+ r-tibble
+ r-tidyr
+ r-tidyselect))
+ (native-inputs (list r-knitr))
+ (home-page "https://github.com/thie1e/cutpointr")
+ (synopsis "Determine and evaluate optimal cutpoints in binary")
+ (description
+ "This package estimates optimal cutpoints for binary classification metrics.
+It also validates performance using bootstrapping. Some methods for more
+robust cutpoint estimation are supported, e.g. a parametric method assuming
+normal distributions, bootstrapped cutpoints, and smoothing of the metric
+values per cutpoint using Generalized Additive Models. Various plotting
+functions are included.")
+ (license license:gpl3)))
+
(define-public r-datawizard
(package
(name "r-datawizard")
base-commit: da1f3aff2ea9a98651ebc69c8385ba136fe2e325
--
2.34.1