[PATCH 0/4] gnu: kubo: Unbundle more inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal
A
A
Artyom V. Poptsov wrote on 18 Jun 21:41 +0200
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1718739586.git.poptsov.artyom@gmail.com
This patchset unbundles "go-github-com-ipld-go-ipld-prime" from Kubo (IPFS.)

Artyom V. Poptsov (4):
gnu: Add go-github-com-polydawn-refmt.
gnu: Add go-github-com-warpfork-go-testmark.
gnu: Add go-github-com-ipld-go-ipld-prime.
gnu: kubo: Unbundle more inputs.

gnu/packages/golang-check.scm | 27 ++++++++++++++++++
gnu/packages/golang-xyz.scm | 28 ++++++++++++++++++
gnu/packages/ipfs.scm | 54 +++++++++++++++++++++++++++++++++--
3 files changed, 107 insertions(+), 2 deletions(-)


base-commit: b993f4735d41e690dbafb8ee2e17fce996a8cf20
--
2.45.1
A
A
Artyom V. Poptsov wrote on 18 Jun 21:43 +0200
[PATCH 1/4] gnu: Add go-github-com-polydawn-refmt.
(address . 71636@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
aafd0173529a9fef2b3291a68f508fa0e6b78c95.1718739586.git.poptsov.artyom@gmail.com
* gnu/packages/golang-xyz.scm (go-github-com-polydawn-refmt): New variable.

Change-Id: I5b300fb826ec7f232cab108614737e49e114afa5
---
gnu/packages/golang-xyz.scm | 28 ++++++++++++++++++++++++++++
1 file changed, 28 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index ca9cdb0b1b..0cb44b0131 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -3135,6 +3135,34 @@ (define-public go-github-com-pion-logging
Pion}.")
(license license:expat)))
+(define-public go-github-com-polydawn-refmt
+ (package
+ (name "go-github-com-polydawn-refmt")
+ (version "0.89.1-0.20231129105047-37766d95467a")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/polydawn/refmt/")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0grgzacc7igfndk1v3n1g6k4wdz6bjsiqfq3n5br2zpr7n40ha9n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/polydawn/refmt"))
+ (propagated-inputs
+ (list go-gopkg-in-yaml-v2
+ go-github.com-smartystreets-goconvey
+ go-github-com-urfave-cli
+ go-github-com-warpfork-go-wish))
+ (home-page "https://github.com/polydawn/refmt/")
+ (synopsis "Object mapping for Go language")
+ (description
+ "@code{refmt} is a serialization and object-mapping library.")
+ (license license:expat)))
+
(define-public go-github-com-prometheus-client-model
(package
(name "go-github-com-prometheus-client-model")
--
2.45.1
A
A
Artyom V. Poptsov wrote on 18 Jun 21:43 +0200
[PATCH 2/4] gnu: Add go-github-com-warpfork-go-testmark.
(address . 71636@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
78db543bf7c36ea8f4907820f15f66402caf45be.1718739586.git.poptsov.artyom@gmail.com
* gnu/packages/golang-check.scm (go-github-com-warpfork-go-testmark): New variable.

Change-Id: Ie8c4524ead7f6199dc9de92c1de86e6ad2289512
---
gnu/packages/golang-check.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (40 lines)
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 3fc628a202..40f05c1025 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1034,6 +1034,33 @@ (define-public go-github-com-go-playground-assert-v2
(arguments
(list #:import-path "github.com/go-playground/assert/v2"))))
+(define-public go-github-com-warpfork-go-testmark
+ (package
+ (name "go-github-com-warpfork-go-testmark")
+ (version "0.12.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/warpfork/go-testmark")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "06v2x3c5qgbj585a2abksr3hgvgdx61j153rjarqi9cvvzwh1xpr"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/warpfork/go-testmark"))
+ (home-page "https://github.com/warpfork/go-testmark")
+ (synopsis "Parser for @code{testmark} format")
+ (description
+ "@code{go-testmark} is a library to parse and patch data and test fixtures from
+Markdown files, using the
+@url{https://github.com/warpfork/go-testmark?tab=readme-ov-file#what-is-the-testmark-format,
+testmark} format, which itself is a subset of Markdown format.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public go-github-com-warpfork-go-wish
(package
(name "go-github-com-warpfork-go-wish")
--
2.45.1
A
A
Artyom V. Poptsov wrote on 18 Jun 21:43 +0200
[PATCH 3/4] gnu: Add go-github-com-ipld-go-ipld-prime.
(address . 71636@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
6350b37fd255d6d6aff1123b73e1830e6231eb1a.1718739586.git.poptsov.artyom@gmail.com
* gnu/packages/ipfs.scm (go-github-com-ipld-go-ipld-prime): New variable.

Change-Id: Icbf768341fda23154b82f10e3701ce435c9ec6e9
---
gnu/packages/ipfs.scm | 51 ++++++++++++++++++++++++++++++++++++++++++-
1 file changed, 50 insertions(+), 1 deletion(-)

Toggle diff (71 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 7fb50452b6..b487062672 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -37,7 +37,8 @@ (define-module (gnu packages ipfs)
#:use-module (gnu packages golang-web)
#:use-module (gnu packages golang-xyz)
#:use-module (gnu packages python)
- #:use-module (gnu packages shells))
+ #:use-module (gnu packages shells)
+ #:use-module (gnu packages specifications))
(define-public go-github-com-ipfs-go-block-format
(package
@@ -298,6 +299,54 @@ (define-public go-github-com-ipfs-go-ipld-format
order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-forest.")
(license license:expat)))
+(define-public go-github-com-ipld-go-ipld-prime
+ (package
+ (name "go-github-com-ipld-go-ipld-prime")
+ (version "0.21.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipld/go-ipld-prime")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1ycb08h0hvq3mw3sbjkjzp5sfcxmss155jxiv5gjg7myxvzk91ja"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:unpack-path "github.com/ipld/go-ipld-prime/"
+ #:import-path "github.com/ipld/go-ipld-prime/"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'copy-ipld-specfs
+ (lambda* (#:key import-path #:allow-other-keys)
+ (copy-recursively
+ (string-append #$(this-package-native-input
+ "specification-ipld")
+ "/share/ipld/")
+ (string-append "src/" import-path "/ipld")))))))
+ (native-inputs
+ (list go-github-com-frankban-quicktest
+ go-github-com-warpfork-go-testmark
+ specification-ipld))
+ (propagated-inputs
+ (list go-github-com-google-go-cmp-cmp
+ go-github-com-multiformats-go-multicodec
+ go-github-com-multiformats-go-multihash
+ go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-cid
+ go-github-com-polydawn-refmt
+ go-gopkg-in-yaml-v2))
+ (home-page "https://github.com/ipld/go-ipld-prime")
+ (synopsis "Golang interfaces for the IPLD Data Model")
+ (description
+ "@code{go-ipld-prime} is an implementation of the IPLD spec interfaces, a
+batteries-included codec implementations of IPLD for CBOR and JSON, and tooling for
+basic operations on IPLD objects (traversals, etc).")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipfs-api
(let ((commit
"dafc2a13a4389ac1a6c2786e34ab70a4f26d3a3f")
--
2.45.1
A
A
Artyom V. Poptsov wrote on 18 Jun 21:43 +0200
[PATCH 4/4] gnu: kubo: Unbundle more inputs.
(address . 71636@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
1b87e7153599e94f7742e4fe7f57d9da8a475720.1718739586.git.poptsov.artyom@gmail.com
* gnu/packages/ipfs.scm (kubo): Unbundle more inputs.
[inputs]: Add go-github-com-ipld-go-ipld-prime.

Change-Id: I30f2739fea38507fde2290cd99b9c9b41b664c40
---
gnu/packages/ipfs.scm | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index b487062672..12817728ee 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -602,6 +602,7 @@ (define-public kubo
"vendor/github.com/ipfs/go-ipfs-util"
"vendor/github.com/ipfs/go-ipld-format"
"vendor/github.com/ipfs/go-log"
+ "vendor/github.com/ipld/go-ipld-prime"
"vendor/github.com/jackpal"
"vendor/github.com/jbenet"
"vendor/github.com/julienschmidt"
@@ -695,7 +696,7 @@ (define-public kubo
;;go-github-com-ipld-go-car
;;go-github-com-ipld-go-car-v2
;;go-github-com-ipld-go-codec-dagpb
- ;;go-github-com-ipld-go-ipld-prime
+ go-github-com-ipld-go-ipld-prime
go-github-com-jbenet-go-random
go-github-com-jbenet-go-temp-err-catcher
go-github-com-jbenet-goprocess
--
2.45.1
S
S
Sharlatan Hellseher wrote on 19 Jun 16:20 +0200
[PATCH 0/4] gnu: kubo: Unbundle more inputs.
(address . 71636-done@debbugs.gnu.org)
874j9pxbdw.fsf@gmail.com
Hi,

Thank you for the patches!

I've modified the last patch to update kubo to the latest version and
unbundled even more packages.

Her is my investigation list of what's passed to vendor, where (+)
package is present in Guix, (+ fail) package is present but kubo build
failed to build with it, (-) package is absent:


Toggle snippet (196 lines)
+ fail go-github-com-cskr-pubsub
+ fail go-github-com-libp2p-go-flow-metrics
+ fail go-github-com-pion-ice-v2

+ go-github-com-docker-go-units
+ go-github-com-felixge-httpsnoop
+ go-github-com-gabriel-vasile-mimetype
+ go-github-com-go-logr-logr
+ go-github-com-go-task-slim-sprig
+ go-github-com-google-gopacket
+ go-github-com-google-pprof
+ go-github-com-miekg-dns
+ go-github-com-onsi-ginkgo
+ go-github-com-pion-mdns
+ go-github-com-quic-go-qpack
+ go-github-com-quic-go-webtransport-go

- go-contrib-go-opencensus-io-exporter-prometheus
- go-github-com-alexbrainman-goissue34681
- go-github-com-andreasbriese-bbloom
- go-github-com-ceramicnetwork-go-dag-jose
- go-github-com-containerd-cgroups
- go-github-com-crackcomm-go-gitignore
- go-github-com-davidlazar-go-crypto
- go-github-com-decred-dcrd
- go-github-com-dgraph-io-badger
- go-github-com-dgraph-io-ristretto
- go-github-com-elastic-gosigar
- go-github-com-facebookgo-atomicfile
- go-github-com-go-kit-log
- go-github-com-go-logfmt
- go-github-com-go-logfmt-logfmt
- go-github-com-go-logr-stdr
- go-github-com-golang-protobuf
- go-github-com-grpc-ecosystem-grpc-gateway
- go-github-com-huin-goupnp
- go-github-com-ipfs-bbloom
- go-github-com-ipfs-boxo
- go-github-com-ipfs-go-bitfield
- go-github-com-ipfs-go-blockservice
- go-github-com-ipfs-go-ds-badger
- go-github-com-ipfs-go-ds-flatfs
- go-github-com-ipfs-go-ds-leveldb
- go-github-com-ipfs-go-ds-measure
- go-github-com-ipfs-go-fs-lock
- go-github-com-ipfs-go-ipfs-blockstore
- go-github-com-ipfs-go-ipfs-chunker
- go-github-com-ipfs-go-ipfs-cmds
- go-github-com-ipfs-go-ipfs-ds-help
- go-github-com-ipfs-go-ipfs-exchange-interface
- go-github-com-ipfs-go-ipfs-pq
- go-github-com-ipfs-go-ipfs-redirects-file
- go-github-com-ipfs-go-ipld-cbor
- go-github-com-ipfs-go-ipld-git
- go-github-com-ipfs-go-ipld-legacy
- go-github-com-ipfs-go-merkledag
- go-github-com-ipfs-go-metrics-interface
- go-github-com-ipfs-go-metrics-prometheus
- go-github-com-ipfs-go-peertaskqueue
- go-github-com-ipfs-go-unixfsnode
- go-github-com-ipfs-go-verifcid
- go-github-com-ipfs-shipyard
- go-github-com-ipfs-shipyard-nopfs
- go-github-com-ipld-go-car
- go-github-com-ipld-go-codec-dagpb
- go-github-com-jorropo-jsync
- go-github-com-koron-go-ssdp
- go-github-com-libp2p-go-buffer-pool
- go-github-com-libp2p-go-cidranger
- go-github-com-libp2p-go-doh-resolver
- go-github-com-mikioh-tcpinfo
- go-github-com-opencontainers-runtime-spec
- go-github-com-openzipkin-zipkin-go
- go-github-com-petar-gollrb
- go-github-com-pion-datachannel
- go-github-com-raulk-go-watchdog
- go-github-com-rs-cors
- go-github-com-samber-lo
- go-github-com-texttheater-golang-levenshtein
- go-github-com-ucarion-urlpath
go-github-com-libp2p-go-libp2p
go-github-com-libp2p-go-libp2p-asn-util
go-github-com-libp2p-go-libp2p-gostream
go-github-com-libp2p-go-libp2p-http
go-github-com-libp2p-go-libp2p-kad-dht
go-github-com-libp2p-go-libp2p-kbucket
go-github-com-libp2p-go-libp2p-pubsub
go-github-com-libp2p-go-libp2p-pubsub-router
go-github-com-libp2p-go-libp2p-record
go-github-com-libp2p-go-libp2p-routing-helpers
go-github-com-libp2p-go-libp2p-testing
go-github-com-libp2p-go-libp2p-xor
go-github-com-libp2p-go-msgio
go-github-com-libp2p-go-nat
go-github-com-libp2p-go-netroute
go-github-com-libp2p-go-reuseport
go-github-com-libp2p-go-socket-activation
go-github-com-libp2p-go-yamux
go-github-com-libp2p-zeroconf
go-github-com-marten-seemann-tcp
go-github-com-mikioh-tcpopt
go-github-com-openzipkin
go-github-com-pion-dtls
go-github-com-pion-interceptor
go-github-com-pion-logging
go-github-com-pion-randutil
go-github-com-pion-rtcp
go-github-com-pion-rtp
go-github-com-pion-sctp
go-github-com-pion-sdp
go-github-com-pion-srtp
go-github-com-pion-stun
go-github-com-pion-transport
go-github-com-pion-turn
go-github-com-pion-webrtc
go-github-com-prometheus-statsd-exporter
go-github-com-whyrusleeping-base32
go-github-com-whyrusleeping-cbor
go-github-com-whyrusleeping-cbor-gen
go-github-com-whyrusleeping-chunker
go-github-com-whyrusleeping-go-keyspace
go-github-com-whyrusleeping-multiaddr-filter
go-go-opencensus-io-internal-tagencoding
go-go-opencensus-io-metric
go-go-opencensus-io-metric-metricdata
go-go-opencensus-io-metric-metricexport
go-go-opencensus-io-metric-metricproducer
go-go-opencensus-io-plugin
go-go-opencensus-io-plugin-ocgrpc
go-go-opencensus-io-resource
go-go-opencensus-io-stats
go-go-opencensus-io-stats-internal
go-go-opencensus-io-stats-view
go-go-opencensus-io-tag
go-go-opencensus-io-trace
go-go-opencensus-io-trace-internal
go-go-opencensus-io-trace-propagation
go-go-opencensus-io-trace-tracestate
go-go-opencensus-io-zpages
go-go-opencensus-io-zpages-internal
go-go-opentelemetry-io-contrib
go-go-opentelemetry-io-contrib-instrumentation
go-go-opentelemetry-io-contrib-propagators
go-go-opentelemetry-io-otel
go-go-opentelemetry-io-otel-attribute
go-go-opentelemetry-io-otel-baggage
go-go-opentelemetry-io-otel-codes
go-go-opentelemetry-io-otel-exporters
go-go-opentelemetry-io-otel-internal
go-go-opentelemetry-io-otel-metric
go-go-opentelemetry-io-otel-propagation
go-go-opentelemetry-io-otel-sdk
go-go-opentelemetry-io-otel-semconv
go-go-opentelemetry-io-otel-trace
go-go-opentelemetry-io-proto
go-go-opentelemetry-io-proto-otlp
go-go4-org-lock
go-gonum-org-v1-gonum
go-google-golang-org
go-google-golang-org-appengine
go-google-golang-org-appengine-internal
go-google-golang-org-appengine-urlfetch
go-google-golang-org-genproto
go-google-golang-org-genproto-googleapis
go-google-golang-org-grpc
go-google-golang-org-grpc-attributes
go-google-golang-org-grpc-backoff
go-google-golang-org-grpc-balancer
go-google-golang-org-grpc-binarylog
go-google-golang-org-grpc-channelz
go-google-golang-org-grpc-codes
go-google-golang-org-grpc-connectivity
go-google-golang-org-grpc-credentials
go-google-golang-org-grpc-encoding
go-google-golang-org-grpc-grpclog
go-google-golang-org-grpc-health
go-google-golang-org-grpc-internal
go-google-golang-org-grpc-keepalive
go-google-golang-org-grpc-metadata
go-google-golang-org-grpc-peer
go-google-golang-org-grpc-resolver
go-google-golang-org-grpc-serviceconfig
go-google-golang-org-grpc-stats
go-google-golang-org-grpc-status
go-google-golang-org-grpc-tap
go-google-golang-org-protobuf
go-google-golang-org-protobuf-cmd
go-google-golang-org-protobuf-compiler
go-google-golang-org-protobuf-encoding
go-google-golang-org-protobuf-internal
go-google-golang-org-protobuf-proto
go-google-golang-org-protobuf-reflect
go-google-golang-org-protobuf-runtime
go-google-golang-org-protobuf-types

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmZy6RsACgkQdtcnv/Ys
0rVhPA/7BRzHO6RNCBD3RnZAQphBAfQl0Zr7P8hUJnGzLmk+jp1TA8Z5bcXPc3WK
ULqe/0SFTcPHOU3pQ/quMSFS8ur4WzDmUQ1CRlAMSFdEGo7/3SY1CDv8Urhj/FsG
AEVlQ4nVuWTAcUVueuNuDOyvZAieEP9bOXV58EfriQA7zKSxMJskMayF7H/GVNiq
yQ1PmuVdLzBwLLPK7N9MCmwJfisZes1guYbCXvYJ3WTdAo/moWDUfEvFuUYBGL3t
P6al9gwFOh9FY+6SxfqQf0andtuQcr6icIUU8EPryzF9RdBKN6jd6Dcq/9sus//6
7+8rXMNN/6Q6GkqRpa/Lan8Z5DfNw2cV31i79vl0EAEGLZZ1FPLpxBMx3BFzWjDS
HUMl0I+84t6FuAxy6F9UFPc45C2BVtdjWo5okYHUjaCh49m7NSuWF3ZwKe/Yrkpc
PfBhYFIW+76C+TF3/Z9iqW1eIQiBAsSBgbSDlmqc5nfRhnzCcEHhxmoSvLNuV0tw
7MToW/nqvBfxMckspj4q3WsNRlL0wJZNm7jAEet11PwMq9IAed36AlPmKK4mvSkW
lRitKOaYLAguYHnF80GZWpex3R0RXfUSwOy2Lpm6PPXv5QS67VIlEOHCRJwz7bew
JeWWfKoOtiViIA+llNe9aTLt5Iv9PVtKfCHesb2OAeTRYpE94Ms=
=2Y7G
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71636@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71636
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch