[PATCH core-updates] gnu: tenacity: Fix build.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • 宋文武
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 9 months ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
4e30ec79764cabc7f7a80395cac5285cff090270.1718726286.git.atai@atai.org
* gnu/packages/audio.scm (tenacity): Fix build.

Change-Id: I851da322ce62882bb38bf80442d5be12b463aa4b
---
gnu/packages/audio.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (17 lines)
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 6c29ea5783..dd6511d59d 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1077,7 +1077,7 @@ (define-public tenacity
(lambda ()
(apply %configure args))
#:unwind? #t)))
- (add-after 'wrap-program 'glib-or-gtk-wrap
+ (add-after 'install 'glib-or-gtk-wrap
(assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))
;; Test suite? Which test suite?
#:tests? #f))

base-commit: cca32c849c3250f7420fa23e91eabb43249ec7d8
--
2.34.1
宋文武 wrote 9 months ago
(name . Andy Tai)(address . atai@atai.org)(address . 71632-done@debbugs.gnu.org)
87v825k4kf.fsf@envs.net
Andy Tai <atai@atai.org> writes:

Toggle quote (23 lines)
> * gnu/packages/audio.scm (tenacity): Fix build.
>
> Change-Id: I851da322ce62882bb38bf80442d5be12b463aa4b
> ---
> gnu/packages/audio.scm | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
> index 6c29ea5783..dd6511d59d 100644
> --- a/gnu/packages/audio.scm
> +++ b/gnu/packages/audio.scm
> @@ -1077,7 +1077,7 @@ (define-public tenacity
> (lambda ()
> (apply %configure args))
> #:unwind? #t)))
> - (add-after 'wrap-program 'glib-or-gtk-wrap
> + (add-after 'install 'glib-or-gtk-wrap
> (assoc-ref glib-or-gtk:%standard-phases 'glib-or-gtk-wrap)))
> ;; Test suite? Which test suite?
> #:tests? #f))
>
> base-commit: cca32c849c3250f7420fa23e91eabb43249ec7d8

Hello, I have pushed a fix as 21485b4d1, thank you!
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71632@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71632
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help