[PATCH 0/5] gnu: make-mingw-w64: Update to 12.0.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Jean-Pierre De Jesus DIAZ
  • Christopher Baines
Owner
unassigned
Submitted by
Jean-Pierre De Jesus DIAZ
Severity
normal
J
J
Jean-Pierre De Jesus DIAZ wrote on 18 Jun 13:17 +0200
(address . guix-patches@gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
cover.1718708756.git.jean@foundation.xyz
This patchset updates MinGW package to the latest version 12.0.0.

I've added a new configure flag to set the default MSVCRT to MSVCRT as
the default now is UCRT. This default is also changed by Debian, other
projects like MSYS2 use a different target triplet for UCRT which is now
the default and could be introduced if necessary on GNU Guix.

Some of the patches present don't apply anymore to MinGW so I've removed
these and the genlib tool has been removed in the 12.0.0 release so I've
removed the phases that built that tool. (and for anyone wondering,
llvm-dlltool replaces it).

Also I've took the liberty of using G-Expressions where possible in the
package definitions.

I've checked the signatures of the released tarball and it verifies
correctly, although, it is the first time I trust the signers public
key:

$ sha256sum mingw-w64-v12.0.0.tar.bz2.sig mingw-w64-v12.0.0.tar.bz2

b2d94b4d9a9afe69626e3c7b6c5876c4aa998a74c5e4209b0c357f86d2785861 mingw-w64-v12.0.0.tar.bz2.sig
cc41898aac4b6e8dd5cffd7331b9d9515b912df4420a3a612b5ea2955bbeed2f mingw-w64-v12.0.0.tar.bz2

gpg: WARNING: no command supplied. Trying to guess what you mean ...
gpg: assuming signed data in 'mingw-w64-v12.0.0.tar.bz2'
gpg: Signature made Wed 29 May 2024 04:39:22 AM CEST
gpg: using DSA key CAF5641F74F7DFBA88AE205693BDB53CD4EBC740
gpg: issuer "jon_y@users.sourceforge.net"
gpg: Good signature from "JonY <jon_y@users.sourceforge.net>" [unknown]
gpg: WARNING: This key is not certified with a trusted signature!
gpg: There is no indication that the signature belongs to the owner.
Primary key fingerprint: CAF5 641F 74F7 DFBA 88AE 2056 93BD B53C D4EB C740

Jean-Pierre De Jesus DIAZ (5):
gnu: make-mingw-w64: Memoize.
gnu: make-mingw-w64: Use G-Expressions.
gnu: make-mingw-w64: Update to 12.0.0.
gnu: mingw-w64-tools: Use G-Expressions.
gnu: mingw-w64-tools: Update to 12.0.0.

gnu/local.mk | 2 -
gnu/packages/mingw.scm | 167 +++++++++---------
.../patches/mingw-w64-6.0.0-gcc.patch | 65 -------
.../mingw-w64-dlltool-temp-prefix.patch | 26 ---
.../mingw-w64-reproducible-gendef.patch | 33 ----
5 files changed, 88 insertions(+), 205 deletions(-)
delete mode 100644 gnu/packages/patches/mingw-w64-6.0.0-gcc.patch
delete mode 100644 gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
delete mode 100644 gnu/packages/patches/mingw-w64-reproducible-gendef.patch


base-commit: 2aeb37def258ad4dd23aaf57ed32f0be44d1bea5
--
2.45.1
J
J
Jean-Pierre De Jesus DIAZ wrote on 18 Jun 13:26 +0200
[PATCH 1/5] gnu: make-mingw-w64: Memoize.
(address . 71630@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
a73cfbc431f42313869cef8bad3557ba3730ae85.1718708756.git.jean@foundation.xyz
* gnu/packages/mingw.scm (make-mingw-w64): Memoize.

Change-Id: Id5653c79e2d6268f6d8200f0f658b27169eab7c5
---
gnu/packages/mingw.scm | 15 ++++++++++-----
1 file changed, 10 insertions(+), 5 deletions(-)

Toggle diff (46 lines)
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index 0ac6f0e767..1ef2c5e1cf 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Carl Dong <contact@carldong.me>
;;; Copyright © 2021 Léo Le Bouter <lle-bout@zaclys.net>
+;;; Copyright © 2024 Foundation Devices, Inc. <hello@foundation.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -24,15 +25,16 @@ (define-module (gnu packages mingw)
#:use-module (gnu packages)
#:use-module (gnu packages cross-base)
#:use-module (guix build-system gnu)
+ #:use-module (guix memoization)
#:use-module (guix packages)
#:use-module (guix download)
#:export (make-mingw-w64))
-(define* (make-mingw-w64 machine
- #:key
- xgcc
- xbinutils
- with-winpthreads?)
+(define* (make-mingw-w64/implementation machine
+ #:key
+ xgcc
+ xbinutils
+ with-winpthreads?)
"Return a mingw-w64 for targeting MACHINE. If XGCC or XBINUTILS is specified,
use that gcc or binutils when cross-compiling. If WITH-WINPTHREADS? is
specified, recurse and return a mingw-w64 with support for winpthreads."
@@ -119,6 +121,9 @@ (define* (make-mingw-w64 machine
several new APIs such as DirectX and DDK, and 64-bit support.")
(license license:fdl1.3+))))
+(define make-mingw-w64
+ (memoize make-mingw-w64/implementation))
+
(define-public mingw-w64-i686
(make-mingw-w64 "i686"))
--
2.45.1
J
J
Jean-Pierre De Jesus DIAZ wrote on 18 Jun 13:26 +0200
[PATCH 2/5] gnu: make-mingw-w64: Use G-Expressions.
(address . 71630@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
b96c2c9f775536446d22c17d2388679260999dff.1718708756.git.jean@foundation.xyz
* gnu/packages/mingw.scm (make-mingw-w64): Use G-Expressions and
move some arguments above phases.

Change-Id: Ie095dceac635f19f146895c8e3f36d9889108a9a
---
gnu/packages/mingw.scm | 67 +++++++++++++++++++++++-------------------
1 file changed, 36 insertions(+), 31 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index 1ef2c5e1cf..825a784e0d 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -25,6 +25,7 @@ (define-module (gnu packages mingw)
#:use-module (gnu packages)
#:use-module (gnu packages cross-base)
#:use-module (guix build-system gnu)
+ #:use-module (guix gexp)
#:use-module (guix memoization)
#:use-module (guix packages)
#:use-module (guix download)
@@ -76,37 +77,41 @@ (define* (make-mingw-w64/implementation machine
,(string-append triplet "/lib")
,(string-append triplet "/lib64"))))))
(arguments
- `(#:configure-flags '(,(string-append "--host=" triplet)
- ,@(if with-winpthreads?
- '("--with-libraries=winpthreads")
- '()))
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'setenv
- (lambda* (#:key inputs #:allow-other-keys)
- (let ((xgcc-core (assoc-ref inputs "xgcc-core"))
- (mingw-headers (string-append
- (getcwd) "/mingw-w64-headers")))
- (setenv "CPP"
- (string-append
- xgcc-core ,(string-append "/bin/" triplet "-cpp")))
- (setenv "CROSS_C_INCLUDE_PATH"
- (string-append
- mingw-headers
- ":" mingw-headers "/include"
- ":" mingw-headers "/crt"
- ":" mingw-headers "/defaults/include"
- ":" mingw-headers "/direct-x/include"))
- (when ,with-winpthreads?
- (let ((xlibc (assoc-ref inputs "xlibc")))
- (setenv "CROSS_LIBRARY_PATH"
- (string-append
- xlibc "/lib" ":"
- xlibc "/" ,triplet "/lib"))))))))
- #:make-flags (list "DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
- #:parallel-build? #f ; parallel builds often fail with empty .a files
- #:tests? #f ; compiles and includes glibc headers
- #:strip-binaries? #f))
+ (list #:parallel-build? #f ; parallel builds often fail with empty .a files
+ #:tests? #f ; compiles and includes glibc headers
+ #:strip-binaries? #f
+ #:configure-flags
+ #~(list #$(string-append "--host=" triplet)
+ #$@(if with-winpthreads?
+ #~("--with-libraries=winpthreads")
+ #~()))
+ #:make-flags #~'("DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'configure 'setenv
+ (lambda _
+ (let ((xgcc-core #+(this-package-native-input
+ "xgcc-core"))
+ (mingw-headers (string-append
+ (getcwd) "/mingw-w64-headers")))
+ (setenv "CPP"
+ (string-append
+ xgcc-core "/bin/" #$triplet "-cpp"))
+ (setenv "CROSS_C_INCLUDE_PATH"
+ (string-append
+ mingw-headers
+ ":" mingw-headers "/include"
+ ":" mingw-headers "/crt"
+ ":" mingw-headers "/defaults/include"
+ ":" mingw-headers "/direct-x/include"))
+ #$@(if with-winpthreads?
+ #~((let ((xlibc #+(this-package-native-input
+ "xlibc")))
+ (setenv "CROSS_LIBRARY_PATH"
+ (string-append
+ xlibc "/lib" ":"
+ xlibc "/" #$triplet "/lib"))))
+ #~())))))))
(home-page "https://mingw-w64.org")
(synopsis "Minimalist GNU for Windows")
(description
--
2.45.1
J
J
Jean-Pierre De Jesus DIAZ wrote on 18 Jun 13:26 +0200
[PATCH 3/5] gnu: make-mingw-w64: Update to 12.0.0.
(address . 71630@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
d53fe6581af2e775bc338a2e873e665771173593.1718708756.git.jean@foundation.xyz
* gnu/packages/mingw.scm (make-mingw-w64): Update to 12.0.0.
* gnu/packages/patches/mingw-w64-6.0.0-gcc.patch: Delete patch.
* gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch: Delete patch.
* gnu/packages/patches/mingw-w64-reproducible-gendef.patch: Delete patch.
* gnu/local.mk: Unregister patches.

Change-Id: Id9d7d17926280b21016a7217da44004e06e436cd
---
gnu/local.mk | 2 -
gnu/packages/mingw.scm | 17 +++--
.../patches/mingw-w64-6.0.0-gcc.patch | 65 -------------------
.../mingw-w64-dlltool-temp-prefix.patch | 26 --------
.../mingw-w64-reproducible-gendef.patch | 33 ----------
5 files changed, 10 insertions(+), 133 deletions(-)
delete mode 100644 gnu/packages/patches/mingw-w64-6.0.0-gcc.patch
delete mode 100644 gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
delete mode 100644 gnu/packages/patches/mingw-w64-reproducible-gendef.patch

Toggle diff (199 lines)
diff --git a/gnu/local.mk b/gnu/local.mk
index c5c9ff48bb..0deb1ee071 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1731,8 +1731,6 @@ dist_patch_DATA = \
%D%/packages/patches/mia-vtk92.patch \
%D%/packages/patches/mia-vtk-version.patch \
%D%/packages/patches/mingw-w64-6.0.0-gcc.patch \
- %D%/packages/patches/mingw-w64-dlltool-temp-prefix.patch \
- %D%/packages/patches/mingw-w64-reproducible-gendef.patch \
%D%/packages/patches/minisat-friend-declaration.patch \
%D%/packages/patches/minisat-install.patch \
%D%/packages/patches/miniz-for-pytorch.patch \
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index 825a784e0d..e2fb84ce63 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -43,7 +43,7 @@ (define* (make-mingw-w64/implementation machine
(package
(name (string-append "mingw-w64" "-" machine
(if with-winpthreads? "-winpthreads" "")))
- (version "11.0.1")
+ (version "12.0.0")
(source
(origin
(method url-fetch)
@@ -51,11 +51,7 @@ (define* (make-mingw-w64/implementation machine
"mirror://sourceforge/mingw-w64/mingw-w64/"
"mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
(sha256
- (base32 "047f4m37kxf7g8qj23qplrzfd9cirfkkv8d175sfv2zfd7hbqriz"))
- (patches
- (search-patches "mingw-w64-6.0.0-gcc.patch"
- "mingw-w64-dlltool-temp-prefix.patch"
- "mingw-w64-reproducible-gendef.patch"))))
+ (base32 "0bzdprdrb8jy5dhkl2j2yhnr2nsiv6wk2wzxrzaqsvjbmj58jhfc"))))
(native-inputs `(("xgcc-core" ,(if xgcc xgcc (cross-gcc triplet)))
("xbinutils" ,(if xbinutils xbinutils
(cross-binutils triplet)))
@@ -84,7 +80,14 @@ (define* (make-mingw-w64/implementation machine
#~(list #$(string-append "--host=" triplet)
#$@(if with-winpthreads?
#~("--with-libraries=winpthreads")
- #~()))
+ #~())
+ ;; The default msvcrt changed on 12.0.0 to use UCRT as the
+ ;; default, this could cause problems with programs expecting
+ ;; MSVCRT as the default.
+ ;;
+ ;; XXX: A new target to use UCRT can be introduced as
+ ;; the MSYS2 project does, e.g: x86_64-w64-ucrt-mingw32.
+ "--with-default-msvcrt=msvcrt")
#:make-flags #~'("DEFS=-DHAVE_CONFIG_H -D__MINGW_HAS_DXSDK=1")
#:phases
#~(modify-phases %standard-phases
diff --git a/gnu/packages/patches/mingw-w64-6.0.0-gcc.patch b/gnu/packages/patches/mingw-w64-6.0.0-gcc.patch
deleted file mode 100644
index 036cf79f91..0000000000
--- a/gnu/packages/patches/mingw-w64-6.0.0-gcc.patch
+++ /dev/null
@@ -1,65 +0,0 @@
-This patch includes
-
- * mingw-w64-headers/include/winnt.h: compile fixes for1 gcc-4.9.3
- * mingw-w64-headers/crt/math.h: Likewise
- * mingw-w64-headers/crt/float.h (FLT_EPSILON,DBL_EPSILON,LDBL_EPSILON): Add
- symbols.
- * mingw-w64-headers/crt/stat.h (S_ISLNK,S_ISSOCK,S_ISUID,S_ISGID,S_ISLINK):
- Add symbols.
- (lstat): Add function.
- * mingw-w64-headers/crt/_mingw_stat64.h: Likewise
- * mingw-w64-headers/crt/stdlib.h (realpath): Add function.
-
-Needed for building with gcc-4.9.3 and using with cross-libtool-2.4.6.
-
-Upstream status: not yet presented upstream.
-
-diff --git a/mingw-w64-headers/crt/float.h b/mingw-w64-headers/crt/float.h
-index 5874f4e..bdf4ead 100644
---- a/mingw-w64-headers/crt/float.h
-+++ b/mingw-w64-headers/crt/float.h
-@@ -22,6 +22,15 @@
- #if (__GNUC__ < 4)
- #error Corrupt install of gcc-s internal headers, or search order was changed.
- #else
-+
-+ /* From gcc-4.9.3 float.h. */
-+ #undef FLT_EPSILON
-+ #undef DBL_EPSILON
-+ #undef LDBL_EPSILON
-+ #define FLT_EPSILON __FLT_EPSILON__
-+ #define DBL_EPSILON __DBL_EPSILON__
-+ #define LDBL_EPSILON __LDBL_EPSILON__
-+
- /* #include_next <float_ginclude.h> */
-
- /* Number of decimal digits, q, such that any floating-point number with q
-diff --git a/mingw-w64-headers/crt/math.h b/mingw-w64-headers/crt/math.h
-index 1e970f4..99a332f 100644
---- a/mingw-w64-headers/crt/math.h
-+++ b/mingw-w64-headers/crt/math.h
-@@ -216,6 +216,7 @@ extern "C" {
- #endif
- }
-
-+#if 0
- __CRT_INLINE long double __cdecl fabsl (long double x)
- {
- #ifdef __arm__
-@@ -226,6 +227,7 @@ extern "C" {
- return res;
- #endif
- }
-+#endif
-
- __CRT_INLINE double __cdecl fabs (double x)
- {
-@@ -905,7 +907,7 @@ __mingw_choose_expr ( \
- /* 7.12.7.3 */
- extern double __cdecl hypot (double, double) __MINGW_ATTRIB_DEPRECATED_MSVC2005; /* in libmoldname.a */
- extern float __cdecl hypotf (float x, float y);
--#ifndef __CRT__NO_INLINE
-+#if 0 //ndef __CRT__NO_INLINE
- __CRT_INLINE float __cdecl hypotf (float x, float y) { return (float) hypot ((double)x, (double)y);}
- #endif
- extern long double __cdecl hypotl (long double, long double);
diff --git a/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch b/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
deleted file mode 100644
index 432cafc162..0000000000
--- a/gnu/packages/patches/mingw-w64-dlltool-temp-prefix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-This following patch was originally found at the debian mingw-w64 team's
-mingw-w64 repo located here:
-https://salsa.debian.org/mingw-w64-team/mingw-w64.git
-
-Invoke the following in the aforementioned repo to see the original patch:
-
- $ git show 4974e2c:debian/patches/dlltool-temp-prefix.patch
-
-Description: Specify dlltool's temp prefix
-Author: Stephen Kitt <steve@sk2.org>
-
-By default dlltool uses its pid for the object files it generates.
-Enforcing its temp prefix allows the files it generates to be
-reproducible.
-
---- a/mingw-w64-crt/Makefile.am
-+++ b/mingw-w64-crt/Makefile.am
-@@ -36,7 +36,7 @@
- DTDEF32=$(GENLIB) $(DLLTOOLFLAGS32) $(AM_DLLTOOLFLAGS)
- DTDEF64=$(GENLIB) $(DLLTOOLFLAGS64) $(AM_DLLTOOLFLAGS)
- else
-- AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@
-+ AM_DLLTOOLFLAGS=-k --as=$(AS) --output-lib $@ --temp-prefix $$(basename $@ .a)
- DLLTOOLFLAGSARM32=-m arm
- DLLTOOLFLAGSARM64=-m arm64
- DLLTOOLFLAGS32=--as-flags=--32 -m i386
diff --git a/gnu/packages/patches/mingw-w64-reproducible-gendef.patch b/gnu/packages/patches/mingw-w64-reproducible-gendef.patch
deleted file mode 100644
index 8dbea54ce9..0000000000
--- a/gnu/packages/patches/mingw-w64-reproducible-gendef.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-This following patch was originally found at the debian mingw-w64 team's
-mingw-w64 repo located here:
-https://salsa.debian.org/mingw-w64-team/mingw-w64.git
-
-Invoke the following in the aforementioned repo to see the original patch:
-
- $ git show 9a33f50:debian/patches/reproducible-build.patch
-
-Description: Drop __DATE__ from gendef and genlib
-Author: Stephen Kitt <skitt@debian.org>
-
-This allows gendef and genlib to be built reproducibly.
-
---- a/mingw-w64-tools/gendef/src/gendef.c
-+++ b/mingw-w64-tools/gendef/src/gendef.c
-@@ -196,7 +196,6 @@
- " By default, the output files are named after their DLL counterparts\n"
- " gendef MYDLL.DLL Produces MYDLL.def\n"
- " gendef - MYDLL.DLL Prints the exports to stdout\n");
-- fprintf (stderr, "\nBuilt on %s\n", __DATE__);
- fprintf (stderr, "\nReport bugs to <mingw-w64-public@lists.sourceforge.net>\n");
- exit (0);
- }
---- a/mingw-w64-tools/genlib/src/genlib.c
-+++ b/mingw-w64-tools/genlib/src/genlib.c
-@@ -123,7 +123,6 @@
- "Usage example:\n"
- " By default, the output file is named after the DLL counterpart\n"
- " genlib mydef.def Produces libmydll.a\n"
--"\nBuilt on " __DATE__ "\n"
- "\nReport bugs to <martellmalone@gmail.com>\n"
- ;
-
--
2.45.1
J
J
Jean-Pierre De Jesus DIAZ wrote on 18 Jun 13:26 +0200
[PATCH 4/5] gnu: mingw-w64-tools: Use G-Expressions.
(address . 71630@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
344b2e60dc52efd6d6f9a09181f045e2daa50702.1718708756.git.jean@foundation.xyz
* gnu/packages/mingw.scm (mingw-w64-tools): Use G-Expressions.

Change-Id: I690d0aeae6c6920d2e3eb43732d6b421a3dfc59b
---
gnu/packages/mingw.scm | 70 +++++++++++++++++++++---------------------
1 file changed, 35 insertions(+), 35 deletions(-)

Toggle diff (87 lines)
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index e2fb84ce63..88a2db2141 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -162,45 +162,45 @@ (define-public mingw-w64-tools
(base32 "047f4m37kxf7g8qj23qplrzfd9cirfkkv8d175sfv2zfd7hbqriz"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (srfi srfi-1))
+ (list
+ #:modules '((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-1))
#:phases
- (append
- (modify-phases %standard-phases
- (add-after 'unpack 'cd-gendef
- (lambda _
- (chdir "mingw-w64-tools/gendef"))))
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
- (chdir "../genidl"))))
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
- (chdir "../genlib"))))
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
- (chdir "../genpeimg"))))
- (append-map
- (lambda (target)
+ #~(append
+ (modify-phases %standard-phases
+ (add-after 'unpack 'cd-gendef
+ (lambda _
+ (chdir "mingw-w64-tools/gendef"))))
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (chdir "../genidl"))))
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (chdir "../genlib"))))
(modify-phases %standard-phases
(replace 'unpack
(lambda _
- (chdir "../widl")
- (false-if-exception
- (delete-file-recursively "../build"))
- #t))
- (replace 'configure
- (lambda args
- (apply (assoc-ref %standard-phases 'configure)
- (append args (list #:out-of-source? #t
- #:configure-flags
- `("--target" ,target
- "--program-prefix"
- ,(string-append target "-")))))))))
- '("i686-w64-mingw32" "x86_64-w64-mingw32")))))
+ (chdir "../genpeimg"))))
+ (append-map
+ (lambda (target)
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda _
+ (chdir "../widl")
+ (false-if-exception
+ (delete-file-recursively "../build"))))
+ (replace 'configure
+ (lambda args
+ (apply (assoc-ref %standard-phases 'configure)
+ (append args (list #:out-of-source? #t
+ #:configure-flags
+ `("--target" ,target
+ "--program-prefix"
+ ,(string-append target "-")))))))))
+ '("i686-w64-mingw32" "x86_64-w64-mingw32")))))
(home-page "https://mingw-w64.org")
(synopsis "Tools of Minimalist GNU for Windows")
(description "This package provides the tools of Minimalist GNU for
--
2.45.1
J
J
Jean-Pierre De Jesus DIAZ wrote on 18 Jun 13:26 +0200
[PATCH 5/5] gnu: mingw-w64-tools: Update to 12.0.0.
(address . 71630@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
10acc10bd882a163c7676fc30e45d668a0d15e80.1718708756.git.jean@foundation.xyz
* gnu/packages/mingw.scm (mingw-w64-tools): Update to 12.0.0.

Change-Id: Ia9060ddb1795ca2941a13435485841dbee0c1200
---
gnu/packages/mingw.scm | 8 ++------
1 file changed, 2 insertions(+), 6 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/mingw.scm b/gnu/packages/mingw.scm
index 88a2db2141..89e08be9ac 100644
--- a/gnu/packages/mingw.scm
+++ b/gnu/packages/mingw.scm
@@ -151,7 +151,7 @@ (define-public mingw-w64 mingw-w64-i686)
(define-public mingw-w64-tools
(package
(name "mingw-w64-tools")
- (version "11.0.1")
+ (version "12.0.0")
(source
(origin
(method url-fetch)
@@ -159,7 +159,7 @@ (define-public mingw-w64-tools
"mirror://sourceforge/mingw-w64/mingw-w64/"
"mingw-w64-release/mingw-w64-v" version ".tar.bz2"))
(sha256
- (base32 "047f4m37kxf7g8qj23qplrzfd9cirfkkv8d175sfv2zfd7hbqriz"))))
+ (base32 "0bzdprdrb8jy5dhkl2j2yhnr2nsiv6wk2wzxrzaqsvjbmj58jhfc"))))
(build-system gnu-build-system)
(arguments
(list
@@ -176,10 +176,6 @@ (define-public mingw-w64-tools
(replace 'unpack
(lambda _
(chdir "../genidl"))))
- (modify-phases %standard-phases
- (replace 'unpack
- (lambda _
- (chdir "../genlib"))))
(modify-phases %standard-phases
(replace 'unpack
(lambda _
--
2.45.1
C
C
Christopher Baines wrote on 15 Jul 23:49 +0200
Re: [bug#71630] [PATCH 0/5] gnu: make-mingw-w64: Update to 12.0.0.
(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)(address . 71630-done@debbugs.gnu.org)
87ikx672bk.fsf@cbaines.net
Jean-Pierre De Jesus DIAZ <jean@foundation.xyz> writes:

Toggle quote (15 lines)
> This patchset updates MinGW package to the latest version 12.0.0.
>
> I've added a new configure flag to set the default MSVCRT to MSVCRT as
> the default now is UCRT. This default is also changed by Debian, other
> projects like MSYS2 use a different target triplet for UCRT which is now
> the default and could be introduced if necessary on GNU Guix.
>
> Some of the patches present don't apply anymore to MinGW so I've removed
> these and the genlib tool has been removed in the 12.0.0 release so I've
> removed the phases that built that tool. (and for anyone wondering,
> llvm-dlltool replaces it).
>
> Also I've took the liberty of using G-Expressions where possible in the
> package definitions.

Thanks for the patches, I've pushed them to master as
bf6ab0e0f5066d999e027a7eb8ecf05db71123ce.

There was one removed patch that was still referenced in local.mk, and I
re-indented the changed package definitions.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmaVmX9fFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XclRRAAkKgqHvEHH+/weO4R/wlRNK3d68c7ZuVP
/rVijzD5tau2IxpnrvDxk9fvuFiUW0ZgiJCWeMr6H6Jg/SS1mwQ+FuZKpZaptHQn
625zIyxd7dMcBj7emDkuyyGQZOxcb8prGp8xLWLPyBPk2ERkchKJHJ56NpBOTY3y
3PoYGm5JS7TDwf6dmN5e0m6MuCLC0VtOjo0+3Lm9w7HsD85AAUfTjEUcFPSH/Cvx
PWnWhudC0yZ6Y3bgheGJbwNHTGPB+CKUGOa4791l8VnViS37IymmT5OakQIRxp7w
f3J/hcJ9UYJFWJRiGNnjCspgn3yh5HJzZ8vkbNQzCCMBRPDsBxWfLQf0tT3VAwvz
wks+sd8iuXo86X9XR1ysz2U4Q/D5DYtRLDhBhweYJqfJ7sCVPtbWrLbEHyv8ldZK
31itRs8LtGm03aXyx1i46/eLjJkepAMASZt0loSu0b8DAO9rSxlJD9AFdQm9IH2L
5BYjjiQA9/ij2nip6l58q5tPQeDgaIo8zOFd40wyN7VKpwt0EE8imrQ9DbXjh2h+
+88UTClaSNGh+IK/z9O8O+sWL6NH4Ga8nmR4AY4ESPGIkRqnJBZGU4EDjzlNouSM
VXyoggW3K2YUSi7TFHnaMhbR+p2vZ7vsRDglGtzYoBzvZDR+lUvs3hDi7GjGHzWA
ELw7MJkAyso=
=1NEz
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71630@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71630
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch