Tomas Volf wrote 9 months ago
(address . guix-patches@gnu.org)(name . Tomas Volf)(address . ~@wolfsden.cz)
Since there is no exported variable containing the list of default modules,
every place that needs it (in #:modules for example) needs to copy&paste it
and pray it never changes.
This commit provides new variable exposing the default list, allowing
constructs like this:
#:modules
`((srfi srfi-34)
,@%gnu-build-system-default-modules)
* guix/build-system/gnu.scm (%gnu-build-system-default-modules): New variable.
(define-module)[#:export]: Export it.
Change-Id: I1da392019a95aea5edeac0301db26266efbeee9e
---
guix/build-system/gnu.scm | 3 +++
1 file changed, 3 insertions(+)
Toggle diff (23 lines)
diff --git a/guix/build-system/gnu.scm b/guix/build-system/gnu.scm
index cdbb547773..53ac2f8cbd 100644
--- a/guix/build-system/gnu.scm
+++ b/guix/build-system/gnu.scm
@@ -28,6 +28,7 @@ (define-module (guix build-system gnu)
#:use-module (srfi srfi-1)
#:use-module (ice-9 match)
#:export (%gnu-build-system-modules
+ %gnu-build-system-default-modules
%strip-flags
%strip-directories
gnu-build
@@ -60,6 +61,8 @@ (define %default-modules
'((guix build gnu-build-system)
(guix build utils)))
+(define %gnu-build-system-default-modules %default-modules)
+
(define* (package-with-explicit-inputs/deprecated p inputs
#:optional
(loc (current-source-location))
--
2.45.1