[PATCH] Split out picocss from Mumi.

  • Open
  • quality assurance status badge
Details
3 participants
  • Arun Isaac
  • Felix Lechner
  • Liliana Marie Prikler
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 17 Jun 19:09 +0200
(address . guix-patches@gnu.org)
1c7c0942bfd3d5f4e690456384d84d29e887cffe.1718644021.git.felix.lechner@lease-up.com
The inclusion of Picocss an inline function in Mumi may not meet project
standards. For example, Picocss is probably not captured as a prerequisite of
software we use; its license is not tracked; and its sources are not backed up
by the Software Heritage archive.

Change-Id: I447aa8d0c34376f5a55dce596f19d956622a5ecf
---
gnu/packages/mail.scm | 15 +++++----------
gnu/packages/web.scm | 22 ++++++++++++++++++++++
2 files changed, 27 insertions(+), 10 deletions(-)

Toggle diff (63 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d853fab4d3..5c4f688f3b 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -4226,16 +4226,11 @@ (define-public mumi
mailutils
xdg-utils))
(native-inputs
- (list autoconf automake pkg-config sassc
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/picocss/pico.git")
- (commit "3052db4bd3439e236479dc0f98069f7d3b559486")))
- (file-name (git-file-name "pico" "1.5.6"))
- (sha256
- (base32
- "1gs1li48hqizx7lc4n2fdxn9i2v4vafkqpza7svvfpcamfz29jpi")))))
+ (list autoconf
+ automake
+ pkg-config
+ picocss
+ sassc))
(home-page "https://git.savannah.gnu.org/cgit/guix/mumi.git/")
(synopsis "Debbugs web interface")
(description "Mumi is a Debbugs web interface.")
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b9991bb9c1..bf688b2f6f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -5064,6 +5064,28 @@ (define-public perl-www-robotrules
their web site.")
(home-page "https://metacpan.org/release/WWW-RobotRules")))
+(define-public picocss
+ (package
+ (name "picocss")
+ (version "1.5.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/picocss/pico.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gs1li48hqizx7lc4n2fdxn9i2v4vafkqpza7svvfpcamfz29jpi"))))
+ (build-system copy-build-system)
+ (home-page "https://picocss.com/")
+ (synopsis "Minimal CSS Framework for Semantic HTML")
+ (description "A minimalist and lightweight starter kit that prioritizes
+semantic syntax, making every HTML element responsive and elegant by default.
+Pico CSS can be used without custom CSS but it was designed as a CSS starting
+point.")
+ (license license:expat)))
+
(define-public python-lambda-4dn
(package
(name "python-lambda-4dn")

base-commit: 71c678a16aae416298a0e3fa322b425315bb7b00
--
2.41.0
A
A
Arun Isaac wrote on 17 Jun 23:29 +0200
(name . Luis Felipe)(address . sirgazil@zoho.com)
87y1736yx5.fsf@systemreboot.net
Hi Felix,

Good point! We should do this. Some comments follow.

It would be good to split this into two separate commits—one adding
picocss, and the other using it in mumi. I will send a v2 patchset where
I have done this.

Also, we should decide on some directory structure for CSS packages like
picocss, similar to how we have a standardized directory structure for
our font packages. Simply copying the entire source tree copies over too
many unnecessary files.

Maybe prefix CSS packages with css-. So, css-picocss instead of
picocss. May also be an idea to put CSS packages in a separate file
gnu/packages/css.scm.

Thanks,
Arun
A
A
Arun Isaac wrote on 17 Jun 23:30 +0200
[PATCH v2 1/2] gnu: Add picocss.
(address . 71615@debbugs.gnu.org)
3100b076edc32dc8cf57df9e42f926df368417c9.1718659740.git.arunisaac@systemreboot.net
From: Felix Lechner <felix.lechner@lease-up.com>

* gnu/packages/web.scm (picocss): New variable.

Change-Id: Ia6fd846f7da810df9675c964506cc59f5f9d3f7b
Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
---
gnu/packages/web.scm | 23 ++++++++++++++++++++++-
1 file changed, 22 insertions(+), 1 deletion(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b9991bb9c1..f645199774 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -63,7 +63,7 @@
;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
;;; Copyright © 2023 Christopher Howard <christopher@librehacker.com>
-;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
+;;; Copyright © 2023, 2024 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
;;;
@@ -5064,6 +5064,27 @@ (define-public perl-www-robotrules
their web site.")
(home-page "https://metacpan.org/release/WWW-RobotRules")))
+(define-public picocss
+ (package
+ (name "picocss")
+ (version "1.5.6")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/picocss/pico")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1gs1li48hqizx7lc4n2fdxn9i2v4vafkqpza7svvfpcamfz29jpi"))))
+ (build-system copy-build-system)
+ (home-page "https://picocss.com/")
+ (synopsis "Minimal CSS framework for semantic HTML")
+ (description "Pico CSS is a minimalist and lightweight CSS framework that
+prioritizes semantic syntax, making every HTML element responsive and elegant
+by default.")
+ (license license:expat)))
+
(define-public python-lambda-4dn
(package
(name "python-lambda-4dn")

base-commit: 71c678a16aae416298a0e3fa322b425315bb7b00
--
2.45.1
A
A
Arun Isaac wrote on 17 Jun 23:30 +0200
[PATCH v2 2/2] gnu: mumi: Use picocss package.
(address . 71615@debbugs.gnu.org)
ea5bb8344e6331ad5d7935b8cd9219f889bd5fdb.1718659740.git.arunisaac@systemreboot.net
From: Felix Lechner <felix.lechner@lease-up.com>

* gnu/packages/mail.scm (mumi)[native-inputs]: Use the picocss package instead
of an unnamed origin object.

Change-Id: Ie77438af93660f03b5ced38b24956d64a045a67f
Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
---
gnu/packages/mail.scm | 16 ++++++----------
1 file changed, 6 insertions(+), 10 deletions(-)

Toggle diff (36 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d853fab4d3..54f6807661 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -56,6 +56,7 @@
;;; Copyright © 2023 Arjan Adriaanse <arjan@adriaan.se>
;;; Copyright © 2023 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Benjamin Slade <slade@lambda-y.net>
+;;; Copyright © 2024 Felix Lechner <felix.lechner@lease-up.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4226,16 +4227,11 @@ (define-public mumi
mailutils
xdg-utils))
(native-inputs
- (list autoconf automake pkg-config sassc
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/picocss/pico.git")
- (commit "3052db4bd3439e236479dc0f98069f7d3b559486")))
- (file-name (git-file-name "pico" "1.5.6"))
- (sha256
- (base32
- "1gs1li48hqizx7lc4n2fdxn9i2v4vafkqpza7svvfpcamfz29jpi")))))
+ (list autoconf
+ automake
+ pkg-config
+ picocss
+ sassc))
(home-page "https://git.savannah.gnu.org/cgit/guix/mumi.git/")
(synopsis "Debbugs web interface")
(description "Mumi is a Debbugs web interface.")
--
2.45.1
L
L
Liliana Marie Prikler wrote on 21 Jun 06:21 +0200
Re: [PATCH v2 1/2] gnu: Add picocss.
(name . Felix Lechner)(address . felix.lechner@lease-up.com)
64f1f77bfa4771d32846884149725f9657f5bf0f.camel@gmail.com
Am Montag, dem 17.06.2024 um 22:30 +0100 schrieb Arun Isaac:
Toggle quote (35 lines)
> From: Felix Lechner <felix.lechner@lease-up.com>
>
> * gnu/packages/web.scm (picocss): New variable.
>
> Change-Id: Ia6fd846f7da810df9675c964506cc59f5f9d3f7b
> Signed-off-by: Arun Isaac <arunisaac@systemreboot.net>
> ---
>  gnu/packages/web.scm | 23 ++++++++++++++++++++++-
>  1 file changed, 22 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
> index b9991bb9c1..f645199774 100644
> --- a/gnu/packages/web.scm
> +++ b/gnu/packages/web.scm
> @@ -63,7 +63,7 @@
>  ;;; Copyright © 2022 Bruno Victal <mirai@makinata.eu>
>  ;;; Copyright © 2023 David Thompson <dthompson2@worcester.edu>
>  ;;; Copyright © 2023 Christopher Howard
> <christopher@librehacker.com>
> -;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
> +;;; Copyright © 2023, 2024 Felix Lechner
> <felix.lechner@lease-up.com>
>  ;;; Copyright © 2023 Evgeny Pisemsky <evgeny@pisemsky.com>
>  ;;; Copyright © 2024 Tomas Volf <~@wolfsden.cz>
>  ;;;
> @@ -5064,6 +5064,27 @@ (define-public perl-www-robotrules
>  their web site.")
>      (home-page "https://metacpan.org/release/WWW-RobotRules")))
>  
> +(define-public picocss
> +  (package
> +    (name "picocss")
> +    (version "1.5.6")
> +    (source (origin
> +              (method git-fetch)
Note: the /css folder, which is probably what'll be interesting here,
contains generated sources. We should try compiling them ourselves
with an SCSS processor.
Toggle quote (9 lines)
> +              (uri (git-reference
> +                    (url "https://github.com/picocss/pico")
> +                    (commit (string-append "v" version))))
> +              (file-name (git-file-name name version))
> +              (sha256
> +               (base32
> +               
> "1gs1li48hqizx7lc4n2fdxn9i2v4vafkqpza7svvfpcamfz29jpi"))))
> +    (build-system copy-build-system)
Note: copy-build-system should be used together with an install plan.
It appears you're missing one.
Toggle quote (13 lines)
> +    (home-page "https://picocss.com/")
> +    (synopsis "Minimal CSS framework for semantic HTML")
> +    (description "Pico CSS is a minimalist and lightweight CSS
> framework that
> +prioritizes semantic syntax, making every HTML element responsive
> and elegant
> +by default.")
> +    (license license:expat)))
> +
>  (define-public python-lambda-4dn
>    (package
>      (name "python-lambda-4dn")
>
Cheers
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71615@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71615
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch