[PATCH] Enable the enqueuing of offline messages by OpenSMTPd.

  • Open
  • quality assurance status badge
Details
One participant
  • Felix Lechner
Owner
unassigned
Submitted by
Felix Lechner
Severity
normal
F
F
Felix Lechner wrote on 17 Jun 18:15 +0200
(address . guix-patches@gnu.org)(name . Felix Lechner)(address . felix.lechner@lease-up.com)
c3f668d7e1fe152131a5fcf08531335555867fc9.1718640856.git.felix.lechner@lease-up.com
Change-Id: I6da8c3650be66f7e2297ea6174a66b7f0b1bc0c0
---
gnu/packages/mail.scm | 4 ++++
1 file changed, 4 insertions(+)

Toggle diff (19 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d853fab4d3..29b727eaaa 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -3293,6 +3293,10 @@ (define-public opensmtpd
;; Fix some incorrectly hard-coded external tool file names.
(add-after 'unpack 'patch-FHS-file-names
(lambda _
+ ;; avoids warning smtpd: couldn't enqueue offline message
+ ;; smtpctl exited abnormally
+ (substitute* "usr.sbin/smtpd/smtpd.h"
+ (("/usr/bin/smtpctl") "/run/setuid-programs/smtpctl"))
(substitute* "usr.sbin/smtpd/smtpctl.c"
;; ‘gzcat’ is auto-detected at compile time, but ‘cat’ isn't.
(("/bin/cat") (which "cat")))

base-commit: 71c678a16aae416298a0e3fa322b425315bb7b00
--
2.41.0
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71613@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71613
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch