[PATCH] gnu: abiword: Switch to the site mirror.

  • Done
  • quality assurance status badge
Details
2 participants
  • jgart
  • Artyom V. Poptsov
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 9 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
283b320938293f946e1920bd6b289ac3beb589be.1718477656.git.poptsov.artyom@gmail.com
* gnu/packages/abiword.scm (abiword): Switch to the site mirror as the original
site is down since around August 2023 (see
[source]: Use a site mirror.
[home-page]: Likewise.
[arguments]: Use gexps.

Change-Id: I4b02ea4e3c60d56547249f83fc1addf56e55055c
---
gnu/packages/abiword.scm | 66 +++++++++++++++++++++-------------------
1 file changed, 35 insertions(+), 31 deletions(-)

Toggle diff (109 lines)
diff --git a/gnu/packages/abiword.scm b/gnu/packages/abiword.scm
index 1635ed54fd..d3b08323f7 100644
--- a/gnu/packages/abiword.scm
+++ b/gnu/packages/abiword.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018, 2021 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@ (define-module (gnu packages abiword)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system glib-or-gtk)
+ #:use-module (guix gexp)
#:use-module (gnu packages)
#:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
@@ -53,7 +55,9 @@ (define-public abiword
(origin
(method url-fetch)
(uri
- (string-append "https://www.abisource.com/downloads/abiword/" version
+ ;; XXX: The main site <https://www.abisource.com/> is down. Only a (partial)
+ ;; mirror is available at <http://www.nl.abisource.com/>.
+ (string-append "http://www.nl.abisource.com/downloads/abiword/" version
"/source/abiword-" version ".tar.gz"))
(sha256
(base32 "1d1179pnslijpjhz1q155fsc828rrlqf7lsn2inqsl3hk5z28mqj"))
@@ -62,35 +66,35 @@ (define-public abiword
(build-system glib-or-gtk-build-system)
(arguments ;; NOTE: rsvg is disabled, since Abiword
- `(#:configure-flags ;; supports it directly, and its BS is broken.
- (list ;; wmf was removed from Guix for security.
- "--enable-clipart" ;; TODO: The following plugins have unresolved
- "--enable-templates" ;; dependencies: aiksaurus, grammar, wpg, gda,
- (string-append ;; wordperfect, psion, mathview.
- "--enable-plugins="
- "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
- "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
- "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
- "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
- "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
- "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
- "wikipedia " "wml " "xslfo")
- "--enable-introspection"
- (string-append "--with-gir-dir="
- (assoc-ref %outputs "out")
- "/share/gir-1.0")
- (string-append "--with-typelib-dir="
- (assoc-ref %outputs "out")
- "/lib/girepository-1.0"))
- ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
- ;; assertion 'GDK_IS_SCREEN (screen)' failed
- ;; GLib-GObject-CRITICAL **: g_object_get_qdata:
- ;; assertion 'G_IS_OBJECT (object)' failed
- ;; Manually starting the X server before the test phase did not help
- ;; the tests to pass.
- #:tests? #f
- #:make-flags
- (list "gtk_update_icon_cache=true")))
+ (list #:configure-flags ;; supports it directly, and its BS is broken.
+ #~(list ;; wmf was removed from Guix for security.
+ "--enable-clipart" ;; TODO: The following plugins have unresolved
+ "--enable-templates" ;; dependencies: aiksaurus, grammar, wpg, gda,
+ (string-append ;; wordperfect, psion, mathview.
+ "--enable-plugins="
+ "applix " "babelfish " "bmp " "clarisworks " "collab " "command "
+ "docbook " "eml " "epub " "freetranslation " "garble " "gdict "
+ "gimp " "goffice " "google " "hancom " "hrtext " "iscii " "kword "
+ "latex " "loadbindings " "mht " "mif " "mswrite " "opendocument "
+ "openwriter " "openxml " "opml " "ots " "paint " "passepartout "
+ "pdb " "pdf " "presentation " "s5 " "sdw " "t602 " "urldict "
+ "wikipedia " "wml " "xslfo")
+ "--enable-introspection"
+ (string-append "--with-gir-dir="
+ #$output
+ "/share/gir-1.0")
+ (string-append "--with-typelib-dir="
+ #$output
+ "/lib/girepository-1.0"))
+ ;; tests fail with: Gtk-CRITICAL **: gtk_settings_get_for_screen:
+ ;; assertion 'GDK_IS_SCREEN (screen)' failed
+ ;; GLib-GObject-CRITICAL **: g_object_get_qdata:
+ ;; assertion 'G_IS_OBJECT (object)' failed
+ ;; Manually starting the X server before the test phase did not help
+ ;; the tests to pass.
+ #:tests? #f
+ #:make-flags
+ #~(list "gtk_update_icon_cache=true")))
(inputs
(list boost
enchant
@@ -120,7 +124,7 @@ (define-public abiword
libtool
pkg-config
python-wrapper))
- (home-page "https://www.abisource.com/")
+ (home-page "http://www.nl.abisource.com/")
(synopsis "Word processing program")
;; HACKERS: The comment below is here so that it shows up early in the

base-commit: 612e4dd98f7d1d015e405af9d029bede3fe3c280
--
2.45.1
jgart wrote 9 months ago
(address . 71575-done@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
ad7d04aadd4c2cc79189f503c7af13fa32f98eeb@dismail.de
Thanks! applied.

all best,

jgart
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71575@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71575
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help