[PATCH] gnu: gnuradio: Update to 3.10.10.0.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Andy Tai
  • Guillaume Le Vaillant
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 9 months ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
da094f9c32365953b869054ce88db5a6f5bcb6e2.1718434575.git.atai@atai.org
* gnu/packages/radio.scm (gnuradio): Update to 3.10.10.0.

Change-Id: I0249f6345455054790a1b0050a4eea51d2780630
---
gnu/packages/radio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 56e674a8ed..daab0f4be0 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -793,7 +793,7 @@ (define-public redsea
(define-public gnuradio
(package
(name "gnuradio")
- (version "3.10.8.0")
+ (version "3.10.10.0")
(source
(origin
(method git-fetch)
@@ -802,7 +802,7 @@ (define-public gnuradio
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11p08qrbfh5dz6l5n4c2g8c2gv1qq8aiydq91ryzfzgp49r0j6p0"))))
+ (base32 "1jq94nycccpgw2cc39hgixjq7cqdw836bnz0fvmynfg3f22mcid4"))))
(build-system cmake-build-system)
(native-inputs
(list doxygen

base-commit: 7770e4140cddd5dc9c9879cb2bfcbd6cd4de59a0
--
2.34.1
Andreas Enge wrote 9 months ago
Build failures
(address . 71564@debbugs.gnu.org)
Zm6iM_36WscF7otn@jurong
Hello Andy,

as one can see on QA:
the upgrade of gnuradio makes the dependent gnss-sdr package fail.

There is a new update of the latter, so I think it would be worthwhile
to try the following:
- Update gnss-sdr and see whether it still builds with the current
gnuradio; if yes, this would be an obvious first patch to apply.
- Then try to update gnuradio again, hoping the latest gnss-sdr
will still be happy with it.
Or if the first test fails, maybe the second one with both new packages
will work.

Since there are not so many packages depending on gnuradio
("guix refresh -l gnuradio" shows 7), the effect of the updates could
already be checked locally.

Would you like to investigate this?

Thanks,

Andreas
Andy Tai wrote 9 months ago
[PATCH v2 0/3] *** Update of gnuradio and fixing dependency build failutes ***
(address . 71564@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
cover.1718599790.git.atai@atai.org
*** Update of gnuradio and dependency gnss-sdr for build failures ***

Andy Tai (3):
gnu: gnuradio: Update to 3.10.10.0.
gnu: Add volk-gnsssdr.
gnu: gnss-sdr: Update to 0.0.19.

gnu/packages/radio.scm | 49 +++++++++++++++++++++++++++++++++++++-----
1 file changed, 44 insertions(+), 5 deletions(-)


base-commit: 612e4dd98f7d1d015e405af9d029bede3fe3c280
prerequisite-patch-id: 546c67add1eb96a99db59239f3b7cb1db463626e
--
2.34.1
Andy Tai wrote 9 months ago
[PATCH v2 1/3] gnu: gnuradio: Update to 3.10.10.0.
(address . 71564@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
c7a063cf69666fa5839ae5fb8d0114f71bbdecd9.1718599790.git.atai@atai.org
* gnu/packages/radio.scm (gnuradio): Update to 3.10.10.0.

Change-Id: I0249f6345455054790a1b0050a4eea51d2780630
---
gnu/packages/radio.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (24 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 56e674a8ed..daab0f4be0 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -793,7 +793,7 @@ (define-public redsea
(define-public gnuradio
(package
(name "gnuradio")
- (version "3.10.8.0")
+ (version "3.10.10.0")
(source
(origin
(method git-fetch)
@@ -802,7 +802,7 @@ (define-public gnuradio
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "11p08qrbfh5dz6l5n4c2g8c2gv1qq8aiydq91ryzfzgp49r0j6p0"))))
+ (base32 "1jq94nycccpgw2cc39hgixjq7cqdw836bnz0fvmynfg3f22mcid4"))))
(build-system cmake-build-system)
(native-inputs
(list doxygen
--
2.34.1
Andy Tai wrote 9 months ago
[PATCH v2 2/3] gnu: Add volk-gnsssdr.
(address . 71564@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
e618bd8eb4fd40bc035a5041dce326cd0a68eb70.1718599790.git.atai@atai.org
* gnu/packages/radio.scm (volk-gnsssdr): New variable.

Change-Id: I76b92e43d21d88c319ec5bbf0e4cb8aa16fd5e2b
---
gnu/packages/radio.scm | 33 +++++++++++++++++++++++++++++++++
1 file changed, 33 insertions(+)

Toggle diff (53 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index daab0f4be0..89e411d6d4 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -40,6 +40,7 @@ (define-module (gnu packages radio)
#:use-module (gnu packages)
#:use-module (gnu packages admin)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages assembly)
#:use-module (gnu packages astronomy)
#:use-module (gnu packages audio)
#:use-module (gnu packages avahi)
@@ -3043,6 +3044,38 @@ (define-public urh
Radios.")
(license license:gpl3+)))
+(define-public volk-gnsssdr
+ (package
+ (name "volk-gnsssdr")
+ (version "0.0.19")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gnss-sdr/gnss-sdr")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0l1hqfqh8ffgy6nxqdk390vmnmhv66x7m8323mz2izczqc5acy1p"))))
+ (build-system cmake-build-system)
+ (native-inputs (list python python-mako))
+ (inputs
+ (list cpu-features))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _ (chdir "src/algorithms/libs/volk_gnsssdr_module/volk_gnsssdr"))))))
+ (home-page "https://github.com/gnss-sdr/gnss-sdr/blob/main/src/algorithms/libs/volk_gnsssdr_module/volk_gnsssdr/")
+ (synopsis "Sub-project of GNSS-SDR, provideing a set of extra kernels used stand-alone or in combination with VOLK's")
+ (description
+ "This library contains kernels of hand-written SIMD code for different
+mathematical operations, mainly with 8-bit and 16-bit real and complex data
+types, offering a platform/architecture agnostic version that will run in all
+machines, plus other versions for different SIMD instruction sets.")
+ (license license:gpl3+)))
+
(define-public gnss-sdr
(package
(name "gnss-sdr")
--
2.34.1
Andy Tai wrote 9 months ago
[PATCH v2 3/3] gnu: gnss-sdr: Update to 0.0.19.
(address . 71564@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
1420524aac75f8223a7613eb7d5da964cb197bcb.1718599790.git.atai@atai.org
* gnu/packages/radio.scm (gnss-sdr): Update to 0.0.19.
[inputs]: Add cpu-features, gnuplot, gnutls and volk-gnsssdr.
[arguments](configure-flags): Disable test building because many tests
depend on downloaded sample data set.

Change-Id: I1b231896a5e481099c96667ef667c6d9e73683da
---
gnu/packages/radio.scm | 12 +++++++++---
1 file changed, 9 insertions(+), 3 deletions(-)

Toggle diff (55 lines)
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 89e411d6d4..5a7222cf14 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -3079,7 +3079,7 @@ (define-public volk-gnsssdr
(define-public gnss-sdr
(package
(name "gnss-sdr")
- (version "0.0.17")
+ (version "0.0.19")
(source
(origin
(method git-fetch)
@@ -3088,7 +3088,7 @@ (define-public gnss-sdr
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0kxn98vmrsd2a157cf3hsmivi6p4k4a3907j5w8hmcs0nn92786i"))))
+ (base32 "0l1hqfqh8ffgy6nxqdk390vmnmhv66x7m8323mz2izczqc5acy1p"))))
(build-system cmake-build-system)
(native-inputs
`(("googletest-source" ,(package-source googletest))
@@ -3099,11 +3099,14 @@ (define-public gnss-sdr
(inputs
(list armadillo
boost
+ cpu-features
fmt
gflags
glog
gmp
gnuradio
+ gnuplot
+ gnutls
gr-osmosdr
libpcap
log4cpp
@@ -3113,11 +3116,14 @@ (define-public gnss-sdr
protobuf
pugixml
spdlog
- volk))
+ volk
+ volk-gnsssdr))
(arguments
`(#:configure-flags
(list "-DENABLE_GENERIC_ARCH=ON"
"-DENABLE_OSMOSDR=ON"
+
+ "-DENABLE_UNIT_TESTING=FALSE" ; many tests needing data download
"-DBLA_VENDOR=OpenBLAS"
(string-append "-DGFLAGS_ROOT="
(assoc-ref %build-inputs "gflags"))
--
2.34.1
Guillaume Le Vaillant wrote 9 months ago
Re: [bug#71564] [PATCH v2 2/3] gnu: Add volk-gnsssdr.
(name . Andy Tai)(address . atai@atai.org)(address . 71564@debbugs.gnu.org)
87cyo4qbqx.fsf@kitej
Andy Tai <atai@atai.org> skribis:

Toggle quote (10 lines)
> * gnu/packages/radio.scm (volk-gnsssdr): New variable.
>
> [...]
>
> +(define-public volk-gnsssdr
> [...]
> + (inputs
> + (list cpu-features))
> [...]

Hi.
It looks like the "cpu-features" package referenced as input here is
not in Guix. Did you forget to send it in this patch series? Or is it
somewhere else in another issue?
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZnvjBg8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j+EgAD/ZtICmQhmOWRDMnCD8aZKPNaFqJIo9Fke3qR3
ibA78McA/3QmXYylv5gDbMY7JoAZgF1f18BOGmE2qgi1bA7aUvJY
=Gfpi
-----END PGP SIGNATURE-----

Andy Tai wrote 9 months ago
(name . Guillaume Le Vaillant)(address . glv@posteo.net)(address . 71564@debbugs.gnu.org)
CAJsg1E_um3D1-yovLRpkiW7YLBY6MEN+DHeEucrEnYiKgmTRUA@mail.gmail.com

On Wed, Jun 26, 2024 at 2:44 AM Guillaume Le Vaillant <glv@posteo.net> wrote:
Toggle quote (17 lines)
>
> Andy Tai <atai@atai.org> skribis:
>
> > * gnu/packages/radio.scm (volk-gnsssdr): New variable.
> >
> > [...]
> >
> > +(define-public volk-gnsssdr
> > [...]
> > + (inputs
> > + (list cpu-features))
> > [...]
>
> Hi.
> It looks like the "cpu-features" package referenced as input here is
> not in Guix. Did you forget to send it in this patch series? Or is it
> somewhere else in another issue?
Guillaume Le Vaillant wrote 9 months ago
Re: [bug#71564] [PATCH v2 0/3] *** Update of gnuradio and fixing dependency build failutes ***
(name . Andy Tai)(address . atai@atai.org)(address . 71564-done@debbugs.gnu.org)
871q4jrcub.fsf@kitej
Patches applied as cd9b667ba04a2acb24c5fdbe9b533d879288382d and
following.
Thanks.
-----BEGIN PGP SIGNATURE-----

iIUEAREKAC0WIQTLxZxm7Ce5cXlAaz5r6CCK3yH+PwUCZnwnPA8cZ2x2QHBvc3Rl
by5uZXQACgkQa+ggit8h/j8exwEAnkAmcC65Vx/oLyzpibDwEiGTmtR9drA+EdlC
gmwNoUYA/0VGQcTdExH46rwRY/fEov6+qJ341uXx2IsLFU85NjwZ
=BNCg
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71564@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71564
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help