[PATCH] pack: Create /tmp in Apptainer images.

  • Done
  • quality assurance status badge
Details
2 participants
  • Lars Bilke
  • Ludovic Courtès
Owner
unassigned
Submitted by
Lars Bilke
Severity
normal

Debbugs page

Lars Bilke wrote 9 months ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
f0d756265210711648de09d3aa54324cebd28b96.1718371428.git.lars.bilke@ufz.de

Change-Id: I576aaa6ba8cb8478acf4c3144d492ae5caf411ca
---
guix/scripts/pack.scm | 3 ++-
tests/pack.scm | 1 +
2 files changed, 3 insertions(+), 1 deletion(-)

Toggle diff (30 lines)
diff --git a/guix/scripts/pack.scm b/guix/scripts/pack.scm
index fe4df042d7..7c5fe76fe0 100644
--- a/guix/scripts/pack.scm
+++ b/guix/scripts/pack.scm
@@ -493,7 +493,8 @@ (define* (squashfs-image name profile
"-p" "/proc d 555 0 0"
"-p" "/sys d 555 0 0"
"-p" "/dev d 555 0 0"
- "-p" "/home d 555 0 0"))
+ "-p" "/home d 555 0 0"
+ "-p" "/tmp d 555 0 0"))
(when database
;; Initialize /var/guix.
diff --git a/tests/pack.scm b/tests/pack.scm
index 40897a5589..f8a9e09c28 100644
--- a/tests/pack.scm
+++ b/tests/pack.scm
@@ -328,6 +328,7 @@ (define rpm-for-tests
(when (and (file-exists? (string-append bin
"/guile"))
(file-exists? "var/guix/db/db.sqlite")
+ (file-is-directory? "tmp")
(string=? (string-append #$%bootstrap-guile "/bin")
(pk 'binlink (readlink bin)))

base-commit: 0beb0dbfe036763e7b5d6c999fe2b3fc89faa6cb
--
2.44.0
Lars Bilke wrote 9 months ago
Re: bug#71552: Acknowledgement ([PATCH] pack: Create /tmp in Apptainer images.)
(address . 71552@debbugs.gnu.org)
4C277C99-CCF0-4B11-AB00-FB23F7300320@ufz.de

We could add the /var/tmp mount point as well.

On 14 Jun 2024, at 15:25, GNU bug Tracking System wrote:

Toggle quote (25 lines)
> Thank you for filing a new bug report with debbugs.gnu.org.
>
> This is an automatically generated reply to let you know your message
> has been received.
>
> Your message is being forwarded to the package maintainers and other
> interested parties for their attention; they will reply in due course.
>
> As you requested using X-Debbugs-CC, your message was also forwarded to
> Christopher Baines <guix@cbaines.net>, Josselin Poiret <dev@jpoiret.xyz>, Ludovic Court**s <ludo@gnu.org>, Mathieu Othacehe <othacehe@gnu.org>, Ricardo Wurmus <rekado@elephly.net>, Simon Tournier <zimon.toutoune@gmail.com>, Tobias Geerinckx-Rice <me@tobias.gr>
> (after having been given a bug report number, if it did not have one).
>
> Your message has been sent to the package maintainer(s):
> guix-patches@gnu.org
>
> If you wish to submit further information on this problem, please
> send it to 71552@debbugs.gnu.org.
>
> Please do not send mail to help-debbugs@gnu.org unless you wish
> to report a problem with the Bug-tracking system.
>
> --
> 71552: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=71552
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
Ludovic Courtès wrote 8 months ago
Re: [bug#71552] [PATCH] pack: Create /tmp in Apptainer images.
(name . Lars Bilke)(address . lars.bilke@ufz.de)
871q4173aj.fsf@gnu.org
Hi Lars,

Lars Bilke <lars.bilke@ufz.de> skribis:

Toggle quote (5 lines)
> <https://git.savannah.gnu.org/cgit/guix.git/commit/?id=7979a287f8eb84cbbfa44629951572408939a756>.
>
> Change-Id: I576aaa6ba8cb8478acf4c3144d492ae5caf411ca

I tweaked the commit log to match our conventions and applied it.
Thanks!

I don’t recall having problems with images that lack /tmp (we use ‘guix
pack -f squashfs’ regularly at work), but I guess having it cannot hurt.

Ludo’.
Closed
Lars Bilke wrote 8 months ago
(name . Ludovic Courtès)(address . ludovic.courtes@inria.fr)
B7C71586-7594-4D17-BA62-BC9C79AE3437@ufz.de
Hi Ludo,

thanks a lot for merging!

Without this patch I could not run OpenMPI / PETSc applications via
apptainer, I had to specify `apptainer exec --bind /tmp:/tmp ...` but I
can't recall the actual error message anymore...

Sincerely,
Lars

On 10 Jul 2024, at 16:03, Ludovic Courtès wrote:

Toggle quote (19 lines)
> Hi Lars,
>
> Lars Bilke <lars.bilke@ufz.de> skribis:
>
>> Related to <https://bugs.gnu.org/37161> and
>> <https://git.savannah.gnu.org/cgit/guix.git/commit/?id=7979a287f8eb84cbbfa44629951572408939a756>
>> .
>>
>> Change-Id: I576aaa6ba8cb8478acf4c3144d492ae5caf411ca
>
> I tweaked the commit log to match our conventions and applied it.
> Thanks!
>
> I don’t recall having problems with images that lack /tmp (we use
> ‘guix
> pack -f squashfs’ regularly at work), but I guess having it cannot
> hurt.
>
> Ludo’.
Attachment: file
Closed
Ludovic Courtès wrote 8 months ago
(name . Lars Bilke)(address . lars.bilke@ufz.de)
87jzhn2iyq.fsf@inria.fr
Hello,

Lars Bilke <lars.bilke@ufz.de> skribis:

Toggle quote (4 lines)
> Without this patch I could not run OpenMPI / PETSc applications via
> apptainer, I had to specify `apptainer exec --bind /tmp:/tmp ...` but
> I can't recall the actual error message anymore...

OK (I believe we only used the older ‘singularity’ command, which might
be different in this regard).

Thanks for explaining,
Ludo’.
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71552@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71552
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help