Lars Bilke wrote 9 months ago
(address . guix-patches@gnu.org)(name . Lars Bilke)(address . lars.bilke@ufz.de)
Related to https://bugs.gnu.org/37161 and
Change-Id: I576aaa6ba8cb8478acf4c3144d492ae5caf411ca
---
guix/scripts/pack.scm | 3 ++-
tests/pack.scm | 1 +
2 files changed, 3 insertions(+), 1 deletion(-)
Toggle diff (30 lines)
diff --git a/guix/scripts/pack.scm b/guix/scripts/pack.scm
index fe4df042d7..7c5fe76fe0 100644
--- a/guix/scripts/pack.scm
+++ b/guix/scripts/pack.scm
@@ -493,7 +493,8 @@ (define* (squashfs-image name profile
"-p" "/proc d 555 0 0"
"-p" "/sys d 555 0 0"
"-p" "/dev d 555 0 0"
- "-p" "/home d 555 0 0"))
+ "-p" "/home d 555 0 0"
+ "-p" "/tmp d 555 0 0"))
(when database
;; Initialize /var/guix.
diff --git a/tests/pack.scm b/tests/pack.scm
index 40897a5589..f8a9e09c28 100644
--- a/tests/pack.scm
+++ b/tests/pack.scm
@@ -328,6 +328,7 @@ (define rpm-for-tests
(when (and (file-exists? (string-append bin
"/guile"))
(file-exists? "var/guix/db/db.sqlite")
+ (file-is-directory? "tmp")
(string=? (string-append #$%bootstrap-guile "/bin")
(pk 'binlink (readlink bin)))
base-commit: 0beb0dbfe036763e7b5d6c999fe2b3fc89faa6cb
--
2.44.0