* gnu/packages/python-xyz.scm (poetry): Update to 1.8.3.
[arguments]: Enable tests.
[propagated-inputs]: Remove python-html5lib, python-msgpack-transitional, and
python-poetry-core-1.0; add python-dulwich, python-fastjsonschema,
python-importlib-metadata, python-installer, python-platformdirs,
python-poetry-core-next, python-poetry-plugin-export-minimal,
python-pypa-build, python-pyproject-hooks, python-tomli,
python-trove-classifiers, and python-xattr.
[native-inputs]: Add python-deepdiff, python-httpretty, python-pytest,
python-pytest-mock, python-pytest-randomly, and python-pytest-xdist.
Change-Id: Id0f0458015d8c2036f320c91469f0406ec4ebafc
---
gnu/packages/python-xyz.scm | 83 ++++++++++++++++++++++---------------
1 file changed, 50 insertions(+), 33 deletions(-)
Toggle diff (103 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3231fc9729..658edecd6e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21557,46 +21557,63 @@ (define-public python-poetry-plugin-export
(define-public poetry
(package
(name "poetry")
- (version "1.1.12")
+ (version "1.8.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "poetry" version))
(sha256
(base32
- "0rr54mvcfcv9cv6vw2122y28xvd2pwqpv2x8c8j5ayz3gwsy4rjw"))))
- (build-system python-build-system)
+ "0j2zlg838nhlk8cd08ihaflxssyg4q6s0wfc87l43awf51lfpx37"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:tests? #f ;PyPI does not have tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-setup-py
- (lambda _
- (substitute* "setup.py"
- ;; Relax some of the requirements.
- (("(keyring>=21.2.0),<22.0.0" _ keyring) keyring)
- (("(packaging>=20.4),<21.0" _ packaging) packaging)))))))
- (propagated-inputs
- (list python-cachecontrol
- python-cachy
- python-cleo
- python-crashtest
- python-entrypoints
- python-html5lib
- python-keyring
- ; Use of deprecated version of msgpack reported upstream:
- ; https://github.com/python-poetry/poetry/issues/3607
- python-msgpack-transitional
- python-packaging
- python-pexpect
- python-pip
- python-pkginfo
- python-poetry-core-1.0
- python-requests
- python-requests-toolbelt
- python-shellingham
- python-tomlkit
- python-virtualenv))
+ (list #:phases #~(modify-phases %standard-phases
+ ;; Almost every dependency is pinned too strictly.
+ (delete 'sanity-check))
+ #:test-flags
+ #~(list
+ "--ignore=tests/installation/test_executor.py"
+ "--ignore=tests/installation/test_chef.py"
+ "-k"
+ (string-append
+ "not test_create_poetry_fails_on_invalid_configuration "
+ "and not test_shell "
+ "and not test_installer_with_pypi_repository "
+ "and not test_builder_setup_generation_runs_with_pip_editable "
+ "and not test_check_invalid"))))
+ (native-inputs (list python-deepdiff
+ python-httpretty
+ python-pytest
+ python-pytest-mock
+ python-pytest-randomly
+ python-pytest-xdist))
+ (propagated-inputs (list python-cachecontrol
+ python-cachy
+ python-cleo
+ python-crashtest
+ python-dulwich
+ python-entrypoints
+ python-fastjsonschema
+ python-importlib-metadata
+ python-installer
+ python-keyring
+ python-packaging
+ python-pexpect
+ python-pip
+ python-pkginfo
+ python-platformdirs
+ python-poetry-core
+ python-poetry-plugin-export
+ python-pypa-build
+ python-pyproject-hooks
+ python-requests
+ python-requests-toolbelt
+ python-shellingham
+ python-tomli
+ python-tomlkit
+ python-trove-classifiers
+ python-virtualenv
+ python-xattr))
(home-page "https://python-poetry.org")
(synopsis "Python dependency management and packaging made easy")
(description "Poetry is a tool for dependency management and packaging
--
2.45.1