[PATCH 0/5] gnu: poetry: Update to 1.7.1.

  • Open
  • quality assurance status badge
Details
3 participants
  • Antero Mejr
  • Sharlatan Hellseher
  • Tanguy LE CARROUR
Owner
unassigned
Submitted by
Antero Mejr
Severity
normal
A
A
Antero Mejr wrote on 13 Jun 21:10 +0200
(address . guix-patches@gnu.org)
877cesu09g.fsf@antr.me
Updating to 1.7.1 instead of the latest, because poetry 1.8.2 requires a
newer python-packaging, which would trigger many rebuilds.

Antero Mejr (5):
gnu: Add python-installer.
gnu: Add python-rapidfuzz.
gnu: Add python-poetry-core-next.
gnu: python-cleo: Update to 2.1.0.
gnu: poetry: Update to 1.7.1.

gnu/packages/python-build.scm | 12 +++
gnu/packages/python-xyz.scm | 144 ++++++++++++++++++++++++++++------
2 files changed, 131 insertions(+), 25 deletions(-)


base-commit: 9901416233867233192b63fde7f616751127b189
--
2.41.0
A
A
Antero Mejr wrote on 13 Jun 21:25 +0200
[PATCH 1/7] gnu: Add python-installer.
(address . 71540@debbugs.gnu.org)
87wmmssl04.fsf@antr.me
* gnu/packages/python-xyz.scm (python-installer): New variable.

Change-Id: Ic8b7b5647a959166e58f69c3c41e05131c1af996
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d3066cab4..1584703ac1 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21290,6 +21290,26 @@ (define-public python-cachy
database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(license license:expat)))
+(define-public python-installer
+ (package
+ (name "python-installer")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "installer" version))
+ (sha256
+ (base32 "0cdnqh3a3amw8k4s1pzfjh0hpvzw4pczgl702s1b16r82qqkwvd2"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core python-pytest))
+ (home-page "https://installer.rtfd.io/")
+ (synopsis "A library for installing Python wheels.")
+ (description
+ "This package provides a low-level library for installing a Python
+package from a wheel distribution. It provides basic functionality and
+abstractions for handling wheels and installing packages from wheels.")
+ (license license:expat)))
+
(define-public poetry
(package
(name "poetry")

base-commit: 9901416233867233192b63fde7f616751127b189
--
2.41.0
A
A
Antero Mejr wrote on 13 Jun 21:26 +0200
[PATCH 2/7] gnu: Add python-poetry-plugin-export.
(address . 71540@debbugs.gnu.org)
87sexgskzb.fsf@antr.me
* gnu/packages/python-xyz.scm (python-poetry-plugin-export): New variable.

Change-Id: Idd7884de2d1e300fce6fea641de44219bf971293
---
gnu/packages/python-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (34 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1584703ac1..7f6dc0cf81 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21310,6 +21310,27 @@ (define-public python-installer
abstractions for handling wheels and installing packages from wheels.")
(license license:expat)))
+(define-public python-poetry-plugin-export
+ (package
+ (name "python-poetry-plugin-export")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "poetry_plugin_export" version))
+ (sha256
+ (base32 "0qgw6w4xaw7cz9ykw376c5hcg9v2k30lnmna6pc9b4ymhn51d9hz"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-poetry-core))
+ (propagated-inputs (list poetry python-poetry-core))
+ (home-page "https://python-poetry.org/")
+ (synopsis "Poetry plugin to export dependencies")
+ (description "This package provides a Poetry plugin that allows the export
+of locked packages to various formats. This plugin provides the same features
+as the existing @code{export} command of Poetry which it will eventually
+replace.")
+ (license license:expat)))
+
(define-public poetry
(package
(name "poetry")
--
2.41.0
A
A
Antero Mejr wrote on 13 Jun 21:27 +0200
[PATCH 3/7] gnu: Add python-poetry-plugin-export-minimal.
(address . 71540@debbugs.gnu.org)
87o784skxi.fsf@antr.me
* gnu/packages/python-xyz.scm (python-poetry-plugin-export-minimal): New
variable.

Change-Id: I110b44f59e987fe6c9e6189d7f517d0eaccd74d6
---
gnu/packages/python-xyz.scm | 10 ++++++++++
1 file changed, 10 insertions(+)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7f6dc0cf81..e5006175cf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21331,6 +21331,16 @@ (define-public python-poetry-plugin-export
replace.")
(license license:expat)))
+(define-public python-poetry-plugin-export-minimal
+ (hidden-package
+ (package
+ (inherit python-poetry-plugin-export)
+ (name "python-poetry-plugin-export-minimal")
+ (arguments (list #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (delete 'sanity-check))))
+ (propagated-inputs '()))))
+
(define-public poetry
(package
(name "poetry")
--
2.41.0
A
A
Antero Mejr wrote on 13 Jun 21:27 +0200
[PATCH 4/7] gnu: Add python-rapidfuzz.
(address . 71540@debbugs.gnu.org)
87jzisskwh.fsf@antr.me
* gnu/packages/python-xyz.scm (python-rapidfuzz): New variable.

Change-Id: I723f0b401d61c42799dbb3bf760c57bfe3bd1204
---
gnu/packages/python-xyz.scm | 18 ++++++++++++++++++
1 file changed, 18 insertions(+)

Toggle diff (31 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e5006175cf..5db5bb9d02 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21012,6 +21012,24 @@ (define-public python-pylev
@url{http://en.wikipedia.org/wiki/Levenshtein_distance}.")
(license license:bsd-3)))
+(define-public python-rapidfuzz
+ (package
+ (name "python-rapidfuzz")
+ (version "3.9.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "rapidfuzz" version))
+ (sha256
+ (base32 "1qh6in6jsybzf414d9samh34npkx34qc95srrqdlal7dx1kfm65k"))))
+ (build-system python-build-system)
+ (native-inputs (list python-hypothesis python-pytest python-scikit-build))
+ (home-page "https://github.com/rapidfuzz/RapidFuzz")
+ (synopsis "Rapid fuzzy string matching for Python")
+ (description "RapidFuzz is a fast string matching library for Python and
+C++, which is using the string similarity calculations from FuzzyWuzzy.")
+ (license license:expat)))
+
(define-public python-cleo
(package
(name "python-cleo")
--
2.41.0
A
A
Antero Mejr wrote on 13 Jun 21:28 +0200
[PATCH 5/7] gnu: Add python-poetry-core-next.
(address . 71540@debbugs.gnu.org)
87frtgskvm.fsf@antr.me
* gnu/packages/python-build.scm (python-poetry-core-next): New variable.

Change-Id: I967f214ffcb0ef91488d4fb9139eca1b82b3cbf0
---
gnu/packages/python-build.scm | 12 ++++++++++++
1 file changed, 12 insertions(+)

Toggle diff (25 lines)
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 76e29b6c90..d323aa805b 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -577,6 +577,18 @@ (define-public python-poetry-core
compatible build front-ends to build Poetry managed projects.")
(license license:expat)))
+(define-public python-poetry-core-next
+ (hidden-package
+ (package
+ (inherit python-poetry-core)
+ (version "1.9.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "poetry_core" version))
+ (sha256
+ (base32 "18imz7hm6a6n94r2kyaw5rjvs8dk22szwdagx0p5gap8x80l0yps")))))))
+
;;; This package exists to bootstrap python-tomli.
(define-public python-flit-core-bootstrap
(package
--
2.41.0
A
A
Antero Mejr wrote on 13 Jun 21:28 +0200
[PATCH 6/7] gnu: python-cleo: Update to 2.1.0.
(address . 71540@debbugs.gnu.org)
87bk44skv0.fsf@antr.me
* gnu/packages/python-xyz.scm (python-cleo): Update to 2.1.0.
[propagated-inputs]: Remove python-backpack, python-clikit, python-pastel, and
python-pylev; add python-rapidfuzz.
[native-inputs]: Add python-crashtest and python-poetry-core.

Change-Id: Idf67960e91106f5c0f7065d84fa00b7f69f5841e
---
gnu/packages/python-xyz.scm | 20 +++++++++++++-------
1 file changed, 13 insertions(+), 7 deletions(-)

Toggle diff (39 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5db5bb9d02..c05526b7cf 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21033,19 +21033,25 @@ (define-public python-rapidfuzz
(define-public python-cleo
(package
(name "python-cleo")
- (version "0.8.1")
+ (version "2.1.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "cleo" version))
(sha256
(base32
- "17q6wi3q280kxmxzb2iwnnqih2xbljn18v0bjx2ip18p079j43ix"))))
- (build-system python-build-system)
+ "08ym7xaalxzka3k9wp7i05n6j9xmmjs1y02ilrz0lrhkbl5qhb0b"))
+ (modules '((guix build utils)))
+ (snippet
+ #~(substitute* "pyproject.toml"
+ (("crashtest = \".*\"") "crashtest = \"^0.3.1\"")))))
+ (build-system pyproject-build-system)
(native-inputs
- (list ;; For testing
- python-mock python-pytest-mock python-pytest))
- (propagated-inputs
- (list python-backpack python-clikit python-pastel python-pylev))
+ (list python-crashtest
+ python-mock
+ python-poetry-core
+ python-pytest-mock
+ python-pytest))
+ (propagated-inputs (list python-rapidfuzz))
(home-page "https://github.com/sdispater/cleo")
(synopsis "Command-line arguments library for Python")
(description
--
2.41.0
A
A
Antero Mejr wrote on 13 Jun 21:29 +0200
[PATCH 7/7] gnu: poetry: Update to 1.7.1.
(address . 71540@debbugs.gnu.org)
877cesskty.fsf@antr.me
* gnu/packages/python-xyz.scm (poetry): Update to 1.7.1.
[propagated-inputs]: Remove python-html5lib, python-msgpack-transitional, and
python-poetry-core-1.0; add python-dulwich, python-fastjsonschema,
python-importlib-metadata, python-installer, python-platformdirs,
python-poetry-core-next, python-poetry-plugin-export-minimal,
python-pypa-build, python-pyproject-hooks, python-tomli,
python-trove-classifiers, and python-xattr.
[native-inputs]: Add python-deepdiff, python-httpretty, python-pytest,
python-pytest-mock, python-pytest-randomly, and python-pytest-xdist.

Change-Id: Ic8949f875d4a6f1e5faa1666c0961067e226dc29
---
gnu/packages/python-xyz.scm | 55 +++++++++++++++++++++++++------------
1 file changed, 37 insertions(+), 18 deletions(-)

Toggle diff (90 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c05526b7cf..8ff5760534 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21368,46 +21368,65 @@ (define-public python-poetry-plugin-export-minimal
(define-public poetry
(package
(name "poetry")
- (version "1.1.12")
+ (version "1.7.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "poetry" version))
(sha256
(base32
- "0rr54mvcfcv9cv6vw2122y28xvd2pwqpv2x8c8j5ayz3gwsy4rjw"))))
- (build-system python-build-system)
+ "0cpzsqjv8c6v9888svxiyi6c516zqrdjbsnhsc5rrbb7gl7afj5k"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:tests? #f ;PyPI does not have tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-setup-py
- (lambda _
- (substitute* "setup.py"
- ;; Relax some of the requirements.
- (("(keyring>=21.2.0),<22.0.0" _ keyring) keyring)
- (("(packaging>=20.4),<21.0" _ packaging) packaging)))))))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ ;; Almost every dependency is pinned too strictly.
+ (delete 'sanity-check))
+ #:test-flags
+ #~(list
+ "--ignore=tests/installation/test_executor.py"
+ "--ignore=tests/installation/test_chef.py"
+ "-k"
+ (string-append
+ "not test_create_poetry_fails_on_invalid_configuration "
+ "and not test_shell "
+ "and not test_installer_with_pypi_repository "
+ "and not test_builder_setup_generation_runs_with_pip_editable "
+ "and not test_check_invalid"))))
+ (native-inputs (list python-deepdiff
+ python-httpretty
+ python-pytest
+ python-pytest-mock
+ python-pytest-randomly
+ python-pytest-xdist))
(propagated-inputs
(list python-cachecontrol
python-cachy
python-cleo
python-crashtest
+ python-dulwich
python-entrypoints
- python-html5lib
+ python-fastjsonschema
+ python-importlib-metadata
+ python-installer
python-keyring
- ; Use of deprecated version of msgpack reported upstream:
- ; https://github.com/python-poetry/poetry/issues/3607
- python-msgpack-transitional
python-packaging
python-pexpect
python-pip
python-pkginfo
- python-poetry-core-1.0
+ python-platformdirs
+ python-poetry-core-next
+ python-poetry-plugin-export-minimal
+ python-pypa-build
+ python-pyproject-hooks
python-requests
python-requests-toolbelt
python-shellingham
+ python-tomli
python-tomlkit
- python-virtualenv))
+ python-trove-classifiers
+ python-virtualenv
+ python-xattr))
(home-page "https://python-poetry.org")
(synopsis "Python dependency management and packaging made easy")
(description "Poetry is a tool for dependency management and packaging
--
2.41.0
S
S
Sharlatan Hellseher wrote on 14 Jun 00:34 +0200
[PATCH 0/5] gnu: poetry: Update to 1.7.1.
(address . 71540@debbugs.gnu.org)(name . Antero Mejr)(address . mail@antr.me)
87frtgpj4l.fsf@gmail.com
Hi,

Thank you for the patches.

Toggle quote (3 lines)
> Updating to 1.7.1 instead of the latest, because poetry 1.8.2 requires a
> newer python-packaging, which would trigger many rebuilds.a

How about to apply patches against python-team branch with the latest version?

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmZrc+oACgkQdtcnv/Ys
0rVPFQ//UYA9IbDFgRk69SfxL+hqkNymL7eoSPDKjFc+GozjMHxofCAmrlCbiaX9
MpzFpDD9+Dho3b++DOgCg/rEu+NfxdoNEGEWR9115xENuuaYw9i89VaGYSu2Ikl+
JAwsPh8Xcrzag5W0MM81aUspqwmNmvAsOGu6iNiwZjiRxd4nlSPtB+uu4NLid2L2
H5sXwMFipsobTHl8Y6OMG1NzlOx8qjLmX3aQD2OF1+RAk0fnSLLZkfC2WUfg9+Mn
y/J3RcPGIk2/E2HwWAJ8IYm8v+6vETFmMS1mIRysT+9yQr8oP+o/UheMW7NFw3nA
FV+CNDBzKwIQcCcfwg/9h/FRxfAUIS/ru+jrjqMDZSi5qgFA0c+stAqy2JOlnnB6
TraBvTvsH2NJbNl5LbU4J2DlX35u0+IR2x3rfCpIjldmv5Vu8Kg7AAQrGwvLNrA5
EAGKVClO2fuAk5TswpQib/jjEtkOzt9OG29pltOwv82HOq1oYeawDBlFr/5kUWzj
UULhKUtjMSG+qvJUO94ePGfAUp8MIJNhARHZYOApX9Ytt5qkbh8TZ5tBjQBMdAJM
a89kZ9+jJ4IE7QK0f6v/pAToIztuECvUkDydrXnzH8AiIRRZDogY7xjHB4A3hzLD
IpU1yUgViJ+c7VXVBO1q/bO+JXFSMDxVLAM6IWVk2eGbPIX8DYc=
=BLHr
-----END PGP SIGNATURE-----

T
T
Tanguy LE CARROUR wrote on 14 Jun 10:33 +0200
171835399913.15842.9755585658776807966@bioneland.org
Hi,


Quoting Antero Mejr (2024-06-13 21:10:35)
Toggle quote (14 lines)
> Updating to 1.7.1 instead of the latest, because poetry 1.8.2 requires a
> newer python-packaging, which would trigger many rebuilds.
>
> Antero Mejr (5):
> gnu: Add python-installer.
> gnu: Add python-rapidfuzz.
> gnu: Add python-poetry-core-next.
> gnu: python-cleo: Update to 2.1.0.
> gnu: poetry: Update to 1.7.1.
>
> gnu/packages/python-build.scm | 12 +++
> gnu/packages/python-xyz.scm | 144 ++++++++++++++++++++++++++++------
> 2 files changed, 131 insertions(+), 25 deletions(-)

Thanks for working on this!


Toggle quote (4 lines)
>> Updating to 1.7.1 instead of the latest, because poetry 1.8.2 requires a
>> newer python-packaging, which would trigger many rebuilds.a
> How about to apply patches against python-team branch with the latest version?

As Oleg said, it would be great to have version 1.8.2. I have to confess that,
because it’s not available in Guix, I’ve been installing it using pipx for few
months now.

This being said here are some (useless) remarks…

- gnu: Add python-installer.
* The synopsis is different from the others. It starts with a "A" and ends with a "."
- gnu: Add python-poetry-plugin-export.
* The package name used in `pypi-uri` contains "_" where I usually see "-".
Is that on purpose?
- gnu: Add python-poetry-plugin-export-minimal.
* LGTM
- gnu: Add python-rapidfuzz.
* LGTM
- gnu: Add python-poetry-core-next.
* The package name used in `pypi-uri` contains "_" where I usually see "-".
- gnu: python-cleo: Update to 2.1.0.
* There is no mention of the `snippet` in the commit message. Wouldn’t it be
worth explaining?
- gnu: poetry: Update to 1.7.1.
* There is no mention to the fact that you enabled some tests that were
previously altogether disabled. Which is good IMHO! ?

But the most important is that it builds and it works! Thanks!

--
Tanguy
A
A
Antero Mejr wrote on 14 Jun 22:41 +0200
[PATCH 1/8] gnu: Add python-installer.
(address . 71540@debbugs.gnu.org)
87ed8zi7e1.fsf@antr.me
* gnu/packages/python-xyz.scm (python-installer): New variable.
---
gnu/packages/python-xyz.scm | 20 ++++++++++++++++++++
1 file changed, 20 insertions(+)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 30b84d284d..6c246c5eff 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21509,6 +21509,26 @@ (define-public python-cachy
database, file, dict stores. Cachy supports python versions 2.7+ and 3.2+.")
(license license:expat)))
+(define-public python-installer
+ (package
+ (name "python-installer")
+ (version "0.7.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "installer" version))
+ (sha256
+ (base32 "0cdnqh3a3amw8k4s1pzfjh0hpvzw4pczgl702s1b16r82qqkwvd2"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-flit-core python-pytest))
+ (home-page "https://installer.rtfd.io/")
+ (synopsis "Installer library for Python wheels")
+ (description
+ "This package provides a low-level library for installing a Python
+package from a wheel distribution. It provides basic functionality and
+abstractions for handling wheels and installing packages from wheels.")
+ (license license:expat)))
+
(define-public poetry
(package
(name "poetry")

base-commit: e4ad2f178af65be6c8ca6e98a667787674cd8c82
--
2.45.1
A
A
Antero Mejr wrote on 14 Jun 22:42 +0200
[PATCH 2/8] gnu: Add python-poetry-plugin-export.
(address . 71540@debbugs.gnu.org)
87a5jni7d1.fsf@antr.me
* gnu/packages/python-xyz.scm (python-poetry-plugin-export): New variable.

Change-Id: Idd7884de2d1e300fce6fea641de44219bf971293
---
gnu/packages/python-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)

Toggle diff (38 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6c246c5eff..3231fc9729 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21529,6 +21529,31 @@ (define-public python-installer
abstractions for handling wheels and installing packages from wheels.")
(license license:expat)))
+(define-public python-poetry-plugin-export
+ (hidden-package
+ (package
+ (name "python-poetry-plugin-export")
+ (version "1.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "poetry_plugin_export" version))
+ (sha256
+ (base32 "0qgw6w4xaw7cz9ykw376c5hcg9v2k30lnmna6pc9b4ymhn51d9hz"))))
+ (build-system pyproject-build-system)
+ ;; Work around the circular dependency introduced by the Poetry devs.
+ (arguments (list #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (delete 'sanity-check))))
+ (native-inputs (list python-poetry-core))
+ (home-page "https://python-poetry.org/")
+ (synopsis "Poetry plugin to export dependencies")
+ (description "This package provides a Poetry plugin that allows the
+export of locked packages to various formats. This plugin provides the same
+features as the existing @code{export} command of Poetry which it will
+eventually replace.")
+ (license license:expat))))
+
(define-public poetry
(package
(name "poetry")
--
2.45.1
A
A
Antero Mejr wrote on 14 Jun 22:47 +0200
[PATCH 3/8] gnu: python-poetry-core: Update to 1.9.0.
(address . 71540@debbugs.gnu.org)
875xubi74y.fsf@antr.me
* gnu/packages/python-build.scm (python-poetry-core): Update to 1.9.0.

Change-Id: Ic65feaa1efbd10368a715fbea1a974355d6fc96f
---
gnu/packages/python-build.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (22 lines)
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 43ff00e148..7f16d2b27f 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -548,13 +548,13 @@ (define-public python-poetry-core-1.0
(define-public python-poetry-core
(package
(name "python-poetry-core")
- (version "1.5.2")
+ (version "1.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "poetry_core" version))
(sha256
- (base32 "053c8dw632p7jkhjb51k0wcx6hdw4r3lk97mds76df653qxnqmf6"))))
+ (base32 "18imz7hm6a6n94r2kyaw5rjvs8dk22szwdagx0p5gap8x80l0yps"))))
(build-system pyproject-build-system)
(arguments
`(#:tests? #f)) ;disabled to avoid extra dependencies
--
2.45.1
A
A
Antero Mejr wrote on 14 Jun 22:48 +0200
[PATCH 4/8] gnu: poetry: Update to 1.8.3.
(address . 71540@debbugs.gnu.org)
871q4zi73x.fsf@antr.me
* gnu/packages/python-xyz.scm (poetry): Update to 1.8.3.
[arguments]: Enable tests.
[propagated-inputs]: Remove python-html5lib, python-msgpack-transitional, and
python-poetry-core-1.0; add python-dulwich, python-fastjsonschema,
python-importlib-metadata, python-installer, python-platformdirs,
python-poetry-core-next, python-poetry-plugin-export-minimal,
python-pypa-build, python-pyproject-hooks, python-tomli,
python-trove-classifiers, and python-xattr.
[native-inputs]: Add python-deepdiff, python-httpretty, python-pytest,
python-pytest-mock, python-pytest-randomly, and python-pytest-xdist.

Change-Id: Id0f0458015d8c2036f320c91469f0406ec4ebafc
---
gnu/packages/python-xyz.scm | 83 ++++++++++++++++++++++---------------
1 file changed, 50 insertions(+), 33 deletions(-)

Toggle diff (103 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3231fc9729..658edecd6e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -21557,46 +21557,63 @@ (define-public python-poetry-plugin-export
(define-public poetry
(package
(name "poetry")
- (version "1.1.12")
+ (version "1.8.3")
(source
(origin
(method url-fetch)
(uri (pypi-uri "poetry" version))
(sha256
(base32
- "0rr54mvcfcv9cv6vw2122y28xvd2pwqpv2x8c8j5ayz3gwsy4rjw"))))
- (build-system python-build-system)
+ "0j2zlg838nhlk8cd08ihaflxssyg4q6s0wfc87l43awf51lfpx37"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:tests? #f ;PyPI does not have tests
- #:phases
- (modify-phases %standard-phases
- (add-before 'build 'patch-setup-py
- (lambda _
- (substitute* "setup.py"
- ;; Relax some of the requirements.
- (("(keyring>=21.2.0),<22.0.0" _ keyring) keyring)
- (("(packaging>=20.4),<21.0" _ packaging) packaging)))))))
- (propagated-inputs
- (list python-cachecontrol
- python-cachy
- python-cleo
- python-crashtest
- python-entrypoints
- python-html5lib
- python-keyring
- ; Use of deprecated version of msgpack reported upstream:
- ; https://github.com/python-poetry/poetry/issues/3607
- python-msgpack-transitional
- python-packaging
- python-pexpect
- python-pip
- python-pkginfo
- python-poetry-core-1.0
- python-requests
- python-requests-toolbelt
- python-shellingham
- python-tomlkit
- python-virtualenv))
+ (list #:phases #~(modify-phases %standard-phases
+ ;; Almost every dependency is pinned too strictly.
+ (delete 'sanity-check))
+ #:test-flags
+ #~(list
+ "--ignore=tests/installation/test_executor.py"
+ "--ignore=tests/installation/test_chef.py"
+ "-k"
+ (string-append
+ "not test_create_poetry_fails_on_invalid_configuration "
+ "and not test_shell "
+ "and not test_installer_with_pypi_repository "
+ "and not test_builder_setup_generation_runs_with_pip_editable "
+ "and not test_check_invalid"))))
+ (native-inputs (list python-deepdiff
+ python-httpretty
+ python-pytest
+ python-pytest-mock
+ python-pytest-randomly
+ python-pytest-xdist))
+ (propagated-inputs (list python-cachecontrol
+ python-cachy
+ python-cleo
+ python-crashtest
+ python-dulwich
+ python-entrypoints
+ python-fastjsonschema
+ python-importlib-metadata
+ python-installer
+ python-keyring
+ python-packaging
+ python-pexpect
+ python-pip
+ python-pkginfo
+ python-platformdirs
+ python-poetry-core
+ python-poetry-plugin-export
+ python-pypa-build
+ python-pyproject-hooks
+ python-requests
+ python-requests-toolbelt
+ python-shellingham
+ python-tomli
+ python-tomlkit
+ python-trove-classifiers
+ python-virtualenv
+ python-xattr))
(home-page "https://python-poetry.org")
(synopsis "Python dependency management and packaging made easy")
(description "Poetry is a tool for dependency management and packaging
--
2.45.1
A
A
Antero Mejr wrote on 14 Jun 22:48 +0200
[PATCH 5/8] gnu: python-betamax: Update to 0.9.0.
(address . 71540@debbugs.gnu.org)
87wmmrgsiv.fsf@antr.me
* gnu/packages/python-web.scm (python-betamax): Update to 0.9.0.

Change-Id: Ia4696d1150e1ee24ca6b27251a7db05d14d1351b
---
gnu/packages/python-web.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (23 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index e8ead0ef12..f8809bc832 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4557,14 +4557,14 @@ (define-public python-cachecontrol-0.11
(define-public python-betamax
(package
(name "python-betamax")
- (version "0.8.1")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "betamax" version))
(sha256
(base32
- "1hki1c2vs7adq7zr56wi6i5bhrkia4s2ywpv2c98ibnczz709w2v"))))
+ "152zil1j4gl1whnldi08zwjr4z2bnlbd061kr3ipjs5wg4b6wcc2"))))
(build-system python-build-system)
(arguments
'(;; Many tests fail because they require networking.
--
2.45.1
A
A
Antero Mejr wrote on 14 Jun 22:48 +0200
[PATCH 6/8] gnu: python-requests-toolbelt: Update to 1.0.0.
(address . 71540@debbugs.gnu.org)
87sexfgsi5.fsf@antr.me
* gnu/packages/python-web.scm (python-requests-toolbelt): Update to 1.0.0.
---
gnu/packages/python-web.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (29 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index f8809bc832..d5022ffbf5 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3761,18 +3761,20 @@ (define-public python-requests-mock
(define-public python-requests-toolbelt
(package
(name "python-requests-toolbelt")
- (version "0.9.1")
+ (version "1.0.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "requests-toolbelt" version))
(sha256
(base32
- "1h3gm88dcjbd7gm229a7x5qkkhnsqsjz0m0l2xyavm2ab3a8k04n"))))
+ "1ijvip427ki177ycrblcn1mfgsq7ixzpvqqfvidjn0a7s2is10bn"))))
(build-system python-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
(add-after 'unpack 'delete-problematic-tests
(lambda _
+ ;; Fails because of connection errors.
+ (delete-file "tests/test_sessions.py")
;; Fails because of expired certificate.
(delete-file "tests/test_x509_adapter.py")
;; Fails due to networking (socket.gaierror: [Errno -2]
--
2.45.1
A
A
Antero Mejr wrote on 14 Jun 22:49 +0200
[PATCH 7/8] gnu: python-jsonpickle: Update to 3.2.1.
(address . 71540@debbugs.gnu.org)
87o783gsh4.fsf@antr.me
* gnu/packages/python-web.scm (python-jsonpickle): Update to 3.2.1.
[native-inputs]: Add python-wheel.

Change-Id: I0d44e79e2e6398ecf7c09a67f44d615bc41272ae
---
gnu/packages/python-web.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index d5022ffbf5..cdb23efa8e 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1539,13 +1539,13 @@ (define-public python-pyscss
(define-public python-jsonpickle
(package
(name "python-jsonpickle")
- (version "3.0.4")
+ (version "3.2.1")
(source (origin
(method url-fetch)
(uri (pypi-uri "jsonpickle" version))
(sha256
(base32
- "0ay6r1bhcw7qy8k5n4xxgy9dqzhxx8syg5ra9wwqzk91ca6lrcd1"))))
+ "0747rx4bn3qpp8azmvq926lp26jsbcv9alh3z6ngg6a1jx07cvab"))))
(build-system pyproject-build-system)
(arguments
(list
@@ -1576,6 +1576,7 @@ (define-public python-jsonpickle
python-simplejson
python-sqlalchemy
python-ujson
+ python-wheel
tzdata-for-tests))
(home-page "https://jsonpickle.github.io/")
(synopsis "Serialize object graphs into JSON")
--
2.45.1
A
A
Antero Mejr wrote on 14 Jun 22:49 +0200
[PATCH 8/8] gnu: Remove python-poetry-core-1.0.
(address . 71540@debbugs.gnu.org)
87jzirgsg8.fsf@antr.me
* gnu/packages/python-build.scm (python-poetry-core-1.0): Delete variable.

Change-Id: Ibf35d50d1c4210a4855ac71eaffa1147cbbbc1a7
---
gnu/packages/python-build.scm | 20 --------------------
1 file changed, 20 deletions(-)

Toggle diff (33 lines)
diff --git a/gnu/packages/python-build.scm b/gnu/packages/python-build.scm
index 7f16d2b27f..7ca741d744 100644
--- a/gnu/packages/python-build.scm
+++ b/gnu/packages/python-build.scm
@@ -525,26 +525,6 @@ (define-public python-pypa-build
order to make bootstrapping easier.")
(license license:expat)))
-(define-public python-poetry-core-1.0
- (package
- (name "python-poetry-core")
- (version "1.0.7")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "poetry-core" version))
- (sha256
- (base32 "01n2rbsvks7snrq3m1d08r3xz9q2715ajb62fdb6rvqnb9sirhcq"))))
- (build-system python-build-system)
- (home-page "https://github.com/python-poetry/poetry-core")
- (synopsis "Poetry PEP 517 build back-end")
- (description
- "The @code{poetry-core} module provides a PEP 517 build back-end
-implementation developed for Poetry. This project is intended to be
-a light weight, fully compliant, self-contained package allowing PEP 517
-compatible build front-ends to build Poetry managed projects.")
- (license license:expat)))
-
(define-public python-poetry-core
(package
(name "python-poetry-core")
--
2.45.1
A
A
Antero Mejr wrote on 14 Jun 22:55 +0200
Re: [PATCH 0/5] gnu: poetry: Update to 1.7.1.
(name . Tanguy LE CARROUR)(address . tanguy@bioneland.org)
87frtfgs76.fsf@antr.me
Tanguy LE CARROUR <tanguy@bioneland.org> writes:

Toggle quote (12 lines)
>>> Updating to 1.7.1 instead of the latest, because poetry 1.8.2 requires a
>>> newer python-packaging, which would trigger many rebuilds.a
>> How about to apply patches against python-team branch with the latest version?
>
> As Oleg said, it would be great to have version 1.8.2. I have to confess that,
> because it’s not available in Guix, I’ve been installing it using pipx for few
> months now.
>
> This being said here are some (useless) remarks…
>
> ...

The new patchset (just sent) is rebased on python-team branch, updates
poetry to 1.8.3, and fixes the above issues.

The recent upgrade to urllib3 2.x on python-team broke a number of
packages, so some fixes for that are also included.

The python-team branch triggers a rebuild of Cmake, which my laptop
cannot handle due to memory limitations. So I'll have to rely on the QA
server to build, or if someone else wants they can build the patches.
T
T
Tanguy LE CARROUR wrote on 17 Jun 08:54 +0200
(name . Antero Mejr)(address . mail@antr.me)
171860726140.2621.18039533966681050255@bioneland.org
Hi,


Quoting Antero Mejr (2024-06-14 22:55:25)
Toggle quote (23 lines)
> Tanguy LE CARROUR <tanguy@bioneland.org> writes:
> >>> Updating to 1.7.1 instead of the latest, because poetry 1.8.2 requires a
> >>> newer python-packaging, which would trigger many rebuilds.a
> >> How about to apply patches against python-team branch with the latest version?
> >
> > As Oleg said, it would be great to have version 1.8.2. I have to confess that,
> > because it’s not available in Guix, I’ve been installing it using pipx for few
> > months now.
> >
> > This being said here are some (useless) remarks…
> >
> > ...
>
> The new patchset (just sent) is rebased on python-team branch, updates
> poetry to 1.8.3, and fixes the above issues.
>
> The recent upgrade to urllib3 2.x on python-team broke a number of
> packages, so some fixes for that are also included.
>
> The python-team branch triggers a rebuild of Cmake, which my laptop
> cannot handle due to memory limitations. So I'll have to rely on the QA
> server to build, or if someone else wants they can build the patches.

I’m building it right now… I’ll let you know.

Regards.

--
Tanguy
T
T
Tanguy LE CARROUR wrote on 17 Jun 18:04 +0200
(name . Antero Mejr)(address . mail@antr.me)
171864026332.12616.14556200188314737937@bioneland.org
Hi,


Quoting Tanguy LE CARROUR (2024-06-17 08:54:21)
Toggle quote (7 lines)
> Quoting Antero Mejr (2024-06-14 22:55:25)
> > The python-team branch triggers a rebuild of Cmake, which my laptop
> > cannot handle due to memory limitations. So I'll have to rely on the QA
> > server to build, or if someone else wants they can build the patches.
>
> I’m building it right now… I’ll let you know.

mmm… doesn’t look good from here! ?

It fails right away on `python-pytest-shutil` for which I add to add a native
input to build, then `python-responses` for which I had to disable some tests,
and now it fails on `poetry` 1.8.3.
I’ll keep trying tomorrow and/or wait to see what the CI says.

Regards,

--
Tanguy
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71540@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71540
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch