[PATCH] gnu: nginx: Update to 1.27.0.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andy Tai
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Andy Tai
Severity
normal

Debbugs page

Andy Tai wrote 9 months ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
84150942d81c8fd5be91c7724514fd19112c7e7f.1718260747.git.atai@atai.org
* gnu/packages/web.scm (nginx): Update to 1.27.0.
(nginx-documentation): Update to 1.27.0.

Change-Id: I447e0bb8677d3f3b14c3a8948c625bcad437ca73
---
gnu/packages/web.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index edbe3bb927..2da4336e99 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -510,14 +510,14 @@ (define-public nginx
;; Track the ‘mainline’ branch. Upstream considers it more reliable than
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
- (version "1.23.3")
+ (version "1.27.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "0m5s8a04jlpv6qhk09sfqbj4rxj38g6923w12j5y3ymrvf3mgjvm"))))
+ "170ja338zh7wdyva34cr7f3wfq59434sssn51d5jvakyz0y0w8xp"))))
(build-system gnu-build-system)
(inputs (list libxml2 libxslt openssl pcre zlib))
(arguments
@@ -607,9 +607,9 @@ (define-public nginx
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
- (let ((version "1.23.3")
- (revision 2916)
- (changeset "178f55cf631a"))
+ (let ((version "1.27.0")
+ (revision 3081)
+ (changeset "1b23e39a3b94"))
(package
(name "nginx-documentation")
(version (simple-format #f "~A-~A-~A" version revision changeset))
@@ -621,7 +621,7 @@ (define-public nginx-documentation
(file-name (string-append name "-" version))
(sha256
(base32
- "0b03dnniwm3p3gd76vqs6lj2z4blqmb7y4lhn9vg7xjz0yqgzvn2"))))
+ "0xnfda8xh8mv00fsycqbwicm8bb7rsvdqmmwv0h372kiwxnazjkh"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test suite
@@ -631,7 +631,7 @@ (define-public nginx-documentation
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(let ((output (assoc-ref outputs "out")))
- (substitute* "umasked.sh"
+ (substitute* "tools/umasked.sh"
((" /bin/sh") (string-append " " (which "sh"))))
;; The documentation includes a banner, which makes sense on
;; the NGinx website, but doesn't make much sense when

base-commit: f65bbca6e4f067935921bf47835e479d48cb2867
--
2.34.1
Andy Tai wrote 9 months ago
[PATCH v2] gnu: nginx: Update to 1.27.0.
(address . 71530@debbugs.gnu.org)(name . Andy Tai)(address . atai@atai.org)
dc91087d4d7f92029a277a9e37f4e2fd8aef33eb.1718689908.git.atai@atai.org
* gnu/packages/web.scm (nginx): Update to 1.27.0.
(nginx-documentation): Update to 1.27.0.
(nginx-accept-language-module)[arguments]: Add configure flags
to enable compatibility and fix build.

Change-Id: I447e0bb8677d3f3b14c3a8948c625bcad437ca73
---
gnu/packages/web.scm | 15 ++++++++-------
1 file changed, 8 insertions(+), 7 deletions(-)

Toggle diff (64 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index b9991bb9c1..84235df2ee 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -510,14 +510,14 @@ (define-public nginx
;; Track the ‘mainline’ branch. Upstream considers it more reliable than
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
- (version "1.23.3")
+ (version "1.27.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "0m5s8a04jlpv6qhk09sfqbj4rxj38g6923w12j5y3ymrvf3mgjvm"))))
+ "170ja338zh7wdyva34cr7f3wfq59434sssn51d5jvakyz0y0w8xp"))))
(build-system gnu-build-system)
(inputs (list libxml2 libxslt openssl pcre zlib))
(arguments
@@ -607,9 +607,9 @@ (define-public nginx
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
- (let ((version "1.23.3")
- (revision 2916)
- (changeset "178f55cf631a"))
+ (let ((version "1.27.0")
+ (revision 3081)
+ (changeset "1b23e39a3b94"))
(package
(name "nginx-documentation")
(version (simple-format #f "~A-~A-~A" version revision changeset))
@@ -621,7 +621,7 @@ (define-public nginx-documentation
(file-name (string-append name "-" version))
(sha256
(base32
- "0b03dnniwm3p3gd76vqs6lj2z4blqmb7y4lhn9vg7xjz0yqgzvn2"))))
+ "0xnfda8xh8mv00fsycqbwicm8bb7rsvdqmmwv0h372kiwxnazjkh"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test suite
@@ -631,7 +631,7 @@ (define-public nginx-documentation
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(let ((output (assoc-ref outputs "out")))
- (substitute* "umasked.sh"
+ (substitute* "tools/umasked.sh"
((" /bin/sh") (string-append " " (which "sh"))))
;; The documentation includes a banner, which makes sense on
;; the NGinx website, but doesn't make much sense when
@@ -733,6 +733,7 @@ (define-public nginx-accept-language-module
"--with-http_v2_module"
"--with-pcre-jit"
"--with-debug"
+ "--with-compat"
;; Even when not cross-building, we pass the
;; --crossbuild option to avoid customizing for the
;; kernel version on the build machine.

base-commit: b993f4735d41e690dbafb8ee2e17fce996a8cf20
--
2.34.1
Maxim Cournoyer wrote 9 months ago
(name . Andy Tai)(address . atai@atai.org)(address . 71530-done@debbugs.gnu.org)
878qyv84hs.fsf@gmail.com
Hi,

Andy Tai <atai@atai.org> writes:

Toggle quote (7 lines)
> * gnu/packages/web.scm (nginx): Update to 1.27.0.
> (nginx-documentation): Update to 1.27.0.
> (nginx-accept-language-module)[arguments]: Add configure flags
> to enable compatibility and fix build.
>
> Change-Id: I447e0bb8677d3f3b14c3a8948c625bcad437ca73

Applied locally, thank you!

--
Thanks,
Maxim
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71530@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71530
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help