Andy Tai wrote 9 months ago
(address . guix-patches@gnu.org)(name . Andy Tai)(address . atai@atai.org)
* gnu/packages/web.scm (nginx): Update to 1.27.0.
(nginx-documentation): Update to 1.27.0.
Change-Id: I447e0bb8677d3f3b14c3a8948c625bcad437ca73
---
gnu/packages/web.scm | 14 +++++++-------
1 file changed, 7 insertions(+), 7 deletions(-)
Toggle diff (56 lines)
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index edbe3bb927..2da4336e99 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -510,14 +510,14 @@ (define-public nginx
;; Track the ‘mainline’ branch. Upstream considers it more reliable than
;; ’stable’ and recommends that “in general you deploy the NGINX mainline
;; branch at all times” (https://www.nginx.com/blog/nginx-1-6-1-7-released/)
- (version "1.23.3")
+ (version "1.27.0")
(source (origin
(method url-fetch)
(uri (string-append "https://nginx.org/download/nginx-"
version ".tar.gz"))
(sha256
(base32
- "0m5s8a04jlpv6qhk09sfqbj4rxj38g6923w12j5y3ymrvf3mgjvm"))))
+ "170ja338zh7wdyva34cr7f3wfq59434sssn51d5jvakyz0y0w8xp"))))
(build-system gnu-build-system)
(inputs (list libxml2 libxslt openssl pcre zlib))
(arguments
@@ -607,9 +607,9 @@ (define-public nginx
(define-public nginx-documentation
;; This documentation should be relevant for the current nginx package.
- (let ((version "1.23.3")
- (revision 2916)
- (changeset "178f55cf631a"))
+ (let ((version "1.27.0")
+ (revision 3081)
+ (changeset "1b23e39a3b94"))
(package
(name "nginx-documentation")
(version (simple-format #f "~A-~A-~A" version revision changeset))
@@ -621,7 +621,7 @@ (define-public nginx-documentation
(file-name (string-append name "-" version))
(sha256
(base32
- "0b03dnniwm3p3gd76vqs6lj2z4blqmb7y4lhn9vg7xjz0yqgzvn2"))))
+ "0xnfda8xh8mv00fsycqbwicm8bb7rsvdqmmwv0h372kiwxnazjkh"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; no test suite
@@ -631,7 +631,7 @@ (define-public nginx-documentation
(replace 'build
(lambda* (#:key outputs #:allow-other-keys)
(let ((output (assoc-ref outputs "out")))
- (substitute* "umasked.sh"
+ (substitute* "tools/umasked.sh"
((" /bin/sh") (string-append " " (which "sh"))))
;; The documentation includes a banner, which makes sense on
;; the NGinx website, but doesn't make much sense when
base-commit: f65bbca6e4f067935921bf47835e479d48cb2867
--
2.34.1