[PATCH] gnu: Add ruby-prism.

  • Done
  • quality assurance status badge
Details
2 participants
  • gemmaro
  • Nicolas Graves
Owner
unassigned
Submitted by
gemmaro
Severity
normal

Debbugs page

gemmaro wrote 9 months ago
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
d6d318e21db7a9baaf228e6bd05638b76d316a76.1718197929.git.gemmaro.dev@gmail.com
* gnu/packages/ruby.scm (ruby-prism): New variable.

Change-Id: I9d51611b005c96884ded4d1892e18b2811c46fe7
---
gnu/packages/ruby.scm | 34 +++++++++++++++++++++++++++++++++-
1 file changed, 33 insertions(+), 1 deletion(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5c1e666bb0..04868d80d9 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -32,7 +32,7 @@
;;; Copyright © 2022-2024 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023, 2024 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -7138,6 +7138,38 @@ (define-public ruby-prawn-manual-builder
(home-page "https://github.com/prawnpdf/prawn-manual_builder")
(license %prawn-project-licenses)))
+(define-public ruby-prism
+ (package
+ (name "ruby-prism")
+ (version "0.30.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ruby/prism")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13izycs2i2rxg22r75n70q25q308g4aga9vza529g7pk0f0zl2xm"))
+ (modules '((guix build utils)))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'compile
+ (lambda _
+ (setenv "CC"
+ #$(cc-for-target))
+ (invoke "rake" "compile"))))))
+ (native-inputs (list ruby-rake-compiler ruby-ffi))
+ (synopsis "Parser for the Ruby programming language")
+ (description
+ "Prism is a parser for the Ruby programming language. It is designed
+to be portable, error tolerant, and maintainable. It is written in
+C99 and has no dependencies.")
+ (home-page "https://ruby.github.io/prism/")
+ (license license:expat)))
+
(define-public ruby-progress_bar
(package
(name "ruby-progress_bar")

base-commit: bb73faea028cc9a15af62cb8ade15d58da51bea2
--
2.45.1
gemmaro wrote 9 months ago
[PATCH v2] gnu: Add ruby-prism.
(address . 71519@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
46df556821252f48e1f0967dd62b6abfcec12e2d.1719495961.git.gemmaro.dev@gmail.com
* gnu/packages/ruby.scm (ruby-prism): New variable.

Change-Id: I9d51611b005c96884ded4d1892e18b2811c46fe7
---
This adds supported-systems to exclude i686-linux and armhf-linux.

gnu/packages/ruby.scm | 37 ++++++++++++++++++++++++++++++++++++-
1 file changed, 36 insertions(+), 1 deletion(-)

Toggle diff (59 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 9547481caf..1f5a966dff 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -32,7 +32,7 @@
;;; Copyright © 2022-2024 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023, 2024 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -7152,6 +7152,41 @@ (define-public ruby-prawn-manual-builder
(home-page "https://github.com/prawnpdf/prawn-manual_builder")
(license %prawn-project-licenses)))
+(define-public ruby-prism
+ (package
+ (name "ruby-prism")
+ (version "0.30.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ruby/prism")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "13izycs2i2rxg22r75n70q25q308g4aga9vza529g7pk0f0zl2xm"))
+ (modules '((guix build utils)))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'compile
+ (lambda _
+ (setenv "CC"
+ #$(cc-for-target))
+ (invoke "rake" "compile"))))))
+ (native-inputs (list ruby-rake-compiler ruby-ffi))
+ (synopsis "Parser for the Ruby programming language")
+ (description
+ "Prism is a parser for the Ruby programming language. It is designed
+to be portable, error tolerant, and maintainable. It is written in
+C99 and has no dependencies.")
+ ;; Some tests fail on i686-linux and armhf-linux.
+ (supported-systems '("x86_64-linux" "aarch64-linux" "riscv64-linux"
+ "powerpc64le-linux"))
+ (home-page "https://ruby.github.io/prism/")
+ (license license:expat)))
+
(define-public ruby-progress_bar
(package
(name "ruby-progress_bar")

base-commit: c6e6001a10d96b7c8f023e3d9b7022d935d9f2f6
--
2.45.2
gemmaro wrote 5 months ago
[PATCH] gnu: Add ruby-prism.
(address . 71519@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
cde3b6606a32d0eaa5eb7ac68b30c786d9ed2543.1730464809.git.gemmaro.dev@gmail.com
* gnu/packages/ruby.scm (ruby-prism): New variable.

Change-Id: I612191bec56f086507d91dcb93d6779f5db61c09
---
This updates to 1.2.0.

gnu/packages/ruby.scm | 35 +++++++++++++++++++++++++++++++++++
1 file changed, 35 insertions(+)

Toggle diff (50 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5af1bb1cef..2f38007c3b 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6987,6 +6987,41 @@ (define-public ruby-parser
(home-page "https://github.com/whitequark/parser")
(license license:expat)))
+(define-public ruby-prism
+ (package
+ (name "ruby-prism")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ruby/prism")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h9hsykhkr5hnh04akhv5zkfc7pgq5cpzfvkpfwdhkkmc6jai1lm"))
+ (modules '((guix build utils)))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'compile
+ (lambda _
+ (setenv "CC"
+ #$(cc-for-target))
+ (invoke "rake" "compile"))))))
+ (native-inputs (list ruby-rake-compiler ruby-ffi))
+ (synopsis "Parser for the Ruby programming language")
+ (description
+ "Prism is a parser for the Ruby programming language. It is designed
+to be portable, error tolerant, and maintainable. It is written in
+C99 and has no dependencies.")
+ ;; Some tests fail on i686-linux and armhf-linux.
+ (supported-systems '("x86_64-linux" "aarch64-linux" "riscv64-linux"
+ "powerpc64le-linux"))
+ (home-page "https://ruby.github.io/prism/")
+ (license license:expat)))
+
(define-public ruby-set
(package
(name "ruby-set")

base-commit: a007045b7c6d26a8a051356c51481beaed6a2bfd
--
2.46.0
Nicolas Graves wrote 5 months ago
(address . 71519@debbugs.gnu.org)
87msigvxeq.fsf@ngraves.fr
Hi gemmaro,

You probably don't need the modules part in the origin source in this
package.

Otherwise LGTM if QA is happy with it.

--
Best regards,
Nicolas Graves
gemmaro wrote 5 months ago
[PATCH v4] gnu: Add ruby-prism.
(address . 71519@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
f698438c925a7459bb70d6d8c60174bd86d645a1.1730702978.git.gemmaro.dev@gmail.com
* gnu/packages/ruby.scm (ruby-prism): New variable.

Change-Id: I9a471843c51fd7449fbfa88fbc18e58a05d4f686
---
This removes the modules part of the previous third patch (sorry that its
revision was missing).

gnu/packages/ruby.scm | 34 ++++++++++++++++++++++++++++++++++
1 file changed, 34 insertions(+)

Toggle diff (49 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 12c439b3a9..439f52ecbf 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -6995,6 +6995,40 @@ (define-public ruby-parser
(home-page "https://github.com/whitequark/parser")
(license license:expat)))
+(define-public ruby-prism
+ (package
+ (name "ruby-prism")
+ (version "1.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ruby/prism")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1h9hsykhkr5hnh04akhv5zkfc7pgq5cpzfvkpfwdhkkmc6jai1lm"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:phases #~(modify-phases %standard-phases
+ (add-before 'build 'compile
+ (lambda _
+ (setenv "CC"
+ #$(cc-for-target))
+ (invoke "rake" "compile"))))))
+ (native-inputs (list ruby-rake-compiler ruby-ffi))
+ (synopsis "Parser for the Ruby programming language")
+ (description
+ "Prism is a parser for the Ruby programming language. It is designed
+to be portable, error tolerant, and maintainable. It is written in
+C99 and has no dependencies.")
+ ;; Some tests fail on i686-linux and armhf-linux.
+ (supported-systems '("x86_64-linux" "aarch64-linux" "riscv64-linux"
+ "powerpc64le-linux"))
+ (home-page "https://ruby.github.io/prism/")
+ (license license:expat)))
+
(define-public ruby-set
(package
(name "ruby-set")

base-commit: 547d97180471e90e404a948015f65431961aa273
--
2.46.0
gemmaro wrote 7 days ago
Re: [PATCH] gnu: Add ruby-prism.
(address . 71519-done@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)(name . Nicolas Graves)(address . ngraves@ngraves.fr)
87zfhm380q.fsf@gmail.com
ruby-prism was introduced in commit
65856d6cec7b8463ca8457cf053a427f4dfba67f;
hence this issue is being closed.
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71519@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71519
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help