[PATCH 0/3] gnu: kubo: Unbundle more inputs.

  • Done
  • quality assurance status badge
Details
2 participants
  • Artyom V. Poptsov
  • Sharlatan Hellseher
Owner
unassigned
Submitted by
Artyom V. Poptsov
Severity
normal

Debbugs page

Artyom V. Poptsov wrote 9 months ago
(address . guix-patches@gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
cover.1718170407.git.poptsov.artyom@gmail.com
This patchset unbundles go-github-com-ipfs-go-ipld-format and
go-github-com-ipfs-go-block-format from Kubo (IPFS.)

Artyom V. Poptsov (3):
gnu: Add go-github-com-ipfs-go-block-format.
gnu: Add go-github-com-ipfs-go-ipld-format.
gnu: kubo: Unbundle more inputs.

gnu/packages/ipfs.scm | 65 +++++++++++++++++++++++++++++++++++++++++--
1 file changed, 63 insertions(+), 2 deletions(-)


base-commit: f1756e2697b867abe21dcf08e047a3dc4d4c96e7
--
2.45.1
Artyom V. Poptsov wrote 9 months ago
[PATCH 1/3] gnu: Add go-github-com-ipfs-go-block-format.
(address . 71501@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
39f313bc712bbdc4fcd552f57a41454a1c659f33.1718170407.git.poptsov.artyom@gmail.com
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-block-format): New variable.

Change-Id: I1120be12ff6c10149e227d679c1c532cb3548a5c
---
gnu/packages/ipfs.scm | 30 ++++++++++++++++++++++++++++++
1 file changed, 30 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index a44c4b0139..4a09993cb5 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -38,6 +38,36 @@ (define-module (gnu packages ipfs)
#:use-module (gnu packages python)
#:use-module (gnu packages shells))
+(define-public go-github-com-ipfs-go-block-format
+ (package
+ (name "go-github-com-ipfs-go-block-format")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-block-format")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0pd8ww06ss922g3w2fgi3w0q66y2mkb9b2q9x5qxabrjj65xranz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipfs/go-block-format"))
+ (propagated-inputs
+ (list go-github-com-multiformats-go-multihash
+ go-github-com-multiformats-go-varint
+ go-github-com-ipfs-go-cid
+ go-github-com-ipfs-go-ipfs-util))
+ (home-page "https://github.com/ipfs/go-block-format")
+ (synopsis "Set of interfaces for CID addressable blocks of data")
+ (description
+ "@code{go-block-format} is a set of interfaces that a type needs to implement in
+order to be a CID addressable block of data.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-cid
(package
(name "go-github-com-ipfs-go-cid")
--
2.45.1
Artyom V. Poptsov wrote 9 months ago
[PATCH 2/3] gnu: Add go-github-com-ipfs-go-ipld-format.
(address . 71501@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
a4e05d3e29e673cb671858b30e50857cc62383e6.1718170407.git.poptsov.artyom@gmail.com
* gnu/packages/ipfs.scm (go-github-com-ipfs-go-ipld-format): New variable.

Change-Id: I65aa1c71cf092c4923c9c4484498d6af684b215a
---
gnu/packages/ipfs.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (42 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 4a09993cb5..faf529b6a7 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -205,6 +205,35 @@ (define-public go-github-com-ipfs-go-ipfs-util
"Common utilities used by @code{go-ipfs} and other related Go packages.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ipld-format
+ (package
+ (name "go-github-com-ipfs-go-ipld-format")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ipld-format")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zl172ncmx9h5z2p3d0j1377xm9glw4zfyamks31p0pvvx2kyn7c"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:go go-1.21
+ #:import-path "github.com/ipfs/go-ipld-format"))
+ (propagated-inputs
+ (list go-github-com-multiformats-go-multihash
+ go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-cid))
+ (home-page "https://github.com/ipfs/go-ipld-format")
+ (synopsis "IPLD Node and Resolver interfaces in Go")
+ (description
+ "@code{go-ipld-format} is a set of interfaces that a type needs to implement in
+order to be a part of the @acronym{IPLD, InterPlanetary Linked Data} merkle-forest.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-ipfs-api
(let ((commit
"dafc2a13a4389ac1a6c2786e34ab70a4f26d3a3f")
--
2.45.1
Artyom V. Poptsov wrote 9 months ago
[PATCH 3/3] gnu: kubo: Unbundle more inputs.
(address . 71501@debbugs.gnu.org)(name . Artyom V. Poptsov)(address . poptsov.artyom@gmail.com)
f0feee66c94a3c9bdfa873220c9da6e445afc1bd.1718170407.git.poptsov.artyom@gmail.com
* gnu/packages/ipfs.scm (kubo): Unbundle more inputs.
[inputs]: Add go-github-com-ipfs-go-block-format,
go-github-com-ipfs-go-ipld-format.

Change-Id: Ia2f7a936d2af4f75c65cc0c0dc230982cc646ef8
---
gnu/packages/ipfs.scm | 6 ++++--
1 file changed, 4 insertions(+), 2 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index faf529b6a7..0681ab8575 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -480,8 +480,10 @@ (define-public kubo
"vendor/github.com/google/uuid"
"vendor/github.com/gorilla"
"vendor/github.com/hashicorp"
+ "vendor/github.com/ipfs/go-block-format"
"vendor/github.com/ipfs/go-cid"
"vendor/github.com/ipfs/go-cidutil"
+ "vendor/github.com/ipfs/go-ipld-format"
"vendor/github.com/ipfs/go-ipfs-util"
"vendor/github.com/ipfs/go-log"
"vendor/github.com/jackpal"
@@ -553,7 +555,7 @@ (define-public kubo
go-github-com-google-uuid
go-github-com-hashicorp-go-multierror
;;go-github-com-ipfs-boxo
- ;;go-github-com-ipfs-go-block-format
+ go-github-com-ipfs-go-block-format
go-github-com-ipfs-go-cid
go-github-com-ipfs-go-cidutil
;;go-github-com-ipfs-go-datastore
@@ -565,7 +567,7 @@ (define-public kubo
;;go-github-com-ipfs-go-fs-lock
;;go-github-com-ipfs-go-ipfs-cmds
;;go-github-com-ipfs-go-ipld-cbor
- ;;go-github-com-ipfs-go-ipld-format
+ go-github-com-ipfs-go-ipld-format
;;go-github-com-ipfs-go-ipld-git
;;go-github-com-ipfs-go-ipld-legacy
go-github-com-ipfs-go-log
--
2.45.1
Sharlatan Hellseher wrote 9 months ago
[PATCH 0/3] gnu: kubo: Unbundle more inputs.
(address . 71501-done@debbugs.gnu.org)
877cenxmes.fsf@gmail.com
Hi,

Pushed as 4797bbb12c..dbd078a5c9 to master.

--
Oleg
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEmEeB3micIcJkGAhndtcnv/Ys0rUFAmZwsUsACgkQdtcnv/Ys
0rXRnw//ZFBCRQ4lFUR9e0efhVFSYp4ZAE3srSKlo9udWmF4wxC8pMDZ2AxCxpyI
bFMzZv9HDNGNia5uKx2ak/ctra6sxJds1WXPVoHSjaCpyghr2TAFQ6HNaAewq9D/
1AF9ZphzVvl/dP+63fB1yxY8aWVr58X8X7OrntGz1g0Kv+7hQGjbboV4Kb7JXgju
Dz7tqlQrFlkVMCONg3eyAlj/A7nF9lIxT2fwEqVjpJZO9PG/0r7shjrDTIJz0uIj
Kcfc8+VEflQCfOy+GBfPxGfehJdU1RAm4P4/9aGvHQx22SD/Syn7LvTFaNoVPm3O
T2KXR52nfpHWZTuRycJp+GYkHsDDvlp1cWC9dRJCnMLISn6xSyShFXmcb4mvrzGO
vGcs3t47Bov+97GrOS031qzCo9tNNgAqp/k6gHwCAxmzfoVQLnwREAzLoxRAXlRj
6LGcZ3yFZFV2Ir7ts8xW19Ka7qIwOBYxeU6aNYIK1uJckArOYHSdZc7sj0Zuw3X1
0M70lwIX7ArpBVoZ+fkyK9WSNc2H0bK458meCDfnIkCrQdDZIX3SxRAgm8LEbaIi
Cx9oVwIWD2y65cHHYc1E3xG/ABTe7uatEotwLxRHcN2OVd2gMQYJDqgQ7lU6hdHK
KlfljxmuEVGPzX7tdl28FZMD+khddB6Tz/9VbkSA+j1EBXTqJxE=
=5KDs
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71501@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71501
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help