[PATCH 1/3] doc: Document mumi am, compose and www subcommands.

  • Done
  • quality assurance status badge
Details
2 participants
  • Arun Isaac
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Arun Isaac
Severity
normal
A
A
Arun Isaac wrote on 10 Jun 15:19 +0200
(address . guix-patches@gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
64b211c1bcab088e6502df4c824f91a28a6aa9e5.1718025563.git.arunisaac@systemreboot.net
* doc/contributing.texi (Debbugs User Interfaces)[Command-line interface]:
Document mumi am, compose and www subcommands.
* doc/guix.texi: Bump copyright year.

Change-Id: I28bde9454ad35115ed60fe4d6ffa35fad599b2d1
---
doc/contributing.texi | 70 ++++++++++++++++++++++++++++++++++++-------
doc/guix.texi | 2 +-
2 files changed, 61 insertions(+), 11 deletions(-)

Toggle diff (112 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index b8adc169d8..1fdf9b4db5 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -2395,9 +2395,9 @@ Debbugs User Interfaces
@subsubsection Command-line interface
Mumi also comes with a command-line interface that can be used to search
-existing issues, open new issues and send patches. You do not need to
-use Emacs to use the mumi command-line client. You interact with it
-only on the command-line.
+existing issues, open new issues, compose replies, apply and send
+patches. You do not need to use Emacs to use the mumi command-line
+client. You interact with it only on the command-line.
To use the mumi command-line interface, navigate to a local clone of the
Guix git repository, and drop into a shell with mumi, git and
@@ -2434,8 +2434,61 @@ Debbugs User Interfaces
opened on 24 Jan 09:42 Z by Efraim Flashner
@end example
-Once an issue is the current issue, you can easily create and send
-patches to it using
+Once an issue is the current issue, you can open the issue in a web
+browser, compose replies, apply patches, send patches, etc. with short
+succinct commands.
+
+Open the issue in your web browser using
+
+@example
+~/guix [env]$ mumi www
+@end example
+
+Compose a reply using
+
+@example
+~/guix [env]$ mumi compose
+@end example
+
+Compose a reply and close the issue using
+
+@example
+~/guix [env]$ mumi compose --close
+@end example
+
+@command{mumi compose} opens your mail client by passing @samp{mailto:}
+URIs to @command{xdg-open}. So, you need to have @command{xdg-open} set
+up to open your mail client correctly.
+
+Apply the latest patchset from the issue using
+
+@example
+~/guix [env]$ mumi am
+@end example
+
+You may also apply a patchset of a specific version (say, v3) using
+
+@example
+~/guix [env]$ mumi am v3
+@end example
+
+Or, you may apply a patch from a specific e-mail message. For example,
+to apply the patch from the 4th message (message index starts from 0),
+run
+
+@example
+~/guix [env]$ mumi am @@4
+@end example
+
+@command{mumi am} is a wrapper around @command{git am}. You can pass
+@command{git am} arguments to it after a @samp{--}. For example, to add
+a Signed-off-by trailer, run
+
+@example
+~/guix [env]$ mumi am -- -s
+@end example
+
+Create and send patches to the issue using
@example
~/guix [env]$ git format-patch origin/master
@@ -2452,11 +2505,8 @@ Debbugs User Interfaces
~/guix [env]$ mumi new
@end example
-and send patches
-
-@example
-~/guix [env]$ mumi send-email foo.patch bar.patch
-@end example
+and send an email (using @command{mumi compose}) or patches (using
+@command{mumi send-email}).
@command{mumi send-email} is really a wrapper around @command{git
send-email} that automates away all the nitty-gritty of sending patches.
diff --git a/doc/guix.texi b/doc/guix.texi
index 769ca1399f..e1d1d4696c 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -53,7 +53,7 @@
Copyright @copyright{} 2017–2022 Tobias Geerinckx-Rice@*
Copyright @copyright{} 2017 George Clemmer@*
Copyright @copyright{} 2017 Andy Wingo@*
-Copyright @copyright{} 2017, 2018, 2019, 2020, 2023 Arun Isaac@*
+Copyright @copyright{} 2017, 2018, 2019, 2020, 2023, 2024 Arun Isaac@*
Copyright @copyright{} 2017 nee@*
Copyright @copyright{} 2018 Rutger Helling@*
Copyright @copyright{} 2018, 2021, 2023 Oleg Pykhalov@*

base-commit: df5648daa1a5d097a430131bbff353b865b476b6
--
2.45.1
A
A
Arun Isaac wrote on 10 Jun 19:41 +0200
[PATCH 3/3] doc: Refer to mumi send-email in Submitting Patches.
(address . 71481@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
3309e26aa68fde18491caed27bf04cef42000bfc.1718025563.git.arunisaac@systemreboot.net
* doc/contributing.texi (Submitting Patches): Refer to mumi send-email.

Change-Id: I009cdc306220ef63e6641fac69d3453ab169bfa2
---
doc/contributing.texi | 11 ++++++-----
1 file changed, 6 insertions(+), 5 deletions(-)

Toggle diff (24 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index c089cfc95e..938c8bfdb1 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -2021,11 +2021,12 @@ Submitting Patches
@code{master}, say @code{core-updates}, specify it in the subject like
@samp{[PATCH core-updates] @dots{}}.
-You may use your email client or the @command{git send-email} command
-(@pxref{Sending a Patch Series}). We prefer to get patches in plain
-text messages, either inline or as MIME attachments. You are advised to
-pay attention if your email client changes anything like line breaks or
-indentation which could potentially break the patches.
+You may use your email client, the @command{git send-email} command
+(@pxref{Sending a Patch Series}) or the @command{mumi send-email}
+command (@pxref{Debbugs User Interfaces}). We prefer to get patches in
+plain text messages, either inline or as MIME attachments. You are
+advised to pay attention if your email client changes anything like line
+breaks or indentation which could potentially break the patches.
Expect some delay when you submit your very first patch to
@email{guix-patches@@gnu.org}. You have to wait until you get an
--
2.45.1
A
A
Arun Isaac wrote on 10 Jun 19:41 +0200
[PATCH 2/3] doc: Add mumi CLI concept index entries.
(address . 71481@debbugs.gnu.org)(name . Arun Isaac)(address . arunisaac@systemreboot.net)
8b8244ef83e48bea1387a59a6a5c6495345cedbc.1718025563.git.arunisaac@systemreboot.net
* doc/contributing.texi (Debbugs User Interfaces)[Command-line interface]: Add
mumi CLI concept index entries.

Change-Id: Ic2e67226c18e87a7360b938476a662aae76dd58e
---
doc/contributing.texi | 5 +++++
1 file changed, 5 insertions(+)

Toggle diff (18 lines)
diff --git a/doc/contributing.texi b/doc/contributing.texi
index 1fdf9b4db5..c089cfc95e 100644
--- a/doc/contributing.texi
+++ b/doc/contributing.texi
@@ -2394,6 +2394,11 @@ Debbugs User Interfaces
@subsubsection Command-line interface
+@cindex mumi CLI
+@cindex mumi am
+@cindex mumi compose
+@cindex mumi send-email
+@cindex mumi www
Mumi also comes with a command-line interface that can be used to search
existing issues, open new issues, compose replies, apply and send
patches. You do not need to use Emacs to use the mumi command-line
--
2.45.1
M
M
Maxim Cournoyer wrote on 12 Jun 16:50 +0200
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
87h6dyxljk.fsf@gmail.com
Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (5 lines)
> * doc/contributing.texi (Debbugs User Interfaces)[Command-line interface]: Add
> mumi CLI concept index entries.
>
> Change-Id: Ic2e67226c18e87a7360b938476a662aae76dd58e

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 12 Jun 16:52 +0200
Re: [bug#71481] [PATCH 1/3] doc: Document mumi am, compose and www subcommands.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
878qzaxlg9.fsf@gmail.com
Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (6 lines)
> * doc/contributing.texi (Debbugs User Interfaces)[Command-line interface]:
> Document mumi am, compose and www subcommands.
> * doc/guix.texi: Bump copyright year.
>
> Change-Id: I28bde9454ad35115ed60fe4d6ffa35fad599b2d1

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
M
M
Maxim Cournoyer wrote on 12 Jun 16:53 +0200
Re: [bug#71481] [PATCH 3/3] doc: Refer to mumi send-email in Submitting Patches.
(name . Arun Isaac)(address . arunisaac@systemreboot.net)
874j9yxlep.fsf@gmail.com
Arun Isaac <arunisaac@systemreboot.net> writes:

Toggle quote (4 lines)
> * doc/contributing.texi (Submitting Patches): Refer to mumi send-email.
>
> Change-Id: I009cdc306220ef63e6641fac69d3453ab169bfa2

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
A
A
Arun Isaac wrote on 12 Jun 23:17 +0200
Re: [bug#71481] [PATCH 1/3] doc: Document mumi am, compose and www subcommands.
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
875xudamil.fsf@systemreboot.net
Hi Maxim,

Thanks for the review! I have pushed these patches now.

Regards,
Arun
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71481@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71481
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch