[PATCH] gnu: Add r-rphyloxml.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal
A
A
Afkhami, Navid wrote on 10 Jun 17:41 +0200
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
1cbabc55454dc7d6042ddd9d322cc14d5f8f71fe.1718034097.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/bioinformatics.scm (r-rphyloxml): New variable.

Change-Id: I5b799986064f2af5fe74454f2e78fea7d9947260
---
gnu/packages/bioinformatics.scm | 43 +++++++++++++++++++++++++++++++++
1 file changed, 43 insertions(+)

Toggle diff (58 lines)
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index cecd94bbb7..3282258b48 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -14096,6 +14096,49 @@ (define-public sambamba
sort, markdup, and depth.")
(license license:gpl2+)))
+(define-public r-rphyloxml
+ (let ((commit "a30e39249239b2de01d6964ae2a2205a6c48b475")
+ (revision "1"))
+ (package
+ (name "r-rphyloxml")
+ (version (git-version "0.0-9000" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/USCbiostats/rphyloxml")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "15ijzqvjxx6vqyqlg5asdbqlhw1g0ix6palf1rism3si0qapddgw"))))
+ (properties `((upstream-name . "rphyloxml")))
+ (build-system r-build-system)
+ (arguments
+ (list
+ #:modules '((guix build r-build-system)
+ (guix build minify-build-system)
+ (guix build utils)
+ (ice-9 match))
+ #:imported-modules `(,@%r-build-system-modules (guix build
+ minify-build-system))
+ #:phases '(modify-phases %standard-phases
+ (add-after 'unpack 'process-javascript
+ (lambda* (#:key inputs #:allow-other-keys)
+ (with-directory-excursion "inst/"
+ (for-each (match-lambda
+ ((source . target) (minify source
+ #:target
+ target)))
+ '())))))))
+ (propagated-inputs (list r-ape r-xml2))
+ (native-inputs (list esbuild))
+ (home-page "https://github.com/USCbiostats/rphyloxml")
+ (synopsis "Read and write phyloXML files in R")
+ (description
+ "The package reads phylogenetic data in the @code{phyloXML} format.
+It also includes functions for writing data in this format.")
+ (license license:expat))))
+
(define-public ritornello
(package
(name "ritornello")

base-commit: 2b2337f275a6421a0d0964c54987df4ac74162e6
--
2.34.1
R
R
Ricardo Wurmus wrote on 28 Jun 22:49 +0200
(address . 71476-done@debbugs.gnu.org)
87zfr4vllb.fsf@elephly.net
Thanks for the patch. This one was incomplete: the importer only
generates a skeleton to replace minified JavaScript files. I fleshed it
out and added the missing inputs.

--
Ricardo
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71476@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71476
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch