[PATCH] gnu: Add emacs-devil.

  • Done
  • quality assurance status badge
Details
2 participants
  • Nicolas Goaziou
  • Spencer King
Owner
unassigned
Submitted by
Spencer King
Severity
normal

Debbugs page

Spencer King wrote 9 months ago
(address . guix-patches@gnu.org)(name . Spencer King)(address . spencer@nursiapress.com)
5b88b61a397bc3b20418baabf2659b3498835c61.1717973526.git.spencer@nursiapress.com
* gnu/packages/emacs-xyz.scm (emacs-devil): New variable.

Change-Id: Ic240d6e80a236a91514f3599eaa051f9ffcd15be
---
gnu/packages/emacs-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bef0afc99f..435fdccd13 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -139,6 +139,7 @@
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
+;;; Copyright © 2024 Spencer King <spencer@nursiapress.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11029,6 +11030,28 @@ (define-public emacs-god-mode
@samp{C-} (among other helpful shortcuts).")
(license license:gpl3+)))
+(define-public emacs-devil
+ (package
+ (name "emacs-devil")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/susam/devil")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1pr9yf6f37sz5qy1snn8ag5bvg6lza7q635jh8jhaqqfp37jvv1y"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/susam/devil")
+ (synopsis "Minor mode for translating key sequences")
+ (description
+ "Devil intercepts your devil key (comma by default) to let you type key sequences
+without using modifier keys. Devil is highly configurable and it can be
+configured to perform other key sequence translations.")
+ (license license:expat)))
+
(define-public emacs-jinja2-mode
(package
(name "emacs-jinja2-mode")

base-commit: bc8a41f4a8d9f1f0525d7bc97c67ed3c8aea3111
--
2.41.0
Nicolas Goaziou wrote 9 months ago
(name . Spencer King)(address . spencer@nursiapress.com)(address . 71457-done@debbugs.gnu.org)(name . Katherine Cox-Buday)(address . cox.katherine.e+guix@gmail.com)(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)(name . Andrew Tropin)(address . andrew@trop.in)
87tthp5pro.fsf@nicolasgoaziou.fr
Hello,

Spencer King <spencer@nursiapress.com> writes:

Toggle quote (2 lines)
> * gnu/packages/emacs-xyz.scm (emacs-devil): New variable.

Applied. Thank you.

Regards,
--
Nicolas Goaziou
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71457@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71457
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help