[PATCH 0/2] gnu: Add itamae.

  • Open
  • quality assurance status badge
Details
One participant
  • gemmaro
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 8 Jun 02:04 +0200
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
cover.1717804696.git.gemmaro.dev@gmail.com
Hello,

This adds Itamae configulation management system and its dependency.

Thank you,
gemmaro.

gemmaro (2):
gnu: Add ruby-schash.
gnu: Add itamae.

gnu/packages/admin.scm | 31 +++++++++++++++++++++++++++++++
gnu/packages/ruby.scm | 28 +++++++++++++++++++++++++++-
2 files changed, 58 insertions(+), 1 deletion(-)


base-commit: 580d77d0fb12448ef1621699cc0c56e787e2aadb
--
2.45.1
G
G
gemmaro wrote on 8 Jun 02:24 +0200
[PATCH 2/2] gnu: Add itamae.
(address . 71423@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
ee1568e6f5b5cd85a8942839369c4d6813bc9da0.1717804696.git.gemmaro.dev@gmail.com
* gnu/packages/admin.scm (itamae): New variable.

Change-Id: I8648f7d0eb12a1e63af2e1cf9811a7dadcee2e43
---
gnu/packages/admin.scm | 31 +++++++++++++++++++++++++++++++
1 file changed, 31 insertions(+)

Toggle diff (51 lines)
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index c730d43819..1d26b1de40 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -65,6 +65,7 @@
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Tomás Ortín Fernández <tomasortin@mailbox.org>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3150,6 +3151,36 @@ (define-public emacs-ansible-doc
'yaml-mode-hook #'ansible-doc-mode)}.")
(license license:gpl3+))))
+(define-public itamae
+ (package
+ (name "itamae")
+ (version "1.14.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "itamae" version))
+ (sha256
+ (base32 "1zhx0cknipkjqp33qdxjlv7lcybgmh1jv9npp55vxaazd8cyfylx"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:test-target "spec:unit"
+ #:phases #~(modify-phases %standard-phases
+ ;; There hasn't been the Fluentd packages yet.
+ (add-before 'check 'remove-fluentd-related-files
+ (lambda _
+ (delete-file
+ "spec/unit/lib/itamae/handler/fluentd_spec.rb"))))))
+ (native-inputs (list ruby-rspec ruby-fakefs))
+ (propagated-inputs (list ruby-ansi ruby-hashie ruby-schash ruby-specinfra
+ ruby-thor))
+ (synopsis "Simple and lightweight configuration management tool")
+ (description
+ "Itamae is a configulation management tool inspired by Chef, but simpler and
+lightweight.")
+ (home-page "https://itamae.kitchen/")
+ (license license:expat)))
+
(define-public cpulimit
(package
(name "cpulimit")
--
2.45.1
G
G
gemmaro wrote on 8 Jun 02:24 +0200
[PATCH 1/2] gnu: Add ruby-schash.
(address . 71423@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
667ee248958dec7b7a50abf9c6ef1c683b5c1b37.1717804696.git.gemmaro.dev@gmail.com
* gnu/packages/ruby.scm (ruby-schash): New variable.

Change-Id: Idb534f17e5e7cbc43b671e8c35d475484d423050
---
gnu/packages/ruby.scm | 28 +++++++++++++++++++++++++++-
1 file changed, 27 insertions(+), 1 deletion(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 5c1e666bb0..28f6fbc7dc 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -32,7 +32,7 @@
;;; Copyright © 2022-2024 Remco van 't Veer <remco@remworks.net>
;;; Copyright © 2022 Taiju HIGASHI <higashi@taiju.info>
;;; Copyright © 2023 Yovan Naumovski <yovan@gorski.stream>
-;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
+;;; Copyright © 2023, 2024 gemmaro <gemmaro.dev@gmail.com>
;;; Copyright © 2023, 2024 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2023, 2024 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -819,6 +819,32 @@ (define-public ruby-rspec-expectations-2
(propagated-inputs
(list ruby-diff-lcs))))
+(define-public ruby-schash
+ (package
+ (name "ruby-schash")
+ (version "0.1.2")
+ (source
+ (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/ryotarai/schash")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q58k844i1rzxapcd8acppkkdm29ikfzn8nxas7kb7b5mf1xv9kv"))))
+ (build-system ruby-build-system)
+ (arguments
+ (list
+ #:test-target "spec"))
+ (native-inputs (list ruby-rspec))
+ (synopsis "Ruby Hash validator")
+ (description
+ "This gem is a Ruby's @code{Hash} validator. It allows library
+users to define their own validator schema using its domain specific
+language, and validate values with it.")
+ (home-page "https://github.com/ryotarai/schash")
+ (license license:expat)))
+
(define-public ruby-sorcerer
(package
(name "ruby-sorcerer")
--
2.45.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71423@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71423
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch