[PATCH] gnu: libinput-gestures: Update to 2.76.

  • Open
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • kiasoc5
Owner
unassigned
Submitted by
kiasoc5
Severity
normal
K
K
kiasoc5 wrote on 7 Jun 04:27 +0200
(address . guix-patches@gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
686648def1516cc739f7fabe771f4c92c0f5afc5.1717727224.git.kiasoc5@disroot.org
* gnu/packages/freedesktop.scm (libinput-gestures): Update to 2.76.

Change-Id: If01b291c6790539af22c508d764c5f09a92ec051
---
gnu/packages/freedesktop.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (27 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index e29c289df2..79dd6d5015 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -747,7 +747,7 @@ (define-public libinput-minimal
(define-public libinput-gestures
(package
(name "libinput-gestures")
- (version "2.73")
+ (version "2.76")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -756,7 +756,7 @@ (define-public libinput-gestures
(file-name (git-file-name name version))
(sha256
(base32
- "1klnc4y43maxpz7c6q0gc2gbly6jfcawnalx3f2jyc61zzgrxl3n"))))
+ "0x7gwdq7c7rahbfj6cdk19jgmm4g87r51i1229rq55wlzm1y1gsd"))))
(build-system gnu-build-system)
(arguments
(list

base-commit: 580d77d0fb12448ef1621699cc0c56e787e2aadb
prerequisite-patch-id: 3105d2dda46daf29f7ea4fd49a21a44826cb965a
--
2.45.1
K
K
kiasoc5 wrote on 7 Jun 04:35 +0200
[PATCH v2] gnu: Add libinput-gestures.
(address . 71403@debbugs.gnu.org)(name . kiasoc5)(address . kiasoc5@disroot.org)
b2605ae412cad93c46f5be64a2b3110ae73f6137.1717727754.git.kiasoc5@disroot.org
Forgot to rebase this forgotten 2-year-old patch!

* gnu/packages/freedesktop.scm (libinput-gestures): New variable.
---
gnu/packages/freedesktop.scm | 56 ++++++++++++++++++++++++++++++++++++
1 file changed, 56 insertions(+)

Toggle diff (71 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6941450436..79dd6d5015 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -744,6 +744,62 @@ (define-public libinput-minimal
"-Ddebug-gui=false" ;requires gtk+@3
,flags))))))
+(define-public libinput-gestures
+ (package
+ (name "libinput-gestures")
+ (version "2.76")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bulletmark/libinput-gestures")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0x7gwdq7c7rahbfj6cdk19jgmm4g87r51i1229rq55wlzm1y1gsd"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:make-flags
+ #~(list (string-append "DESTDIR=" #$output))
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure) ; no configure
+ (add-before 'install 'fix-hardcoded-paths
+ (lambda _
+ (substitute* "libinput-gestures"
+ (("PROGPATH = Path(sys.argv[0])")
+ "PROGPATH = Path(\"libinput-gestures\")")
+ (("'libinput'")
+ (string-append
+ "'" (search-input-file %build-inputs "/bin/libinput") "'")))))
+ (add-before 'install 'delete-mentions-of-usr
+ (lambda _
+ (substitute* "libinput-gestures-setup"
+ (("/usr") ""))))
+ ;; TODO: replace this phase
+ (add-before 'patch-dot-desktop-files 'patch-desktop-file-manually
+ (lambda _
+ (substitute* "libinput-gestures.desktop"
+ (("/usr/bin/libinput-gestures")
+ (string-append #$output "/bin/libinput-gestures")))))
+ (add-after 'install 'remove-systemd-service
+ (lambda _
+ (delete-file-recursively (string-append #$output "/lib"))))
+ (delete 'check) ; no tests
+ )))
+ (inputs
+ (list python libinput hicolor-icon-theme))
+ (home-page "https://github.com/bulletmark/libinput-gestures")
+ (synopsis "Actions gestures on your touchpad using libinput")
+ (description
+ "@code{libinput-gestures} is a utility which reads libinput gestures from
+your touchpad and maps them to gestures you configure in a configuration file.
+Each gesture can be configured to activate a shell command. It can be used for
+X window managers and Wayland compositors that do not support libinput gestures
+natively.")
+ (license license:gpl3+)))
+
(define-public libxdg-basedir
(package
(name "libxdg-basedir")

base-commit: 580d77d0fb12448ef1621699cc0c56e787e2aadb
--
2.45.1
A
A
Andreas Enge wrote on 29 Jun 11:49 +0200
Comment
(address . 71403@debbugs.gnu.org)
Zn_Yr-vM026gXHjF@jurong
Hello,

I was about to apply your patch, but then I saw a line
;; TODO: replace this phase

Is it still relevant? To the untrained eye the phase looks okay.

Concerning the description, I would suggest the following:
"@code{libinput-gestures} is a utility which reads libinput gestures from
the touchpad and maps them to gestures defined in a configuration file.
Each gesture can be configured to activate a shell command. It can be used for
X window managers and Wayland compositors that do not support libinput gestures
natively."
to remove the "you" and one of many "configur{e,ation}".

Andreas
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71403@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71403
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch