[PATCH] gnu: mu: Update to 1.12.5.

  • Done
  • quality assurance status badge
Details
2 participants
  • Christopher Baines
  • Sergey Trofimov
Owner
unassigned
Submitted by
Sergey Trofimov
Severity
normal

Debbugs page

Sergey Trofimov wrote 9 months ago
(address . guix-patches@gnu.org)(name . Sergey Trofimov)(address . sarg@sarg.org.ru)
4c4eb04bbb532849833d331cf014f8fce052448b.1717658545.git.sarg@sarg.org.ru
* gnu/packages/mail.scm (mu): Update to 1.12.5. Wrap /bin/mu to enable
running Guile extension scripts.
---
gnu/packages/mail.scm | 20 +++++++++++++++-----
1 file changed, 15 insertions(+), 5 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index b96645f53b..dbf27d3533 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1260,14 +1260,14 @@ (define-public emacs-mew
(define-public mu
(package
(name "mu")
- (version "1.12.4")
+ (version "1.12.5")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/djcb/mu/releases/download/v"
version "/mu-" version ".tar.xz"))
(sha256
- (base32 "1ja4b9r9712zjvz8223r5vh2kmmyhkrmb7cbhxdn9hbpa5n16hdx"))))
+ (base32 "1jwalqmvk5s4mf7bnz7gnzh6rii7n348bsflgdvyinia0zir42vp"))))
(build-system meson-build-system)
(native-inputs
(list pkg-config
@@ -1280,8 +1280,11 @@ (define-public mu
(list
#:modules '((guix build meson-build-system)
(guix build emacs-utils)
+ ((guix build guile-build-system)
+ #:select (target-guile-effective-version))
(guix build utils))
#:imported-modules `(,@%meson-build-system-modules
+ (guix build guile-build-system)
(guix build emacs-utils))
#:configure-flags
#~(list (format #f "-Dguile-extension-dir=~a/lib" #$output))
@@ -1303,11 +1306,18 @@ (define-public mu
(("\"libguile-mu\"")
(format #f "\"~a/lib/libguile-mu\"" #$output)))))
(add-after 'install 'install-emacs-autoloads
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda _
(emacs-generate-autoloads
"mu4e"
- (string-append (assoc-ref outputs "out")
- "/share/emacs/site-lisp/mu4e")))))))
+ (string-append #$output
+ "/share/emacs/site-lisp/mu4e"))))
+ (add-after 'install 'wrap-executable
+ (lambda _
+ (let* ((bin (string-append #$output "/bin"))
+ (version (target-guile-effective-version))
+ (scm (string-append #$output "/share/guile/site/" version)))
+ (wrap-program (string-append bin "/mu")
+ `("GUILE_LOAD_PATH" ":" prefix (,scm)))))))))
(home-page "https://www.djcbsoftware.nl/code/mu/")
(synopsis "Quickly find emails")
(description

base-commit: 2b2337f275a6421a0d0964c54987df4ac74162e6
--
2.45.1
Christopher Baines wrote 9 months ago
(name . Sergey Trofimov)(address . sarg@sarg.org.ru)(address . 71390-done@debbugs.gnu.org)
8734pjaenb.fsf@cbaines.net
Sergey Trofimov <sarg@sarg.org.ru> writes:

Toggle quote (6 lines)
> * gnu/packages/mail.scm (mu): Update to 1.12.5. Wrap /bin/mu to enable
> running Guile extension scripts.
> ---
> gnu/packages/mail.scm | 20 +++++++++++++++-----
> 1 file changed, 15 insertions(+), 5 deletions(-)

Looks good to me, I've pushed this to master as
cc2c6049723f936ba394f5eeed331f980ea296f1.

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZoOFhfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9Xfk2BAAlsutID4Qs0YxdRLfLRWkiXlM8rc6Rl5A
NASBOgXWifuJ0lHN6Er5EK8uRuv8wCJC6D38wgyzK1Ydjbf78LHGy0Gf6A3UIVB5
5YEtvDZlIzipflebsJKYsw1kPBllS+Ugu4bmD07PbbJgOKM7zfXXpyDbra7M2r7S
C5KOBiIvcvok0M+VD3F9cN/Runmd4o4hVVN9ansKOSpb1hdLJ4jedmhlbxh4l1ts
GLk5gip5mezfk5ZlloDq63nP7DNKVD1D328FGYb0dsEW4+4vm4kjnrP04Quff9Hv
2joB2EogHxtBzcgI+fvn/gAwJPLl65za/jIHSv4tHs7i21YPRcOzhVfMpovWIiSn
MhaCNvGiEe6y7ddQNdSLvj7xMWhcCH4nfFLZfrJV63mcBSAU8zGArasGGJtSRdzt
IoXzMHEvlfrLJBzh4FiJTeo10l4iwrdhiTsbF6PCH6hU8X5S0j/RH2VtSQ4x7ftm
PkyK5aAEH8UVQPaVezsQ9mkmwINW3GBjLPSE8oEhQW5maKV61r2wrobuElHIYZBm
zGdA5qKCBzls3kJcI5xUqpoozK7NuMi7MoNqqcl1FWr7eh+kA8xxFKu1IWORY2V/
2VKWrwYGyR7Er1uBh8yxG0tJwEwA/JAXJV/rB1VkQR65RHvOTmxH+Ux9sHFR0dFl
KRnYhR79PBc=
=O7QM
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71390@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71390
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch
You may also tag this issue. See list of standard tags. For example, to set the confirmed and easy tags
mumi command -t +confirmed -t +easy
Or, remove the moreinfo tag and set the help tag
mumi command -t -moreinfo -t +help