[PATCH] gnu: Add emacs-org-timeblock.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Ilya Chernyshov
Owner
unassigned
Submitted by
Ilya Chernyshov
Severity
normal
I
I
Ilya Chernyshov wrote on 3 Jun 20:00 +0200
(address . guix-patches@gnu.org)
6a9f22becd6264c14b7fa63b3bd3a6c19bcb4433.1717437358.git.ichernyshovvv@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-org-timeblock): New variable.

Change-Id: I7a5844bc11d263131b4e1d2fb23a223747c4f63c
---
gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
1 file changed, 29 insertions(+)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2209169864..c15e99c9fc 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -23545,6 +23545,35 @@ (define-public emacs-org-recur
for defining recurring tasks and easily scheduling them.")
(license license:gpl3+)))
+(define-public emacs-org-timeblock
+ (let ((revision "0")
+ (commit "b423b01712b9c25dff3e4203c7cde736225f62ef"))
+ (package
+ (name "emacs-org-timeblock")
+ (version (git-version "0.2" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/ichernyshovvv/org-timeblock.git")
+ (commit commit)))
+ (sha256
+ (base32 "1q0271nli4yw01rwybkzdlqcj8ivqwh5r70yv9x0qqwxa955c9k9"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/ichernyshovvv/org-timeblock")
+ (synopsis
+ "Schedule your day visually, using timeblocking technique inside Emacs")
+ (description "The builtin orgmode package for viewing tasks or events
+for a particular day, org-agenda, does not help you to quickly understand,
+where, for example, you have free time in your day or where you have overlapping
+tasks. Just a list of tasks is not sufficient. This package is created to
+fix this problem and provide some of the functionality that modern calendars
+provide.")
+ (license license:gpl3+))))
+
(define-public emacs-org-super-agenda
(package
(name "emacs-org-super-agenda")

base-commit: 2e53fa5346bf52f6d6d26e035bc905ebd410dabb
prerequisite-patch-id: fec8c38c077df9e314d4c220cc9314e3ec50d550
--
2.41.0
A
A
Andrew Tropin wrote on 5 Jun 11:20 +0200
87ikynhhkk.fsf@trop.in
On 2024-06-04 01:00, Ilya Chernyshov wrote:

Toggle quote (51 lines)
> * gnu/packages/emacs-xyz.scm (emacs-org-timeblock): New variable.
>
> Change-Id: I7a5844bc11d263131b4e1d2fb23a223747c4f63c
> ---
> gnu/packages/emacs-xyz.scm | 29 +++++++++++++++++++++++++++++
> 1 file changed, 29 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 2209169864..c15e99c9fc 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -23545,6 +23545,35 @@ (define-public emacs-org-recur
> for defining recurring tasks and easily scheduling them.")
> (license license:gpl3+)))
>
> +(define-public emacs-org-timeblock
> + (let ((revision "0")
> + (commit "b423b01712b9c25dff3e4203c7cde736225f62ef"))
> + (package
> + (name "emacs-org-timeblock")
> + (version (git-version "0.2" revision commit))
> + (source
> + (origin
> + (method git-fetch)
> + (uri
> + (git-reference
> + (url "https://github.com/ichernyshovvv/org-timeblock.git")
> + (commit commit)))
> + (sha256
> + (base32 "1q0271nli4yw01rwybkzdlqcj8ivqwh5r70yv9x0qqwxa955c9k9"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (propagated-inputs (list emacs-compat))
> + (home-page "https://github.com/ichernyshovvv/org-timeblock")
> + (synopsis
> + "Schedule your day visually, using timeblocking technique inside Emacs")
> + (description "The builtin orgmode package for viewing tasks or events
> +for a particular day, org-agenda, does not help you to quickly understand,
> +where, for example, you have free time in your day or where you have overlapping
> +tasks. Just a list of tasks is not sufficient. This package is created to
> +fix this problem and provide some of the functionality that modern calendars
> +provide.")
> + (license license:gpl3+))))
> +
> (define-public emacs-org-super-agenda
> (package
> (name "emacs-org-super-agenda")
>
> base-commit: 2e53fa5346bf52f6d6d26e035bc905ebd410dabb
> prerequisite-patch-id: fec8c38c077df9e314d4c220cc9314e3ec50d550

Hi Ilya!

You can use `guix lint` to see the recommendations for code formatting,
please run it next time before submitting the package.

Toggle snippet (5 lines)
./pre-inst-env guix lint emacs-org-timeblock
gnu/packages/emacs-xyz.scm:23569:19: emacs-org-timeblock@0.2-0.b423b01: sentences in description should be followed by two spaces; possible infractions at 217, 257
gnu/packages/emacs-xyz.scm:23555:7: emacs-org-timeblock@0.2-0.b423b01: permanent redirect from https://github.com/ichernyshovvv/org-timeblock.git to https://github.com/ichernyshovvv/org-timeblock

I incorporated the suggestions from linter and pushed the changes as

Thank you for the patch!

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmZgLcsACgkQIgjSCVjB
3rA5Ig//Su+142tWngp7AOm/FvIk1h+utOxL5uL7sue1bRhKPdCkFUkQNqhEP0E2
xtL+44FK0TzPv5+blotK6K7y+ds7qUcxNYGs9uZeY/9MVQ/NFwsmcd/8Y/v3K3tR
RdCU9OwVcUZQpTtTH7huMZZ1e/7Iepm2ivwe2yxZzLgGUem3GJNarWazHrdJmIuw
o08rQeKS9KIKZEsPe0WsClmoDgEKRgrnRj4YXDUS9CJzIMIKpObr8iBXyLZsfH+C
LmkHdIT0gDK9GqduL0r/bazOniwPv0OHzVuug78mjmGF0kcS3TD/sy0KNB42mSfX
bH0yg47uQ0Lt110nLgaASsQnKcTG08MNvPRS2snAGXCvZvfk5lGolm64+QyrEqtx
3n9bhl3wBPvKo2pM7DZ1Z03zaUOOymD8X6CTeeh9zH6Mw65piuo0wTar6pNMhxBX
vjCoJF2w+bJYIIWd65AIWHjvuf0B42i5LRC9tYOFsLZ48PqqHxw40zBuM3OTUsWX
wxKPeKz4yW2UEGo4HLLNb4x3BdARtniZnDElkP0z2AQFry7bFT9NP84fHBCRWbkU
QxyEiN6vud3YJoY9d5H4/9W/b+p808CesBl6jInmZhFLYDZ6oz2g0whbvARRN8jG
ozDnnYy6UmFX5hgOlc4NdKhAyj6c/kE0+HjdTnEQyqzT9MPmlbI=
=0b7+
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71347@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71347
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch