[PATCH 0/3] gnu: Update vim-vader and vim-coqtail

  • Done
  • quality assurance status badge
Details
2 participants
  • Jean-Pierre De Jesus DIAZ
  • Christopher Baines
Owner
unassigned
Submitted by
Jean-Pierre De Jesus DIAZ
Severity
normal
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jun 18:46 +0200
(address . guix-patches@gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
cover.1717432980.git.jean@foundation.xyz
This patch set updates vim-vader and vim-coqtail and their neovim
variants respectively.

The vim-vader package also has been fixed since some tests have broke.

Also a patch adds python-pynvim to neovim-coqtail for convenience as the
plugin needs it (and to avoid manual installation).

Jean-Pierre De Jesus DIAZ (3):
gnu: vim-vader: Update to 0.4.0-1.429b669.
gnu: neovim-coqtail: Propagated python-pynvim.
gnu: vim-coqtail: Update to 1.7.1-1.d77080e.

gnu/packages/vim.scm | 26 ++++++++++++++++----------
1 file changed, 16 insertions(+), 10 deletions(-)


base-commit: 879fc9b3f0c2e58c6232da03b94eba98c78e2d99
--
2.41.0
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jun 19:01 +0200
[PATCH 1/3] gnu: vim-vader: Update to 0.4.0-1.429b669.
(address . 71346@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
dee7157b76062cf8a72c877091eac1b9bee18d8a.1717432980.git.jean@foundation.xyz
* gnu/packages/vim.scm (vim-vader): Update to 0.4.0-1.429b669 and fix
'check phase.
(neovim-vader): Ditto.

Change-Id: I3dc73652596dcbded804dfc80c0ed9f2876ae89b
---
gnu/packages/vim.scm | 13 ++++++++-----
1 file changed, 8 insertions(+), 5 deletions(-)

Toggle diff (43 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 6b5eaabf8e..f09a39e008 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -1527,8 +1527,8 @@ (define-public vim-nerdcommenter
(license license:cc0)))
(define-public vim-vader
- (let ((revision "0")
- (commit "6fff477431ac3191c69a3a5e5f187925466e275a"))
+ (let ((revision "1")
+ (commit "429b669e6158be3a9fc110799607c232e6ed8e29"))
(package
(name "vim-vader")
(version (git-version "0.4.0" revision commit))
@@ -1540,7 +1540,7 @@ (define-public vim-vader
(file-name (git-file-name name version))
(sha256
(base32
- "179dbbqdyl6qf6jdb6kdazn3idz17m1h2n88rlggb1wnly74vjin"))))
+ "0jf4gshr31c1i64f6qykqq17nsasfaljrqz41kzqcxw8fvra8y4c"))))
(build-system vim-build-system)
(arguments
'(#:plugin-name "vader"
@@ -1549,11 +1549,14 @@ (define-public vim-vader
(add-before 'install 'check
(lambda* (#:key tests? vim? neovim? #:allow-other-keys)
(when tests?
- ;; FIXME: suite1.vader fails with an unknown reason,
+ ;; FIXME: suite1.vader, suite2.vader and
+ ;; highlight-after-comment.vader fail with unknown reasons,
;; lang-if.vader requires Python and Ruby.
(substitute* "test/vader.vader"
(("Include.*feature/suite1.vader.*$") "")
- (("Include.*feature/lang-if.vader.*$") ""))
+ (("Include.*feature/suite2.vader.*$") "")
+ (("Include.*feature/lang-if.vader.*$") "")
+ (("Include.*regression/highlight-after-comment.vader.*$") ""))
(display "Running Vim tests\n")
(with-directory-excursion "test"
--
2.41.0
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jun 19:01 +0200
[PATCH 2/3] gnu: neovim-coqtail: Propagated python-pynvim.
(address . 71346@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
912bd31c8b1ea781a93cdc2075d7513c6c875e48.1717432980.git.jean@foundation.xyz
* gnu/packages/vim.scm (neovim-coqtail) <propagated-inputs>: Add
python-pynvim.

Change-Id: Ic55bba3a959a1400e75788bf2054d816bb6146a6
---
gnu/packages/vim.scm | 5 ++++-
1 file changed, 4 insertions(+), 1 deletion(-)

Toggle diff (18 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index f09a39e008..d51147fd29 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -529,7 +529,10 @@ (define-public neovim-coqtail
(native-inputs
(modify-inputs (package-native-inputs vim-coqtail)
(replace "vim-vader" neovim-vader)
- (append python-minimal python-pynvim)))))
+ (append python-minimal python-pynvim)))
+ (propagated-inputs
+ (modify-inputs (package-propagated-inputs vim-coqtail)
+ (append python-pynvim)))))
(define-public vim-fugitive
(package
--
2.41.0
J
J
Jean-Pierre De Jesus DIAZ wrote on 3 Jun 19:01 +0200
[PATCH 3/3] gnu: vim-coqtail: Update to 1.7.1-1.d77080e.
(address . 71346@debbugs.gnu.org)(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)
37cb2cb52b1a952f1064db1a74786742e0f7664a.1717432980.git.jean@foundation.xyz
* gnu/packages/vim.scm (vim-coqtail): Update to 1.7.1-1.d77080e.
(neovim-coqtail): Ditto.

Change-Id: Ifea28105a394c50a78cc1afaa2fa0217fe0cf39b
---
gnu/packages/vim.scm | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index d51147fd29..1ab69b9572 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -455,11 +455,11 @@ (define-public vim-context-filetype
(license license:expat)))) ; ??? check again
(define-public vim-coqtail
- (let ((commit "dfe3939c9caff69d9af76bfd74f1a40fb7dc5609")
- (revision "0"))
+ (let ((commit "d77080e17787afe9ad0366d86327658da36febbb")
+ (revision "1"))
(package
(name "vim-coqtail")
- (version (git-version "1.7.0" revision commit))
+ (version (git-version "1.7.1" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
@@ -468,7 +468,7 @@ (define-public vim-coqtail
(file-name (git-file-name name version))
(sha256
(base32
- "0av2m075n6z05ah9ndrgnp9s16yrz6n2lj0igd9fh3c5k41x5xks"))))
+ "03qq50mas5dk3aj1rbv1f0x68rfa9b07cacj12sxp76sda9c0prz"))))
(build-system vim-build-system)
(arguments
`(#:plugin-name "coqtail"
--
2.41.0
J
J
Jean-Pierre De Jesus Diaz wrote on 11 Jun 13:57 +0200
Re: [bug#71346] [PATCH 0/3] gnu: Update vim-vader and vim-coqtail
(name . Christopher Baines)(address . mail@cbaines.net)(address . 71346-done@debbugs.gnu.org)
CAG1gdUreRW2TwvEBMzGnRZPA-ZGLA3MVZ5=_m9bJgdH54zkDog@mail.gmail.com
Hello,

Thanks for merging and I'm sorry about the extra stuff in the commit messages!

On Tue, Jun 11, 2024 at 11:42?AM Christopher Baines <mail@cbaines.net> wrote:
Toggle quote (29 lines)
>
> Jean-Pierre De Jesus DIAZ <jean@foundation.xyz> writes:
>
> > This patch set updates vim-vader and vim-coqtail and their neovim
> > variants respectively.
> >
> > The vim-vader package also has been fixed since some tests have broke.
> >
> > Also a patch adds python-pynvim to neovim-coqtail for convenience as the
> > plugin needs it (and to avoid manual installation).
> >
> > Jean-Pierre De Jesus DIAZ (3):
> > gnu: vim-vader: Update to 0.4.0-1.429b669.
> > gnu: neovim-coqtail: Propagated python-pynvim.
> > gnu: vim-coqtail: Update to 1.7.1-1.d77080e.
> >
> > gnu/packages/vim.scm | 26 ++++++++++++++++----------
> > 1 file changed, 16 insertions(+), 10 deletions(-)
>
> Looks good to me, I've pushed this to master as
> ec031bbbf136ceb0c6c62c68652ca98f74f86d8b.
>
> I tweaked the commit mesasges a bit, the changelog entries are more
> around what you change rather than the effects, so I removed the bits
> about neovim "Ditto".
>
> Thanks,
>
> Chris
Closed
C
C
Christopher Baines wrote on 11 Jun 13:42 +0200
(name . Jean-Pierre De Jesus DIAZ)(address . jean@foundation.xyz)(address . 71346-done@debbugs.gnu.org)
87bk47aep8.fsf@cbaines.net
Jean-Pierre De Jesus DIAZ <jean@foundation.xyz> writes:

Toggle quote (16 lines)
> This patch set updates vim-vader and vim-coqtail and their neovim
> variants respectively.
>
> The vim-vader package also has been fixed since some tests have broke.
>
> Also a patch adds python-pynvim to neovim-coqtail for convenience as the
> plugin needs it (and to avoid manual installation).
>
> Jean-Pierre De Jesus DIAZ (3):
> gnu: vim-vader: Update to 0.4.0-1.429b669.
> gnu: neovim-coqtail: Propagated python-pynvim.
> gnu: vim-coqtail: Update to 1.7.1-1.d77080e.
>
> gnu/packages/vim.scm | 26 ++++++++++++++++----------
> 1 file changed, 16 insertions(+), 10 deletions(-)

Looks good to me, I've pushed this to master as
ec031bbbf136ceb0c6c62c68652ca98f74f86d8b.

I tweaked the commit mesasges a bit, the changelog entries are more
around what you change rather than the effects, so I removed the bits
about neovim "Ditto".

Thanks,

Chris
-----BEGIN PGP SIGNATURE-----

iQKlBAEBCgCPFiEEPonu50WOcg2XVOCyXiijOwuE9XcFAmZoOBNfFIAAAAAALgAo
aXNzdWVyLWZwckBub3RhdGlvbnMub3BlbnBncC5maWZ0aGhvcnNlbWFuLm5ldDNF
ODlFRUU3NDU4RTcyMEQ5NzU0RTBCMjVFMjhBMzNCMEI4NEY1NzcRHG1haWxAY2Jh
aW5lcy5uZXQACgkQXiijOwuE9XeJkg/+NXOTuMSTrPiUM3iNAzJqk7kOKkGaQscW
tYGj7Y+35n08b7DgQSdxkgSbKxA63vfCitaetIYNxze+MXU9pTkkG9JbJYmiUWq3
f0bJMPElSX+/t6Bw4EA6cTFmgqTmh9del7QdGsP3Vf/wP6v6jPum1xFWK29YDTrk
R3rd/PccOCPgRNj3Kl9V1Va/SZRenWhY1Q9XRpooiahTOtGsBeraa0LcEOjaZ0pI
CLh4W4oQ6o2vexHRQWPIeNyM1KVvnBBFAQjdEYTCtRHQko2xjDtE7PrnBM+m6UW6
Trtd5TCaZ495GJqEUxKzLCWISB56lPaUn7f4lqUOUhf4W4ZYhglyNMwllFx6Bl8a
PFgW3JTazgcQcUSAF7SW5xWJErEsrelJqI4nbFkM3jQ8TOmNQo5Kxmrd3WmuHRud
ppGoS9f8bn01FJsGrusPC0qQiFToCn5Uv2NpsysXehbrIY8LGCzOEp5o759w9B+k
WhxpIk4U9IbZMjiH3pqvGpJVFakm1q9Sd1x1q0sHvQ49znwpyfq2qjQn1rMr8aSV
b3A/xTwSUhcBljP/XMtZ96XLKN9Gkf2zBLl1gkWu3VBcepipRn9EXX6qyQztzTMM
jeb+0rHabuQneWIqEQgtFrBaHeI/wUsTmDG2eY0nEhwGVcgwiRyJ7RFYGWS71lpM
Vg9sZgQt4T0=
=kz3S
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71346@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71346
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch