[PATCH] gnu: Add r-topdom.

  • Done
  • quality assurance status badge
Details
2 participants
  • Afkhami, Navid
  • Ricardo Wurmus
Owner
unassigned
Submitted by
Afkhami, Navid
Severity
normal
A
A
Afkhami, Navid wrote on 3 Jun 16:47 +0200
(address . guix-patches@gnu.org)(name . Afkhami, Navid)(address . Navid.Afkhami@mdc-berlin.de)
264adf3424ada808c111117a9adec5fe93b36d33.1717426055.git.Navid.Afkhami@mdc-berlin.de
* gnu/packages/cran.scm (r-topdom): New variable.

Change-Id: I63d265470499affc8f0de94f88739c6631281a0d
---
gnu/packages/cran.scm | 24 ++++++++++++++++++++++++
1 file changed, 24 insertions(+)

Toggle diff (41 lines)
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 16a864be93..b0ccee37bb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31108,6 +31108,30 @@ (define-public r-tolerance
Visualizations are also available for most of these settings.")
(license license:gpl2+)))
+(define-public r-topdom
+ (package
+ (name "r-topdom")
+ (version "0.10.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "TopDom" version))
+ (sha256
+ (base32 "1rryfnwvdlpdrjgs6sciy91cxfp4jykll0swclasydjvj4n642i6"))))
+ (properties `((upstream-name . "TopDom")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-ggplot2 r-matrixstats r-reshape2 r-tibble))
+ (home-page "https://github.com/HenrikBengtsson/TopDom")
+ (synopsis "Efficient method for Identifying genomic topological domains")
+ (description
+ "This method identifies topological domains in genomes from Hi-C sequence data.
+The authors published an implementation of their method as an R script. This package
+originates from those original @code{TopDom} R scripts and provides help pages adopted
+from the original @code{TopDom} PDF documentation. It also provides a small number of
+bug fixes to the original code.")
+ ;; Either version of the GPL
+ (license (list license:gpl2 license:gpl3))))
+
;; Keep this in sync with the liblantern package.
(define-public r-torch
(package

base-commit: 1615084a9a4115d48b75b3db048761e7534efc87
prerequisite-patch-id: 191a8394dbe6f865a9dc55bfc1b62e9dffc2180d
prerequisite-patch-id: 3ddb7b281335b1bb4ced1e60a1f243a12a5cba2b
--
2.34.1
R
R
Ricardo Wurmus wrote on 28 Jun 11:44 +0200
(address . 71341-done@debbugs.gnu.org)
87pls1wgf2.fsf@elephly.net
I've applied it with minor formatting and spelling changes. Thanks!

--
Ricardo
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71341@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71341
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch