[PATCH] gnu: Add emacs-enlight.

  • Done
  • quality assurance status badge
Details
2 participants
  • Andrew Tropin
  • Ilya Chernyshov
Owner
unassigned
Submitted by
Ilya Chernyshov
Severity
normal
I
I
Ilya Chernyshov wrote on 3 Jun 13:47 +0200
(address . guix-patches@gnu.org)
87a5k2qmcw.fsf@gmail.com
From a411c84f26718c81fd2a762ca310fb0bfd6f60f6 Mon Sep 17 00:00:00 2001
Message-ID: <a411c84f26718c81fd2a762ca310fb0bfd6f60f6.1717415177.git.ichernyshovvv@gmail.com>
From: Ilya Chernyshov <ichernyshovvv@gmail.com>
Date: Mon, 3 Jun 2024 10:53:18 +0000
Subject: [PATCH] gnu: Add emacs-enlight.

* gnu/packages/emacs-xyz.scm (emacs-enlight): New variable.

Change-Id: Ifb1d519d1bd89dec7414ee0fd5858a26e49dc1ca
---
gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
1 file changed, 21 insertions(+)

Toggle diff (43 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 349c495184..2209169864 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -138,6 +138,7 @@
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26619,6 +26620,26 @@ (define-public emacs-dashboard
sections for bookmarks, Projectile projects, Org Agenda and more.")
(license license:gpl3+)))
+(define-public emacs-enlight
+ (package
+ (name "emacs-enlight")
+ (version "0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ichernyshovvv/enlight")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0crccz28f54xc0202gdbnpkn7kfsxf66p2m2grs6wnwyjxrmpnsq"))))
+ (build-system emacs-build-system)
+ (propagated-inputs (list emacs-compat))
+ (home-page "https://github.com/ichernyshovvv/enlight")
+ (synopsis "Highly customizable startup screen for Emacs.")
+ (description "Lightweight yet very flexible startup screen for Emacs.")
+ (license license:gpl3+)))
+
(define-public emacs-slime-company
(package
(name "emacs-slime-company")

base-commit: 2e53fa5346bf52f6d6d26e035bc905ebd410dabb
--
2.41.0
A
A
Andrew Tropin wrote on 5 Jun 11:41 +0200
87ed9bhglr.fsf@trop.in
On 2024-06-03 18:47, Ilya Chernyshov wrote:

Toggle quote (55 lines)
> From a411c84f26718c81fd2a762ca310fb0bfd6f60f6 Mon Sep 17 00:00:00 2001
> Message-ID: <a411c84f26718c81fd2a762ca310fb0bfd6f60f6.1717415177.git.ichernyshovvv@gmail.com>
> From: Ilya Chernyshov <ichernyshovvv@gmail.com>
> Date: Mon, 3 Jun 2024 10:53:18 +0000
> Subject: [PATCH] gnu: Add emacs-enlight.
>
> * gnu/packages/emacs-xyz.scm (emacs-enlight): New variable.
>
> Change-Id: Ifb1d519d1bd89dec7414ee0fd5858a26e49dc1ca
> ---
> gnu/packages/emacs-xyz.scm | 21 +++++++++++++++++++++
> 1 file changed, 21 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 349c495184..2209169864 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -138,6 +138,7 @@
> ;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
> ;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
> ;;; Copyright © 2024 dan <i@dan.games>
> +;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
> ;;;
> ;;; This file is part of GNU Guix.
> ;;;
> @@ -26619,6 +26620,26 @@ (define-public emacs-dashboard
> sections for bookmarks, Projectile projects, Org Agenda and more.")
> (license license:gpl3+)))
>
> +(define-public emacs-enlight
> + (package
> + (name "emacs-enlight")
> + (version "0.3")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/ichernyshovvv/enlight")
> + (commit version)))
> + (file-name (git-file-name name version))
> + (sha256
> + (base32
> + "0crccz28f54xc0202gdbnpkn7kfsxf66p2m2grs6wnwyjxrmpnsq"))))
> + (build-system emacs-build-system)
> + (propagated-inputs (list emacs-compat))
> + (home-page "https://github.com/ichernyshovvv/enlight")
> + (synopsis "Highly customizable startup screen for Emacs.")
> + (description "Lightweight yet very flexible startup screen for Emacs.")
> + (license license:gpl3+)))
> +
> (define-public emacs-slime-company
> (package
> (name "emacs-slime-company")
>
> base-commit: 2e53fa5346bf52f6d6d26e035bc905ebd410dabb

Applied, removed trailing dot in synopsis, pushed as

Thank you!

--
Best regards,
Andrew Tropin
-----BEGIN PGP SIGNATURE-----

iQIzBAEBCgAdFiEEKEGaxlA4dEDH6S/6IgjSCVjB3rAFAmZgMrAACgkQIgjSCVjB
3rD7Mw//dE9C6/LLI1ybyGlC5pF+CziRS09iTFNYyPpP0XgYeI3sQKmbAKDV6Ecc
EkCLAoptOv2jUypgVep9bczcNUInImFPugNpUF5/6FkgBQsq0OJRss8F73fjbwku
Q9GbuYUm5n71xcD/DS+oqFtX3yJ3W07t4eXvsQRGjDjDTBj7M0GyYPZlJ6u5/W5H
GV1W+ldnD3jsoh4+IyXCWUmPcBE0hH3XYMXSs5g7rZEhwH2wo69J5MIbnsmO3YRo
0bnf4k6ceATLcuz11O6gH2YV3qAIIi02X7ixcYJA9t7+4ypgXfjYbc+M9t4lnWPU
l9gMaV5b9xHISAxyhG+3O/ZWks430GHH6+/OleoE4AlsVjvLGflLd7DcUnEHPnSM
lRljdAFWs4UZvrETvFPIIGcnK1/MF8bGD6vXAgyZbITdNooTJbTL9xF+mMz4iYbZ
EcIMvZWnk3hrJ1y7MDwSv300Vs3VCvjZwY5DbyN32Z2cDirGBakmk4+jYcMzxmEC
4Km0u6ibooQYiWW3hhKRk/Xx4hA2xkOcsPRLBRnBg35ffZQw+jYa5RgtRA3RfZH+
AYAxLhfibpFtCSTvGB/d47xjwZNyCv+AC4VSRprN8ruaw/tX0CcdCA0ciAXa+XMx
ymoecBgSDrYJvS68mOpSEUkAr5tq/eKMTUwgYj7IyOiIA2YjloQ=
=FyIV
-----END PGP SIGNATURE-----

Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71335@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71335
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch