[PATCH] gnu: add fzf-tab

  • Done
  • quality assurance status badge
Details
2 participants
  • Andreas Enge
  • Trevor Arjeski
Owner
unassigned
Submitted by
Trevor Arjeski
Severity
normal
T
T
Trevor Arjeski wrote on 2 Jun 22:20 +0200
(address . guix-patches@gnu.org)(name . Trevor Arjeski)(address . tmarjeski@gmail.com)
09955ca9942f69fc78ccc8e75921304e5779fb0b.1717359642.git.tmarjeski@gmail.com
fzf-tab is a zsh plugin that replaces the default autocompletion with fzf so
that you can use fuzzy finding and multi-selection.

Change-Id: I821eb28c9ac12e8d6449ce7bc389538d260d6091
---
gnu/packages/shellutils.scm | 27 +++++++++++++++++++++++++++
1 file changed, 27 insertions(+)

Toggle diff (39 lines)
diff --git a/gnu/packages/shellutils.scm b/gnu/packages/shellutils.scm
index be8d9bdc25..80ce5df719 100644
--- a/gnu/packages/shellutils.scm
+++ b/gnu/packages/shellutils.scm
@@ -912,3 +912,30 @@ (define-public liquidprompt
\"source \" liquidprompt \"/share/liquidprompt/themes/powerline/powerline.theme\"))))))
@end example\n")
(license license:agpl3+)))
+
+(define-public fzf-tab
+ (package
+ (name "fzf-tab")
+ (version "1.1.2")
+ (home-page "https://github.com/Aloxaf/fzf-tab")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Aloxaf/fzf-tab.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "061jjpgghn8d5q2m2cd2qdjwbz38qrcarldj16xvxbid4c137zs2"))))
+ (build-system copy-build-system)
+ (arguments
+ '(#:install-plan '(("lib" "/share/zsh/plugins/fzf-tab/")
+ ("modules" "/share/zsh/plugins/fzf-tab/")
+ ("fzf-tab.plugin.zsh" "/share/zsh/plugins/fzf-tab/")
+ ("fzf-tab.zsh" "/share/zsh/plugins/fzf-tab/")
+ ("README.md" "/share/doc/fzf-tab/"))))
+ (synopsis "Replace zsh's default completion menu with fzf.")
+ (description
+ "Replaces zsh's default completion menu with fzf, enabling fuzzy finding
+and multi-selection.")
+ (license license:expat)))

base-commit: fa7906d64881ee12e0c418136b44c73766e3d169
--
2.41.0
A
A
Andreas Enge wrote on 29 Jun 11:57 +0200
Close
(address . 71328-done@debbugs.gnu.org)
Zn_aoiTwxfFnFyak@jurong
Hello,

I have just pushed the commit with tiny changes to the commit message,
the synopsis and the description.

Thanks!

Andreas
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71328@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71328
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch