[PATCH 1/8] gnu: libbytesize: Update to 2.10.

  • Open
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 3 Jun 04:43 +0200
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
1b493965d8ba0a4dc3c06fa813314c4ffa551b3c.1717382583.git.maxim.cournoyer@gmail.com
* gnu/packages/c.scm (libbytesize): Update to 2.10.

Change-Id: Id0640e9c118fcf3ced3f6c6aa145a0f15e4f07d8
---
gnu/packages/c.scm | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

Toggle diff (26 lines)
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index d13b62b5e2..bb75dccf8e 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -404,7 +404,7 @@ (define-public python-pcpp
(define-public libbytesize
(package
(name "libbytesize")
- (version "2.6")
+ (version "2.10")
(source (origin
(method url-fetch)
(uri (string-append
@@ -412,7 +412,7 @@ (define-public libbytesize
"download/" version "/libbytesize-" version ".tar.gz"))
(sha256
(base32
- "0h87ryi0mp8msq43h1cna453cqaw5knx1xaggfzm4fxvn8sjpapg"))))
+ "1lfa02ac96p12xxq75ilx3qk7kym4xrlqyfh26axb7y5iazf670x"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f))

base-commit: dc4c48f10281007a0ab3541b8a64198c60c6d5b0
--
2.45.1
M
M
Maxim Cournoyer wrote on 3 Jun 14:02 +0200
[PATCH 3/8] gnu: libblockdev: Fix inputs.
(address . 71327@debbugs.gnu.org)
0c573ccaad8a4f674545b67a769760e290b90b2d.1717382584.git.maxim.cournoyer@gmail.com
From: Sarah Morgensen <iskarian@mgsn.dev>

Add missing inputs; make util-linux a regular input since libblockdev
retains references to it.

* gnu/packages/disk.scm (libblockdev):
[native-inputs]: Move util-linu...
[inputs]: ... here. Add bcache-tools, e2fsprogs, gptfdisk, multipath-tools,
and ntfs-3g.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I0eca44547a03e787e992e45ec4f71792e293868a
---
gnu/packages/disk.scm | 11 ++++++++---
1 file changed, 8 insertions(+), 3 deletions(-)

Toggle diff (38 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 10073864ed..2541828dd3 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1208,23 +1208,28 @@ (define-public libblockdev
(native-inputs
(list gobject-introspection
pkg-config
- python-wrapper
- util-linux))
+ python-wrapper))
(inputs
- (list btrfs-progs
+ (list bcache-tools
+ btrfs-progs
cryptsetup
dosfstools
dmraid
+ e2fsprogs
eudev
glib
+ gptfdisk
kmod
libbytesize
libyaml
lvm2
mdadm
+ multipath-tools
ndctl
nss
+ ntfs-3g
parted
+ util-linux
volume-key
xfsprogs))
(home-page "https://github.com/storaged-project/libblockdev")
--
2.45.1
M
M
Maxim Cournoyer wrote on 3 Jun 14:02 +0200
[PATCH 6/8] gnu: udisks: Remove input labels.
(address . 71327@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
f718ea416a61af5219f71b4ef608a7089c8109a7.1717382584.git.maxim.cournoyer@gmail.com
* gnu/packages/freedesktop.scm (udisks) [native-inputs]: Remove input labels.
[phases]: Remove trailing #t.

Change-Id: I805df6ac2e5ad96cf7a092d34354aefb12bd7586
---
gnu/packages/freedesktop.scm | 67 +++++++++++++++++-------------------
1 file changed, 31 insertions(+), 36 deletions(-)

Toggle diff (105 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 6941450436..bb0858cd9e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -27,7 +27,7 @@
;;; Copyright © 2021 Robby Zambito <contact@robbyzambito.me>
;;; Copyright © 2021, 2022, 2023 Maxime Devos <maximedevos@telenet.be>
;;; Copyright © 2021, 2022 John Kehayias <john.kehayias@protonmail.com>
-;;; Copyright © 2021, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Daniel Meißner <daniel.meissner-i4k@ruhr-uni-bochum.de>
;;; Copyright © 2022 Wamm K. D. <jaft.r@outlook.com>
;;; Copyright © 2022 Petr Hodina <phodina@protonmail.com>
@@ -1732,34 +1732,31 @@ (define-public udisks
"06cq52kp1nyy15qzylywy9s7hhhqc45k0s3y68crf0zsmjyng0yj"))))
(build-system gnu-build-system)
(native-inputs
- `(("docbook-xml" ,docbook-xml-4.3) ; to build the manpages
- ("docbook-xsl" ,docbook-xsl)
- ("glib:bin" ,glib "bin") ; for glib-mkenums
- ("gnome-common" ,gnome-common) ; TODO: Why is this needed?
- ("gobject-introspection" ,gobject-introspection)
- ("gtk-doc" ,gtk-doc/stable)
- ("intltool" ,intltool)
- ("pkg-config" ,pkg-config)
- ("xsltproc" ,libxslt)))
+ (list docbook-xml-4.3 ; to build the manpages
+ docbook-xsl
+ `(,glib "bin") ; for glib-mkenums
+ gnome-common ; TODO: Why is this needed?
+ gobject-introspection
+ gtk-doc/stable
+ intltool
+ pkg-config
+ libxslt))
(propagated-inputs
- (list glib)) ; required by udisks2.pc
+ (list glib)) ; required by udisks2.pc
(inputs
- `(,acl
- ;; TODO(staging): Make unconditional.
- ,@(if (%current-target-system)
- (list bash-minimal) ; for wrap-program
- '())
- ,cryptsetup
- ,libatasmart
- ,libblockdev
- ,libgudev
- ,polkit
- ,util-linux))
+ (list acl
+ bash-minimal
+ cryptsetup
+ libatasmart
+ libblockdev
+ libgudev
+ polkit
+ util-linux))
(outputs '("out"
- "doc")) ;5 MiB of gtk-doc HTML
+ "doc")) ;5 MiB of gtk-doc HTML
(arguments
- `(#:tests? #f ; requiring system message dbus
- #:disallowed-references ("doc") ;enforce separation of "doc"
+ `(#:tests? #f ; requiring system message dbus
+ #:disallowed-references ("doc") ;enforce separation of "doc"
#:configure-flags
(list "--enable-man"
"--enable-available-modules" ; Such as lvm2, btrfs, etc.
@@ -1786,15 +1783,14 @@ (define-public udisks
docbook-xml-catalog-file)))
#:phases
(modify-phases %standard-phases
- (add-before
- 'configure 'fix-girdir
- (lambda _
- ;; Install introspection data to its own output.
- (substitute* "udisks/Makefile.in"
- (("girdir = .*")
- "girdir = $(datadir)/gir-1.0\n")
- (("typelibsdir = .*")
- "typelibsdir = $(libdir)/girepository-1.0\n"))))
+ (add-before 'configure 'fix-girdir
+ (lambda _
+ ;; Install introspection data to its own output.
+ (substitute* "udisks/Makefile.in"
+ (("girdir = .*")
+ "girdir = $(datadir)/gir-1.0\n")
+ (("typelibsdir = .*")
+ "typelibsdir = $(libdir)/girepository-1.0\n"))))
(add-after 'install 'wrap-udisksd
(lambda* (#:key outputs inputs #:allow-other-keys)
;; Tell 'udisksd' where to find the 'mount' command.
@@ -1809,8 +1805,7 @@ (define-public udisks
;; partitions, e.g. in gnome-disks
,(string-append cryptsetup "/sbin")
"/run/current-system/profile/bin"
- "/run/current-system/profile/sbin")))
- #t))))))
+ "/run/current-system/profile/sbin")))))))))
(home-page "https://www.freedesktop.org/wiki/Software/udisks/")
(synopsis "Disk manager service")
(description
--
2.45.1
M
M
Maxim Cournoyer wrote on 3 Jun 14:02 +0200
[PATCH 7/8] gnu: udisks: Update to 2.10.1.
(address . 71327@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
24b1b395816a71df1a173a6dd6a32b0c1ad1da0b.1717382584.git.maxim.cournoyer@gmail.com
* gnu/packages/freedesktop.scm (udisks): Update to 2.10.1.
[native-inputs]: Replace intltool with gettext-minimal. Remove gnome-common.

Change-Id: I4fbc4f6949eb14763dad58dbccd9974793ea02f6
---
gnu/packages/freedesktop.scm | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)

Toggle diff (34 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index bb0858cd9e..063816282b 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1721,7 +1721,7 @@ (define-public libatasmart
(define-public udisks
(package
(name "udisks")
- (version "2.8.4")
+ (version "2.10.1")
(source (origin
(method url-fetch)
(uri (string-append
@@ -1729,16 +1729,15 @@ (define-public udisks
version "/udisks-" version ".tar.bz2"))
(sha256
(base32
- "06cq52kp1nyy15qzylywy9s7hhhqc45k0s3y68crf0zsmjyng0yj"))))
+ "1klf5pcr9yg8g88mwwh3q2j0idfwd8hfr2q6nknhsm02yv638mxp"))))
(build-system gnu-build-system)
(native-inputs
(list docbook-xml-4.3 ; to build the manpages
docbook-xsl
+ gettext-minimal
`(,glib "bin") ; for glib-mkenums
- gnome-common ; TODO: Why is this needed?
gobject-introspection
gtk-doc/stable
- intltool
pkg-config
libxslt))
(propagated-inputs
--
2.45.1
M
M
Maxim Cournoyer wrote on 3 Jun 14:02 +0200
[PATCH 8/8] gnu: udisks: Remove obsolete wrap-udisksd phase.
(address . 71327@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
1e1fb7edb9a0338ef9247bdd143b452814a1b736.1717382584.git.maxim.cournoyer@gmail.com
The tools are now patched in the libblockdev plugin sources directly.

* gnu/packages/freedesktop.scm (udisks) [phases]: Delete the wrap-udisksd
phase.

Change-Id: I0de4016adb0cb8af2dca4ef9ebec82e5951b689c
---
gnu/packages/freedesktop.scm | 17 +----------------
1 file changed, 1 insertion(+), 16 deletions(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 063816282b..39ca00296e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -1789,22 +1789,7 @@ (define-public udisks
(("girdir = .*")
"girdir = $(datadir)/gir-1.0\n")
(("typelibsdir = .*")
- "typelibsdir = $(libdir)/girepository-1.0\n"))))
- (add-after 'install 'wrap-udisksd
- (lambda* (#:key outputs inputs #:allow-other-keys)
- ;; Tell 'udisksd' where to find the 'mount' command.
- (let ((out (assoc-ref outputs "out"))
- (utils (assoc-ref inputs "util-linux"))
- (cryptsetup (assoc-ref inputs "cryptsetup"))
- (parted (assoc-ref inputs "parted")))
- (wrap-program (string-append out "/libexec/udisks2/udisksd")
- `("PATH" ":" prefix
- (,(string-append utils "/bin") ;for 'mount'
- ;; cryptsetup is required for setting encrypted
- ;; partitions, e.g. in gnome-disks
- ,(string-append cryptsetup "/sbin")
- "/run/current-system/profile/bin"
- "/run/current-system/profile/sbin")))))))))
+ "typelibsdir = $(libdir)/girepository-1.0\n")))))))
(home-page "https://www.freedesktop.org/wiki/Software/udisks/")
(synopsis "Disk manager service")
(description
--
2.45.1
M
M
Maxim Cournoyer wrote on 3 Jun 14:02 +0200
[PATCH 2/8] gnu: libblockdev: Embed executable paths.
(address . 71327@debbugs.gnu.org)
0c4bd8c7db24d0734320d4fdb2a2ce1f86a801d2.1717382583.git.maxim.cournoyer@gmail.com
From: Sarah Morgensen <iskarian@mgsn.dev>

* gnu/packages/disk.scm (libblockdev)[arguments]<#:phases>: Add
'patch-plugin-paths' phase.

Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I96f9e2f03650b22ffef5a7fe091159450e4c5b67
---
gnu/packages/disk.scm | 10 +++++++++-
1 file changed, 9 insertions(+), 1 deletion(-)

Toggle diff (37 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 10d546b918..10073864ed 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -22,6 +22,7 @@
;;; Copyright © 2021 Mathieu Othacehe <othacehe@gnu.org>
;;; Copyright © 2021 Brice Waegeneire <brice@waegenei.re>
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
+;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2014, 2022 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
@@ -29,6 +30,7 @@
;;; Copyright © 2023 Morgan Smith <Morgan.J.Smith@outlook.com>
;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
;;; Copyright © 2024 Sharlatan Hellseher <sharlatanus@gmail.com>
+
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1196,7 +1198,13 @@ (define-public libblockdev
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))
(substitute* "src/lib/blockdev.c"
- (("/etc/libblockdev/conf.d/" path) (string-append out path)))))))))
+ (("/etc/libblockdev/conf.d/" path) (string-append out path))))))
+ (add-after 'unpack 'patch-plugin-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "src/plugins" "\\.c$")
+ (("(gchar \\*arg.+\\{\")([^\"]+)" all start program)
+ ;; XXX: Use 'search-input-file' when available.
+ (string-append start (or (which program) program)))))))))
(native-inputs
(list gobject-introspection
pkg-config
--
2.45.1
M
M
Maxim Cournoyer wrote on 3 Jun 14:02 +0200
[PATCH 5/8] gnu: libblockdev: Use gexps.
(address . 71327@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
0980caab2c95ff572b945bba1a223d2d9a59d210.1717382584.git.maxim.cournoyer@gmail.com
* gnu/packages/disk.scm (libblockdev)
[phases]: Use gexps.
{patch-plugin-paths}: Use search-input-file.

Change-Id: I61f9b3dfdd4dc249fb0f59abb99826a8e759bb42
---
gnu/packages/disk.scm | 31 +++++++++++++++++++------------
1 file changed, 19 insertions(+), 12 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 7fbd6a52d7..1cdeb53597 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1192,19 +1192,26 @@ (define-public libblockdev
"1ny2glwmb5dcdv2x0giinbyma9fhk59z8117k1kr15pm7yjk7jx5"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-configuration-directory
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch-configuration-directory
+ (lambda _
(substitute* "src/lib/blockdev.c"
- (("/etc/libblockdev/conf.d/" path) (string-append out path))))))
- (add-after 'unpack 'patch-plugin-paths
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* (find-files "src/plugins" "\\.c$")
- (("(gchar \\*arg.+\\{\")([^\"]+)" all start program)
- ;; XXX: Use 'search-input-file' when available.
- (string-append start (or (which program) program)))))))))
+ (("/etc/libblockdev/conf.d/" path)
+ (string-append #$output path)))))
+ (add-after 'unpack 'patch-plugin-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* (find-files "src/plugins" "\\.c$")
+ (("(gchar \\*arg.+\\{\")([^\"]+)" all start program)
+ (string-append
+ start (or (false-if-exception
+ (search-input-file inputs
+ (string-append "bin/" program)))
+ (false-if-exception
+ (search-input-file inputs
+ (string-append "sbin/" program)))
+ program)))))))))
(native-inputs
(list gobject-introspection
pkg-config
--
2.45.1
M
M
Maxim Cournoyer wrote on 3 Jun 14:02 +0200
[PATCH 4/8] gnu: libblockdev: Update to 3.1.1.
(address . 71327@debbugs.gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
f996ae3853901326aae02cf31faf0d16f2f73769.1717382584.git.maxim.cournoyer@gmail.com
* gnu/packages/disk.scm (libblockdev): Update to 3.1.1.
[inputs]: Add keyutils and libnvme.

Change-Id: I6b229426531d584669a50b02c0c5acef9021a2fa
---
gnu/packages/disk.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 2541828dd3..7fbd6a52d7 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -24,7 +24,7 @@
;;; Copyright © 2021 Justin Veilleux <terramorpha@cock.li>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2014, 2022 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2022, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Disseminate Dissent <disseminatedissent@protonmail.com>
;;; Copyright © 2023 Timotej Lazar <timotej.lazar@araneo.si>
;;; Copyright © 2023 Morgan Smith <Morgan.J.Smith@outlook.com>
@@ -1181,7 +1181,7 @@ (define-public dmraid
(define-public libblockdev
(package
(name "libblockdev")
- (version "2.28")
+ (version "3.1.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/storaged-project/"
@@ -1189,7 +1189,7 @@ (define-public libblockdev
version "-1/libblockdev-" version ".tar.gz"))
(sha256
(base32
- "1x3xbgd2dyjhcqvyalpnrp727xidfxmaxgyyvv5gwx4aw90wijc2"))))
+ "1ny2glwmb5dcdv2x0giinbyma9fhk59z8117k1kr15pm7yjk7jx5"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -1219,8 +1219,10 @@ (define-public libblockdev
eudev
glib
gptfdisk
+ keyutils
kmod
libbytesize
+ libnvme
libyaml
lvm2
mdadm
--
2.45.1
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71327@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71327
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch