ld-wrapper does not handle all possibilities to specify libraries and their search paths

  • Open
  • quality assurance status badge
Details
One participant
  • Stefan
Owner
unassigned
Submitted by
Stefan
Severity
normal
S
S
Stefan wrote on 2 Jun 15:29 +0200
(address . bug-guix@gnu.org)
a7fdaad7-56ea-c53c-8c56-107ac1b3a16d@vodafonemail.de
Hi!

Beside using an absolute path, the ld of Binutils has eight ways¹ to pass a library like libfoo.so via options:

-lfoo
-l foo
-library=foo
--library=foo
-l:libfoo.so
-l :libfoo.so
-library=:libfoo.so
--library=:libfoo.so

The ld-wrapper however only supports one of these possibilities, which is the most common: -lfoo. GCC itself does not support the -[-]library= variants.


Similarly there are four ways to specify a library search path /bar for ld:

-L/bar
-L /bar
-library-path=/bar
--library-path=/bar

The ld-wrapper only supports the first two. GCC itself does not support the -[-]library-path= variant.


The lld form the LLVM project supports all these different options as well.


Bye

Stefan


?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71326@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71326
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch