[PATCH 0/2] gnu: emacs-ddskk: Update to 17.1 revision 0.

  • Done
  • quality assurance status badge
Details
3 participants
  • gemmaro
  • Liliana Marie Prikler
  • Nicolas Goaziou
Owner
unassigned
Submitted by
gemmaro
Severity
normal
G
G
gemmaro wrote on 2 Jun 09:56 +0200
(address . guix-patches@gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
cover.1717314904.git.gemmaro.dev@gmail.com
Hello,

This updates emacs-ddskk to the latest commit.
It also applies the newer package style.

Best,
gemmaro.

gemmaro (2):
gnu: emacs-ddskk: Update to 17.1 revision 0.
gnu: emacs-ddskk: Improve package style.

gnu/packages/emacs-xyz.scm | 59 ++++++++++++++++++++------------------
1 file changed, 31 insertions(+), 28 deletions(-)


base-commit: fa7906d64881ee12e0c418136b44c73766e3d169
--
2.41.0
G
G
gemmaro wrote on 2 Jun 11:08 +0200
[PATCH 1/2] gnu: emacs-ddskk: Update to 17.1 revision 0.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
3e991841bf01280a06d083d3f51db71199599ac7.1717314904.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk): Update to version 17.1 revision
0 (commit 8c47f46).

Change-Id: Iefd35340dfaad9daf2dbba3bcb1524716e90bd21
---
gnu/packages/emacs-xyz.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (45 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 75ea4d3a19..b4ce751b86 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -138,6 +138,7 @@
;;; Copyright © 2023 Ian Eure <ian@retrospec.tv>
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36784,22 +36785,24 @@ (define-public emacs-org-static-blog
(license license:bsd-3)))
(define-public emacs-ddskk
- ;; XXX: Upstream adds code names to their release tags, so version and code
- ;; name below need to be updated together.
+ ;; XXX: Upstream adds code names to their release tags, so version
+ ;; and code name need to be declared and updated together when the
+ ;; next version is released (e.g. "Neppu" in 17.1.)
(let ((version "17.1")
- (code-name "Neppu"))
+ (commit "8c47f46e38a29a0f3eabcd524268d20573102467")
+ (revision "0"))
(package
(name "emacs-ddskk")
- (version version)
+ (version (git-version version revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/skk-dev/ddskk")
- (commit (string-append "ddskk-" version "_" code-name))))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0xm53rybxki2784gyjkafg6956viyhhcq51kbmnrwc6aw3yzh7aw"))))
+ (base32 "0vfdbab3ncns8wwrna8h6y2w0grkphzr9s65sgxq98lpqmxbbr72"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
--
2.41.0
G
G
gemmaro wrote on 2 Jun 11:08 +0200
[PATCH 2/2] gnu: emacs-ddskk: Improve package style.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
f40ed4cbd943a61c5c5404bdbf4ccd4c750d48b6.1717314904.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk)[arguments]: Use newer package style.

Change-Id: Ie6ed743ded35b55fa55bb61d02353456a0f2c79f
---
gnu/packages/emacs-xyz.scm | 44 +++++++++++++++++++-------------------
1 file changed, 22 insertions(+), 22 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b4ce751b86..66a685c82d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36805,28 +36805,28 @@ (define-public emacs-ddskk
(base32 "0vfdbab3ncns8wwrna8h6y2w0grkphzr9s65sgxq98lpqmxbbr72"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (guix build emacs-utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build emacs-utils))
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (make-file-writable "SKK-MK")
- (emacs-substitute-variables "SKK-MK"
- ("PREFIX" (assoc-ref outputs "out"))
- ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
- ("SKK_PREFIX" "")
- ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
- (for-each make-file-writable (find-files "./doc"))
- #t))
- (add-after 'unpack 'fix-test
- (lambda _
- (substitute* "Makefile"
- (("/bin/rm") (which "rm"))))))))
+ (list #:modules '((guix build gnu-build-system)
+ (guix build utils)
+ (guix build emacs-utils))
+ #:imported-modules `(,@%gnu-build-system-modules
+ (guix build emacs-utils))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (make-file-writable "SKK-MK")
+ (emacs-substitute-variables "SKK-MK"
+ ("PREFIX" (assoc-ref outputs "out"))
+ ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
+ ("SKK_PREFIX" "")
+ ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
+ (for-each make-file-writable (find-files "./doc"))
+ #t))
+ (add-after 'unpack 'fix-test
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/rm") (which "rm"))))))))
(native-inputs
(list emacs-minimal ruby))
(home-page "https://github.com/skk-dev/ddskk")
--
2.41.0
G
G
gemmaro wrote on 11 Jun 13:20 +0200
[PATCH v2 3/3] gnu: emacs-ddskk-nicola: Improve package style.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
80aa9ac79b1b8577ce04dec98909fb9e2d0bf9fc.1718104831.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk-nicola)[arguments]: Use newer
package style. This is necessary due to the emacs-ddskk package style update
since emacs-ddskk-nicola inherits this. It also removes the last #t values
from the lambda expressions in phases.

Change-Id: Ief8761bca476eba5e675d995b22d0a070f90de2f
---
gnu/packages/emacs-xyz.scm | 38 +++++++++++++++++++-------------------
1 file changed, 19 insertions(+), 19 deletions(-)

Toggle diff (51 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index e6f5eb356c..4690fffc56 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36894,25 +36894,25 @@ (define-public emacs-ddskk-nicola
(propagated-inputs
(list emacs-ddskk))
(arguments
- `(#:make-flags
- (let ((out (assoc-ref %outputs "out")))
- (append
- (list (string-append "PREFIX=" out)
- (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))
- #:tests? #f ; no tests in this subtree
- ,@(substitute-keyword-arguments (package-arguments emacs-ddskk)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "nicola")
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (make-file-writable "NICOLA-DDSKK-CFG")
- (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
- ("setq NICOLA-DDSKK_PREFIX" ""))
- #t)))))))
+ (append
+ (list #:make-flags
+ #~(let ((out (assoc-ref %outputs "out")))
+ (append
+ (list (string-append "PREFIX=" out)
+ (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))
+ #:tests? #f ;no tests in this subtree
+ )
+ (substitute-keyword-arguments (package-arguments emacs-ddskk)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "nicola")))
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (make-file-writable "NICOLA-DDSKK-CFG")
+ (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
+ ("setq NICOLA-DDSKK_PREFIX" "")))))))))
(synopsis "Nicola layout for Daredevil SKK")
(description
"Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
--
2.45.1
G
G
gemmaro wrote on 11 Jun 13:20 +0200
[PATCH v2 2/3] gnu: emacs-ddskk: Improve package style.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
73fdffde326d9fdb418056b636e08be7b5be8644.1718104831.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk)[arguments]: Use newer package style.

Change-Id: Ie6ed743ded35b55fa55bb61d02353456a0f2c79f
---
gnu/packages/emacs-xyz.scm | 44 +++++++++++++++++++-------------------
1 file changed, 22 insertions(+), 22 deletions(-)

Toggle diff (57 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 14be801e9e..e6f5eb356c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -36856,28 +36856,28 @@ (define-public emacs-ddskk
(base32 "0vfdbab3ncns8wwrna8h6y2w0grkphzr9s65sgxq98lpqmxbbr72"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (guix build emacs-utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build emacs-utils))
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (make-file-writable "SKK-MK")
- (emacs-substitute-variables "SKK-MK"
- ("PREFIX" (assoc-ref outputs "out"))
- ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
- ("SKK_PREFIX" "")
- ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
- (for-each make-file-writable (find-files "./doc"))
- #t))
- (add-after 'unpack 'fix-test
- (lambda _
- (substitute* "Makefile"
- (("/bin/rm") (which "rm"))))))))
+ (list #:modules '((guix build gnu-build-system)
+ (guix build utils)
+ (guix build emacs-utils))
+ #:imported-modules `(,@%gnu-build-system-modules
+ (guix build emacs-utils))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda* (#:key outputs #:allow-other-keys)
+ (make-file-writable "SKK-MK")
+ (emacs-substitute-variables "SKK-MK"
+ ("PREFIX" (assoc-ref outputs "out"))
+ ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
+ ("SKK_PREFIX" "")
+ ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
+ (for-each make-file-writable (find-files "./doc"))
+ #t))
+ (add-after 'unpack 'fix-test
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/rm") (which "rm"))))))))
(native-inputs
(list emacs-minimal ruby))
(home-page "https://github.com/skk-dev/ddskk")
--
2.45.1
G
G
gemmaro wrote on 11 Jun 13:20 +0200
[PATCH v2 1/3] gnu: emacs-ddskk: Update to 17.1 revision 0.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
4328ea3c1b2e79691a6ed1d76e21688a5452f410.1718104831.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk): Update to 17.1 revision 0 (commit 8c47f46).

Change-Id: Iefd35340dfaad9daf2dbba3bcb1524716e90bd21
---
gnu/packages/emacs-xyz.scm | 15 +++++++++------
1 file changed, 9 insertions(+), 6 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2a943f5846..14be801e9e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -139,6 +139,7 @@
;;; Copyright © 2024 Suhail Singh <suhail@bayesians.ca>
;;; Copyright © 2024 dan <i@dan.games>
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -36835,22 +36836,24 @@ (define-public emacs-org-static-blog
(license license:bsd-3)))
(define-public emacs-ddskk
- ;; XXX: Upstream adds code names to their release tags, so version and code
- ;; name below need to be updated together.
+ ;; XXX: Upstream adds code names to their release tags, so version
+ ;; and code name need to be declared and updated together when the
+ ;; next version is released (e.g. "Neppu" in 17.1.)
(let ((version "17.1")
- (code-name "Neppu"))
+ (commit "8c47f46e38a29a0f3eabcd524268d20573102467")
+ (revision "0"))
(package
(name "emacs-ddskk")
- (version version)
+ (version (git-version version revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/skk-dev/ddskk")
- (commit (string-append "ddskk-" version "_" code-name))))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0xm53rybxki2784gyjkafg6956viyhhcq51kbmnrwc6aw3yzh7aw"))))
+ (base32 "0vfdbab3ncns8wwrna8h6y2w0grkphzr9s65sgxq98lpqmxbbr72"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)

base-commit: aed2e17768bc2a2bbac95066637bbf00a60765b2
--
2.45.1
N
N
Nicolas Goaziou wrote on 19 Jun 13:12 +0200
(name . gemmaro)(address . gemmaro.dev@gmail.com)
87zfrh425a.fsf@nicolasgoaziou.fr
Hello,

gemmaro <gemmaro.dev@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ddskk): Update to 17.1 revision
> 0 (commit 8c47f46).

Thank you. Some comments follow.

Toggle quote (7 lines)
> (define-public emacs-ddskk
> - ;; XXX: Upstream adds code names to their release tags, so version and code
> - ;; name below need to be updated together.
> + ;; XXX: Upstream adds code names to their release tags, so version
> + ;; and code name need to be declared and updated together when the
> + ;; next version is released (e.g. "Neppu" in 17.1.)

Since you're moving the package away from code names, you should also
remove references to them in the comment above. I.e., we just use
cherry-picked commits instead of tags.

Toggle quote (9 lines)
> (let ((version "17.1")
> - (code-name "Neppu"))
> + (commit "8c47f46e38a29a0f3eabcd524268d20573102467")
> + (revision "0"))
> (package
> (name "emacs-ddskk")
> - (version version)
> + (version (git-version version revision commit))

You can replace version above with "17.1" and remove the binding above,
as it is usually done.

Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 19 Jun 13:14 +0200
Re: [bug#71319] [PATCH v2 3/3] gnu: emacs-ddskk-nicola: Improve package style.
(name . gemmaro)(address . gemmaro.dev@gmail.com)
87v825421u.fsf@nicolasgoaziou.fr
Hello,

gemmaro <gemmaro.dev@gmail.com> writes:

Toggle quote (5 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ddskk-nicola)[arguments]: Use newer
> package style. This is necessary due to the emacs-ddskk package style update
> since emacs-ddskk-nicola inherits this. It also removes the last #t values
> from the lambda expressions in phases.

Thank you. Some comments follow.

Toggle quote (4 lines)
> + (append
> + (list #:make-flags
> + #~(let ((out (assoc-ref %outputs "out")))

You can remove this and use #$output instead.

Toggle quote (4 lines)
> + (append
> + (list (string-append "PREFIX=" out)
> + (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))

See above.

Toggle quote (3 lines)
> + #:tests? #f ;no tests in this subtree
> + )

Please do not leave dangling parenthesis like this one.

Toggle quote (12 lines)
> + (substitute-keyword-arguments (package-arguments emacs-ddskk)
> + ((#:phases phases)
> + #~(modify-phases #$phases
> + (add-after 'unpack 'chdir
> + (lambda _
> + (chdir "nicola")))
> + (replace 'configure
> + (lambda* (#:key outputs #:allow-other-keys)
> + (make-file-writable "NICOLA-DDSKK-CFG")
> + (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
> + ("setq NICOLA-DDSKK_PREFIX" "")))))))))

You can use (lambda _ ...) instead of (lambda* (#:key outputs ...) ...)
since you don't make use of OUTPUTS argument.

Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 19 Jun 13:16 +0200
Re: [bug#71319] [PATCH v2 2/3] gnu: emacs-ddskk: Improve package style.
(name . gemmaro)(address . gemmaro.dev@gmail.com)
87r0ct41yk.fsf@nicolasgoaziou.fr
Hello,

gemmaro <gemmaro.dev@gmail.com> writes:

Toggle quote (3 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ddskk)[arguments]: Use newer
> package style.

Thanks. Some comments follow.

Toggle quote (11 lines)
> + (list #:modules '((guix build gnu-build-system)
> + (guix build utils)
> + (guix build emacs-utils))
> + #:imported-modules `(,@%gnu-build-system-modules
> + (guix build emacs-utils))
> + #:test-target "test"
> + #:phases
> + #~(modify-phases %standard-phases
> + (replace 'configure
> + (lambda* (#:key outputs #:allow-other-keys)

Use (lambda _ ...) here.

Toggle quote (2 lines)
> + (make-file-writable "SKK-MK")

I don't think this line is necessary. Could you double-check?

Toggle quote (3 lines)
> + (emacs-substitute-variables "SKK-MK"
> + ("PREFIX" (assoc-ref outputs "out"))

(assoc-ref outputs "out") -> #$output

Toggle quote (6 lines)
> + ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
> + ("SKK_PREFIX" "")
> + ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
> + (for-each make-file-writable (find-files "./doc"))
> + #t))

Could you remove this trailing #T, too?

Regards,
--
Nicolas Goaziou
G
G
gemmaro wrote on 20 Jun 01:32 +0200
[PATCH v3 1/3] gnu: emacs-ddskk: Update to 17.1 revision 0.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
378f901df9ae830b822653251f5e9db18cc18e0e.1718839586.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk): Update to 17.1 revision 0 (commit
8c47f46).

Change-Id: I7a312f1dbbeb93666121646dd79becdd08f16b79
---
gnu/packages/emacs-xyz.scm | 13 ++++++-------
1 file changed, 6 insertions(+), 7 deletions(-)

Toggle diff (44 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d000e7fd02..2eee8cfcb5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -141,6 +141,7 @@
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37016,22 +37017,20 @@ (define-public emacs-org-static-blog
(license license:bsd-3)))
(define-public emacs-ddskk
- ;; XXX: Upstream adds code names to their release tags, so version and code
- ;; name below need to be updated together.
- (let ((version "17.1")
- (code-name "Neppu"))
+ (let ((commit "8c47f46e38a29a0f3eabcd524268d20573102467")
+ (revision "0"))
(package
(name "emacs-ddskk")
- (version version)
+ (version (git-version "17.1" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/skk-dev/ddskk")
- (commit (string-append "ddskk-" version "_" code-name))))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0xm53rybxki2784gyjkafg6956viyhhcq51kbmnrwc6aw3yzh7aw"))))
+ (base32 "0vfdbab3ncns8wwrna8h6y2w0grkphzr9s65sgxq98lpqmxbbr72"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)

base-commit: e1a66d2ddd9b5ab382569f3a1130508797844d3b
--
2.45.1
G
G
gemmaro wrote on 20 Jun 01:32 +0200
[PATCH v3 2/3] gnu: emacs-ddskk: Improve package style.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
bb21d583c959bfc1d19a1592c699d72c3a066b42.1718839586.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk)[arguments]: Use newer package
style. Make use of gexps and #$output and removed trailing #t. Also, SKK-MK
and doc files are not made writable, and the rm in nicola/Makefile is fixed.

Change-Id: Ie6ed743ded35b55fa55bb61d02353456a0f2c79f
---
gnu/packages/emacs-xyz.scm | 43 +++++++++++++++++++-------------------
1 file changed, 21 insertions(+), 22 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2eee8cfcb5..855d75e390 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37033,28 +37033,27 @@ (define-public emacs-ddskk
(base32 "0vfdbab3ncns8wwrna8h6y2w0grkphzr9s65sgxq98lpqmxbbr72"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (guix build emacs-utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build emacs-utils))
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (make-file-writable "SKK-MK")
- (emacs-substitute-variables "SKK-MK"
- ("PREFIX" (assoc-ref outputs "out"))
- ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
- ("SKK_PREFIX" "")
- ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
- (for-each make-file-writable (find-files "./doc"))
- #t))
- (add-after 'unpack 'fix-test
- (lambda _
- (substitute* "Makefile"
- (("/bin/rm") (which "rm"))))))))
+ (list #:modules '((guix build gnu-build-system)
+ (guix build utils)
+ (guix build emacs-utils))
+ #:imported-modules `(,@%gnu-build-system-modules
+ (guix build emacs-utils))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (emacs-substitute-variables "SKK-MK"
+ ("PREFIX" #$output)
+ ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
+ ("SKK_PREFIX" "")
+ ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))))
+ (add-after 'unpack 'fix-test
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/rm") (which "rm")))
+ (substitute* "nicola/Makefile"
+ (("/bin/rm") (which "rm"))))))))
(native-inputs
(list emacs-minimal ruby))
(home-page "https://github.com/skk-dev/ddskk")
--
2.45.1
G
G
gemmaro wrote on 20 Jun 01:32 +0200
[PATCH v3 3/3] gnu: emacs-ddskk-nicola: Improve package style.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
3b7722e4eba090d4b45b739175c5094aa1907f03.1718839586.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk-nicola)[arguments]: Use newer
package style. This is necessary due to the emacs-ddskk package style update
since emacs-ddskk-nicola inherits this. It also remove making
NICOLA-DDSKK-CFG writable, and removes the last #t values from the lambda
expressions in phases.

Change-Id: Ief8761bca476eba5e675d995b22d0a070f90de2f
---
gnu/packages/emacs-xyz.scm | 36 +++++++++++++++++-------------------
1 file changed, 17 insertions(+), 19 deletions(-)

Toggle diff (49 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 855d75e390..fbdd58ab9e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37070,25 +37070,23 @@ (define-public emacs-ddskk-nicola
(propagated-inputs
(list emacs-ddskk))
(arguments
- `(#:make-flags
- (let ((out (assoc-ref %outputs "out")))
- (append
- (list (string-append "PREFIX=" out)
- (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))
- #:tests? #f ; no tests in this subtree
- ,@(substitute-keyword-arguments (package-arguments emacs-ddskk)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'unpack 'chdir
- (lambda _
- (chdir "nicola")
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (make-file-writable "NICOLA-DDSKK-CFG")
- (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
- ("setq NICOLA-DDSKK_PREFIX" ""))
- #t)))))))
+ (append
+ (list #:make-flags
+ #~(append
+ (list (string-append "PREFIX=" #$output)
+ (string-append "LISPDIR=" #$output "/share/emacs/site-lisp")))
+ ;; no tests in this subtree
+ #:tests? #f)
+ (substitute-keyword-arguments (package-arguments emacs-ddskk)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'fix-test 'chdir
+ (lambda _
+ (chdir "nicola")))
+ (replace 'configure
+ (lambda _
+ (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
+ ("setq NICOLA-DDSKK_PREFIX" "")))))))))
(synopsis "Nicola layout for Daredevil SKK")
(description
"Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
--
2.45.1
L
L
Liliana Marie Prikler wrote on 20 Jun 18:04 +0200
Re: [bug#71319] [PATCH v3 2/3] gnu: emacs-ddskk: Improve package style.
eee4a5e576d0641857f452210c914eb9da2f4f4e.camel@gmail.com
Am Donnerstag, dem 20.06.2024 um 08:32 +0900 schrieb gemmaro:
Toggle quote (6 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ddskk)[arguments]: Use newer
> package
> style.  Make use of gexps and #$output and removed trailing #t. 
> Also, SKK-MK
> and doc files are not made writable, and the rm in nicola/Makefile is
> fixed.
This ChangeLog really could use some love. "Use newer package style"
should probably go to the commit message (instead of "Improve package
style").

Also, don't sneak in actual code changes with formatting ones. These
might need to go with the previous commit instead.

I'd suggest something like

… [arguments]: Convert to list of G-Expressions.
Use #$output rather than the outputs alist.
Removed trailing #t.

Cheers
L
L
Liliana Marie Prikler wrote on 20 Jun 18:06 +0200
Re: [bug#71319] [PATCH v3 3/3] gnu: emacs-ddskk-nicola: Improve package style.
f06da2a619dee0d6501f57722233be8347db4358.camel@gmail.com
Am Donnerstag, dem 20.06.2024 um 08:32 +0900 schrieb gemmaro:
Toggle quote (8 lines)
> * gnu/packages/emacs-xyz.scm (emacs-ddskk-nicola)[arguments]: Use
> newer
> package style.  This is necessary due to the emacs-ddskk package
> style update
> since emacs-ddskk-nicola inherits this.  It also remove making
> NICOLA-DDSKK-CFG writable, and removes the last #t values from the
> lambda
> expressions in phases.
Again, don't sneak in code changes with formatting ones; and the
ChangeLog formatting hints to the previous patch mostly apply here as
well.

The "this is necessary, because…" part should probably go before the
ChangeLog, with the explanation that it is a follow-up to the previous
commit.

Cheers
G
G
gemmaro wrote on 22 Jun 01:02 +0200
[PATCH v4 1/3] gnu: emacs-ddskk: Update to 17.1 revision 0.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
6364a0f1d329f7600523d9e27cc71fbebc4655be.1719010975.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk): Update to 17.1 revision 0 (commit 8c47f46).
[arguments]: The SKK-MK and the doc files are now not explicitly made writable.
The rm in nicola/Makefile is fixed.
(emacs-ddskk-nicola)[arguments]: Move the chdir phase after the fix-test phase.
The NICOLA-DDSKK-CFG file is now not explicitly made writable.

Change-Id: I7a312f1dbbeb93666121646dd79becdd08f16b79
---
gnu/packages/emacs-xyz.scm | 20 +++++++++-----------
1 file changed, 9 insertions(+), 11 deletions(-)

Toggle diff (79 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d000e7fd02..ae6f1ed3d9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -141,6 +141,7 @@
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;; Copyright © 2024 Wilko Meyer <w@wmeyer.eu>
;;; Copyright © 2024 Noé Lopez <noelopez@free.fr>
+;;; Copyright © 2024 gemmaro <gemmaro.dev@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37016,22 +37017,20 @@ (define-public emacs-org-static-blog
(license license:bsd-3)))
(define-public emacs-ddskk
- ;; XXX: Upstream adds code names to their release tags, so version and code
- ;; name below need to be updated together.
- (let ((version "17.1")
- (code-name "Neppu"))
+ (let ((commit "8c47f46e38a29a0f3eabcd524268d20573102467")
+ (revision "0"))
(package
(name "emacs-ddskk")
- (version version)
+ (version (git-version "17.1" revision commit))
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://github.com/skk-dev/ddskk")
- (commit (string-append "ddskk-" version "_" code-name))))
+ (commit commit)))
(file-name (git-file-name name version))
(sha256
- (base32 "0xm53rybxki2784gyjkafg6956viyhhcq51kbmnrwc6aw3yzh7aw"))))
+ (base32 "0vfdbab3ncns8wwrna8h6y2w0grkphzr9s65sgxq98lpqmxbbr72"))))
(build-system gnu-build-system)
(arguments
`(#:modules ((guix build gnu-build-system)
@@ -37044,17 +37043,17 @@ (define-public emacs-ddskk
(modify-phases %standard-phases
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (make-file-writable "SKK-MK")
(emacs-substitute-variables "SKK-MK"
("PREFIX" (assoc-ref outputs "out"))
("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
("SKK_PREFIX" "")
("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
- (for-each make-file-writable (find-files "./doc"))
#t))
(add-after 'unpack 'fix-test
(lambda _
(substitute* "Makefile"
+ (("/bin/rm") (which "rm")))
+ (substitute* "nicola/Makefile"
(("/bin/rm") (which "rm"))))))))
(native-inputs
(list emacs-minimal ruby))
@@ -37081,13 +37080,12 @@ (define-public emacs-ddskk-nicola
,@(substitute-keyword-arguments (package-arguments emacs-ddskk)
((#:phases phases)
`(modify-phases ,phases
- (add-after 'unpack 'chdir
+ (add-after 'fix-test 'chdir
(lambda _
(chdir "nicola")
#t))
(replace 'configure
(lambda* (#:key outputs #:allow-other-keys)
- (make-file-writable "NICOLA-DDSKK-CFG")
(emacs-substitute-sexps "NICOLA-DDSKK-CFG"
("setq NICOLA-DDSKK_PREFIX" ""))
#t)))))))

base-commit: 594419b09e124b84d3d6141f1e47b5c346eeb704
--
2.45.1
G
G
gemmaro wrote on 22 Jun 01:02 +0200
[PATCH v4 2/3] gnu: emacs-ddskk: Use newer package style.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
01992d075af9014d054c586982f3838ca76447d0.1719010975.git.gemmaro.dev@gmail.com
* gnu/packages/emacs-xyz.scm (emacs-ddskk)[arguments]:
Convert to list of G-Expressions.
Use #$output rather than the outputs alist.
Removed #t.

Change-Id: Ie6ed743ded35b55fa55bb61d02353456a0f2c79f
---
gnu/packages/emacs-xyz.scm | 43 +++++++++++++++++++-------------------
1 file changed, 21 insertions(+), 22 deletions(-)

Toggle diff (56 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index ae6f1ed3d9..7128bbd1f1 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37033,28 +37033,27 @@ (define-public emacs-ddskk
(base32 "0vfdbab3ncns8wwrna8h6y2w0grkphzr9s65sgxq98lpqmxbbr72"))))
(build-system gnu-build-system)
(arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (guix build emacs-utils))
- #:imported-modules (,@%gnu-build-system-modules
- (guix build emacs-utils))
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (emacs-substitute-variables "SKK-MK"
- ("PREFIX" (assoc-ref outputs "out"))
- ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
- ("SKK_PREFIX" "")
- ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))
- #t))
- (add-after 'unpack 'fix-test
- (lambda _
- (substitute* "Makefile"
- (("/bin/rm") (which "rm")))
- (substitute* "nicola/Makefile"
- (("/bin/rm") (which "rm"))))))))
+ (list #:modules '((guix build gnu-build-system)
+ (guix build utils)
+ (guix build emacs-utils))
+ #:imported-modules `(,@%gnu-build-system-modules
+ (guix build emacs-utils))
+ #:test-target "test"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'configure
+ (lambda _
+ (emacs-substitute-variables "SKK-MK"
+ ("PREFIX" #$output)
+ ("LISPDIR" '(expand-file-name "/share/emacs/site-lisp" PREFIX))
+ ("SKK_PREFIX" "")
+ ("SKK_INFODIR" '(expand-file-name "info" PREFIX)))))
+ (add-after 'unpack 'fix-test
+ (lambda _
+ (substitute* "Makefile"
+ (("/bin/rm") (which "rm")))
+ (substitute* "nicola/Makefile"
+ (("/bin/rm") (which "rm"))))))))
(native-inputs
(list emacs-minimal ruby))
(home-page "https://github.com/skk-dev/ddskk")
--
2.45.1
G
G
gemmaro wrote on 22 Jun 01:02 +0200
[PATCH v4 3/3] gnu: emacs-ddskk-nicola: Use new package style.
(address . 71319@debbugs.gnu.org)(name . gemmaro)(address . gemmaro.dev@gmail.com)
0732e895c25fb516a64c38909ede3e9fb3d679da.1719010975.git.gemmaro.dev@gmail.com
This is a follow-up to commit d8577f604e91a7deebc1c6928a140ac4cfda5895.

* gnu/packages/emacs-xyz.scm (emacs-ddskk-nicola)[arguments]:
Convert to list of G-Expressions.
Use #$output rather than the outputs alist.
Removed trailing #t.

Change-Id: Ief8761bca476eba5e675d995b22d0a070f90de2f
---
gnu/packages/emacs-xyz.scm | 35 +++++++++++++++++------------------
1 file changed, 17 insertions(+), 18 deletions(-)

Toggle diff (48 lines)
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 7128bbd1f1..fbdd58ab9e 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -37070,24 +37070,23 @@ (define-public emacs-ddskk-nicola
(propagated-inputs
(list emacs-ddskk))
(arguments
- `(#:make-flags
- (let ((out (assoc-ref %outputs "out")))
- (append
- (list (string-append "PREFIX=" out)
- (string-append "LISPDIR=" out "/share/emacs/site-lisp"))))
- #:tests? #f ; no tests in this subtree
- ,@(substitute-keyword-arguments (package-arguments emacs-ddskk)
- ((#:phases phases)
- `(modify-phases ,phases
- (add-after 'fix-test 'chdir
- (lambda _
- (chdir "nicola")
- #t))
- (replace 'configure
- (lambda* (#:key outputs #:allow-other-keys)
- (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
- ("setq NICOLA-DDSKK_PREFIX" ""))
- #t)))))))
+ (append
+ (list #:make-flags
+ #~(append
+ (list (string-append "PREFIX=" #$output)
+ (string-append "LISPDIR=" #$output "/share/emacs/site-lisp")))
+ ;; no tests in this subtree
+ #:tests? #f)
+ (substitute-keyword-arguments (package-arguments emacs-ddskk)
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (add-after 'fix-test 'chdir
+ (lambda _
+ (chdir "nicola")))
+ (replace 'configure
+ (lambda _
+ (emacs-substitute-sexps "NICOLA-DDSKK-CFG"
+ ("setq NICOLA-DDSKK_PREFIX" "")))))))))
(synopsis "Nicola layout for Daredevil SKK")
(description
"Daredevil SKK is a version of @acronym{SKK, Simple Kana to Kanji
--
2.45.1
L
L
Liliana Marie Prikler wrote on 23 Jun 10:16 +0200
da59c4116e31c7b7cc0e562db7ea760d14469234.camel@gmail.com
Am Samstag, dem 22.06.2024 um 08:02 +0900 schrieb gemmaro:
Toggle quote (2 lines)
> This is a follow-up to commit
> d8577f604e91a7deebc1c6928a140ac4cfda5895.
I avoided the breaking hash by squashing the two commits, just like the
prior update was squashed. I've also reworded the previous commit to
refer to the actual version as output by Guix.

Anyhow, this is pushed now as commit
d69270b696a9badd0ba91fd1ec94f6f292ac1a53, so go and have fun with it :)
Closed
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71319@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71319
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch