[PATCH] fixed dependencies for latexindent

  • Done
  • quality assurance status badge
Details
2 participants
  • aria
  • Nicolas Goaziou
Owner
unassigned
Submitted by
aria
Severity
normal
A
(address . guix-patches@gnu.org)
1f0ef43bf3ea11a82810e0bc817b582f@chytrid.org
From eec57fe778c5dd90f1a773793740a39177e3a9a4 Mon Sep 17 00:00:00 2001
From: Aria Nolan <aria@chytrid.org>
Date: Sat, 1 Jun 2024 15:01:16 -0400
Subject: [PATCH] fixed dependencies for latexindent

Change-Id: I70e90419b0a513c66292218ae307fc186465ca60
---
gnu/packages/tex.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (15 lines)
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 4e46c1a..1df707f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -38510,6 +38510,7 @@ (define-public texlive-latexindent
(build-system texlive-build-system)
(arguments (list #:link-scripts #~(list "latexindent.pl")))
(inputs (list perl))
+ (propagated-inputs (list perl perl-yaml-tiny perl-file-homedir))
(home-page "https://ctan.org/pkg/latexindent")
(synopsis "Indent a LaTeX document, highlighting the programming
structure")
(description
--
2.45.1
N
N
Nicolas Goaziou wrote on 2 Jun 15:05 +0200
(address . aria@chytrid.org)(address . 71317@debbugs.gnu.org)
87zfs37awq.fsf@nicolasgoaziou.fr
Hello,

aria@chytrid.org writes:

Toggle quote (5 lines)
> From eec57fe778c5dd90f1a773793740a39177e3a9a4 Mon Sep 17 00:00:00 2001
> From: Aria Nolan <aria@chytrid.org>
> Date: Sat, 1 Jun 2024 15:01:16 -0400
> Subject: [PATCH] fixed dependencies for latexindent

Thank you.

Toggle quote (3 lines)
> (inputs (list perl))
> + (propagated-inputs (list perl perl-yaml-tiny perl-file-homedir))

Perl is already an input, it should not be a propagated input, too.
`perl-yaml-tiny' and `perl-file-homedir' should also be moved to inputs.
In that case, you will probably need to add a phase such as this one:

(add-after 'link-scripts 'wrap-perl-script
(lambda _
(wrap-program (string-append #$output "/bin/latexindent")
`("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))


Could you send an updated patch?


Regards,
--
Nicolas Goaziou
N
N
Nicolas Goaziou wrote on 10 Jun 20:34 +0200
(name . Nicolas Goaziou via Guix-patches via)(address . guix-patches@gnu.org)
87msnswssk.fsf@nicolasgoaziou.fr
Hello,

Nicolas Goaziou via Guix-patches via <guix-patches@gnu.org> writes:

Toggle quote (9 lines)
> Perl is already an input, it should not be a propagated input, too.
> `perl-yaml-tiny' and `perl-file-homedir' should also be moved to inputs.
> In that case, you will probably need to add a phase such as this one:
>
> (add-after 'link-scripts 'wrap-perl-script
> (lambda _
> (wrap-program (string-append #$output "/bin/latexindent")
> `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))

I went ahead and applied the changes suggested, then pushed it.

Thank you for your initial report!

Regards,
--
Nicolas Goaziou
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71317@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71317
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch