[PATCH gnome-team] gnu: gtk: Fix build on i686-linux.

  • Done
  • quality assurance status badge
Details
3 participants
  • Andreas Enge
  • Liliana Marie Prikler
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Liliana Marie Prikler
Severity
normal
L
L
Liliana Marie Prikler wrote on 30 May 10:25 +0200
(address . guix-patches@gnu.org)
6aa777e0ad96e8cb208b86c1e8450784b0e102e3.1717058246.git.liliana.prikler@gmail.com
* gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section dedicated to
failures on i686-linux.
---
gnu/packages/gtk.scm | 15 ++++++++++++++-
1 file changed, 14 insertions(+), 1 deletion(-)

Toggle diff (30 lines)
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index d5777ae67b..1c78a969f6 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -1235,7 +1235,20 @@ (define-public gtk
;; The inscription-markup.ui fails due to /etc/machine-id
;; related warnings (see:
;; https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
- (("[ \t]*'inscription-markup.ui',") ""))))
+ (("[ \t]*'inscription-markup.ui',") ""))
+ ;; XXX: These failures appear specific to i686 – investigate them.
+ #$@(if (target-x86-32?)
+ #~((substitute* "testsuite/gsk/meson.build"
+ (("'empty-(fill|stroke)\\.node',") "")
+ (("'fill2?\\.node',") "")
+ (("'stroke\\.node',") "")
+ (("'fill-fractional-([a-z-]*)-nogl',") "")
+ (("\\[ 'path-special-cases' \\],") "")
+ (("\\[ '(path|curve)-special-cases' \\],") "")
+ (("\\[ 'path-private' \\],") ""))
+ (substitute* "testsuite/a11y/meson.build"
+ (("\\{ 'name': 'text(view)?' \\},") "")))
+ #~())))
(add-before 'build 'set-cache
(lambda _
(setenv "XDG_CACHE_HOME" (getcwd))))

base-commit: 4b5b1fa8125c3055ddea36f37e0c5311489e1563
--
2.41.0
M
M
Maxim Cournoyer wrote on 1 Jun 17:04 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
871q5gln6g.fsf@gmail.com
Hi Liliana,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (30 lines)
> * gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section dedicated to
> failures on i686-linux.
> ---
> gnu/packages/gtk.scm | 15 ++++++++++++++-
> 1 file changed, 14 insertions(+), 1 deletion(-)
>
> diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> index d5777ae67b..1c78a969f6 100644
> --- a/gnu/packages/gtk.scm
> +++ b/gnu/packages/gtk.scm
> @@ -1235,7 +1235,20 @@ (define-public gtk
> ;; The inscription-markup.ui fails due to /etc/machine-id
> ;; related warnings (see:
> ;; https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
> - (("[ \t]*'inscription-markup.ui',") ""))))
> + (("[ \t]*'inscription-markup.ui',") ""))
> + ;; XXX: These failures appear specific to i686 – investigate them.
> + #$@(if (target-x86-32?)
> + #~((substitute* "testsuite/gsk/meson.build"
> + (("'empty-(fill|stroke)\\.node',") "")
> + (("'fill2?\\.node',") "")
> + (("'stroke\\.node',") "")
> + (("'fill-fractional-([a-z-]*)-nogl',") "")
> + (("\\[ 'path-special-cases' \\],") "")
> + (("\\[ '(path|curve)-special-cases' \\],") "")
> + (("\\[ 'path-private' \\],") ""))
> + (substitute* "testsuite/a11y/meson.build"
> + (("\\{ 'name': 'text(view)?' \\},") "")))
> + #~())))

Are you sure these are specific to i686 and not to 32 bit architectures
such as armhf also?

--
Thanks,
Maxim
L
L
Liliana Marie Prikler wrote on 1 Jun 18:20 +0200
(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
5a5d554ab6798f3d3ae77ebd0bbed1f74314ddf7.camel@gmail.com
Am Samstag, dem 01.06.2024 um 11:04 -0400 schrieb Maxim Cournoyer:
Toggle quote (43 lines)
> Hi Liliana,
>
> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>
> > * gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section
> > dedicated to
> > failures on i686-linux.
> > ---
> >  gnu/packages/gtk.scm | 15 ++++++++++++++-
> >  1 file changed, 14 insertions(+), 1 deletion(-)
> >
> > diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
> > index d5777ae67b..1c78a969f6 100644
> > --- a/gnu/packages/gtk.scm
> > +++ b/gnu/packages/gtk.scm
> > @@ -1235,7 +1235,20 @@ (define-public gtk
> >                  ;; The inscription-markup.ui fails due to
> > /etc/machine-id
> >                  ;; related warnings (see:
> >                  ;;
> > https://gitlab.gnome.org/GNOME/gtk/-/issues/5169).
> > -                (("[ \t]*'inscription-markup.ui',") ""))))
> > +                (("[ \t]*'inscription-markup.ui',") ""))
> > +              ;; XXX: These failures appear specific to i686 –
> > investigate them.
> > +              #$@(if (target-x86-32?)
> > +                     #~((substitute* "testsuite/gsk/meson.build"
> > +                          (("'empty-(fill|stroke)\\.node',") "")
> > +                          (("'fill2?\\.node',") "")
> > +                          (("'stroke\\.node',") "")
> > +                          (("'fill-fractional-([a-z-]*)-nogl',")
> > "")
> > +                          (("\\[ 'path-special-cases' \\],") "")
> > +                          (("\\[ '(path|curve)-special-cases'
> > \\],") "")
> > +                          (("\\[ 'path-private' \\],") ""))
> > +                        (substitute* "testsuite/a11y/meson.build"
> > +                           (("\\{ 'name': 'text(view)?' \\},")
> > "")))
> > +                    #~())))
>
> Are you sure these are specific to i686 and not to 32 bit
> architectures such as armhf also?
Well, I only tested it on x86-32. If we see the same failures on
armhf, I can just update the predicate.

WDYT?
M
M
Maxim Cournoyer wrote on 3 Jun 14:10 +0200
(name . Liliana Marie Prikler)(address . liliana.prikler@gmail.com)
87y17mi5w3.fsf@gmail.com
Hi,

Liliana Marie Prikler <liliana.prikler@gmail.com> writes:

Toggle quote (9 lines)
> Am Samstag, dem 01.06.2024 um 11:04 -0400 schrieb Maxim Cournoyer:
>> Hi Liliana,
>>
>> Liliana Marie Prikler <liliana.prikler@gmail.com> writes:
>>
>> > * gnu/packages/gtk.scm (gtk)[#:phases]<patch>: Add section
>> > dedicated to
>> > failures on i686-linux.

OK, let's do this!

Reviewed-by: Maxim Cournoyer <maxim.cournoyer@gmail>

--
Thanks,
Maxim
A
A
Andreas Enge wrote on 6 Jul 12:59 +0200
Close
(address . 71306-done@debbugs.gnu.org)
ZokjgudrSaTqm_mS@jurong
This has been applied to master as commit ad7505d16f882e69926008a22f9c12c37b32f4ee .
Closing the bug.

Thanks,

Andreas
Closed
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71306@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71306
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch