(address . bug-guix@gnu.org)
Dear Maintainers,
guix upgrade failed with:
[...]
building
/gnu/store/xjfs44qvk7rry6nbrbrd18irxdiycs2f-python-matplotlib-3.8.2.drv...
100% 'check'
?????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????????builder
for
`/gnu/store/xjfs44qvk7rry6nbrbrd18irxdiycs2f-python-matplotlib-3.8.2.drv'
failed with exit code 1
build of
/gnu/store/xjfs44qvk7rry6nbrbrd18irxdiycs2f-python-matplotlib-3.8.2.drv
failed
View build log at
'/var/log/guix/drvs/xj/fs44qvk7rry6nbrbrd18irxdiycs2f-python-matplotlib-3.8.2.drv.bz2'.
guix upgrade: error: build of
`/gnu/store/xjfs44qvk7rry6nbrbrd18irxdiycs2f-python-matplotlib-3.8.2.drv'
failed
[...]
=================================== FAILURES
===================================
_________________________ test_warn_big_data_best_loc
__________________________
[gw13] linux -- Python 3.10.7
/gnu/store/jh59fh48mcffyz5wmsjj0p96xkkflbz0-python-wrapper-3.10.7/bin/python
def test_warn_big_data_best_loc():
fig, ax = plt.subplots()
fig.canvas.draw() # So that we can call draw_artist later.
for idx in range(1000):
ax.plot(np.arange(5000), label=idx)
with rc_context({'legend.loc': 'best'}):
legend = ax.legend()
with pytest.warns(UserWarning) as records:
fig.draw_artist(legend) # Don't bother drawing the lines
-- it's slow.
# The _find_best_position method of Legend is called twice,
duplicating
# the warning message.
> assert len(records) == 2
E assert 1 == 2
E + where 1 = len(WarningsChecker(record=True))
/gnu/store/1ngk3nn61g4p64ym7p5fd3nkgrig5iba-python-matplotlib-3.8.2/lib/python3.10/site-packages/matplotlib/tests/test_legend.py:1146:
AssertionError
=========================== short test summary info
============================
FAILED tests/test_legend.py::test_warn_big_data_best_loc - assert 1 == 2
=========== 1 failed, 5622 passed, 2644 skipped, 9 xfailed in 30.86s
===========
error: in phase 'check': uncaught exception:
%exception #<&invoke-error program: "pytest" arguments: ("-n" "16"
"--pyargs" "matplotlib" "-m" "not network" "-k" "not
test_figure_legend_outside and not test_lazy_auto_backend_selection")
exit-status: 1 term-signal: #f stop-signal: #f>
phase `check' failed after 31.1 seconds
command "pytest" "-n" "16" "--pyargs" "matplotlib" "-m" "not network"
"-k" "not test_figure_legend_outside and not
test_lazy_auto_backend_selection" failed with status 1
$ guix describe
Generation 114 Mai 31 2024 10:14:09 (current)
guix 01de171
repository URL: https://git.savannah.gnu.org/git/guix.git
branch: master
commit: 01de17143c4830926af6f00f5233d1ba32d7038d
I hope it helps and thanks in advance
Francis