[PATCH 1/3] gnu: grass: Improve package style.

  • Open
  • quality assurance status badge
Details
One participant
  • Vinicius Monego
Owner
unassigned
Submitted by
Vinicius Monego
Severity
normal
V
V
Vinicius Monego wrote on 30 May 20:08 +0200
(address . guix-patches@gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
4d9e85d82fc2c3a030a0255faf2da4915450b653.1717092444.git.monego@posteo.net
* gnu/packages/geo.scm (grass)[inputs, native-inputs]: Remove package labels.
[arguments]: Use G-Expressions and Gexp variables. Remove trailing #t from
phases.

Change-Id: Ifa2d992da5ffb14ee178ad811046ab90d6ab87cd
---
gnu/packages/geo.scm | 140 +++++++++++++++++++++----------------------
1 file changed, 68 insertions(+), 72 deletions(-)

Toggle diff (193 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index c9152fb4f8..e79b2fc4b3 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2744,106 +2744,102 @@ (define-public grass
(base32 "1gpfbppfajc8d6b9alw9fdzgaa83w26kl6fff1395bc9gal215ms"))))
(build-system gnu-build-system)
(inputs
- `(("bzip2" ,bzip2)
- ("cairo" ,cairo)
- ("fftw" ,fftw)
- ("freetype" ,freetype)
- ("gdal" ,gdal)
- ("geos" ,geos)
- ("glu" ,glu)
- ("libpng" ,libpng)
- ("libtiff" ,libtiff)
- ("mesa" ,mesa)
- ("mariadb-dev" ,mariadb "dev")
- ("mariadb-lib" ,mariadb "lib")
- ("netcdf" ,netcdf)
- ("openblas" ,openblas)
- ("perl" ,perl)
- ("postgresql" ,postgresql)
- ("proj" ,proj)
- ("python" ,python)
- ("python-dateutil" ,python-dateutil)
- ("python-numpy" ,python-numpy)
- ("python-wxpython" ,python-wxpython)
- ("readline" ,readline)
- ("sqlite" ,sqlite)
- ("wxwidgets" ,wxwidgets)
- ("zlib" ,zlib)
- ("zstd" ,zstd "lib")))
+ (list bzip2
+ cairo
+ fftw
+ freetype
+ gdal
+ geos
+ glu
+ libpng
+ libtiff
+ mesa
+ `(,mariadb "dev")
+ `(,mariadb "lib")
+ netcdf
+ openblas
+ perl
+ postgresql
+ proj
+ python
+ python-dateutil
+ python-numpy
+ python-wxpython
+ readline
+ sqlite
+ wxwidgets
+ zlib
+ `(,zstd "lib")))
(native-inputs
- `(("bash" ,bash-minimal)
- ("bison" ,bison)
- ("flex" ,flex)
- ("pkg-config" ,pkg-config)))
+ (list bash-minimal
+ bison
+ flex
+ pkg-config))
(arguments
- `(#:tests? #f ; No tests
- #:modules ((guix build gnu-build-system)
+ (list
+ #:tests? #f ; No tests
+ #:modules `((guix build gnu-build-system)
((guix build python-build-system) #:prefix python:)
(guix build utils))
- #:imported-modules (,@%gnu-build-system-modules
+ #:imported-modules `(,@%gnu-build-system-modules
(guix build python-build-system))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'fix-lapack
- (lambda _
- (substitute* "./configure"
- (("-lblas") "-lopenblas")
- (("-llapack") "-lopenblas"))))
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((shell (search-input-file inputs "/bin/bash")))
- (setenv "SHELL" shell)
- (setenv "CONFIG_SHELL" shell)
- (setenv "LDFLAGS" (string-append "-Wl,-rpath -Wl,"
- (assoc-ref outputs "out")
- "/" ,grassxx "/lib")))
- (invoke "./configure"
- (string-append "--prefix="
- (assoc-ref outputs "out"))
- "--with-blas"
- "--with-bzlib"
- (string-append "--with-freetype-includes="
- (assoc-ref inputs "freetype")
- "/include/freetype2")
- (string-append "--with-freetype-libs="
- (assoc-ref inputs "freetype")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-lapack
+ (lambda _
+ (substitute* "./configure"
+ (("-lblas") "-lopenblas")
+ (("-llapack") "-lopenblas"))))
+ (replace 'configure
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((shell (search-input-file inputs "/bin/bash")))
+ (setenv "SHELL" shell)
+ (setenv "CONFIG_SHELL" shell)
+ (setenv "LDFLAGS" (string-append "-Wl,-rpath -Wl,"
+ #$output
+ "/" #$grassxx "/lib")))
+ (invoke "./configure"
+ (string-append "--prefix=" #$output)
+ "--with-blas"
+ "--with-bzlib"
+ (string-append "--with-freetype-includes="
+ #$(this-package-input "freetype")
+ "/include/freetype2")
+ (string-append "--with-freetype-libs="
+ #$(this-package-input "freetype")
"/lib")
"--with-geos"
"--with-lapack"
"--with-mysql"
(string-append "--with-mysql-includes="
- (assoc-ref inputs "mariadb-dev")
+ (ungexp (this-package-input "mariadb") "dev")
"/include/mysql")
(string-append "--with-mysql-libs="
- (assoc-ref inputs "mariadb-lib")
+ (ungexp (this-package-input "mariadb") "lib")
"/lib")
"--with-netcdf"
"--with-postgres"
(string-append "--with-proj-share="
- (assoc-ref inputs "proj")
+ #$(this-package-input "proj")
"/share/proj")
"--with-pthread"
"--with-readline"
"--with-sqlite"
"--with-wxwidgets")))
(add-after 'install 'install-links
- (lambda* (#:key outputs #:allow-other-keys)
+ (lambda _
;; Put links for includes and libraries in the standard places.
- (let* ((out (assoc-ref outputs "out"))
- (dir (string-append out "/" ,grassxx)))
+ (let* ((dir (string-append #$output "/" #$grassxx)))
(symlink (string-append dir "/include")
- (string-append out "/include"))
+ (string-append #$output "/include"))
(symlink (string-append dir "/lib")
- (string-append out "/lib")))
- #t))
+ (string-append #$output "/lib")))))
(add-after 'install-links 'python:wrap
(assoc-ref python:%standard-phases 'wrap))
(add-after 'python:wrap 'wrap-with-python-interpreter
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- (wrap-program (string-append out "/bin/" ,grassxx)
- `("GRASS_PYTHON" = (,(which "python3"))))
- #t))))))
+ (lambda _
+ (wrap-program (string-append #$output "/bin/" #$grassxx)
+ `("GRASS_PYTHON" = (,(which "python3")))))))))
(synopsis "GRASS Geographic Information System")
(description
"GRASS (Geographic Resources Analysis Support System), is a Geographic

base-commit: dc8fb5672464b6386f6b4b94723f9b36edc4e625
prerequisite-patch-id: 773c85d1be2cd6c14792cefa3855e6c2f1962c73
prerequisite-patch-id: 40dee8ca9d21c3a433af58e9bf49422620721eb1
prerequisite-patch-id: da9af05380d56f1e7aab9c9ee3853d7361982d3c
prerequisite-patch-id: 86a8d9abf4ed3884ce07df56d07f3e3ccedc06d2
prerequisite-patch-id: 1b8c747f40718f0e8ef37fdc1a313aef4046e55c
prerequisite-patch-id: dbb183058bd531219603f0611a88e3faae7497f8
prerequisite-patch-id: 63ad2f6e26a7a7e6e28dd8ce5fb6422b66cd2e32
prerequisite-patch-id: ccd49dc6a0012f25b975b7de0b1b389d813c0ace
prerequisite-patch-id: 3f6f0ed6801942cc8f124e3a0368af7291456f31
prerequisite-patch-id: c3a135b6c179a25a56cb5b7f0158d1907b2d1105
--
2.39.2
V
V
Vinicius Monego wrote on 30 May 20:11 +0200
[PATCH 3/3] gnu: grass: Add input python-matplotlib.
(address . 71279@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
c363ecbc1907d9721cdf65372fac8df4097d41a2.1717092444.git.monego@posteo.net
* gnu/packages/geo.scm (grass)[inputs]: Add python-matplotlib.

Change-Id: I07f82a760075450de9fef0ae0a3743928de01610
---
gnu/packages/geo.scm | 1 +
1 file changed, 1 insertion(+)

Toggle diff (14 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 8cff578a74..c1c6d5baae 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2765,6 +2765,7 @@ (define-public grass
proj
python
python-dateutil
+ python-matplotlib
python-numpy
python-wxpython
readline
--
2.39.2
V
V
Vinicius Monego wrote on 30 May 20:11 +0200
[PATCH 2/3] gnu: grass: Update to 8.3.2.
(address . 71279@debbugs.gnu.org)(name . Vinicius Monego)(address . monego@posteo.net)
d2bcc44253c618c72a2d56c3effbb0f04b196349.1717092444.git.monego@posteo.net
* gnu/packages/geo.scm (grass): Update to 8.3.2.
[inputs]: Add libxml2, pdal.
[arguments]<#:phases>: Correct the binary name in the
'wrap-with-python-interpreter phase.

Change-Id: I6dcc11f1ec1acdcb9c5d213920eea84c794c6a41
---
gnu/packages/geo.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (47 lines)
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index e79b2fc4b3..8cff578a74 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2729,7 +2729,7 @@ (define-public openorienteering-mapper
(license license:gpl3+)))
(define-public grass
- (let* ((version "7.8.8")
+ (let* ((version "8.3.2")
(majorminor (string-join (list-head (string-split version #\.) 2) ""))
(grassxx (string-append "grass" majorminor)))
(package
@@ -2741,7 +2741,7 @@ (define-public grass
(uri (string-append "https://grass.osgeo.org/" grassxx
"/source/grass-" version ".tar.gz"))
(sha256
- (base32 "1gpfbppfajc8d6b9alw9fdzgaa83w26kl6fff1395bc9gal215ms"))))
+ (base32 "0g54zfcmmj5zigqrc3h1fyrxcppgamwh1n6dz6fsszfpr5w4k4mb"))))
(build-system gnu-build-system)
(inputs
(list bzip2
@@ -2753,11 +2753,13 @@ (define-public grass
glu
libpng
libtiff
+ libxml2
mesa
`(,mariadb "dev")
`(,mariadb "lib")
netcdf
openblas
+ pdal
perl
postgresql
proj
@@ -2838,7 +2840,7 @@ (define-public grass
(assoc-ref python:%standard-phases 'wrap))
(add-after 'python:wrap 'wrap-with-python-interpreter
(lambda _
- (wrap-program (string-append #$output "/bin/" #$grassxx)
+ (wrap-program (string-append #$output "/bin/grass")
`("GRASS_PYTHON" = (,(which "python3")))))))))
(synopsis "GRASS Geographic Information System")
(description
--
2.39.2
?
Your comment

Commenting via the web interface is currently disabled.

To comment on this conversation send an email to 71279@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71279
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch