[PATCH 0/2] Update pre-commit to 3.7.1

  • Done
  • quality assurance status badge
Details
4 participants
  • Vinicius Monego
  • Nicolas Graves
  • Noé Lopez
  • Noé Lopez
Owner
unassigned
Submitted by
Noé Lopez
Severity
normal
N
N
Noé Lopez wrote on 30 May 00:41 +0200
(address . guix-patches@gnu.org)(name . Noé Lopez)(address . noelopez@free.fr)
cover.1717021909.git.noelopez@free.fr
Hi Guix,

These two patches update pre-commit to version 3.7.1 and its dependency
python-identify to 2.5.36. This allows pre-commit to be used with more recent
hooks, like clang-format 18.

Good evening,
Noé Lopez

Noé Lopez (2):
gnu: pre-commit: Update to 3.7.1
gnu: python-identify: Update to 2.5.36

gnu/packages/python-xyz.scm | 8 +++++---
gnu/packages/version-control.scm | 5 +++--
2 files changed, 8 insertions(+), 5 deletions(-)


base-commit: 6f72ad465c1e2df965e8d73b209497b4ef456527
prerequisite-patch-id: 75f6ba7d50cdb966f5d5ee00f03f0061bcf76bb6
--
2.41.0
N
N
Noé Lopez wrote on 30 May 00:45 +0200
[PATCH 1/2] gnu: pre-commit: Update to 3.7.1
(address . 71266@debbugs.gnu.org)(name . Noé Lopez)(address . noelopez@free.fr)
0564db319b4260e5ea8b839edbfe806066c00cd9.1717021909.git.noelopez@free.fr
* gnu/packages/version-control.scm (pre-commit): Update to 3.7.1

Change-Id: I85e7f8d6ff1dd13b444ba2c06193e66344cafa37
---
gnu/packages/version-control.scm | 5 +++--
1 file changed, 3 insertions(+), 2 deletions(-)

Toggle diff (32 lines)
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c01eb9decd..6189fdaa52 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2014,7 +2014,7 @@ (define-public gitile
(define-public pre-commit
(package
(name "pre-commit") ;formerly known as python-pre-commit
- (version "3.3.3")
+ (version "3.7.1")
(source
(origin
(method git-fetch) ; no tests in PyPI release
@@ -2023,7 +2023,7 @@ (define-public pre-commit
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1spkg3ld3s6l7wz24lcywlf1z2ywp751bcdlxjfdsln76bi9ylp8"))
+ (base32 "1m2cs21xq2j1x80s7bh47fm2nsbnfxgscxfijaqwdsi2rrf4vlzv"))
(modules '((guix build utils)))
(snippet '(substitute* "setup.cfg"
(("virtualenv>=20.10.0") ;our virtualenv (20.3.1) is fine
@@ -2072,6 +2072,7 @@ (define-public pre-commit
"--ignore=tests/languages/perl_test.py"
"--ignore=tests/languages/rust_test.py"
"--ignore=tests/languages/swift_test.py"
+ "--ignore=tests/languages/haskell_test.py"
"-k"
(string-append
;; TODO: these tests fail with AssertionError. It may
--
2.41.0
N
N
Noé Lopez wrote on 30 May 00:45 +0200
[PATCH 2/2] gnu: python-identify: Update to 2.5.36
(address . 71266@debbugs.gnu.org)(name . Noé Lopez)(address . noelopez@free.fr)
9dad5899b80ac986e65c0af2dc6bdb91ea88b432.1717021909.git.noelopez@free.fr
* gnu/packages/python-xyz.scm (python-identify): Update to 2.5.36

Change-Id: I040c7571fc69c194d98d89685e5d468092f515c0
---
gnu/packages/python-xyz.scm | 8 +++++---
1 file changed, 5 insertions(+), 3 deletions(-)

Toggle diff (35 lines)
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 9d3066cab4..279ffd2ec6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -27254,7 +27254,7 @@ (define-public python-requests-file
(define-public python-identify
(package
(name "python-identify")
- (version "1.4.25")
+ (version "2.5.36")
(source
(origin
;; There are no tests in the PyPI tarball.
@@ -27264,7 +27264,7 @@ (define-public python-identify
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1fqgci6skckcq0x5pnxh6k2qjzn1ndsrgha1j6wwv1ld4g9bd3hz"))))
+ (base32 "1il0d1zh31jx36m0lvhpiykx95i95dcfrgrfbz2x6la884zsmvq8"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -27274,7 +27274,9 @@ (define-public python-identify
(replace 'check
(lambda* (#:key tests? #:allow-other-keys)
(when tests?
- (invoke "pytest" "-vv")))))))
+ (invoke "pytest"
+ "-k" "not test_license" ; dependency on ukkonen
+ "-vv")))))))
(native-inputs
(list python-coverage python-pytest))
(propagated-inputs
--
2.41.0
V
V
Vinicius Monego wrote on 30 May 20:36 +0200
Re: [PATCH 0/2] Update pre-commit to 3.7.1
e5aafc06b4651e4dd8145330dca035061bfb864f.camel@posteo.net
Em qui, 2024-05-30 às 00:41 +0200, Noé Lopez escreveu:
Toggle quote (3 lines)
> Hi Guix,
>

Hi Noé,

Toggle quote (21 lines)
> These two patches update pre-commit to version 3.7.1 and its
> dependency
> python-identify to 2.5.36. This allows pre-commit to be used with
> more recent
> hooks, like clang-format 18.
>
> Good evening,
> Noé Lopez
>
> Noé Lopez (2):
>   gnu: pre-commit: Update to 3.7.1
>   gnu: python-identify: Update to 2.5.36
>
>  gnu/packages/python-xyz.scm      | 8 +++++---
>  gnu/packages/version-control.scm | 5 +++--
>  2 files changed, 8 insertions(+), 5 deletions(-)
>
>
> base-commit: 6f72ad465c1e2df965e8d73b209497b4ef456527
> prerequisite-patch-id: 75f6ba7d50cdb966f5d5ee00f03f0061bcf76bb6

There is an open patch at 69980. However, pre-commit now has over 300
dependents because of python-jupytext, so this or 69980 may need to go
to staging. pre-commit should really be removed from jupytext native-
inputs as it's only used for a few unit tests.
N
N
Noé Lopez wrote on 31 May 15:03 +0200
(name . Vinicius Monego)(address . monego@posteo.net)
87bk4mb0b1.fsf@xn--no-cja.eu
Vinicius Monego <monego@posteo.net> writes:

Toggle quote (33 lines)
> Em qui, 2024-05-30 às 00:41 +0200, Noé Lopez escreveu:
>> Hi Guix,
>>
>
> Hi Noé,
>
>> These two patches update pre-commit to version 3.7.1 and its
>> dependency
>> python-identify to 2.5.36. This allows pre-commit to be used with
>> more recent
>> hooks, like clang-format 18.
>>
>> Good evening,
>> Noé Lopez
>>
>> Noé Lopez (2):
>>   gnu: pre-commit: Update to 3.7.1
>>   gnu: python-identify: Update to 2.5.36
>>
>>  gnu/packages/python-xyz.scm      | 8 +++++---
>>  gnu/packages/version-control.scm | 5 +++--
>>  2 files changed, 8 insertions(+), 5 deletions(-)
>>
>>
>> base-commit: 6f72ad465c1e2df965e8d73b209497b4ef456527
>> prerequisite-patch-id: 75f6ba7d50cdb966f5d5ee00f03f0061bcf76bb6
>
> There is an open patch at 69980. However, pre-commit now has over 300
> dependents because of python-jupytext, so this or 69980 may need to go
> to staging. pre-commit should really be removed from jupytext native-
> inputs as it's only used for a few unit tests.
>

Hi Vinicius,

Thanks for the answer, 69980 seems much more complete. Is there anything
blocking it from being merged? I could look into it.
V
V
Vinicius Monego wrote on 1 Jun 16:31 +0200
(name . Noé Lopez)(address . noe@xn--no-cja.eu)
d487ce7ce6eafc9e361c067773818a8447fc6814.camel@posteo.net
Em sex, 2024-05-31 às 15:03 +0200, Noé Lopez escreveu:
Toggle quote (44 lines)
> Vinicius Monego <monego@posteo.net> writes:
>
> > Em qui, 2024-05-30 às 00:41 +0200, Noé Lopez escreveu:
> > > Hi Guix,
> > >
> >
> > Hi Noé,
> >
> > > These two patches update pre-commit to version 3.7.1 and its
> > > dependency
> > > python-identify to 2.5.36. This allows pre-commit to be used with
> > > more recent
> > > hooks, like clang-format 18.
> > >
> > > Good evening,
> > > Noé Lopez
> > >
> > > Noé Lopez (2):
> > >   gnu: pre-commit: Update to 3.7.1
> > >   gnu: python-identify: Update to 2.5.36
> > >
> > >  gnu/packages/python-xyz.scm      | 8 +++++---
> > >  gnu/packages/version-control.scm | 5 +++--
> > >  2 files changed, 8 insertions(+), 5 deletions(-)
> > >
> > >
> > > base-commit: 6f72ad465c1e2df965e8d73b209497b4ef456527
> > > prerequisite-patch-id: 75f6ba7d50cdb966f5d5ee00f03f0061bcf76bb6
> >
> > There is an open patch at 69980. However, pre-commit now has over
> > 300
> > dependents because of python-jupytext, so this or 69980 may need to
> > go
> > to staging. pre-commit should really be removed from jupytext
> > native-
> > inputs as it's only used for a few unit tests.
> >
>
> Hi Vinicius,
>
> Thanks for the answer, 69980 seems much more complete. Is there
> anything
> blocking it from being merged? I could look into it.

There are no blockers other than python-jupytext having 300+
dependents. I'd like to merge 69980 but I'm not sure if I can do it on
master, or if it'd have to be done on staging or python-team. I only
work on the master branch.

Vinicius
N
N
Nicolas Graves wrote on 1 Jun 16:35 +0200
control message for bug #71266
(address . control@debbugs.gnu.org)
874jacbujd.fsf@ngraves.fr
close 71266
thanks

Guix QA review form submission:
This looks good but will trigger (guix refresh -l) more than 300
rebuilds. The patch series 69980 tries to reduce the dependents on
pre-commit after updating it, which should trigger less rebuilds in the
long run. Due to the number of rebuilds, it should probably go to
python-team branch anyway.

I will resubmit a v3 including this further update of pre-commit and
python-identify. Thanks Noé!

Items marked as checked: Lint warnings, Package builds, Commit messages

--
Best regards,
Nicolas Graves
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71266@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71266
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch