[PATCH] build-system: qt: Fix default parallel-tests? value to #t.

  • Done
  • quality assurance status badge
Details
One participant
  • Maxim Cournoyer
Owner
unassigned
Submitted by
Maxim Cournoyer
Severity
normal
M
M
Maxim Cournoyer wrote on 29 May 07:59 +0200
(address . guix-patches@gnu.org)(name . Maxim Cournoyer)(address . maxim.cournoyer@gmail.com)
ea83a3cf4896bc71350d409c084b34a4dd83dc9d.1716962354.git.maxim.cournoyer@gmail.com
There is no reason to have this diverge from the underlying cmake build
system.

* guix/build-system/qt.scm (qt-build) <#:parallel-tests?>: Default to #t.

Change-Id: I65db3d6c6727bd24549af4a44940e7362064aed6
---

guix/build-system/qt.scm | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

Toggle diff (26 lines)
diff --git a/guix/build-system/qt.scm b/guix/build-system/qt.scm
index 978aed0fc1..dc5d65436e 100644
--- a/guix/build-system/qt.scm
+++ b/guix/build-system/qt.scm
@@ -130,7 +130,7 @@ (define* (qt-build name inputs
(build-type "RelWithDebInfo")
(tests? #t)
(test-target "test")
- (parallel-build? #t) (parallel-tests? #f)
+ (parallel-build? #t) (parallel-tests? #t)
(validate-runpath? #t)
(patch-shebangs? #t)
(strip-binaries? #t)

base-commit: 473cdecd8965a301ef6817027090bc61c6907a18
prerequisite-patch-id: b08347d79d8a5d273ec3a286ce5c97d59b922773
prerequisite-patch-id: d6b9760ab60a43440c651d69cf0daab21a8d13ab
prerequisite-patch-id: bbd0a1b5369a87bf40912ba83ed67b40a1486f5d
prerequisite-patch-id: 419aadf0ea2be7f73de86fd1ce54b16ab54b0cd6
prerequisite-patch-id: 08cef39c34455ee882df4d36f4ddf2f2f2a1220b
prerequisite-patch-id: 67819567d11f112ab65d48930e0e4ecbcd4c6837
prerequisite-patch-id: 6a6219293008cb948c8030d9384778946ad593b2
prerequisite-patch-id: 440539329222e54486be96cff8a6fde0807d3d9f
prerequisite-patch-id: 190785afb338901679186c0b7321f22076891e24
--
2.41.0
M
M
Maxim Cournoyer wrote on 24 Jun 04:46 +0200
control message for bug #71255
(address . control@debbugs.gnu.org)
87le2v6oru.fsf@gmail.com
close 71255
quit
?
Your comment

This issue is archived.

To comment on this conversation send an email to 71255@debbugs.gnu.org

To respond to this issue using the mumi CLI, first switch to it
mumi current 71255
Then, you may apply the latest patchset in this issue (with sign off)
mumi am -- -s
Or, compose a reply to this issue
mumi compose
Or, send patches to this issue
mumi send-email *.patch